如何将移到另一个 Mac 工作簿的 Excel 的模块代码

文章翻译 文章翻译
文章编号: 288401 - 查看本文应用于的产品
本文已归档。它按“原样”提供,并且不再更新。
展开全部 | 关闭全部

概要

本文介绍如何将 Microsoft Visual Basic 应用程序 (VBA) 代码的数据从一个工作簿移到另一个。

更多信息

如果要移动到其他工作簿的 VBA 代码不能移动直接与工作表类似。而是,您必须从原始工作簿中模块中复制代码然后代码并粘贴到模块其他工作簿中。

若要移动到不同的 Microsoft Excel 为 Mac 工作簿的 VBA 代码,请按照下列步骤操作:
  1. 打开包含要移动的宏模块的工作簿。
  2. 打开要向其中移动该的代码的工作簿或打开一个新的工作簿。
  3. 工具 菜单上指向 ,然后单击 Visual Basic 编辑器。
  4. 在工程窗口中选择的项目 (工作簿) 要将宏模块。如果不可见工程窗口中单击在 视图 菜单上的 工程资源管理器

    注意在为 Mac 和更高版本的 Microsoft Excel X,工程窗口不能关闭,并且不是在 视图 菜单上可用。
  5. 插入 菜单上单击 模块
  6. 在工程窗口中双击包含已有的宏项目。
  7. 项目下, 双击 模块 文件夹,然后双击打开模块的代码窗口下面模块。
  8. 在现有的模块中选择的所有代码,然后按命令 + C 复制它。
  9. 窗口 菜单上单击您在步骤 5 中创建的新模块。该代码窗口内单击,然后按命令 + V 粘贴复制的代码,在此新的模块工作表中。
  10. 如果要删除原始的模块项目窗口中选择原始模块 ; 在 文件 菜单上单击 删除模块,在提示时单击 删除模块。
  11. 如果存在其他模块重复步骤 4-10 复制、 粘贴,和 (可选) 从原始项目中移除这些模块。
  12. 文件 菜单 (这是为 Mac 及更高版本的 Excel X 中 Excel 菜单) 中,单击 关闭 返回到 Excel 的 Mac.保存这两个工作簿。
如果要运行原始宏分配按钮或对象,并且您已经移动代码重新分配按钮或对象以新宏的位置。要做到这点,按住控制、 单击按钮或对象,然后单击快捷菜单上的 指定宏。查找宏名称,然后双击该新宏的位置重新分配到该位置按钮。

属性

文章编号: 288401 - 最后修改: 2013年10月23日 - 修订: 3.4
这篇文章中的信息适用于:
  • Microsoft Excel 2004 for Mac
  • Microsoft Excel X for Mac
  • Microsoft Excel 2001 for Mac
  • Microsoft Excel 98 for Macintosh
关键字:?
kbnosurvey kbarchive kbmt kbinfo KB288401 KbMtzh
机器翻译
注意:这篇文章是由无人工介入的微软自动的机器翻译软件翻译完成。微软很高兴能同时提供给您由人工翻译的和由机器翻译的文章, 以使您能使用您的语言访问所有的知识库文章。然而由机器翻译的文章并不总是完美的。它可能存在词汇,语法或文法的问题,就像是一个外国人在说中文时总是可能犯这样的错误。虽然我们经常升级机器翻译软件以提高翻译质量,但是我们不保证机器翻译的正确度,也不对由于内容的误译或者客户对它的错误使用所引起的任何直接的, 或间接的可能的问题负责。
点击这里察看该文章的英文版: 288401
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。

提供反馈

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com