W3wp.exe crashes when you decline a meeting request by using Outlook Web App or an EWS application in an Exchange Server 2010 environment

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Article ID: 2888911 - View products that this article applies to.
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Symptoms

Assume that you receive a meeting request in a Microsoft Exchange Server 2010 organization that has Update Rollup 5 for Exchange Server 2010 Service Pack 2 (SP2) or a later update rollup that is earlier than Update Rollup 3 for Exchange Server 2010 Service Pack 3 (SP3) installed. You decline the request by using Outlook Web App or an Exchange Web Services (EWS) application. In this situation, the W3wp.exe process for the Outlook Web App application pool or for the Exchange Web Service application pool crashes. Additionally, one of the following events is logged in the Application log:

Log Name:      Application
Source:        MSExchange Common
Event ID:      4999
Task Category: General
Level:         Error
Description:
Watson report about to be sent for process id: ProcessID, with parameters: E12, BuildType, VersionNumber, OWA, M.E.Data.Storage, M.E.D.S.AppointmentTombstone..ctor, System.OverflowException, xxxx, VersionNumber.
ErrorReportingEnabled: False

Log Name:      Application
Source:        MSExchange Common
Event ID:      4999
Task Category: General
Level:         Error
Description:
Watson report about to be sent for process id: ProcessID, with parameters: E12, BuildType, VersionNumber, EWS, M.E.Data.Storage, M.E.D.S.AppointmentTombstone..ctor, System.OverflowException, xxxx, VersionNumber.
ErrorReportingEnabled: False

Cause

This issue occurs because the tombstone data for the meeting request is corrupted. Then, a negative value is used to create a byte array. Therefore, an overflow exception is thrown.

Resolution

To resolve this issue, install the following update rollup:
2891587 Description of Update Rollup 3 for Exchange Server 2010 Service Pack 3

Workaround

To work around this issue, use the MFCMAPI tool to remove the corrupted tombstone data.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More information

Download MFCMAPI from the following Microsoft website:
Download MFCMAPI
Note Only an Exchange administrator who has full permissions for a mailbox can use the MFCMAPI tool to remove the corrupted tombstone data.

Properties

Article ID: 2888911 - Last Review: November 25, 2013 - Revision: 1.0
Applies to
  • Microsoft Exchange Server 2010 Service Pack 3, when used with:
    • Microsoft Exchange Server 2010 Enterprise
    • Microsoft Exchange Server 2010 Standard
Keywords: 
kbqfe kbfix kbsurveynew kbexpertiseinter KB2888911

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