Cannot Mount Mailbox Store After Offline Defragramentation Error -540

Article translations Article translations
Article ID: 289079 - View products that this article applies to.
This article was previously published under Q289079
Expand all | Collapse all

SYMPTOMS

The following error may appear in the application log when you mount a mailbox store after you run an offline defragmentation (such as eseutil /d):
Event Type: Error
Event Source: MSExchangeIS
Event Category: General
Event ID: 9519
Computer: SERVER
Description:
Error 0xfffffde4 starting database "First Storage Group\Mailbox Store (SERVER)" on the Microsoft Exchange Information Store.
Running eseutil or isinteg to repair or verify the database also returns error -540 (0xfffffde4 in hexadecimal).

CAUSE

This behavior can occur when the defragmentation process is interrupted while copying the temporary .stm and .edb files over the original files.

RESOLUTION

To resolve this behavior, find the temporary files (TEMP####.stm and TEMP####.edb) and copy them back to their original location and original name. Be sure that the dates on the temporary files match the date that you ran the defragmentation operation. In addition, back up all files to a safe location before overwriting or deleting these files.

MORE INFORMATION

You can view the database signatures and creation dates by running the following two commands:
eseutil /mh streaming file path and filename
eseutil /mh edb file path and filename
These values must match in order to avoid the error described in the "Symptoms" section.

Properties

Article ID: 289079 - Last Review: December 3, 2007 - Revision: 4.5
APPLIES TO
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange 2000 Server Standard Edition
  • Microsoft Windows Small Business Server 2003 Premium Edition
  • Microsoft Windows Small Business Server 2003 Standard Edition
Keywords: 
kbprb KB289079

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com