Condição de corrida ocorre e Autochk.exe pára de responder durante reinicialização

Traduções deste artigo Traduções deste artigo
ID do artigo: 289166 - Exibir os produtos aos quais esse artigo se aplica.
Este artigo foi arquivado. É oferecido "como está" e não será mais atualizado.
Expandir tudo | Recolher tudo

Sintomas

Enquanto o Autochk.exe é executado durante uma reinicialização, uma condição de corrida pode ocorrer e fazer com que Autochk.exe pare de responder. Porque o computador não reinicia, o Autochk.exe não é concluído as tarefas no volume de sistema NTFS. Isso é mais provável ocorrer em sistemas de multiprocessadores.

Causa

Esse comportamento pode ocorrer porque a variável interna que controla a quantidade de memória permanece não está protegida contra a condição de corrida.

Resolução

Para resolver esse problema, obtenha o service pack mais recente para o Windows 2000. Para obter informações adicionais, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
260910Como obter o Service Pack mais recente do Windows 2000

Como Contornar

Para contornar esse problema, use um dos seguintes opções:
  • Ignore o processo de Autochk:

    1. Reinicie o sistema e, em seguida, pressione F8 no menu de inicialização.
    2. No menu Opções avançadas , selecione última configuração válida para ignorar a operação de Chkdsk agendado (Autochk) e permitem que você retornar para o sistema.
    3. Se Autochk está agendada para ser executado em um volume quando o computador for reiniciado, no ponto apropriado durante a reinicialização você pode ignorar Autochk pressionando qualquer tecla. Autochk não executar esse volume e também remove a entrada do Registro relevantes, para que Autochk não é executado em relação a esse volume no futuro.
  • Se ignorar o processo de Autochk não é desejável, execute o console de recuperação:

    1. Iniciar o computador usando os discos de programa de instalação do Windows 2000 ou se o computador oferecer suporte a partir de um CD-ROM, inicie o computador usando o CD-ROM do Windows 2000.
    2. Na tela "Bem-vindo à instalação", pressione R para reparar e, em seguida, pressione C para iniciar o console de recuperação.
    3. Após você efetuar logon no seu computador no console de recuperação, digite Chkdsk /P , e, em seguida, pressione ENTER.
    4. Depois que o processo terminar, digite Exit e pressione ENTER para reiniciar o computador.

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados no começo deste artigo.

Esse problema foi corrigido primeiro no Windows 2000 Service Pack 2.

Mais Informações

Para obter informações adicionais sobre a ferramenta de Autochk, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
218461CHKDSK Avançado, Autochk e Chkntfs ferramentas no Windows 2000

Para obter informações adicionais sobre como usar o console de recuperação, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
229716Descrição do console de recuperação do Windows 2000

Propriedades

ID do artigo: 289166 - Última revisão: quarta-feira, 23 de outubro de 2013 - Revisão: 3.2
A informação contida neste artigo aplica-se a:
  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Professional SP1
Palavras-chave: 
kbnosurvey kbarchive kbmt kbbug kbfilesystems kbfix kbwin2000presp2fix KB289166 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 289166

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com