Backup Takes Much Longer When PAE Is Enabled

Article translations Article translations
Article ID: 289261 - View products that this article applies to.
This article was previously published under Q289261
This article has been archived. It is offered "as is" and will no longer be updated.
Expand all | Collapse all

On This Page

SYMPTOMS

When you finish a backup while you are using Ntbackup.exe, if you start the computer with the PAE switch enabled, the backup may take longer than expected to complete (up to or longer than 10 times longer than expected). If you start the computer without the PAE switch, the backup finishes as expected.

CAUSE

NTbackup must write to a tape by using a tape block size in powers of two. When the PAE switch is used, the
MaxPhysicalPages
value is reduced by one to allow for one extra level of page translation. This behavior causes the block size to be an odd-numbered size. When NTbackup tries to read or write to a tape whose block size exceeds the
MaxPhysicalPages
value multiplied by 4 kilobytes (KB) (MaximumPhysicalPages × 4KB), NTBackup defaults to a 1024-byte block size. This smaller block size severely reduces read and write performance.

The block size is calculated by multiplying the value in
MaxPhysicalPages
by PAGE_SIZE (4096). With a non-PAE Kernel, this is 16 X 4096 = 65536, and with the PAE kernel, it is 15 X 4096 = 61440, which is not a power of two. Because of this, RSM and Ntbackup both default to a 1KB block size when preparing or writing to a tape, which severly affects performance.

RESOLUTION

Service Pack Information

To resolve this problem, obtain the latest service pack for Microsoft Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
260910 How to Obtain the Latest Windows 2000 Service Pack

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The US English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date        Time     Version           Size   File name
   ------------------------------------------------------- 
   8/20/2002   05:01p   5.0.2195.5988   10,928   Tape.sys
				
NOTE: To view the version number, right-click the file in Windows Explorer, click Properties on the shortcut menu, and then click the Version tab.

NOTE: Before NTBackup can use the proper block size, you have to re-prepare the tape media by using Removable Storage Manager (RSM). As soon as it is prepared, the tape block size will be adjusted to the largest block size available while using the power of two.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Windows 2000 Service Pack 4.

MORE INFORMATION

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the article number below to view the article in the Microsoft Knowledge Base:
265173 The Datacenter Program and Windows 2000 Datacenter Server Product

Properties

Article ID: 289261 - Last Review: February 28, 2014 - Revision: 4.7
APPLIES TO
  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Advanced Server SP3
  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows 2000 Professional SP2
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Datacenter Server
Keywords: 
kbnosurvey kbarchive kbautohotfix kbhotfixserver kbqfe kbwin2ksp4fix kbbackup kbbug kbfix kboswin2000fix kbperformance kbwin2000presp4fix KB289261

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com