Task sequence fails in Configuration Manager if software updates require multiple restarts

Article ID: 2894518 - View products that this article applies to.
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Symptoms

If a Configuration Manager task sequence that uses the "Install Software Updates" step installs a software update that triggers multiple restarts after the task sequence successfully runs the Install Software Updates task, the task sequence can fail and generate the following error message:

Task Sequence environment not found

Cause

The first restart that is initiated by the software update is controlled by the task sequence. However, the second restart request is initiated by a Windows component (typically, Component-Based Servicing) and therefore is not controlled by the task sequence. Because the second restart is not controlled by the task sequence, the task sequence execution state is not saved before the restart. When the task sequence resumes after the second restart, no state is available to continue successfully.

Resolution

To resolve this issue, we recommend that you apply any updates that require dual restarts by using the usual Software Updates feature of Configuration Manager instead of using task sequences. The following software updates were reported as requiring multiple restarts. This article will be updated as more updates are reported. 
2862330 MS13-081: Description of the security update for 2862330: October 8, 2013

2771431 A servicing stack update is available for Windows 8 and Windows Server 2012

2871777 A servicing stack update is available for Windows RT, Windows 8, and Windows Server 2012: September 2013

2821895 A servicing stack update is available for Windows RT and Windows 8: June 2013
2545698 Text in some core fonts appears blurred in Internet Explorer 9 on a computer that is running Windows Vista, Windows Server 2008, Windows 7, or Windows Server 2008 R2
2529073 Binary files in some USB drivers are not updated after you install Windows 7 SP1 or Windows Server 2008 R2 SP1

More information

Because this second restart is not controlled by the task sequence, no execution state is saved before the restart. And when the task sequence resumes after the restart, no state is available to continue successfully. Additionally, the Smsts.log file may contain the following message when you experience this issue:

!sVolumeID.empty(), HRESULT=80004005
!sTSMDataPath.empty(), HRESULT=80070002
TS::Utility::GetTSMDataPath( sDataDir ), HRESULT=80070002
Failed to set log directory. Some execution history may be lost.
The system cannot find the file specified. (Error: 80070002; Source: Windows)
Executing task sequence
!sVolumeID.empty(), HRESULT=80004005
!sTSMDataPath.empty(), HRESULT=80070002
Task Sequence environment not found

Also, clients that are running releases earlier than System Center 2012 Configuration Manager Service Pack 1 may contain the following log entry:

Task sequence completed in Windows PE. 

Note The client computer may also be stuck in provisioning mode after the task sequence failure. You can determine whether the computer is in provisioning mode by checking the following registry subkey:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\CCM\CcmExec


ProvisioningMode should be set to false. If it set to true, use one of the following methods to take the client out of provisioning mode:
  • Use the Windows Management Instrumentation (WMI) method SetClientProvisioningMode to correctly take the client out of provisioning mode. The easiest way to do this is to run the following Windows PowerShell command:
    Invoke-WmiMethod -Namespace root\CCM -Class SMS_Client -Name SetClientProvisioningMode -ArgumentList $false
    Or from an elevated command prompt run the following command:

    powershell Invoke-WmiMethod -Namespace root\CCM -Class SMS_Client -Name SetClientProvisioningMode -ArgumentList $false
  • Reinstall the client.
Important Do not try to fix the client by changing the value of ProvisioningMode to false. This action will not fully take the client out of provisioning mode.
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Properties

Article ID: 2894518 - Last Review: July 8, 2014 - Revision: 10.0
Applies to
  • Windows Server 2012 R2 Standard
  • Windows Server 2012 Standard
  • Windows Server 2008 R2 Standard
  • Windows Server 2008 Standard
  • Windows 8.1
  • Windows 8
  • Windows 7 Enterprise
  • Windows 7 Professional
  • Windows Vista Business
  • Windows Vista Business 64-bit Edition
  • Windows Vista Enterprise
  • Windows Vista Enterprise 64-bit Edition
  • Microsoft System Center 2012 Configuration Manager
  • Microsoft System Center 2012 R2 Configuration Manager
  • Microsoft System Center Configuration Manager 2007 R2
  • Microsoft System Center Configuration Manager 2007
Keywords: 
KB2894518

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