How to install and use the Support.dot template in Word 2002

Article translations Article translations
Article ID: 289506 - View products that this article applies to.
This article was previously published under Q289506
Expand all | Collapse all

On This Page

SUMMARY

This article is intended to help you determine where a problem exists when you have not been able to identify or isolate your problem by other means in Microsoft Word. To find issues and articles about specific problems you may be experiencing, please query in the Microsoft Knowledge Base. To do this, see the following Microsoft Web site:
http://support.microsoft.com/default.aspx
This step-by-step article describes the Support.dot template, which includes automated methods using macros that were created by Microsoft Product Support Services. The Support.dot template is a template that contains special code (macros) to assist in troubleshooting and solving problems within Word. Three types of macros are available to assist in troubleshooting. various problems.

Macro Name Description
Troubleshoot Utility TShoot This macro can be used to troubleshoot various problems with Word. You can use the macro to rename your data key and Normal.dot file and to turn off Word add-ins.

NOTE: You must start Word with the /a switch before you run this macro.
Registry Options RegOptions This macro can be used to modify Word settings that are stored in the Windows registry.
AutoCorrect Backup AutoCorrectBackup This macro backs up your AutoCorrect list to a file. You can take this file to another computer and run the macro again to restore your AutoCorrect list.




How to Install the Support.dot Template

The Support.dot template is installed with a Complete Setup. It is not installed with a Typical or Upgrade Now Setup. If the Support.dot template is not installed, follow these steps:
  1. Quit Microsoft Word and all Microsoft Office programs.
  2. Click Start, point to Settings, and then click Control Panel.
  3. In Control Panel, double-click Add/Remove Programs.
  4. Follow the steps for your computer's operating system.
    • In Microsoft Windows 98, Microsoft Windows Millennium Edition (Me), or Microsoft Windows NT 4.0, click to select Microsoft Office XP (Microsoft Word 2002) on the Install/Uninstall tab, and then click Add/Remove.

      -or-
    • In Microsoft Windows 2000 or Microsoft Windows XP, click to select Change or Remove Programs. In the Currently installed programs list, click Microsoft Office XP (Microsoft Word 2002), and then click Change.
  5. In Microsoft Office XP Setup (Microsoft Word 2002 Setup), click to select Add or Remove Features, and then click Next.
  6. In the Features to install list, follow these steps.NOTE: Click the plus sign (+) to the left of the feature to expand it.

    1. Click to expand Microsoft Word for Windows.
    2. Click to expand Wizards and Templates.
    3. Click the icon for More Templates and Macros, and then click to select Run all from my computer on the shortcut menu.
  7. : Click the plus sign (+) to the left of the feature to expand it.Click Update to install the Support.dot template.


How to Open the Support.dot Template

To open the Support.dot template, follow these steps:
  1. On the File menu, click Open.
  2. Change the Files of type box to Document Templates (*.dot).
  3. Change the Look in box to the following folder:
    C:\Program Files\Microsoft Office\Office10\Macros\
  4. Click to select Support.dot, and then click Open.
  5. In the table contained in the file, in the Macro column, click the appropriate button to run the macro that you want. For example, click Troubleshoot Utility,Registry Options, or AutoCorrect Backup.


How to Use the Troubleshoot Utility

The Troubleshoot Utility is a macro provided by Microsoft Product Support Services. This macro can help automate the process of troubleshooting Microsoft Word problems by removing certain key components that may be damaged or that may cause a conflict with Microsoft Word. Use this utility to disable (in the order listed) the following components that are normally loaded during Word startup:
  • The Data registry key
  • The Normal.dot global template
  • Add-ins and templates
  • COM add-ins
  • The Options registry key
If any of these items is damaged or incompatible, Word may fail to start or may fail to function correctly. You can temporarily bypass these items and other items by starting Word with the /a switch.

Starting Microsoft Word with the /a Switch

To start Word by using the /a switch, follow these steps:
  1. Click Start and then click Run.
  2. In the Run dialog box, do one of the following:
    • In the Open box, type Winword.exe /a.

      -or-
    • Click Browse. Locate and select the Winword.exe file. To do this, follow these steps:
      1. In the Look in list, select the folder that contains the Word program files. Select the Winword.exe file, and then click Open.

        This step fills in the Open box in the Run dialog box.
      2. In the Open box, move the insertion point after Winword.exe.

        NOTE: The path to the Winword.exe file in the Run dialog box is enclosed in quotation marks. Be sure to move the insertion point to the right of the closing quotation mark.
      3. Type a space, and then type /a.

        The statement in the Open box should look similar to the following:
        "C:\Program Files\Microsoft Office\Office10\Winword.exe" /a
  3. In the Run dialog box, click OK.
If Word starts and operates correctly when you use the /a switch, the problem is with one of the components listed at the beginning of the "How to Use the Troubleshoot Utility" section of this article. Use the Troubleshoot Utility to determine which component is causing the problem. To use the Troubleshoot Utility, you may need to install Support.dot.

NOTE: If the problem still occurs when you start Word with the /a switch, you do not need to use the Troubleshoot Utility.

Step-by-Step: Using the Troubleshoot Utility

To isolate and remove the component that is causing the problem in Word, remove each of the following components (one at a time and in the order listed) by using the Troubleshoot Utility: Step 1: Delete the Data Registry Key

Step 2: Rename the Normal.dot Global Template

Step 3: Disable the Word Startup Folder Add-Ins

Step 4: Delete the COM Add-Ins Registry Key

Step 5: Delete the Options Registry Key

Step 1: Delete the Data Registry Key

Most frequently used options (click Options on the Tools menu) are stored in the Data key. One troubleshooting step is to delete the Data key. Word rebuilds this Data key by using the default settings the next time the program is started.

NOTE: Deleting the Data key resets several options back to their default settings, including the most recently used file list on the File menu and many settings that you customize in the Options dialog box.

To delete the Data key, follow these steps:
  1. Quit all Office programs.
  2. Start Word by using the /a switch. To start Word with the /a switch, please see the "Starting Microsoft Word with the /a Switch" section of this article.
  3. Open the Support.dot template. To do this, please see the "How to Open the Support.dot Template" section of this article.
  4. In the Support.dot template, click the Troubleshoot Utility button.
  5. In the Microsoft Word Troubleshooting Utility dialog box, in the Select an Item list, click Data Registry Key, and then click Delete.
  6. Click OK when you see the following message:
    HKEY_CURRENT_USER\Software\Microsoft Office\10.0\Word\Data
    Backup file for this registry key is present at:
    C:\WINDOWS\TEMP\wddata10.0

    Registry key has been deleted.
  7. Click Close.
  8. On the File menu, click Exit to quit Word.
  9. Start Word the way that you usually do. Do not use the procedure in the "Starting Microsoft Word with the /a Switch" section of this article.
If Word starts and functions correctly, you resolved the problem. The problem was a damaged Data registry key. You may need to change a few settings to restore your favorite options in Word.

If the problem is not resolved, restore your old Data registry key. To do this, follow these steps:
  1. Quit all Office programs.
  2. Start Word by using the /a switch. To start Word with the /a switch, please see the "Starting Microsoft Word with the /a Switch" section of this article.
  3. Open the Support.dot template. To do this, please see the "How to Open the Support.dot Template" section of this article.
  4. In the Support.dot template, click the Troubleshoot Utility button.
  5. In the Microsoft Word Troubleshooting Utility dialog box, in the Select an Item list, click Data Registry Key, and then click Restore.
  6. Click Yes when you see the following message:
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Data

    This key is present in the registry.
    Overwrite it?
  7. Click OK when you see the following message:
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Data

    Registry key restoration successful.
  8. Do one of the following:
Back to Top of Using the Troubleshoot Utility

Step 2: Rename the Normal.dot Global Template

To prevent formatting, AutoText, and macros that are stored in the global template (Normal.dot) from affecting the behavior of Word and documents that you open, rename your global template. Renaming this file allows you to quickly determine whether the global template is causing the problem.

NOTE: Renaming the Normal.dot file resets several options back to their default settings, including custom styles, custom toolbars, macros, and AutoText entries. For this reason, Microsoft strongly recommends that you do not delete your Normal.dot file.

Certain kinds of configurations can create more than one Normal.dot file. These situations include cases in which multiple versions of Word are running on the same computer, or cases in which several workstation installations exist on the same computer. In these situations, be sure to rename the correct copy of Normal.dot.

To rename the Normal.dot file, follow these steps:
  1. Quit all Office programs.
  2. Start Word by using the /a switch. To start Word with the /a switch, please see the "Starting Microsoft Word with the /a Switch" section of this article.
  3. Open the Support.dot template. To do this, please see the "How to Open the Support.dot Template" section of this article.
  4. In the Support.dot template, click the Troubleshoot Utility button.
  5. In the Microsoft Word Troubleshooting Utility dialog box, in the Select an Item list, click Normal.dot Global Template, and then click Rename.
  6. Click OK when you receive the following message:
    path\Application Data\Microsoft\Templates\Normal.dot
    Copied To
    path\Application Data\Microsoft\Templates\10Normal.dot
    NOTE: The path to your Normal.dot file may be different.
  7. Click Close to close the Microsoft Word Troubleshooting Utility dialog box.
  8. On the File menu, click Exit to quit Word.
  9. Start Word the way that you usually do. Do not use the procedure in the "Starting Microsoft Word with the /a Switch" section of this article.
If Word starts correctly, you resolved the problem. In this case, the problem is a damaged Normal.dot file. You may need to change a few settings to restore your favorite options. If the Normal.dot file that you renamed contains customizations, such as styles, macros, or AutoText entries that cannot be easily re-created, you may be able to copy those customizations from the 10Normal.dot file (your old Normal.dot) to the new Normal.dot file by using the Organizer.

For more information about using the Organizer, click Microsoft Word Help on the Help menu, type Organizer in the Office Assistant or the Answer Wizard, and then click Search to view the topics returned.

If the problem is not resolved, restore your old Normal.dot file (10Normal.dot). To do this, follow these steps:
  1. Quit all Office programs.
  2. Start Word by using the /a switch. To start Word with the /a switch, please see the "Starting Microsoft Word with the /a Switch" section of this article.
  3. Open the Support.dot template. To do this, please see the "How to Open the Support.dot Template" section of this article.
  4. In the Support.dot template, click the Troubleshoot Utility button.
  5. In the Microsoft Word Troubleshooting Utility dialog box, in the Select an Item list, click Normal.dot Global Template, and then click Restore.
  6. Click Yes when you see the following message:
    path\Application Data\Microsoft\Templates\Normal.dot

    Backup of this file already exists.

    Overwrite it?
    NOTE: The path to your Normal.dot file may be different.
  7. Click OK when you see the following message:
    path\Application Data\Microsoft\Templates\10Normal.dot
    Copied To
    path\Templates\Normal.dot
  8. Do one of the following:
Back to Top of Using the Troubleshoot Utility

Step 3: Disable the Word Startup Folder Add-Ins

When you start Word, Word automatically loads templates and add-ins that are located in the Startup folders. Errors in Word may be the result of conflicts or problems with an add-in. To determine whether an item in a Startup folder is causing the problem, you can temporarily disable the registry setting that points to these add-ins.

To temporarily disable the add-ins registry key, follow these steps:
  1. Quit all Office programs.
  2. Start Word by using the /a switch. To start Word with the /a switch, please see the "Starting Microsoft Word with the /a Switch" section of this article.
  3. Open the Support.dot template. To do this, please see the "How to Open the Support.dot Template" section of this article.
  4. In the Support.dot template, click the Troubleshoot Utility button.
  5. In the Microsoft Word Troubleshooting Utility dialog box, in the Select an Item list, click Word Startup Folder Add-Ins, and then click Rename.
  6. Do one of the following:
    • Click OK when you see the following message:
      No files found to rename/restore.
      NOTE: If you receive this message, you have no add-ins that are loaded when you start Word. After you click OK, proceed to the Step 4: Delete the COM Add-Ins Registry Key section of this article.

      -or-
    • Click OK when you see the following message:
      path\Application Data\Microsoft\Word\Startup\file name
      Copied To
      path\Application Data\Microsoft\Word\Startup\file name

      path\Program Files\Microsoft Office\Office10\Startup\file name
      Copied To
      path\Program Files\Microsoft Office\Office10\Startup\file name
      NOTE: The paths and file names on your system may be different.
  7. Click Close to close the Microsoft Word Troubleshooting Utility dialog box.
  8. On the File menu, click Exit to quit Word.
  9. Start Word the way that you usually do. Do not use the procedure in the "Starting Microsoft Word with the /a Switch" section of this article.
  10. Do one of the following:
    • If you can no longer reproduce the problem, and startup items were removed in step 6, you have determined that the problem is caused by an add-in item. To determine which startup item is causing the problem, follow these steps:
      1. Quit all Office programs.
      2. Start Word by using the /a switch. To start Word with the /a switch, please see the "Starting Microsoft Word with the /a Switch" section of this article.
      3. Open the Support.dot template. To do this, please see the "How to Open the Support.dot Template" section of this article.
      4. In the Support.dot template, click the Troubleshoot Utility button.
      5. In the Microsoft Word Troubleshooting Utility dialog box, in the Select an Item list, click Word Startup Folder Addins, and then click Restore.
      6. Click OK when you see the following message:
        path\Application Data\Microsoft\Word\Startup\file name
        Copied To
        path\Application Data\Microsoft\Word\Startup\file name

        path\Program Files\Microsoft Office\Office10\Startup\file name
        Copied To
        path\Program Files\Microsoft Office\Office10\Startup\file name
        NOTE: The paths and file names on your system may be different.
      7. Click Close to close the Microsoft Word Troubleshooting Utility dialog box.
      8. On the File menu, click Exit to quit Word.
      9. Double-click My Computer, and then open one of the folders that is specified in step f. For example:
        path\Application Data\Microsoft\Word\Startup\

        -or-

        path\Program Files\Microsoft Office\Office10\Startup\
      10. Right-click one of the files contained in the folder, and then click Rename on the shortcut menu.
      11. Type a new name for the file, and then press ENTER.

        IMPORTANT: Make a note the original name of the file, because you may need to rename the file back to its original name.
      12. Start Word the way that you usually do. Do not use the procedure in the "Starting Microsoft Word with the /a Switch" section of this article.
      If you can no longer reproduce the problem, you have found the specific add-in item that is causing the problem. If you need the features that are provided by the add-in item, you must determine which Word add-in includes the specific item and contact the vendor for an update.

      If the problem is not resolved, rename the add-in back to its original name, and then repeat steps h through i for each file in the folders that are specified in the messages shown in step f.

      -or-

    • If you can no longer reproduce the problem, you have found the specific add-in item that is causing the problem. If you need the features that are provided by the add-in item, you must determine which Word add-in includes the specific item and contact the vendor for an update. If the problem is not resolved, restore your add-in items, and then proceed to the next step. To do this, follow these steps:
      1. Quit all Office programs.
      2. Start Word by using the /a switch. To start Word with the /a switch, please see the "Starting Microsoft Word with the /a Switch" section of this article.
      3. Open the Support.dot template. To do this, please see the "How to Open the Support.dot Template" section of this article.
      4. In the Support.dot template, click the Troubleshoot Utility button.
      5. In the Microsoft Word Troubleshooting Utility dialog box, in the Select an Item list, click Word Startup Folder Addins, and then click Restore.
      6. Click OK when you see the following message:
        path\Application Data\Microsoft\Word\Startup\file name
        Copied To
        path\Application Data\Microsoft\Word\Startup\file name

        path\Program Files\Microsoft Office\Office10\Startup\file name
        Copied To
        path\Program Files\Microsoft Office\Office10\Startup\file name
        NOTE: The paths and file names on your system may be different.
      7. Proceed to the Step 4: Delete the COM Add-Ins Registry Key section of this article.
Back to Top of Using the Troubleshoot Utility

Step 4: Delete the COM Add-Ins Registry Key

COM add-ins can be installed in any location and are installed by programs that interact with Word. To remove the Windows registry settings for any COM add-ins that are installed, follow these steps:
  1. Quit all Office programs.
  2. Start Word by using the /a switch. To start Word with the /a switch, please see the "Starting Microsoft Word with the /a Switch" section of this article.
  3. Open the Support.dot template. To do this, please see the "How to Open the Support.dot Template" section of this article.
  4. In the Support.dot template, click the Troubleshoot Utility button.
  5. In the Microsoft Word Troubleshooting Utility dialog box, in the Select an Item list, click COM-Addins Registry Key, and then click Delete.
  6. Click OK when you see the following message:
    HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins
    Backup file for this registry key is present at:
    C:\Windows\TEMP\wdaddn10.0

    Registry key has been deleted.
  7. Click Close to close the Microsoft Word Troubleshooting Utility dialog box.
  8. On the File menu, click Exit to quit Word.
  9. Start Word the way you usually do. Do not use the procedure in the "Starting Microsoft Word with the /a Switch" section of this article.
  10. Do one of the following:
    • If you can no longer reproduce the problem, you have determined that a COM add-in is causing the problem. To determine which COM add-in is causing the problem, follow these steps:
      1. Quit all Office programs.
      2. Start Word by using the /a switch. To start Word with the /a switch, please see the "Starting Microsoft Word with the /a Switch" section of this article.
      3. Open the Support.dot template. To do this, please see the "How to Open the Support.dot Template" section of this article.
      4. In the Support.dot template, click the Troubleshoot Utility button.
      5. In the Microsoft Word Troubleshooting Utility dialog box, in the Select an Item list, click COM-Addins Registry Key, and then click Restore.
      6. Click OK when you see the following message:
        HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins

        Registry key restoration successful.
      7. Click Close to close the Microsoft Word Troubleshooting Utility dialog box.
      8. On the File menu, click Exit to quit Word.
      9. Start Word the way that you usually do. Do not use the procedure in the "Starting Microsoft Word with the /a Switch" section of this article.
      10. On the Tools menu, click Customize.
      11. Click the Commands tab. In the Categories list, click Tools.
      12. In the Commands list, click COM Add-Ins, and then drag the command to one of your toolbars.
      13. Click Close to close the Customize dialog box.
      14. Click the COM Add-Ins button that you just added in steps k through m.
      15. In the COM Add-Ins dialog box, if an add-in is listed, click to clear the add-in check box.

        NOTE: If more than one add-in is listed, click to clear only one add-in check box at a time, to determine which add-in is causing the problem.
      16. Click OK to close the COM Add-Ins dialog box.
      17. Click Exit on the File menu to quit Word.
      18. Start Word the way that you usually do. Do not use the procedure in the "Starting Microsoft Word with the /a Switch" section of this article.
      19. Do one of the following:
        • If you can no longer reproduce the problem, you have found the COM add-in that is causing the problem. If you need the features provided by the add-in item, you must determine which Word add-in includes the specific item and contact the vendor for an update.

          -or-
        • If the problem is not resolved, click the COM Add-Ins button that you added in steps k through m. Click to select the add-in check box that you cleared in step o. Then click to clear the check box of a different add-in, and repeat steps p through s. Repeat this procedure as many times as needed, for each add-in, until you determine which add-in is causing the problem.
      -or-

    • -or-If the problem is not resolved, restore your COM add-ins registry key, and then proceed to the next step. To do this, follow these steps:
      1. Quit all Office programs.
      2. Start Word by using the /a switch. To start Word with the /a switch, please see the "Starting Microsoft Word with the /a Switch" section of this article.
      3. Open the Support.dot template. To do this, please see the "How to Open the Support.dot Template" section of this article.
      4. In the Support.dot template, click the Troubleshoot Utility button.
      5. In the Microsoft Word Troubleshooting Utility dialog box, in the Select an Item list, click COM-Addins Registry Key, and then click Restore.
      6. Click OK when you see the following message:
        HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins

        Registry key restoration successful.
      7. Click Close to close the Microsoft Word Troubleshooting Utility dialog box.
      8. On the File menu, click Exit to quit Word.
      9. Proceed to the Step 5: Delete the Options Registry Key section of this article.
Back to Top of Using the Troubleshoot Utility

Step 5: Delete the Options Registry Key

The Options registry key stores those options that you can set from Word, either by changing menu options or by running the RegOptions macro. These are the editable options.

The settings fall into two groups: default settings and optional settings. Default settings are established during Setup, and you can change them by modifying options in Word. Optional settings are not created during Setup; to add them you must run the RegOptions macro (discussed later in this article).

To delete the Options key, follow these steps:
  1. Quit all Office programs.
  2. Start Word by using the /a switch. To start Word with the /aswitch, please see the "Starting Microsoft Word with the /a Switch" section of this article.
  3. Open the Support.dot template. To do this, please see the "How to Open the Support.dot Template" section of this article.
  4. In the Support.dot template, click the Troubleshoot Utility button.
  5. In the Microsoft Word Troubleshooting Utility dialog box, in the Select an Item list, click Options Registry Key, and then click Delete.
  6. Click OK when you see the following message:
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Options
    Backup file for this registry key is present at:
    C:\WINDOWS\TEMP\wdoptn10.0

    Registry key has been deleted.
  7. Start Word the way that you normally do. Do not use the /a switch to start Word as described in the "Starting Microsoft Word with the /a Switch" section of this article.
If Word starts correctly and functions correctly, you have resolved the problem. The problem was a damaged Options key. You may need to change a few settings to restore your favorite options in Word.

If the problem is not resolved, quit Word and then add the Options key information back to the Windows registry. To do this, follow these steps:
  1. Quit all Office programs.
  2. Start Word by using the /aswitch. To start Word with the /a switch, please see the "Starting Microsoft Word with the /a Switch" section of this article.
  3. Open the Support.dot template. To do this, please see the "How to Open the Support.dot Template" section of this article.
  4. In the Support.dot template, click the Troubleshoot Utility button, which is located in the table that is contained in the file.
  5. In the Microsoft Word Troubleshooting Utility dialog box, in the Select an Item list, click Options Registry Key, and then click Restore.
  6. Click Yes when you see the following message:
    HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Options

    This key is present in the registry.
    Overwrite it?
  7. Click OK when you see the following message:
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Options

    Registry key restoration successful.
  8. Click Close to close the Microsoft Word Troubleshooting Utility dialog box.
  9. On the File menu, click Exit to quit Word.
Back to Top of Using the Troubleshoot Utility



How to Use the Registry Options Macro

You can use the RegOptions macro to examine and make changes to Word settings in the Windows registry. The following is a list of the options that are available in the macro and a brief description of each option's purpose:
Word Options

AutoSave-Path: Sets the folder where AutoRecovery files are saved.

DOC-Path: The default folder that is used for Word documents.

Picture-Path: Sets the default path that is used when you point to Picture on the Insert menu and then click From File.

Startup-Path: Sets the path for Word startup files, such as templates and .wll files (WLLs) that are loaded when you start Word.

Tools-Path: Sets a location in which Word searches for proofing tools, filters, converters, and other components, in the event that they are not registered correctly or cannot be found.

User-Dot-Path: The path for user templates. Note that when this setting is changed for Word, the change affects all of the Microsoft Office programs.

Workgroup-Dot-Path: The path for workgroup templates. You can specify a UNC path.

BAK-Extension: The default file extension that is used for Word backup files. The default extension is *.wbk.

DOC-Extension: The default file extension that is used for Word documents. The default is *.doc.

DOT-Extension: The default file extension that is used for Word templates. The default is *.dot.

NoFontMRUList: Turns on or off the most recently used (MRU) font list. To turn on the MRU font list, type 0 (zero). To turn off the MRU font list, type 1.

SpellingWavyUnderlineColor: Allows you to control the color of the wavy underline that is displayed under misspelled words.

GrammarWavyUnderlineColor: Allows you to control the color of the wavy underline that is displayed under grammar errors.

SmartTagUnderlineColor: Allows you to control the color of the dotted underline that is displayed under smart tags.

FormatConsistencyWavyUnderlineColor: Allows you to control the color of the wavy underline that is displayed under formatting errors.

OLEDOT: Specifies the document template that is used when you create a document object within Word or another OLE application.
Equation Editor Options

Appdir: The Equation Editor program folder. Equation Editor must be installed and run once, in order for this and other Equation Editor settings to be displayed.

CustomZoom: The Custom Zoom setting. This setting only takes effect when you start Equation Editor in a separate window via the ForceOpen setting.

ForceOpen: Forces Equation Editor to open in its own separate window. Type 0 (zero) to open in place, or type 1 to open in a separate window.

ShowAll: Displays or hides nonprinting characters.

ToolBarDocked: Sets whether the toolbar is docked. Choose Yes (1) or No (0).

ToolBarDockPos: Position of the Equation Editor toolbar when it is docked. 1 sets the toolbar at the top of the Equation Editor window. 2 sets the toolbar at the bottom of the Equation Editor window.

ToolBarShown: Sets whether the toolbar is displayed. Choose Yes (1) or No (0).

ToolBarWinPos: Position of the toolbar when it is not docked, specified in X, Y coordinates, with the upper-left corner as the origin. The units are in pixels.

Zoom: The standard zoom size that is selected on the View menu.
To use the RegOptions macro, follow these steps:
  1. On the File menu, click Open.
  2. Change the Files of type box to Document Templates (*.dot).
  3. Change the Look in box to the following folder:
    C:\Program Files\Microsoft Office\Office10\Macros\
  4. Click to select Support.dot, and then click Open.
  5. In the Macro column of the table contained in the file, click the Registry Options button.
  6. On the Word Options tab or Equation Editor Options tab, click to select the option that you want to change, type the new setting in the Setting box (or click Browse, if available, and then click to select the setting that you want), and then click Change.
  7. Click Close to close the Set Registry Options dialog box.


How to Use the AutoCorrect Backup Utility

You can use the AutoCorrect Backup utility to move AutoCorrect entries between computers. For additional information about the AutoCorrect Backup utility, click the following article number to view the article in the Microsoft Knowledge Base:
269006 HOW TO: Move Word AutoCorrect Entries Between Computers in Word 2002


Advanced Users Only

The information in this section is not required when you use the macros in the Support.dot template. This information is provided only if you want to make these macros available globally in Microsoft Word, or if you want to view the macro code.



How to Make the Macros Available Globally

To make the macros available globally in Microsoft Word, use one of the following methods.

Method 1: Add to the Global Templates and Add-Ins

If you plan to use the macros occasionally (or if you want to see what the macros do before you decide to make them easily accessible), add the macro templates as global templates.

To add one of the templates listed in the "Summary" section of this article as a global template, follow these steps:
  1. On the Tools menu, click Templates and Add-Ins.
  2. Under Global Templates and Add-Ins, click Add.
  3. Change the Look in box to the folder that contains the sample macro template. In the Files of type box, select All Files (*.*).
  4. Select the sample macro template, and then click OK.
  5. After the sample macro template appears in the Templates and Add-Ins dialog box, make sure that the check box for the template is selected, and then click OK.

    IMPORTANT: When you load a template in the Global Templates and Add-Ins, the template remains loaded for the current Word session only. If you quit and then restart Word, the template is not automatically reloaded. You must reselect the template that you want to use. To do this, click Templates and Add-Ins on the Tools menu. In the Templates and Add-Ins dialog box, click to select the template that you want to use macros from, and then click OK.
  6. To run a specific macro, follow these steps:
    1. On the Tools menu, point to Macro, and then click Macros.
    2. In the Macros dialog box, change the Macros in box to the template that contains the macro that you want. For example, click to select Support.dot (global template).
    3. In the Macro name list, click to select the macro that you want, and then click Run.

Method 2: Add the Template to the Startup Folder

Move the template into the Startup folder. Microsoft Word automatically has access to any macros in templates that are placed in the following folder:
C:\Program Files\Microsoft Office\Office10\Startup
Use Microsoft Windows Explorer to place a copy of the sample macro template into the Startup folder.

When you start Word, a template located in the Startup folder is loaded as a global template, and the macros in the template are available in the Macros dialog box. A disadvantage to this method is that Word may take a little longer to start (each time Word starts, Word loads these templates globally).

To run a specific macro, follow these steps:
  1. On the Tools menu, point to Macro, and then click Macros.
  2. In the Macros dialog box, change the Macros in box to the template that contains the macro that you want. For example, click to select Support.dot (global template).
  3. In the Macro name list, click to select the macro that you want, and then click Run.

Method 3: Copy the Macro into the Normal Template

To run a specific macro without having to open its template, copy the macro into your global template (Normal.dot). To do this, follow these steps:
  1. Open the sample macro template.
  2. On the Tools menu, click Templates and Add-Ins.
  3. In the Templates and Add-Ins dialog box, click Organizer.
  4. In the Organizer dialog box, click to select the Macro Project Items tab.
  5. The macros in the sample macro template are listed on one side of the dialog box. Your global template (Normal.dot) appears open on the opposite side.

    NOTE: If your Normal.dot (global template) is not open, click Close File on the opposite side. The Close File button changes to an Open File button. Click Open File. Click to select your Normal.dot template file, and then click Open.
  6. On the sample macro template side, click to select the macro project items that are listed in the sample macro template, and then click Copy.

    NOTE: To select all of the items that are listed, hold down CTRL while you click each macro project item.
  7. Click Copy to copy the macro project items to your Normal.dot template.
  8. Click OK to close the Organizer dialog box.
  9. To run a specific macro, follow these steps:
    1. On the Tools menu, point to Macro, and then click Macros.
    2. In the Macros dialog box, change the Macros in box to the template that contains the macro that you want. For example, click to select Normal.dot (global template).
    3. In the Macro name list, click to select the macro that you want, and then click Run.


How to View the Macro Code

Microsoft provides programming examples for illustration only, without warranty either expressed or implied. This includes, but is not limited to, the implied warranties of merchantability or fitness for a particular purpose. This article assumes that you are familiar with the programming language that is being demonstrated and with the tools that are used to create and to debug procedures. Microsoft support engineers can help explain the functionality of a particular procedure, but they will not modify these examples to provide added functionality or construct procedures to meet your specific requirements. To view the macro code for a sample macro, follow these steps:
  1. On the File menu, click Open.
  2. In the Open dialog box, change the Look in box to the folder that contains the sample macro template, change the Files of type box to All Files (*.*), and then click to select the appropriate sample macro template.
  3. Hold SHIFT and click Open.
  4. On the Tools menu, point to Macro, and then click Macros.
  5. In the Macros dialog box, change the Macros in box to the sample macro template that you just opened.
  6. Select the appropriate macro, and then click Edit.

Properties

Article ID: 289506 - Last Review: July 27, 2006 - Revision: 2.2
APPLIES TO
  • Microsoft Word 2002 Standard Edition
Keywords: 
kbdta kbhowtomaster KB289506

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com