Installazione e utilizzo del modello Support.dot in Word 2002

Traduzione articoli Traduzione articoli
Identificativo articolo: 289506 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sommario

Le informazioni fornite in questo articolo possono facilitare l'identificazione dell'origine di un eventuale problema, qualora non sia stato possibile individuarlo o isolarlo con altri metodi in Microsoft Word. Per trovare informazioni e articoli su problemi specifici, effettuare una ricerca nella Microsoft Knowledge Base. A tale scopo, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/default.aspx
In questo articolo viene descritto in dettaglio il modello Support.dot nel quale sono inclusi metodi automatizzati basati sull'utilizzo di macro create dal Servizio Supporto Tecnico Clienti Microsoft. Il modello Support.dot contiene codice speciale (macro) per facilitare la risoluzione e l'eliminazione dei problemi di Word. Per facilitare la risoluzione di numerosi problemi sono disponibili tre tipi di macro.

Macro Nome Descrizione
Risoluzione dei problemi TShoot Questa macro pu˛ essere utilizzata per risolvere vari problemi riguardanti Word. Consente di rinominare la chiave Data e il modello Normal.dot e di disattivare i componenti aggiuntivi di Word.

NOTA: per eseguire questa macro Ŕ necessario avviare Word con l'opzione /a.
Opzioni del registro RegOptions Questa macro pu˛ essere utilizzata per modificare le impostazioni di Word memorizzate nel Registro di sistema di Windows.
Backup correzione autom. AutoCorrectBackup Questa macro esegue il backup dell'elenco Correzione automatica salvandolo in un file. ╚ quindi possibile trasferire il file in un altro computer ed eseguire la macro per ripristinare l'elenco dei termini inclusi nella Correzione automatica.




Installazione del modello Support.dot

Il modello Support.dot viene installato durante un'installazione Completa. Non viene invece installato quando si sceglie un'installazione Tipica o Aggiorna. Se il modello Support.dot non Ŕ installato, attenersi alla seguente procedura:
  1. Chiudere Microsoft Word e tutti i programmi di Microsoft Office.
  2. Fare clic sul pulsante Start, scegliere Impostazioni, quindi Pannello di controllo.
  3. Nel Pannello di controllo fare doppio clic su Installazione applicazioni.
  4. Attenersi alla procedura appropriata per il sistema operativo in uso.
    • In Microsoft Windows 98, Windows Millennium Edition (Me) o Windows NT 4.0 selezionare Microsoft Office XP (Microsoft Word 2002) nella scheda Installa/Rimuovi, quindi scegliere Aggiungi/Rimuovi.

      Oppure
    • In Microsoft Windows 2000 o Microsoft Windows XP selezionare Cambia/Rimuovi programmi. Nell'elenco Programmi attualmente installati fare clic su Microsoft Office XP (Microsoft Word 2002), quindi scegliere Cambia.
  5. In Installazione di Microsoft Office XP (Installazione di Microsoft Word 2002) selezionare Aggiungi/Rimuovi caratteristiche, quindi scegliere Avanti.
  6. Nell'elenco Caratteristiche da installare eseguire la procedura descritta di seguito. NOTA: fare clic sul segno pi¨ (+) a sinistra della caratteristica per espanderla.

    1. Espandere Microsoft Word per Windows.
    2. Espandere Creazioni guidate e modelli.
    3. Fare clic sull'icona Altri modelli e macro, quindi scegliere Esecuzione completa dal computer locale dal menu di scelta rapida.
  7. Fare clic sul segno pi¨ (+) a sinistra della caratteristica per espanderla. Scegliere Aggiorna per installare il modello Support.dot.


Apertura del modello Support.dot

Per aprire il modello Support.dot, attenersi alla seguente procedura:
  1. Scegliere Apri dal menu File.
  2. Nella casella Tipo file selezionare Modelli di documento (*.dot).
  3. Nella casella Cerca in passare alla seguente cartella:
    C:\Programmi\Microsoft Office\Office10\Macros\
  4. Selezionare Support.dot, quindi scegliere Apri.
  5. Nella tabella contenuta nel file, nella colonna Macro fare clic sul pulsante appropriato per eseguire la macro desiderata. Ad esempio, fare clic su Risoluzione dei problemi,Opzioni del registro, o Backup correzione autom.


Utilizzo della macro Risoluzione dei problemi

La macro Risoluzione dei problemi viene fornita dal Servizio Supporto Tecnico Clienti Microsoft. Questa macro facilita la risoluzione automatica dei problemi di Word attraverso la rimozione di determinati componenti chiave che potrebbero essere stati danneggiati o causare conflitti con Microsoft Word. Utilizzare questa utilitÓ per disattivare, nell'ordine elencato, i seguenti componenti caricati normalmente all'avvio di Word:
  • Chiave del Registro di sistema Data
  • Modello generale Normal.dot
  • Componenti aggiuntivi e modelli
  • Componenti aggiuntivi COM
  • Chiave del Registro di sistema Options
Se uno di questi componenti Ŕ danneggiato o non compatibile, Ŕ possibile che Word non venga avviato o non funzioni correttamente. ╚ possibile ignorare temporaneamente questi e altri elementi avviando Word con l'opzione /a.

Avvio di Microsoft Word con l'opzione /a

Per avviare Word con l'opzione /a, attenersi alla seguente procedura:
  1. Fare clic sul pulsante Start, quindi scegliere Esegui.
  2. Nella finestra di dialogo Esegui effettuare una delle seguenti operazioni:
    • Nella casella Apri digitare Winword.exe /a.

      Oppure
    • Fare clic su Sfoglia. Individuare e selezionare il file Winword.exe. Per effettuare questa operazione, attenersi alla seguente procedura:
      1. Nell'elenco Cerca in selezionare la cartella contenente i file di programma di Word. Selezionare il file Winword.exe, quindi scegliere Apri.

        Il nome del file verrÓ visualizzato nella casella Apri della finestra di dialogo Esegui.
      2. Nella casella Apri spostare il punto di inserimento dopo Winword.exe.

        NOTA: il percorso del file Winword.exe nella finestra di dialogo Esegui Ŕ racchiuso tra virgolette. Assicurarsi di spostare il punto di inserimento a destra delle virgolette di chiusura.
      3. Inserire uno spazio, quindi digitare /a.

        L'istruzione nella casella Apri dovrebbe essere simile alla seguente:
        "C:\Programmi\Microsoft Office\Office10\Winword.exe" /a
  3. Nella finestra di dialogo Esegui scegliere OK.
Se Word viene avviato ed eseguito correttamente utilizzando l'opzione /a, significa che il problema riguarda uno dei componenti elencati all'inizio della sezione "Utilizzo della macro Risoluzione dei problemi" in questo articolo. Utilizzare la macro Risoluzione dei problemi per determinare quale componente causa il problema. Per utilizzare questa utilitÓ, potrebbe essere necessario installare il modello Support.dot.

NOTA: se il problema persiste anche avviando Word con l'opzione /a, non Ŕ necessario utilizzare la macro Risoluzione dei problemi.

Procedura: Utilizzo della macro Risoluzione dei problemi

Per isolare e rimuovere il componente che causa il problema in Word, disinstallare ognuno dei seguenti componenti (uno alla volta nell'ordine elencato) utilizzando la macro Risoluzione dei problemi: Passaggio 1: eliminare la chiave del Registro di sistema Data

Passaggio 2: rinominare il modello generale Normal.dot

Passaggio 3: disattivare i componenti aggiuntivi della cartella Esecuzione automatica di Word

Passaggio 4: eliminare la chiave del Registro di sistema COM Add-ins

Passaggio 5: eliminare la chiave del Registro di sistema Options

Passaggio 1: eliminare la chiave del Registro di sistema Data

Le opzioni utilizzate pi¨ di frequente (scegliere Opzioni dal menu Strumenti) sono memorizzate nella chiave Data. Uno dei passaggi della risoluzione dei problemi consiste nell'eliminare la chiave Data. In questo modo, al successivo avvio dell'applicazione, la chiave Data di Word verrÓ ricreata automaticamente con le impostazioni predefinite.

NOTA: l'eliminazione della chiave Data comporta il ripristino delle impostazioni predefinite di numerose opzioni, ad esempio l'elenco dei file utilizzati di recente presente nel menu File e molte delle impostazioni personalizzate disponibili nella finestra di dialogo Opzioni.

Per eliminare la chiave Data, attenersi alla seguente procedura:
  1. Chiudere tutti i programmi di Office.
  2. Avviare Word con l'opzione /a. Per avviare Word con l'opzione /a , vedere la sezione "Avvio di Word con l'opzione /a" di questo articolo.
  3. Aprire il modello Support.dot. Per eseguire questa operazione, vedere la sezione "Apertura del modello Support.dot" di questo articolo.
  4. Nel modello Support.dot fare clic sul pulsante Risoluzione dei problemi.
  5. Nella finestra di dialogo UtilitÓ per la risoluzione dei problemi di Microsoft Word, nella casella Selezionare un elemento fare clic su Data Registry Key, quindi scegliere Elimina.
  6. Scegliere OK quando viene visualizzato il seguente messaggio:
    HKEY_CURRENT_USER\Software\Microsoft Office\10.0\Word\Data
    Il file di backup file per la chiave del Registro di sistema si trova in questa posizione:
    C:\WINDOWS\TEMP\wddata10.0.

    Chiave del Registro di sistema eliminata.
  7. Scegliere Chiudi.
  8. Scegliere Esci dal menu File per chiudere Word.
  9. Avviare normalmente Word. Non utilizzare la procedura descritta nella sezione "Avvio di Microsoft Word con l'opzione /a" di questo articolo.
Se Word viene avviato ed eseguito correttamente significa che il problema Ŕ stato risolto e che tale problema era causato dalla chiave del Registro di sistema Data danneggiata. Potrebbe essere necessario modificare alcune impostazioni per ripristinare le opzioni personalizzate in Microsoft Word.

Se il problema persiste, ripristinare la chiave Data precedente. Per effettuare questa operazione, attenersi alla seguente procedura:
  1. Chiudere tutti i programmi di Office.
  2. Avviare Word con l'opzione /a. Per avviare Word con l'opzione /a , vedere la sezione "Avvio di Word con l'opzione /a" di questo articolo.
  3. Aprire il modello Support.dot. Per eseguire questa operazione, vedere la sezione "Apertura del modello Support.dot" di questo articolo.
  4. Nel modello Support.dot fare clic sul pulsante Risoluzione dei problemi.
  5. Nella finestra di dialogo UtilitÓ per la risoluzione dei problemi di Microsoft Word, nella casella Selezionare un elemento fare clic su Data Registry Key, quindi scegliere Ripristina.
  6. Scegliere quando viene visualizzato il seguente messaggio:
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Data

    Chiave presente nel Registro di sistema.
    Sovrascriverlo?
  7. Scegliere OK quando viene visualizzato il seguente messaggio:
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Data

    Ripristino della chiave del Registro di sistema eseguito.
  8. Effettuare una delle seguenti operazioni:
Torna all'inizio di Utilizzo della macro Risoluzione dei problemi

Passaggio 2: rinominare il modello generale Normal.dot

Per impedire che la formattazione, le voci di glossario e le macro memorizzate nel modello generale Normal.dot influiscano sull'apertura di Microsoft Word e dei documenti, rinominare tale modello. La ridenominazione di questo file consente di determinare rapidamente se il problema Ŕ causato dal modello generale.

NOTA: la ridenominazione del file Normal.dot implica il ripristino delle impostazioni predefinite di numerose opzioni, compresi gli stili personalizzati, le barre degli strumenti personalizzate, le macro e le voci di glossario. Per questo motivo Microsoft consiglia di non eliminare il file Normal.dot.

Con alcuni tipi di configurazione Ŕ possibile che vengano creati pi¨ file Normal.dot, ad esempio quando nello stesso computer sono installate pi¨ versioni di Word oppure pi¨ installazioni workstation. In tali casi prestare attenzione a rinominare la copia corretta di Normal.dot.

Per rinominare il file Normal.dot, attenersi alla seguente procedura:
  1. Chiudere tutti i programmi di Office.
  2. Avviare Word con l'opzione /a. Per avviare Word con l'opzione /a , vedere la sezione "Avvio di Word con l'opzione /a" di questo articolo.
  3. Aprire il modello Support.dot. Per eseguire questa operazione, vedere la sezione "Apertura del modello Support.dot" di questo articolo.
  4. Nel modello Support.dot fare clic sul pulsante Risoluzione dei problemi.
  5. Nella finestra di dialogo UtilitÓ per la risoluzione dei problemi di Microsoft Word, nella casella Selezionare un elemento fare clic su Normal.dot Global Template, quindi scegliere Rinomina.
  6. Scegliere OK quando viene visualizzato il seguente messaggio:
    percorso\Dati applicazioni\Microsoft\Modelli\Normal.dot
    Copiato in
    percorso\Dati applicazioni\Microsoft\Templates\10Normal.dot
    NOTA: il percorso del file Normal.dot potrebbe essere diverso nel sistema in uso.
  7. Scegliere Chiudi per chiudere la finestra di dialogo UtilitÓ per la risoluzione dei problemi di Microsoft Word.
  8. Scegliere Esci dal menu File per chiudere Word.
  9. Avviare normalmente Word. Non utilizzare la procedura descritta nella sezione "Avvio di Microsoft Word con l'opzione /a" di questo articolo.
Se Word viene avviato correttamente significa che il problema Ŕ stato risolto e che tale problema era determinato da un modello Normal.dot danneggiato. Potrebbe essere necessario modificare alcune impostazioni per ripristinare le opzioni personalizzate. Se il file Normal.dot rinominato contiene personalizzazioni, quali stili, macro e voci di glossario che non Ŕ possibile ricreare facilmente, Ŕ possibile copiare tali personalizzazioni dal file 10Normal.dot, ovvero il file Normal.dot precedente, in un nuovo file Normal.dot utilizzando la Libreria.

Per ulteriori informazioni sull'utilizzo della Libreria, scegliere Guida in linea Microsoft Word dal menu ?, digitare Libreria nella casella dell'Assistente di Office o della Ricerca libera, quindi scegliere Cerca per visualizzare gli argomenti disponibili.

Se il problema persiste, ripristinare il file Normal.dot precedente, ovvero il file 10Normal.dot. Per effettuare questa operazione, attenersi alla seguente procedura:
  1. Chiudere tutti i programmi di Office.
  2. Avviare Word con l'opzione /a. Per avviare Word con l'opzione /a , vedere la sezione "Avvio di Word con l'opzione /a" di questo articolo.
  3. Aprire il modello Support.dot. Per eseguire questa operazione, vedere la sezione "Apertura del modello Support.dot" di questo articolo.
  4. Nel modello Support.dot fare clic sul pulsante Risoluzione dei problemi.
  5. Nella finestra di dialogo UtilitÓ per la risoluzione dei problemi di Microsoft Word, nella casella Selezionare un elemento fare clic su Normal.dot Global Template, quindi scegliere Ripristina.
  6. Scegliere quando viene visualizzato il seguente messaggio:
    percorso\Dati applicazioni\Microsoft\Modelli\Normal.dot

    Backup del file giÓ esistente.

    Sovrascriverlo?
    NOTA: il percorso del file Normal.dot potrebbe essere diverso nel sistema in uso.
  7. Scegliere OK quando viene visualizzato il seguente messaggio:
    percorso\Dati applicazioni\Microsoft\Modelli\10Normal.dot
    Copiato in
    percorso\Modelli\Normal.dot
  8. Effettuare una delle seguenti operazioni:
Torna all'inizio di Utilizzo della macro Risoluzione dei problemi

Passaggio 3: disattivare i componenti aggiuntivi della cartella Esecuzione automatica di Word

All'avvio di Word vengono caricati automaticamente modelli e componenti aggiuntivi presenti nella cartella Esecuzione automatica. Eventuali errori in Word possono dipendere da problemi o conflitti relativi a un componente aggiuntivo. Per determinare se uno specifico problema Ŕ causato da un elemento contenuto nella cartella Esecuzione automatica, Ŕ possibile provare a disattivare temporaneamente l'impostazione del Registro di sistema che si riferisce ai componenti aggiuntivi.

Per disattivare temporaneamente la chiave del Registro di sistema relativa ai componenti aggiuntivi, attenersi alla seguente procedura:
  1. Chiudere tutti i programmi di Office.
  2. Avviare Word con l'opzione /a. Per avviare Word con l'opzione /a , vedere la sezione "Avvio di Word con l'opzione /a" di questo articolo.
  3. Aprire il modello Support.dot. Per eseguire questa operazione, vedere la sezione "Apertura del modello Support.dot" di questo articolo.
  4. Nel modello Support.dot fare clic sul pulsante Risoluzione dei problemi.
  5. Nella finestra di dialogo UtilitÓ per la risoluzione dei problemi di Microsoft Word, nella casella Selezionare un elemento fare clic su Word Startup Folder Addins, quindi scegliere Rinomina.
  6. Effettuare una delle seguenti operazioni:
    • Scegliere OK quando viene visualizzato il seguente messaggio:
      Nessun file da rinominare/ripristinare.
      NOTA: se viene visualizzato questo messaggio significa che non esistono componenti aggiuntivi da caricare all'avvio di Word. Dopo aver scelto OK, andare al Passaggio 4: eliminare la chiave del Registro di sistema COM Add-ins di questo articolo.

      Oppure
    • Scegliere OK quando viene visualizzato il seguente messaggio:
      percorso\Dati applicazioni\Microsoft\Word\Esecuzione automatica\nome file
      Copiato in
      percorso\Dati applicazioni\Microsoft\Word\Esecuzione automatica\nome file

      percorso\Programmi\Microsoft Office\Office10\Esecuzione automatica\nome file
      Copiato in
      percorso\Programmi\Microsoft Office\Office10\Esecuzione automatica\nome file
      NOTA: i percorsi e i nomi di file potrebbero essere diversi nel sistema in uso.
  7. Scegliere Chiudi per chiudere la finestra di dialogo UtilitÓ per la risoluzione dei problemi di Microsoft Word.
  8. Scegliere Esci dal menu File per chiudere Word.
  9. Avviare normalmente Word. Non utilizzare la procedura descritta nella sezione "Avvio di Microsoft Word con l'opzione /a" di questo articolo.
  10. Effettuare una delle seguenti operazioni:
    • Se dopo avere rimosso i componenti aggiuntivi dalla cartella Esecuzione automatica seguendo la procedura descritta nel passaggio 6 il problema non si ripresenta, significa che Ŕ causato da un componente aggiuntivo. A questo punto, per individuare il componente aggiuntivo specifico all'origine del problema, attenersi alla seguente procedura:
      1. Chiudere tutti i programmi di Office.
      2. Avviare Word con l'opzione /a. Per avviare Word con l'opzione /a , vedere la sezione "Avvio di Word con l'opzione /a" di questo articolo.
      3. Aprire il modello Support.dot. Per eseguire questa operazione, vedere la sezione "Apertura del modello Support.dot" di questo articolo.
      4. Nel modello Support.dot fare clic sul pulsante Risoluzione dei problemi.
      5. Nella finestra di dialogo UtilitÓ per la risoluzione dei problemi di Microsoft Word, nella casella Selezionare un elemento fare clic su Word Startup Folder Addins, quindi scegliere Ripristina.
      6. Scegliere OK quando viene visualizzato il seguente messaggio:
        percorso\Dati applicazioni\Microsoft\Word\Esecuzione automatica\nome file
        Copiato in
        percorso\Dati applicazioni\Microsoft\Word\Esecuzione automatica\nome file

        percorso\Programmi\Microsoft Office\Office10\Esecuzione automatica\nome file
        Copiato in
        percorso\Programmi\Microsoft Office\Office10\Esecuzione automatica\nome file
        NOTA: i percorsi e i nomi di file potrebbero essere diversi nel sistema in uso.
      7. Scegliere Chiudi per chiudere la finestra di dialogo UtilitÓ per la risoluzione dei problemi di Microsoft Word.
      8. Scegliere Esci dal menu File per chiudere Word.
      9. Fare doppio clic su Risorse del computer, quindi aprire una delle cartelle specificate nel passaggio f. Ad esempio:
        percorso\Dati applicazioni\Microsoft\Word\Esecuzione automatica\

        Oppure

        percorso\Programmi\Microsoft Office\Office10\Esecuzione automatica\
      10. Fare clic con il pulsante destro del mouse su uno dei file contenuti nella cartella, quindi scegliere Rinomina dal menu di scelta rapida.
      11. Assegnare un nuovo nome al file, quindi premere INVIO.

        IMPORTANTE: prendere nota del nome originale del file, in quanto potrebbe essere necessario ripristinarlo.
      12. Avviare normalmente Word. Non utilizzare la procedura descritta nella sezione "Avvio di Microsoft Word con l'opzione /a" di questo articolo.
      Se il problema non si ripresenta, significa che Ŕ stato identificato il componente aggiuntivo specifico all'origine del problema. Qualora fosse necessario disporre delle funzionalitÓ fornite da tale componente aggiuntivo, identificare il componente aggiuntivo di Word che include l'elemento specifico e contattare il fornitore per ottenere un aggiornamento.

      Se il problema persiste, ripristinare il nome originale del componente aggiuntivo, quindi ripetere i passaggi da h a i per ciascun file presente nella cartella e specificato nei messaggi riportati al passaggio f.

      Oppure

    • Se il problema non si ripresenta, significa che Ŕ stato identificato il componente aggiuntivo specifico all'origine del problema. Qualora fosse necessario disporre delle funzionalitÓ fornite da tale componente aggiuntivo, identificare il componente aggiuntivo di Word che include l'elemento specifico e contattare il fornitore per ottenere un aggiornamento. Se il problema persiste, ripristinare i componenti aggiuntivi, quindi procedere al passaggio successivo. Per effettuare questa operazione, attenersi alla seguente procedura:
      1. Chiudere tutti i programmi di Office.
      2. Avviare Word con l'opzione /a. Per avviare Word con l'opzione /a , vedere la sezione "Avvio di Word con l'opzione /a" di questo articolo.
      3. Aprire il modello Support.dot. Per eseguire questa operazione, vedere la sezione "Apertura del modello Support.dot" di questo articolo.
      4. Nel modello Support.dot fare clic sul pulsante Risoluzione dei problemi.
      5. Nella finestra di dialogo UtilitÓ per la risoluzione dei problemi di Microsoft Word, nella casella Selezionare un elemento fare clic su Word Startup Folder Addins, quindi scegliere Ripristina.
      6. Scegliere OK quando viene visualizzato il seguente messaggio:
        percorso\Dati applicazioni\Microsoft\Word\Esecuzione automatica\nome file
        Copiato in
        percorso\Dati applicazioni\Microsoft\Word\Esecuzione automatica\nome file

        percorso\Programmi\Microsoft Office\Office10\Esecuzione automatica\nome file
        Copiato in
        percorso\Programmi\Microsoft Office\Office10\Esecuzione automatica\nome file
        NOTA: i percorsi e i nomi di file potrebbero essere diversi nel sistema in uso.
      7. Andare al Passaggio 4: eliminare la chiave del Registro di sistema COM Add-ins di questo articolo.
Torna all'inizio di Utilizzo della macro Risoluzione dei problemi

Passaggio 4: eliminare la chiave del Registro di sistema COM Add-Ins

I componenti aggiuntivi COM possono essere installati in qualunque posizione da qualsiasi programma che interagisce con Word. Per rimuovere dal Registro di sistema di Windows le impostazioni relative a tutti i componenti aggiuntivi COM installati, attenersi alla seguente procedura:
  1. Chiudere tutti i programmi di Office.
  2. Avviare Word con l'opzione /a. Per avviare Word con l'opzione /a , vedere la sezione "Avvio di Word con l'opzione /a" di questo articolo.
  3. Aprire il modello Support.dot. Per eseguire questa operazione, vedere la sezione "Apertura del modello Support.dot" di questo articolo.
  4. Nel modello Support.dot fare clic sul pulsante Risoluzione dei problemi.
  5. Nella finestra di dialogo UtilitÓ per la risoluzione dei problemi di Microsoft Word, nella casella Selezionare un elemento fare clic su COM-Addins Registry Key, quindi scegliere Elimina.
  6. Scegliere OK quando viene visualizzato il seguente messaggio:
    HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins
    Il file di backup per la chiave del Registro di sistema si trova in questa posizione:
    C:\Windows\TEMP\wdaddn10.0

    Chiave del Registro di sistema eliminata.
  7. Scegliere Chiudi per chiudere la finestra di dialogo UtilitÓ per la risoluzione dei problemi di Microsoft Word.
  8. Scegliere Esci dal menu File per chiudere Word.
  9. Avviare normalmente Word. Non utilizzare la procedura descritta nella sezione "Avvio di Microsoft Word con l'opzione /a" di questo articolo.
  10. Effettuare una delle seguenti operazioni:
    • Se il problema non si ripresenta, significa che Ŕ causato da un componente aggiuntivo COM. Per individuare il componente aggiuntivo COM specifico all'origine del problema, attenersi alla seguente procedura:
      1. Chiudere tutti i programmi di Office.
      2. Avviare Word con l'opzione /a. Per avviare Word con l'opzione /a , vedere la sezione "Avvio di Word con l'opzione /a" di questo articolo.
      3. Aprire il modello Support.dot. Per eseguire questa operazione, vedere la sezione "Apertura del modello Support.dot" di questo articolo.
      4. Nel modello Support.dot fare clic sul pulsante Risoluzione dei problemi.
      5. Nella finestra di dialogo UtilitÓ per la risoluzione dei problemi di Microsoft Word, nella casella Selezionare un elemento fare clic su COM-Addins Registry Key, quindi scegliere Ripristina.
      6. Scegliere OK quando viene visualizzato il seguente messaggio:
        HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins

        Ripristino della chiave del Registro di sistema eseguito.
      7. Scegliere Chiudi per chiudere la finestra di dialogo UtilitÓ per la risoluzione dei problemi di Microsoft Word.
      8. Scegliere Esci dal menu File per chiudere Word.
      9. Avviare normalmente Word. Non utilizzare la procedura descritta nella sezione "Avvio di Microsoft Word con l'opzione /a" di questo articolo.
      10. Scegliere Personalizza dal menu Strumenti.
      11. Scegliere la scheda Comandi. Nell'elenco Categorie fare clic su Strumenti.
      12. Nell'elenco Comandi fare clic su Componenti aggiuntivi COM, quindi trascinare il comando su una delle barre degli strumenti.
      13. Scegliere Chiudi per chiudere la finestra di dialogo Personalizza.
      14. Fare clic sul pulsante Componenti aggiuntivi COM aggiunto nei passaggi da k a m.
      15. Se nella finestra di dialogo Componenti aggiuntivi COM Ŕ elencato un unico componente aggiuntivo, fare clic per deselezionare la relativa casella di controllo.

        NOTA: se sono elencati pi¨ componenti aggiuntivi, deselezionare una sola casella di controllo alla volta, in modo da poter determinare il componente aggiuntivo all'origine del problema.
      16. Scegliere OK per chiudere la finestra di dialogo Componenti aggiuntivi COM.
      17. Scegliere Esci dal menu File per chiudere Word.
      18. Avviare normalmente Word. Non utilizzare la procedura descritta nella sezione "Avvio di Microsoft Word con l'opzione /a" di questo articolo.
      19. Effettuare una delle seguenti operazioni:
        • Se il problema non si ripresenta, significa che Ŕ stato identificato il componente aggiuntivo COM specifico all'origine del problema. Qualora fosse necessario disporre delle funzionalitÓ fornite da tale componente aggiuntivo, identificare il componente aggiuntivo di Word che include l'elemento specifico e contattare il fornitore per ottenere un aggiornamento.

          Oppure
        • Se il problema persiste, fare clic sul pulsante Componenti aggiuntivi COM aggiunto nei passaggi da k a m. Fare clic per selezionare la casella di controllo del componente aggiuntivo deselezionata nel passaggio o, deselezionare quella relativa a un diverso componente aggiuntivo e ripetere i passaggi da p a s. Ripetere la stessa procedura per ciascun componente aggiuntivo, finchÚ non verrÓ identificato quello all'origine del problema.
      Oppure

    • Se il problema persiste, ripristinare la chiave del Registro di sistema COM Add-ins e procedere al passaggio successivo Per effettuare questa operazione, attenersi alla seguente procedura:
      1. Chiudere tutti i programmi di Office.
      2. Avviare Word con l'opzione /a. Per avviare Word con l'opzione /a , vedere la sezione "Avvio di Word con l'opzione /a" di questo articolo.
      3. Aprire il modello Support.dot. Per eseguire questa operazione, vedere la sezione "Apertura del modello Support.dot" di questo articolo.
      4. Nel modello Support.dot fare clic sul pulsante Risoluzione dei problemi.
      5. Nella finestra di dialogo UtilitÓ per la risoluzione dei problemi di Microsoft Word, nella casella Selezionare un elemento fare clic su COM-Addins Registry Key, quindi scegliere Ripristina.
      6. Scegliere OK quando viene visualizzato il seguente messaggio:
        HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins

        Ripristino della chiave del Registro di sistema eseguito.
      7. Scegliere Chiudi per chiudere la finestra di dialogo UtilitÓ per la risoluzione dei problemi di Microsoft Word.
      8. Scegliere Esci dal menu File per chiudere Word.
      9. Andare al Passaggio 5: eliminare la chiave del Registro di sistema Options di questo articolo.
Torna all'inizio di Utilizzo della macro Risoluzione dei problemi

Passaggio 5: eliminare la chiave del Registro di sistema Options

Nella chiave del Registro di sistema Options vengono memorizzate le varie opzioni modificabili che Ŕ possibile impostare da Word cambiando le opzioni di menu o eseguendo la macro RegOptions. Si tratta delle opzioni modificabili.

Le impostazioni rientrano in due gruppi: predefinite e facoltative. Le impostazioni predefinite sono quelle definite durante l'installazione e possono essere modificate cambiando le opzioni in Word. Le impostazioni facoltative non vengono create durante l'installazione e vengono aggiunte eseguendo la macro RegOptions, descritta pi¨ avanti.

Per eliminare la chiave Options, attenersi alla seguente procedura:
  1. Chiudere tutti i programmi di Office.
  2. Avviare Word con l'opzione /a. Per avviare Word con l'opzione /a , vedere la sezione "Avvio di Word con l'opzione /a" di questo articolo.
  3. Aprire il modello Support.dot. Per eseguire questa operazione, vedere la sezione "Apertura del modello Support.dot" di questo articolo.
  4. Nel modello Support.dot fare clic sul pulsante Risoluzione dei problemi.
  5. Nella finestra di dialogo UtilitÓ per la risoluzione dei problemi di Microsoft Word, nella casella Selezionare un elemento fare clic su Options Registry Key, quindi scegliere Elimina.
  6. Scegliere OK quando viene visualizzato il seguente messaggio:
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Options
    Il file di backup per la chiave del Registro di sistema si trova in questa posizione:
    C:\WINDOWS\TEMP\wdoptn10.0

    Chiave del Registro di sistema eliminata.
  7. Avviare normalmente Word. Non utilizzare l'opzione /a per avviare Word come descritto nella sezione "Avvio di Word con l'opzione /a" di questo articolo.
Se Word viene avviato ed eseguito correttamente, il problema Ŕ stato risolto e dipendeva da una chiave Options danneggiata. Potrebbe essere necessario modificare alcune impostazioni per ripristinare le opzioni personalizzate in Microsoft Word.

Se il problema non Ŕ stato risolto, chiudere Microsoft Word e aggiungere nuovamente le informazioni della chiave Options nel Registro di sistema di Windows. Per effettuare questa operazione, attenersi alla seguente procedura:
  1. Chiudere tutti i programmi di Office.
  2. Avviare Word con l'opzione /a. Per avviare Word con l'opzione /a , vedere la sezione "Avvio di Word con l'opzione /a" di questo articolo.
  3. Aprire il modello Support.dot. Per eseguire questa operazione, vedere la sezione "Apertura del modello Support.dot" di questo articolo.
  4. Nel modello Support.dot fare clic sul pulsante Risoluzione dei problemi che si trova nella tabella contenuta nel file.
  5. Nella finestra di dialogo UtilitÓ per la risoluzione dei problemi di Microsoft Word, nella casella Selezionare un elemento fare clic su Options Registry Key, quindi scegliere Ripristina.
  6. Scegliere quando viene visualizzato il seguente messaggio:
    HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Options

    Chiave presente nel Registro di sistema.
    Sovrascriverlo?
  7. Scegliere OK quando viene visualizzato il seguente messaggio:
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Options

    Ripristino della chiave del Registro di sistema eseguito.
  8. Scegliere Chiudi per chiudere la finestra di dialogo UtilitÓ per la risoluzione dei problemi di Microsoft Word.
  9. Scegliere Esci dal menu File per chiudere Word.
Torna all'inizio di Utilizzo della macro Risoluzione dei problemi



Utilizzo della macro Opzioni del registro

Per esaminare e apportare modifiche alle impostazioni di Word nel Registro di sistema di Windows Ŕ possibile utilizzare la macro RegOptions. Di seguito Ŕ riportato un elenco di tutte le opzioni disponibili nella macro con una breve descrizione del relativo scopo.
Opzioni di Word

AutoSave-Path: consente di impostare la cartella in cui vengono salvati i file del salvataggio automatico.

DOC-Path: consente di specificare la cartella predefinita utilizzata per i documenti di Word.

Picture-Path: consente di impostare il percorso predefinito utilizzato quando si sceglie Immagine dal menu Inserisci e si fa clic su Da file.

Startup-Path: consente di impostare il percorso per i file di avvio di Word, come i modelli e i file WLL che vengono caricati quando si avvia Word.

Tools-Path: consente di impostare il percorso in cui viene effettuata la ricerca di strumenti di correzione, filtri, convertitori e altri componenti, nel caso in cui non siano stati registrati correttamente o non vengano trovati.

User-Dot-Path: consente di specificare il percorso per i modelli dell'utente. Quando si modifica questa impostazione per Word, la modifica influisce anche su tutti gli altri programmi di Microsoft Office.

Workgroup-Dot-Path: consente di specificare il percorso dei modelli per gruppi di lavoro. ╚ possibile specificare un percorso UNC.

BAK-Extension: Ŕ l'estensione file predefinita che viene utilizzata per i file di backup di Word. L'estensione predefinita Ŕ wbk.

DOC-Extension: Ŕ l'estensione file predefinita che viene utilizzata per i documenti di Word. L'estensione predefinita Ŕ doc.

DOT-Extension: Ŕ l'estensione file predefinita che viene utilizzata per i modelli di Word. L'estensione predefinita Ŕ dot.

NoFontMRUList: consente di attivare o disattivare l'elenco dei tipi di carattere utilizzati pi¨ di recente. Per attivare l'elenco dei tipi di carattere utilizzati pi¨ di recente, digitare 0 (zero). Per disattivare l'elenco dei tipi di carattere utilizzati pi¨ di recente, digitare 1.

SpellingWavyUnderlineColor: consente di controllare il colore della sottolineatura ondulata visualizzata sotto le parole con errori di ortografia.

GrammarWavyUnderlineColor: consente di controllare il colore della sottolineatura ondulata visualizzata sotto gli errori grammaticali.

SmartTagUnderlineColor: consente di controllare il colore della sottolineatura tratteggiata visualizzata sotto gli smart tag.

FormatConsistencyWavyUnderlineColor: consente di controllare il colore della sottolineatura ondulata visualizzata sotto gli errori di formattazione.

OLEDOT: consente di specificare il modello di documento utilizzato durante la creazione di un oggetto documento in Word o in un'altra applicazione OLE.
Opzioni di Equation Editor

Appdir: consente di specificare la cartella del programma Equation Editor. Per consentire la visualizzazione di questa e altre impostazioni di Equation Editor, Ŕ necessario che il programma sia installato ed eseguito una volta.

CustomZoom: consente di specificare l'impostazione Personalizza zoom. Diventa attiva solo quando Equation Editor viene avviato in una finestra distinta tramite l'impostazione ForceOpen.

ForceOpen: consente di imporre l'apertura di Equation Editor in una finestra distinta. Digitare 0 (zero) per aprire il programma nella stessa finestra oppure digitare 1 per aprirlo in una finestra distinta.

ShowAll: consente di visualizzare o nascondere i caratteri non stampabili.

ToolBarDocked: consente di specificare se la barra degli strumenti Ŕ ancorata. Scegliere Sý (1) o No (0).

ToolBarDockPos: consente di specificare la posizione della barra degli strumenti di Equation Editor quando Ŕ ancorata. 1 posiziona la barra degli strumenti nella parte superiore della finestra di Equation Editor. 2 posiziona la barra degli strumenti nella parte inferiore della finestra di Equation Editor.

ToolBarShown: consente di specificare se la barra degli strumenti viene visualizzata. Scegliere Sý (1) o No (0).

ToolBarWinPos: corrisponde alla la posizione della barra degli strumenti quando Ŕ ancorata, in base alle coordinate X e Y con l'angolo superiore sinistro come origine. Le unitÓ di misura sono in pixel.

Zoom: consente di specificare la dimensione standard dello zoom scelta dal menu Visualizza.
Per utilizzare la macro RegOptions, attenersi alla seguente procedura:
  1. Scegliere Apri dal menu File.
  2. Nella casella Tipo file selezionare Modelli di documento (*.dot).
  3. Nella casella Cerca in passare alla seguente cartella
    C:\Programmi\Microsoft Office\Office10\Macros\
  4. Selezionare Support.dot, quindi scegliere Apri.
  5. Nella colonna Macro della tabella contenuta nel file fare clic sul pulsante Opzioni del registro.
  6. Nella scheda Opzioni di Word o Opzioni di Equation Editor fare clic sull'opzione che si desidera modificare, digitare la nuova impostazione nella casella Impostazione (o scegliere Sfoglia, se disponibile, e fare clic sull'impostazione desiderata), quindi scegliere Cambia.
  7. Fare clic su Chiudi per chiudere la finestra di dialogo Impostazione opzioni del registro di configurazione.


Utilizzo della macro Backup correzione automatica

╚ possibile utilizzare l'utilitÓ Backup correzione automatica per spostare le voci della Correzione automatica tra computer. Per ulteriori informazioni sull'utilitÓ Backup correzione automatica, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
269006 WD2002: Spostamento delle voci di Correzione automatica di Word da un computer a un altro


Solo utenti avanzati

Le informazioni in questa sezione non sono necessarie se si utilizzano le macro contenute nel modello Support.dot. Queste informazioni vengono fornite solo se si desidera rendere disponibili queste macro a livello generale in Microsoft Word oppure per visualizzare il codice delle macro.



DisponibilitÓ generale delle macro

Per rendere le macro di esempio disponibili a livello generale in Microsoft Word, utilizzare uno dei metodi descritti di seguito.

Metodo 1: Aggiunta delle macro a Modelli e aggiunte generali

Se si prevede di utilizzare le macro saltuariamente oppure se si desidera verificarne il funzionamento prima di decidere se renderle facilmente accessibili, aggiungere i modelli di macro ai modelli generali.

Per aggiungere uno dei modelli elencati nella sezione "Sommario" di questo articolo come modello generale, attenersi alla seguente procedura:
  1. Scegliere Modelli e aggiunte dal menu Strumenti.
  2. In Modelli e aggiunte generali scegliere Aggiungi.
  3. Nella casella Cerca in passare alla cartella contenente il modello di macro di esempio. Nella casella Tipo file selezionare Tutti i file (*.*).
  4. Selezionare il modello di macro di esempio, quindi scegliere OK.
  5. Dopo che il modello di macro di esempio sarÓ visualizzato nella finestra di dialogo Modelli e aggiunte, controllare che la casella di controllo del modello sia selezionata, quindi scegliere OK.

    IMPORTANTE: quando si carica un modello in Modelli e aggiunte generali, il modello rimane caricato solo per la sessione corrente di Word. Se si chiude e si riavvia Word, il modello non viene ricaricato automaticamente. ╚ quindi necessario selezionare di nuovo il modello che si desidera utilizzare. A tale fine, scegliere Modelli e aggiunte dal menu Strumenti. Nella finestra di dialogo Modelli e aggiunte selezionare il modello dal quale si desidera utilizzare le macro, quindi scegliere OK.
  6. Per eseguire una macro particolare, attenersi alla seguente procedura:
    1. Scegliere Macro dal menu Strumenti, quindi fare clic su Macro.
    2. Nella finestra di dialogo Macro impostare il modello contenente le macro desiderate nella casella Macro in. Ad esempio, selezionare Support.dot (modello generale).
    3. Nella casella Nome macro selezionare la macro desiderata, quindi fare clic su Esegui.

Metodo 2: Aggiunta del modello alla cartella Esecuzione automatica

Spostare il modello nella cartella Esecuzione automatica. L'accesso alle macro contenute nei modelli inseriti nella seguente cartella avviene automaticamente:
C:\Programmi\Microsoft Office\Office10\Startup
Per inserire una copia del modello di macro di esempio nella cartella Esecuzione automatica utilizzare Esplora risorse di Microsoft Windows.

Quando si avvia Word, il modello contenuto nella cartella Esecuzione automatica viene caricato come modello generale e le macro contenute nel modello sono disponibili nella finestra di dialogo Macro. Uno svantaggio che deriva dall'applicazione di questo metodo Ŕ il fatto che l'avvio di Word pu˛ richiedere qualche istante in pi¨, perchÚ ogni volta che si avvia l'applicazione vengono caricati anche questi modelli.

Per eseguire una macro particolare, attenersi alla seguente procedura:
  1. Scegliere Macro dal menu Strumenti, quindi fare clic su Macro.
  2. Nella finestra di dialogo Macro impostare il modello contenente le macro desiderate nella casella Macro in. Ad esempio, selezionare Support.dot (modello generale).
  3. Nella casella Nome macro selezionare la macro desiderata, quindi fare clic su Esegui.

Metodo 3: Copia della macro nel modello Normal

Per eseguire una macro particolare senza aprire il relativo modello, copiare la macro nel modello generale (Normal.dot). Per effettuare questa operazione, attenersi alla seguente procedura:
  1. Aprire il modello di macro di esempio.
  2. Scegliere Modelli e aggiunte dal menu Strumenti.
  3. Nella finestra di dialogo Modelli e aggiunte fare clic su Libreria.
  4. Nella finestra di dialogo Libreria scegliere la scheda Macro.
  5. Le macro contenute nel modello di macro di esempio sono elencate in un lato della finestra di dialogo, mentre il modello generale (Normal.dot) viene visualizzato nell'altro lato.

    NOTA: se il modello Normal.dot (modello generale) non Ŕ aperto, fare clic su Chiudi file nel lato opposto. L'etichetta del pulsante Chiudi file diventa Apri file. Scegliere Apri file. Selezionare il file del modello Normal.dot, quindi scegliere Apri.
  6. Nel lato della finestra in cui Ŕ elencato il modello di macro di esempio selezionare le macro contenute nel modello, quindi scegliere Copia.

    NOTA: per selezionare tutte le macro, tenere premuto CTRL e fare clic sulle singole macro.
  7. Scegliere Copia per copiare le macro nel modello Normal.dot.
  8. Scegliere OK per chiudere la finestra di dialogo Libreria.
  9. Per eseguire una macro particolare, attenersi alla seguente procedura:
    1. Scegliere Macro dal menu Strumenti, quindi fare clic su Macro.
    2. Nella finestra di dialogo Macro impostare il modello contenente le macro desiderate nella casella Macro in. Ad esempio, selezionare Normal.dot (modello generale).
    3. Nella casella Nome macro selezionare la macro desiderata, quindi fare clic su Esegui.


Visualizzazione del codice delle macro

Microsoft fornisce esempi di programmazione a scopo puramente illustrativo, senza alcuna garanzia di qualsiasi tipo, sia espressa che implicita, ivi incluse, senza limitazioni, le garanzie implicite di commerciabilitÓ o idoneitÓ per uno scopo particolare. In questo articolo si presume che l'utente conosca il linguaggio di programmazione in questione e gli strumenti utilizzati per creare ed eseguire il debug delle procedure. Gli esperti Microsoft sono autorizzati a fornire spiegazioni in merito alla funzionalitÓ di una particolare procedura, ma in nessun caso a modificare questi esempi per fornire funzionalitÓ aggiuntive o a creare procedure atte a soddisfare specifiche esigenze. Per visualizzare il codice di una macro di esempio, attenersi alla seguente procedura:
  1. Scegliere Apri dal menu File.
  2. Nella casella Cerca in della finestra di dialogo Apri passare alla cartella contenente il modello di macro di esempio. Nella casella Tipo file selezionare Tutti i file (*.*), quindi selezionare il modello di macro di esempio corretto.
  3. Tenere premuto MAIUSC e scegliere Apri.
  4. Scegliere Macro dal menu Strumenti, quindi fare clic su Macro.
  5. Nella finestra di dialogo Macro selezionare il modello di macro di esempio che Ŕ appena stato aperto nella casella Macro in.
  6. Selezionare la macro appropriata e scegliere Modifica.

ProprietÓ

Identificativo articolo: 289506 - Ultima modifica: venerdý 25 agosto 2006 - Revisione: 2.1
Le informazioni in questo articolo si applicano a
  • Microsoft Word 2002 Standard Edition
Chiavi:á
kbdta kbhowtomaster KB289506
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com