Jak nainstalovat a používat šablonu Support.dot v aplikaci Word 2002 (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)

Překlady článku Překlady článku
ID článku: 289506 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Souhrn

Tento článek je určen jinými prostředky v aplikaci Word vám pomohou určit, kde existuje problém při nebyl schopen identifikovat nebo izolovat problém. Vyhledat problémy a články týkající se konkrétních potíží může docházet k dotazu v Knowledge Base. Chcete-li to provést, naleznete na následujícím webu:
http://support.microsoft.com/default.aspx
Tento podrobný článek popisuje šablony Support.dot, která obsahuje makra, které byly vytvořeny odbornou pomocí automatické metody. Šablony obsahuje speciální kód (makra) k pomoci při řešení potíží a řešení problémů v aplikaci Word je šablona Support.dot. Tři typy makra jsou k dispozici pomoci při řešení potíží. různé problémy.

Macro Name Description
Troubleshoot Utility TShoot This macro can be used to troubleshoot various problems with Word. You can use the macro to rename your data key and Normal.dot file and to turn off Word add-ins.

NOTE: You must start Word with the /a switch before you run this macro.
Registry Options RegOptions This macro can be used to modify Word settings that are stored in the Windows registry.
AutoCorrect Backup AutoCorrectBackup This macro backs up your AutoCorrect list to a file. You can take this file to another computer and run the macro again to restore your AutoCorrect list.




Jak nainstalovat šablony Support.dot

Šablony Support.dot je nainstalován s instalací Dokončeno. Není nainstalován s Typické nebo Upgrade nyní nastavení. Pokud šablony Support.dot není nainstalována, postupujte takto:
  1. Ukončete aplikace a Microsoft Office všechny programy.
  2. Klepněte na tlačítko Start, přejděte na příkaz Nastavení a klepněte na položku Ovládací panely.
  3. V Ovládacích panelech poklepejte na ikonu Grafem.@je programy.
  4. Postupujte podle pokynů pro operační systém počítače.
    • V systému Windows 98, Microsoft Windows Millennium Edition (ME) nebo Windows NT 4.0 klepněte na položku Microsoft Office XP (Microsoft Word 2002) kartě a poté klepněte na tlačítko Přidat nebo odebrat.

      Nebo
    • V systému Windows 2000 nebo Microsoft Windows XP klepnutím vyberte změnit nebo odebrat programy. V seznamu nainstalovaných programů klepněte na tlačítko Microsoft Office XP (Microsoft Word 2002) a potom klepněte na tlačítko změnit.
  5. V Instalaci Microsoft Office XP (Instalace Microsoft Word 2002) klepnutím vyberte Přidat či odebrat funkce a potom klepněte na tlačítko Další.
  6. V seznamu instalované postupujte takto. Poznámka: Klepnutím na znaménko plus (+) vlevo funkce rozbalte ji.

    1. Klepnutím rozbalte položku Microsoft Word pro Windows.
    2. Klepnutím rozbalte položku Průvodci a šablony.
    3. Klepněte na ikonu Další šablony a makra a klepnutím vyberte položku Spouštět vše z tohoto počítače v místní nabídce.
  7. : Klepněte na znaménko plus (+) vlevo funkce rozbalte it.Click Update nainstalujte šablonu Support.dot.


Jak otevřít šablonu Support.dot

Otevřete šablonu Support.dot, postupujte takto:
  1. V nabídce soubor klepněte na tlačítko Otevřít.
  2. Změnit Typ souboru políčka šablony (* .dot).
  3. Změna pole oblast následující složce:
    C:\Program Files\Microsoft Office\Office10\Macros\
  4. Klepnutím vyberte support.dot a potom klepněte na tlačítko Otevřít.
  5. V tabulce obsažené v souboru ve sloupci makra klepněte na příslušné tlačítko, které chcete makro spustit. Klepněte například na položku Troubleshoot Utility,Registry Options,Nebo AutoCorrect Backup.


Jak použít Poradce

Poradce při potížích je makro poskytované produktů odborné. Toto makro může pomoci automatizují proces potíží aplikace odebráním určitých klíčových součástí, které mohou být poškozeny nebo mohou způsobit konflikt s aplikací Microsoft Word. Tento nástroj slouží k zakázání (v uvedeném pořadí), které jsou obvykle načteny při spuštění Word následující součásti:
  • Klíč registru data
  • Globální šablona Normal.dot
  • Doplňky a šablony
  • Doplňky modelu COM
  • Klíč registru Options
Pokud tyto položky je poškozený nebo nekompatibilní, Word může spuštění selhat nebo může selhat fungovat správně. Tyto položky a jiné můžete dočasně obejít spuštěním Word s přepínačem /a.

Spuštění aplikace pomocí přepínače /a

Začněte použití přepínače /, postupujte takto:
  1. Klepněte na tlačítko Start a potom klepněte na příkaz Spustit.
  2. V dialogovém okně Spustit proveďte jednu z následujících akcí:
    • Do pole Otevřít zadejte Winword.exe /a.

      Nebo
    • Klepněte na tlačítko Procházet. Vyhledejte a vyberte soubor Winword.exe. Postupujte takto:
      1. V seznamu Oblast hledání vyberte složku obsahující soubory programu Word. Vyberte soubor Winword.exe a klepněte na tlačítko Otevřít.

        Tento krok se vyplní pole Otevřít v dialogovém okně Spustit.
      2. Do pole Otevřít přesunout kurzor po Winword.exe.

        Poznámka: cesta k souboru Winword.exe v dialogovém okně Spustit uzavřený v uvozovkách. Nezapomeňte přesunout kurzor vpravo od uzavírací uvozovky.
      3. Zadejte mezeru a zadejte /a.

        Příkaz v poli Otevřít by měl vypadat podobná následující:
        "C:\Program Files\Microsoft Office\Office10\Winword.exe" /a
  3. V dialogovém okně Spustit klepněte na tlačítko OK.
Pokud aplikace spustí a použijete přepínač /a funguje správně, je problém s součásti uvedené na začátku "Jak k použití Poradce nástroj" části tohoto článku. Pomocí nástroje Poradce určit, které součásti je příčinou problému. Použití Poradce při potížích, může být nutné nainstalovat support.dot.

Poznámka: Pokud stále dochází k problému, při spuštění aplikace Word s přepínačem /a, není nutné použít Poradce při potížích.

Podrobný: Použití Poradce

Chcete-li izolovat a odebrat komponentu, která způsobuje potíže v aplikaci Word, odebrat všechny následující součásti (jeden současně a v uvedeném pořadí) pomocí nástroje Poradce: Step 1: Delete the Data Registry Key

Step 2: Rename the Normal.dot Global Template

Step 3: Disable the Word Startup Folder Add-Ins

Step 4: Delete the COM Add-Ins Registry Key

Step 5: Delete the Options Registry Key

Krok 1: Odstranit klíč registru data

Nejčastěji používané možnosti (v nabídce Nástroje klepněte na příkaz Možnosti) jsou uloženy v klíč data. Jeden krok řešení potíží je odstranění klíče data. Pomocí výchozího nastavení při příštím spuštění programu Word znovu sestaví klíč tohoto data.

Poznámka: odstranění klíče obnoví data zpět na jejich výchozí nastavení několik možností včetně naposledy použit seznam souborů v nabídce soubor a mnoho nastavení přizpůsobit v dialogovém okně Možnosti.

Klíč data odstranit, postupujte takto:
  1. Ukončete všechny aplikace systému Office.
  2. Začněte použití přepínače /. Ke spuštění aplikace Word s přepínačem /a, naleznete "Starting Microsoft Word with the /a Switch"části tohoto článku.
  3. Otevřete šablonu Support.dot. Chcete-li to provést, naleznete "How to Open the Support.dot Template"části tohoto článku.
  4. V šabloně Support.dot klepněte na tlačítko Poradce při potížích.
  5. V Microsoft Word odstraňování nástroj dialogové okno, v seznamu Vyberte položku, klepněte na Klíč registru data a klepněte na příkaz Odstranit.
  6. Po zobrazení následující zprávy klepněte na tlačítko OK:
    HKEY_CURRENT_USER\Software\Microsoft Office\10.0\Word\Data
    Záložní soubor tohoto klíče registru se nalézá v následujícím umístění:
    C:\WINDOWS\TEMP\wddata10.0

    Klíč registru byl odstraněn.
  7. Klepněte na tlačítko Zavřít.
  8. V nabídce soubor klepněte na příkaz Konec ukončete aplikaci Word.
  9. Spuštění obvykle způsobem. Proveďte není použití postupu v tomto článku v části "Spuštění aplikace s /a přepnout".
Pokud aplikace spustí a správně funguje, problém vyřešen. Potíže způsoboval poškozený klíč registru data. Potřebujete změnit několik nastavení obnovit svoje oblíbené možnosti v aplikaci Word.

Pokud problém není vyřešen, obnovte původní klíč registru data. Postupujte takto:
  1. Ukončete všechny aplikace systému Office.
  2. Začněte použití přepínače /. Ke spuštění aplikace Word s přepínačem /a, naleznete "Starting Microsoft Word with the /a Switch"části tohoto článku.
  3. Otevřete šablonu Support.dot. Chcete-li to provést, naleznete "How to Open the Support.dot Template"části tohoto článku.
  4. V šabloně Support.dot klepněte na tlačítko Poradce při potížích.
  5. V Microsoft Word odstraňování nástroj dialogové okno, v seznamu Vyberte položku klepněte na Klíč registru data a potom klepněte na tlačítko Obnovit.
  6. Klepněte na tlačítko Ano po zobrazení následující zprávy:
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Data

    Tento klíč registru existuje.
    Chcete jej přepsat?
  7. Po zobrazení následující zprávy klepněte na tlačítko OK:
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Data

    Registru klíče obnovení úspěšné.
  8. Proveďte jednu z následujících akcí:
Back to Top of Using the Troubleshoot Utility

Krok 2: Přejmenování globální šablony Normal.dot

Chcete-li zabránit formátování, položek automatického textu a maker uložených v globální šabloně (Normal.dot) ovlivnily chování aplikace Word a dokumenty, které otevřete, přejmenujte globální šablonu. Přejmenování tento soubor umožňuje rychle zjistit, zda je globální šablona příčinou problému.

Poznámka: přejmenování soubor Normal.dot obnoví několik možností na jejich výchozí nastavení, včetně vlastní styly, vlastní panely nástrojů, makra a položky automatického textu. Z tohoto důvodu společnost Microsoft důrazně doporučuje odstranit soubor Normal.dot.

Některé druhy konfigurací lze vytvořit více než jeden soubor Normal.dot. Mezi takové situace patří případy, kdy je v jednom počítači více verzí aplikace Word nebo v jednom počítači existuje několik instalací pracovní stanice. V těchto situacích nezapomeňte přejmenovat správnou kopii Normal.dot.

Chcete-li přejmenovat soubor Normal.dot, postupujte takto:
  1. Ukončete všechny aplikace systému Office.
  2. Začněte použití přepínače /. Ke spuštění aplikace Word s přepínačem /a, naleznete "Starting Microsoft Word with the /a Switch"části tohoto článku.
  3. Otevřete šablonu Support.dot. Chcete-li to provést, naleznete "How to Open the Support.dot Template"části tohoto článku.
  4. V šabloně Support.dot klepněte na tlačítko Poradce při potížích.
  5. V Microsoft Word odstraňování nástroj dialogové okno, v seznamu Vyberte položku klepněte Globální šablony Normal.dot a pak klepněte na příkaz Přejmenovat.
  6. Klepněte na tlačítko OK, obdržíte následující zprávu:
    path\Application Data\Microsoft\Templates\Normal.dot
    zkopírováno do
    path\Application Data\Microsoft\Templates\10Normal.dot
    Poznámka: cesta k souboru Normal.dot může být odlišné.
  7. Klepnutím na tlačítko Zavřít zavřete Microsoft Word odstraňování nástroj dialogové okno.
  8. V nabídce soubor klepněte na příkaz Konec ukončete aplikaci Word.
  9. Spuštění obvykle způsobem. Proveďte není použití postupu v tomto článku v části "Spuštění aplikace s /a přepnout".
Pokud aplikace Word spustí správně, problém vyřešen. V tomto případě problém je poškozený soubor Normal.dot. Bude možná třeba změnit některá nastavení, abyste obnovili své oblíbené možnosti. Pokud přejmenovaný soubor Normal.dot obsahuje vlastní nastavení, například styly, makra nebo položky automatického textu nemohou být snadno znovu, pravděpodobně zkopírovat tato nastavení ze souboru 10Normal.dot (staré Normal.dot) nového souboru Normal.dot pomocí nástroje Organizátor.

Další informace o používání organizátoru klepněte v nabídce Nápověda na příkaz Nápověda pro Microsoft Word, zadejte médií v Pomocníkovi Office nebo průvodce a klepněte na tlačítko Hledat zobrazte vrácená témata.

Pokud problém není vyřešen, obnovte původní soubor Normal.dot (10Normal.dot). Postupujte takto:
  1. Ukončete všechny aplikace systému Office.
  2. Začněte použití přepínače /. Ke spuštění aplikace Word s přepínačem /a, naleznete "Starting Microsoft Word with the /a Switch"části tohoto článku.
  3. Otevřete šablonu Support.dot. Chcete-li to provést, naleznete "How to Open the Support.dot Template"části tohoto článku.
  4. V šabloně Support.dot klepněte na tlačítko Poradce při potížích.
  5. V Microsoft Word odstraňování nástroj dialogové okno, v seznamu Vyberte položku klepněte Globální šablony Normal.dot a pak klepněte na tlačítko Obnovit.
  6. Klepněte na tlačítko Ano po zobrazení následující zprávy:
    path\Application Data\Microsoft\Templates\Normal.dot

    Záložní kopie souboru již existuje.

    Chcete jej přepsat?
    Poznámka: cesta k souboru Normal.dot může být odlišné.
  7. Po zobrazení následující zprávy klepněte na tlačítko OK:
    path\Application Data\Microsoft\Templates\10Normal.dot
    zkopírováno do
    path\Templates\Normal.dot
  8. Proveďte jednu z následujících akcí:
Back to Top of Using the Troubleshoot Utility

Krok 3: Zakázání doplňků Word spouštěcí složce

Po spuštění aplikace Word dojde k automatickému načtení šablon a doplňků umístěných ve složkách Po spuštění. Chyby aplikace Word mohou být důsledkem konfliktu nebo problémů s doplňkem. Chcete-li zjistit, zda položka ve spouštěcí složce způsobuje potíže, můžete dočasně zakázat nastavení registru, které na tyto doplňky odkazuje.

Klíč registru pro doplňky dočasně zakázat, postupujte takto:
  1. Ukončete všechny aplikace systému Office.
  2. Začněte použití přepínače /. Ke spuštění aplikace Word s přepínačem /a, naleznete "Starting Microsoft Word with the /a Switch"části tohoto článku.
  3. Otevřete šablonu Support.dot. Chcete-li to provést, naleznete "How to Open the Support.dot Template"části tohoto článku.
  4. V šabloně Support.dot klepněte na tlačítko Poradce při potížích.
  5. V Microsoft Word odstraňování nástroj dialogové okno, v seznamu Vyberte položku, klepněte na tlačítko Add-Ins Word spouštěcí složka a klepněte na příkaz Přejmenovat.
  6. Proveďte jednu z následujících akcí:
    • Po zobrazení následující zprávy klepněte na tlačítko OK:
      Nebyly nalezeny žádné soubory k přejmenování nebo obnovení.
      Poznámka: Pokud se zobrazí tato zpráva, máte k dispozici žádné doplňky, které jsou načteny při spuštění. Po klepnutí na tlačítko OK pokračujte Step 4: Delete the COM Add-Ins Registry Keyčásti tohoto článku.

      Nebo
    • Po zobrazení následující zprávy klepněte na tlačítko OK:
      pathfile name \Application Data\Microsoft\Word\Startup\
      zkopírováno do
      pathfile name \Application Data\Microsoft\Word\Startup\

      pathfile name \Program Files\Microsoft Office\Office10\Startup\
      zkopírováno do
      pathfile name \Program Files\Microsoft Office\Office10\Startup\
      Poznámka: uvedené cesty a názvy souborů v systému může být odlišné.
  7. Klepnutím na tlačítko Zavřít zavřete Microsoft Word odstraňování nástroj dialogové okno.
  8. V nabídce soubor klepněte na příkaz Konec ukončete aplikaci Word.
  9. Spuštění obvykle způsobem. Proveďte není použití postupu v tomto článku v části "Spuštění aplikace s /a přepnout".
  10. Proveďte jednu z následujících akcí:
    • Pokud již reprodukci problému a byly odebrány položky po spuštění v kroku 6, zjistili jste, je problém způsoben k položce Chcete-li zjistit, která spouštěcí položka je příčinou problému, postupujte takto:
      1. Ukončete všechny aplikace systému Office.
      2. Začněte použití přepínače /. Ke spuštění aplikace Word s přepínačem /a, naleznete "Starting Microsoft Word with the /a Switch"části tohoto článku.
      3. Otevřete šablonu Support.dot. Chcete-li to provést, naleznete "How to Open the Support.dot Template"části tohoto článku.
      4. V šabloně Support.dot klepněte na tlačítko Poradce při potížích.
      5. V Microsoft Word odstraňování nástroj dialogové okno, v seznamu Vyberte položku klepněte Doplňky Word spouštěcí složka a klepněte na tlačítko Obnovit.
      6. Po zobrazení následující zprávy klepněte na tlačítko OK:
        pathfile name \Application Data\Microsoft\Word\Startup\
        zkopírováno do
        pathfile name \Application Data\Microsoft\Word\Startup\

        pathfile name \Program Files\Microsoft Office\Office10\Startup\
        zkopírováno do
        pathfile name \Program Files\Microsoft Office\Office10\Startup\
        Poznámka: uvedené cesty a názvy souborů v systému může být odlišné.
      7. Klepnutím na tlačítko Zavřít zavřete Microsoft Word odstraňování nástroj dialogové okno.
      8. V nabídce soubor klepněte na příkaz Konec ukončete aplikaci Word.
      9. Poklepejte na ikonu Tento počítač a potom otevřete složky určené v kroku f. Například:
        path\Application Data\Microsoft\Word\Startup\

        Nebo

        path\Program Files\Microsoft Office\Office10\Startup\
      10. Klepněte pravým tlačítkem myši soubory obsažené ve složce a v místní nabídce klepněte na příkaz Přejmenovat.
      11. Zadejte nový název souboru a stiskněte klávesu ENTER.

        Důležité: vytvořit poznámku původní název souboru, protože můžete potřebovat přejmenujte soubor na původní název.
      12. Spuštění obvykle způsobem. Proveďte není použití postupu v tomto článku v části "Spuštění aplikace s /a přepnout".
      Pokud problém, již lze reprodukovat, našli jste konkrétní doplněk zboží, které je příčinou problému. Pokud potřebujete funkce, které jsou k dispozici add - in položku, musíte určit, které Word add - v obsahuje určité položky a obraťte se na dodavatele pro aktualizaci.

      Pokud problém není vyřešen, přejmenujte doplněk zpět na původní název a opakujte kroky h prostřednictvím i pro každý soubor složky zadané v kroku f zobrazené zprávy.

      Nebo

    • Pokud problém, již lze reprodukovat, našli jste konkrétní doplněk zboží, které je příčinou problému. Pokud potřebujete funkce, které jsou k dispozici add - in položku, musíte určit, které Word add - v obsahuje určité položky a obraťte se na dodavatele pro aktualizaci. Pokud problém není vyřešen, obnovte vaše položky doplněk a pokračujte dalším krokem. Postupujte takto:
      1. Ukončete všechny aplikace systému Office.
      2. Začněte použití přepínače /. Ke spuštění aplikace Word s přepínačem /a, naleznete "Starting Microsoft Word with the /a Switch"části tohoto článku.
      3. Otevřete šablonu Support.dot. Chcete-li to provést, naleznete "How to Open the Support.dot Template"části tohoto článku.
      4. V šabloně Support.dot klepněte na tlačítko Poradce při potížích.
      5. V Microsoft Word odstraňování nástroj dialogové okno, v seznamu Vyberte položku klepněte Doplňky Word spouštěcí složka a klepněte na tlačítko Obnovit.
      6. Po zobrazení následující zprávy klepněte na tlačítko OK:
        pathfile name \Application Data\Microsoft\Word\Startup\
        zkopírováno do
        pathfile name \Application Data\Microsoft\Word\Startup\

        pathfile name \Program Files\Microsoft Office\Office10\Startup\
        zkopírováno do
        pathfile name \Program Files\Microsoft Office\Office10\Startup\
        Poznámka: uvedené cesty a názvy souborů v systému může být odlišné.
      7. Pokračujte Step 4: Delete the COM Add-Ins Registry Keyčásti tohoto článku.
Back to Top of Using the Troubleshoot Utility

Krok 4: Odstranění klíče registru doplňků COM

Doplňky modelu COM lze nainstalovat do libovolného umístění a jsou nainstalovány programy, které spolupracují s aplikací Word. Chcete-li odebrat nastavení registru systému Windows žádné doplňky modelu COM, které jsou nainstalovány, postupujte takto:
  1. Ukončete všechny aplikace systému Office.
  2. Začněte použití přepínače /. Ke spuštění aplikace Word s přepínačem /a, naleznete "Starting Microsoft Word with the /a Switch"části tohoto článku.
  3. Otevřete šablonu Support.dot. Chcete-li to provést, naleznete "How to Open the Support.dot Template"části tohoto článku.
  4. V šabloně Support.dot klepněte na tlačítko Poradce při potížích.
  5. V Microsoft Word odstraňování nástroj dialogové okno, v seznamu Vyberte položku, klepněte na Klíč registru pro doplňky COM a klepněte na příkaz Odstranit.
  6. Po zobrazení následující zprávy klepněte na tlačítko OK:
    HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins
    Záložní soubor tohoto klíče registru se nalézá v následujícím umístění:
    C:\Windows\TEMP\wdaddn10.0

    Klíč registru byl odstraněn.
  7. Klepnutím na tlačítko Zavřít zavřete Microsoft Word odstraňování nástroj dialogové okno.
  8. V nabídce soubor klepněte na příkaz Konec ukončete aplikaci Word.
  9. Spuštění způsobem obvykle provést. Proveďte není použití postupu v tomto článku v části "Spuštění aplikace s /a přepnout".
  10. Proveďte jednu z následujících akcí:
    • Pokud již můžete reprodukovat problém, zjistili jste, že doplněk COM je příčinou problému. Určit, které COM doplněk je příčinou problému, postupujte takto:
      1. Ukončete všechny aplikace systému Office.
      2. Začněte použití přepínače /. Ke spuštění aplikace Word s přepínačem /a, naleznete "Starting Microsoft Word with the /a Switch"části tohoto článku.
      3. Otevřete šablonu Support.dot. Chcete-li to provést, naleznete "How to Open the Support.dot Template"části tohoto článku.
      4. V šabloně Support.dot klepněte na tlačítko Poradce při potížích.
      5. V Microsoft Word odstraňování nástroj dialogové okno, v seznamu Vyberte položku, klepněte na Klíč registru pro doplňky COM a klepněte na tlačítko Obnovit.
      6. Po zobrazení následující zprávy klepněte na tlačítko OK:
        HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins

        Registru klíče obnovení úspěšné.
      7. Klepnutím na tlačítko Zavřít zavřete Microsoft Word odstraňování nástroj dialogové okno.
      8. V nabídce soubor klepněte na příkaz Konec ukončete aplikaci Word.
      9. Spuštění obvykle způsobem. Proveďte není použití postupu v tomto článku v části "Spuštění aplikace s /a přepnout".
      10. V nabídce Nástroje klepněte na tlačítko Vlastní.
      11. Klepněte na kartu Příkazy. V seznamu Kategorie klepněte na Nástroje.
      12. V seznamu PříkazyDoplňky COM klepněte a přetáhněte příkaz na vaše panely nástrojů.
      13. Klepnutím na tlačítko Zavřít zavřete dialogové okno Vlastní.
      14. Klepněte na tlačítko Doplňky COM, které jste právě přidali v kroky kB až m.
      15. V dialogovém okně Doplňky COM Pokud doplněk uveden, klepnutím zrušte zaškrtnutí políčka doplňku.

        Poznámka: Pokud více než jeden doplněk uveden, klepněte na tlačítko Vymazat pouze jeden doplněk políčka současně, určit, který doplněk způsobuje potíže.
      16. Klepněte na tlačítko OK zavřete dialogové okno Doplňky COM.
      17. Klepněte na příkaz Konec v nabídce soubor ukončete aplikaci Word.
      18. Spuštění obvykle způsobem. Proveďte není použití postupu v tomto článku v části "Spuštění aplikace s /a přepnout".
      19. Proveďte jednu z následujících akcí:
        • Pokud problém, již lze reprodukovat, našli jste doplněk COM způsobující problém. Pokud potřebujete funkce poskytované na položku, musíte určit, které doplněk Word obsahuje určité položky a obraťte se na dodavatele pro aktualizaci.

          Nebo
        • Pokud problém není vyřešen, klepněte na tlačítko Doplňky COM, které jste přidali k kroky prostřednictvím m. Klepnutím vyberte doplněk políčko, které jste zrušili v kroku o. Potom zrušte zaškrtnutí políčka jiného doplňku a opakujte kroky p prostřednictvím s. opakovat tento postup tolikrát, kolikrát potřeby pro každý doplněk, dokud nezjistíte, který doplněk způsobuje potíže.
      Nebo

    • - nebo - Pokud problém není vyřešen, obnovit váš COM Doplňky registru klíč a pokračujte dalším krokem. Postupujte takto:
      1. Ukončete všechny aplikace systému Office.
      2. Začněte použití přepínače /. Ke spuštění aplikace Word s přepínačem /a, naleznete "Starting Microsoft Word with the /a Switch"části tohoto článku.
      3. Otevřete šablonu Support.dot. Chcete-li to provést, naleznete "How to Open the Support.dot Template"části tohoto článku.
      4. V šabloně Support.dot klepněte na tlačítko Poradce při potížích.
      5. V Microsoft Word odstraňování nástroj dialogové okno, v seznamu Vyberte položku, klepněte na Klíč registru pro doplňky COM a klepněte na tlačítko Obnovit.
      6. Po zobrazení následující zprávy klepněte na tlačítko OK:
        HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins

        Registru klíče obnovení úspěšné.
      7. Klepnutím na tlačítko Zavřít zavřete Microsoft Word odstraňování nástroj dialogové okno.
      8. V nabídce soubor klepněte na příkaz Konec ukončete aplikaci Word.
      9. Pokračujte Step 5: Delete the Options Registry Keyčásti tohoto článku.
Back to Top of Using the Troubleshoot Utility

Krok 5: Odstranit klíč registru Options

Klíč registru Options ukládá tyto možnosti můžete z aplikace nastavit změnou možností nabídky nebo spuštěním makra RegOptions. Tyto jsou upravitelné možnosti.

Nastavení spadají do dvou skupin: výchozí nastavení a volitelná nastavení. Výchozí nastavení jsou vytvořena během instalace a lze je změnit úpravou možností v aplikaci Word. Volitelná nastavení nejsou vytvořeny během instalace; jejich přidání musíte spustit makra RegOptions (popsány dále v tomto článku).

Odstranění klíče možností, postupujte takto:
  1. Ukončete všechny aplikace systému Office.
  2. Začněte použití přepínače /. Ke spuštění aplikace Word s přepínačem /a, naleznete "Starting Microsoft Word with the /a Switch"části tohoto článku.
  3. Otevřete šablonu Support.dot. Chcete-li to provést, naleznete "How to Open the Support.dot Template"části tohoto článku.
  4. V šabloně Support.dot klepněte na tlačítko Poradce při potížích.
  5. V Microsoft Word odstraňování nástroj klepněte na Klíč registru Options dialogové okno, v seznamu Vyberte položku a klepněte na příkaz Odstranit.
  6. Po zobrazení následující zprávy klepněte na tlačítko OK:
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Options
    Záložní soubor tohoto klíče registru se nalézá v následujícím umístění:
    C:\WINDOWS\TEMP\wdoptn10.0

    Klíč registru byl odstraněn.
  7. Spuštění způsobem obvyklým způsobem. Nepoužívejte přepínač /a ke spuštění aplikace Word, jak je popsáno v "Starting Microsoft Word with the /a Switch"části tohoto článku.
Pokud aplikace spustí správně a funguje správně, problém byl vyřešen. Potíže způsoboval poškozený klíč Options. Potřebujete změnit několik nastavení obnovit svoje oblíbené možnosti v aplikaci Word.

Pokud problém není vyřešen, ukončete aplikaci Word a přidat Možnosti informace klíče do registru systému Windows. Postupujte takto:
  1. Ukončete všechny aplikace systému Office.
  2. Začněte použití přepínače /. Ke spuštění aplikace Word s přepínačem /a, naleznete "Starting Microsoft Word with the /a Switch"části tohoto článku.
  3. Otevřete šablonu Support.dot. Chcete-li to provést, naleznete "How to Open the Support.dot Template"části tohoto článku.
  4. V šabloně Support.dot klepněte na tlačítko Poradce při potížích, které je umístěn v tabulce obsažené v souboru.
  5. V Microsoft Word odstraňování nástroj klepněte na Klíč registru Options dialogové okno, v seznamu Vyberte položku a klepněte na tlačítko Obnovit.
  6. Klepněte na tlačítko Ano po zobrazení následující zprávy:
    HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Options

    Tento klíč registru existuje.
    Chcete jej přepsat?
  7. Po zobrazení následující zprávy klepněte na tlačítko OK:
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Options

    Registru klíče obnovení úspěšné.
  8. Klepnutím na tlačítko Zavřít zavřete Microsoft Word odstraňování nástroj dialogové okno.
  9. V nabídce soubor klepněte na příkaz Konec ukončete aplikaci Word.
Back to Top of Using the Troubleshoot Utility



Použití maker možnosti registru

Makra RegOptions můžete zkontrolovat a provést změny nastavení aplikace Word v registru systému Windows. Následuje seznam možností, které jsou k dispozici v makru a stručný popis účelu jednotlivých možností:
Možností aplikace

Uložení cesta: Nastaví složky, kde jsou uloženy soubory automatické.

Cesta dokumentu: výchozí složka používaná pro dokumenty aplikace Word.

Obrázek cesta: Nastaví výchozí cestu, která je použita při přejděte na příkaz obrázek v nabídce Vložit a potom klepněte na příkaz Ze souboru.

Spuštění cesta: Nastaví cestu pro spouštěcí soubory Word jako například šablony a soubory WLL (WLLs), které jsou načteny při spuštění.

Nástroje cesta: Nastaví umístění, ve kterém Word hledá nástroje kontroly pravopisu, filtry, převaděče a další součásti v případě, že nejsou správně registrovány nebo nebyl nalezen.

Uživatel dot-Path: cesta pro šablony uživatele. Všimněte si, že při změně tohoto nastavení pro Word, ovlivní změna všechny aplikace sady Microsoft Office.

Workgroup-Dot-Path: cesta pro šablony pracovní skupiny. Zadat cestu UNC.

BAK-Extension: Výchozí přípona souboru používaná pro záložní soubory aplikace Word. Výchozí přípona je WBK.

DOC-Extension: Výchozí přípona souboru používaná pro dokumenty aplikace Word. Výchozí hodnota je *. doc.

DOT-Extension: Výchozí přípona souboru používaná pro šablony aplikace Word. Výchozí hodnota je * .dot.

NoFontMRUList: Zapne nebo vypne seznam naposledy použitých písem (MRU). Zapnout písmo seznam MRU, zadejte 0 (nula). Chcete-li vypnout MRU seznamu písem, typ 1.

SpellingWavyUnderlineColor: umožňuje řídit barvu podtržení vlnovkou zobrazeného pod slovy s chybným.

GrammarWavyUnderlineColor: umožňuje řídit barvu podtržení vlnovkou zobrazeného pod gramatické chyby.

SmartTagUnderlineColor: umožňuje řídit barvu tečkovaná zobrazí pod inteligentní značky.

FormatConsistencyWavyUnderlineColor: umožňuje řídit barvu podtržení vlnovkou zobrazeného pod chybami formátování.

OLEDOT: Určuje šablonu dokumentu, který se používá při vytváření objektu dokumentu v rámci Word nebo jiné aplikaci OLE.
Možnosti editoru rovnic

Appdir: složku programu The Equation Editor. Editor rovnic musí být nainstalována a spustit jednou, v pořadí pro tuto a další nastavení Editor rovnic být zobrazeny.

CustomZoom: Lupa vlastní nastavení. Toto nastavení pouze projeví při spuštění Editor rovnic ve zvláštním okně prostřednictvím nastavení ForceOpen.

ForceOpen: Vynutí editoru rovnic otevřít v samostatném okně. Zadejte 0 (nula) otevřete v místě nebo typ 1 otevřít v samostatném okně.

ShowAll: Zobrazí nebo skryje netisknutelné znaky.

ToolBarDocked: Určuje, zda ukotvený panel nástrojů. Zvolte Ano (1) nebo Ne (0).

ToolBarDockPos: umístění nástrojů Editoru rovnic, pokud je ukotven. 1 nastaví panelu nástrojů v horní části okna Editor rovnic. 2 nastaví panelu nástrojů v dolní části okna Editor rovnic.

ToolBarShown: Určuje, zda je panel nástrojů zobrazen. Zvolte Ano (1) nebo Ne (0).

ToolBarWinPos: umístění panelu nástrojů, když není ukotven, zadané v X, Y souřadnic, s levý horní roh jako původ. Jednotky jsou v pixelech.

Přiblížení: velikost standardní zvětšení vybrané v nabídce Zobrazit.
Chcete-li použít makra RegOptions, postupujte takto:
  1. V nabídce soubor klepněte na tlačítko Otevřít.
  2. Změnit Typ souboru políčka šablony (* .dot).
  3. Změna pole oblast následující složce:
    C:\Program Files\Microsoft Office\Office10\Macros\
  4. Klepnutím vyberte support.dot a potom klepněte na tlačítko Otevřít.
  5. Ve sloupci makra tabulky obsažené v souboru klepněte na tlačítko Možnosti registru.
  6. Na kartě Možnosti Word nebo kartu Možnosti editoru rovnic vyberte možnost, kterou chcete změnit, zadejte nové nastavení pole Nastavení (nebo klepněte na tlačítko Procházet, pokud je k dispozici a klepněte na tlačítko vyberte nastavení, které chcete) a potom klepněte na tlačítko změnit.
  7. Zavřete klepnutím na tlačítko Zavřít v dialogovém okně Nastavit možnosti registru.


Použití automatických zálohování

Použít program Backup automatických automatických přesunout položky mezi počítači. Další informace o programu Backup opravy klepněte na následující číslo článku databáze Microsoft Knowledge Base:
269006Postupy: Přesunout položky automatických Word mezi počítači v aplikaci Word 2002


Pouze zkušení uživatelé

Informace v této části není vyžadován při použití makra v šabloně Support.dot. Tato informace je k dispozici, pouze pokud chcete zpřístupnit tyto makra globálně v aplikaci Word nebo pokud chcete zobrazit kód makra.



Jak lze globálně zpřístupnění makra

Zpřístupnit makra globálně v aplikaci Word, použijte jednu z následujících metod.

Metoda 1: Přidání globální šablony a doplňky

Pokud plánujete použít makra příležitostně (nebo pokud chcete zobrazit makra proveďte před rozhodnout provést snadno přístupné), přidat makra šablony jako globální šablony.

Přidat šablony uvedeny v části "Shrnutí" Tento článek jako globální šablony, postupujte takto:
  1. V nabídce Nástroje klepněte na příkaz šablony a doplňky.
  2. Ve skupinovém rámečku globální šablony a doplňky klepněte na tlačítko Přidat.
  3. Změnit pole oblast složku obsahující šablonu ukázkové makro. V poli Typ souboru vyberte všechny soubory (*. *).
  4. Vyberte šablonu ukázkové makro a klepněte na tlačítko OK.
  5. Po ukázkové makro šablona se zobrazí v dialogovém okně šablony a doplňky, ujistěte se, zda je zaškrtnuto políčko pro šablonu a potom klepněte na tlačítko OK.

    Důležité: Po načtení šablony v globální šablony a doplňky zůstane šablony v aktuální relaci pouze načten. Pokud ukončete a restartujte aplikaci Word na šablonu není automaticky znovu. Musí znovu vyberte šablonu, kterou chcete použít. To provést, klepněte na příkaz šablony a doplňky v nabídce Nástroje. V dialogovém okně šablony a doplňky klepnutím vyberte šablonu, kterou chcete použít makra z a potom klepněte na tlačítko OK.
  6. Spuštění určitého makra, postupujte takto:
    1. V nabídce Nástroje přejděte na příkaz makro a potom klepněte na příkaz makra.
    2. V dialogovém okně makra k šabloně obsahující makra, které chcete změnit v rozevíracím seznamu Prohledat. Například klepnutím vyberte support.dot (globální šablona).
    3. V seznamu název makra klepnutím vyberte požadované makro a potom klepněte na příkaz Spustit.

Metoda 2: Přidání šablony do složky Po spuštění

Přesunout šablonu do složky Po spuštění. Aplikace automaticky má přístup k libovolné makra v šablonách, které jsou umístěny v následující složce:
C:\Program Files\Microsoft Office\Office10\Startup
Pomocí Průzkumníka Windows kopii šablony ukázkové makro umístit do složky Po spuštění.

Při spuštění šablona umístěná ve složce Po spuštění aplikace je načten jako globální šablony a makra v šabloně jsou k dispozici v dialogovém okně makra. Nevýhodou této metody je Word může trvat trochu déle spuštění (při každém spuštění Word, Word načte tyto šablony globálně).

Spuštění určitého makra, postupujte takto:
  1. V nabídce Nástroje přejděte na příkaz makro a potom klepněte na příkaz makra.
  2. V dialogovém okně makra k šabloně obsahující makra, které chcete změnit v rozevíracím seznamu Prohledat. Například klepnutím vyberte support.dot (globální šablona).
  3. V seznamu název makra klepnutím vyberte požadované makro a potom klepněte na příkaz Spustit.

Metoda 3: Zkopírujte makro do šablony Normal

Spuštění určitého makra bez nutnosti otevírat jeho šablony zkopírovat makro do globální šabloně (Normal.dot). Postupujte takto:
  1. Otevřete šablonu ukázkové makro.
  2. V nabídce Nástroje klepněte na příkaz šablony a doplňky.
  3. V dialogovém okně šablony a doplňky klepněte na tlačítko Organizátor.
  4. V dialogovém okně médií klepněte na kartu Makra.
  5. Makra v šabloně ukázkové makro jsou uvedeny na jedné straně dialogového okna. Otevřít na opačné straně se zobrazí globální šabloně (Normal.dot).

    Poznámka: Pokud Normal.dot (globální šablona) není otevřené, klepněte na příkaz Zavřít soubor na opačné straně. Tlačítko Zavřít soubor změní na tlačítko Otevřít soubor. Klepněte na příkaz Otevřít soubor. Klepnutím vyberte soubor šablony Normal.dot a pak klepněte na tlačítko Otevřít.
  6. Na straně ukázkové makro šablony vyberte položky projektu makra, které jsou uvedeny v šabloně ukázkové makro a klepněte na příkaz Kopírovat.

    Poznámka: všechny položky, které jsou uvedeny výběr, podržte stisknutou klávesu CTRL klepněte na jednotlivé položky projektu makra.
  7. Klepněte na tlačítko Kopírovat kopírování položky projektu makra vaše Normal.dot šablony.
  8. Klepnutím na tlačítko OK zavřete dialogové okno Organizátor.
  9. Spuštění určitého makra, postupujte takto:
    1. V nabídce Nástroje přejděte na příkaz makro a potom klepněte na příkaz makra.
    2. V dialogovém okně makra k šabloně obsahující makra, které chcete změnit v rozevíracím seznamu Prohledat. Například klepnutím vyberte Normal.dot (globální šablona).
    3. V seznamu název makra klepnutím vyberte požadované makro a potom klepněte na příkaz Spustit.


Jak zobrazit kód maker

Společnost Microsoft poskytuje ukázky programování pouze pro ilustraci, bez žádné záruky výslovně uvedené nebo odvozené,. včetně, bez omezení, odvozených záruk vztahujících se k obchodovatelnosti nebo vhodnosti pro určitý účel. Tento článek předpokládá, že uživatel je obeznámen s programovacím jazykem, který je předmětem ukázky, a s nástroji použitými pro vytvoření a ladění skriptu. Pracovníci technické podpory společnosti Microsoft mohou vysvětlit funkce určitého postupu, nemohou však následující příklady rozšířit o další funkce nebo konstrukce podle konkrétních požadavků uživatele. Zobrazení kódu makra ukázkové makro, postupujte takto:
  1. V nabídce soubor klepněte na tlačítko Otevřít.
  2. V dialogovém okně Otevřít Změna pole oblast složku obsahující šablonu ukázkové makro, změna políčka Typ souboruvšechny soubory (*. *) a klepněte na šablonu odpovídající ukázkové makro.
  3. Podržte klávesu SHIFT a klepněte na tlačítko Otevřít.
  4. V nabídce Nástroje přejděte na příkaz makro a potom klepněte na příkaz makra.
  5. V dialogovém okně makra změnit v rozevíracím seznamu Prohledat šablony ukázkové makro, které jste otevřeli.
  6. Vyberte příslušné makro a potom klepněte na tlačítko Upravit.

Vlastnosti

ID článku: 289506 - Poslední aktualizace: 27. července 2006 - Revize: 2.2
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Word 2002 Standard Edition
Klíčová slova: 
kbmt kbdta kbhowtomaster KB289506 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:289506

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com