CÓMO: Instalar y utilizar la plantilla Support.dot en Microsoft Word 2002

Seleccione idioma Seleccione idioma
Id. de artículo: 289506 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Resumen

Este artículo está pensado para ayudarle a determinar la causa de un problema cuando no es capaz de identificarlo o aislarlo mediante otros medios en Microsoft Word. Para buscar temas y artículos acerca de problemas específicos que esté experimentando, consulte en Microsoft Knowledge Base. Para ello, visite el siguiente sitio Web de Microsoft:
http://support.microsoft.com/default.aspx
Este artículo paso a paso describe la plantilla Support.dot, que incluye métodos automatizados para usar macros creadas por los Servicios de soporte técnico de Microsoft. Support.dot es una plantilla que contiene código especial (macros) para ayudar a determinar y solucionar problemas en Word. Hay tres tipos de macros que se pueden utilizar para solucionar diversos problemas.

Macro Nombre Descripción
Utilidad para solucionar problemas TShoot Esta macro se puede utilizar para solucionar varios problemas con Word. Puede usar la macro para cambiar el nombre de la clave de datos y del archivo Normal.dot con el fin de desactivar complementos de Word.

NOTA: antes de ejecutar esta macro debe iniciar Word con el modificador /a.
Opciones de registro RegOptions Esta macro se puede utilizar para modificar la configuración de Word almacenada en el Registro de Windows.
Copia de seguridad de Autocorrección AutoCorrectBackup Esta macro realiza una copia de seguridad de la lista Autocorrección en un archivo. Puede llevar este archivo a otro equipo y volver a ejecutar la macro para restaurar la lista de Autocorrección.




Cómo instalar la plantilla Support.dot

La plantilla Support.dot se instala con la instalación Completa. No se instala con la instalación Típica ni con la instalación Actualizar ahora. Si la plantilla Support.dot no se ha instalado, siga estos pasos:
  1. Cierre Microsoft Word y todos los programas de Microsoft Office.
  2. Haga clic en Inicio, seleccione Configuración y, a continuación, haga clic en Panel de control.
  3. En el Panel de control, haga doble clic en Agregar o quitar programas.
  4. Siga estos pasos dependiendo de su sistema operativo.
    • En Microsoft Windows 98, Windows Millennium Edition (Me) o Windows NT 4.0, haga clic en Microsoft Office XP (Microsoft Word 2002) en la ficha Instalar o desinstalar y, a continuación, haga clic en Agregar o quitar.

      O bien
    • En Microsoft Windows 2000 o Microsoft Windows XP, seleccione Cambiar o quitar programas. En la lista Programas instalados actualmente, haga clic en Microsoft Office XP (Microsoft Excel 2002) y, después, haga clic en Cambiar.
  5. En el Programa de instalación de Microsoft Office XP (Programa de instalación de Microsoft Word 2002), haga clic en Agregar o quitar funciones para activarlo y, a continuación, haga clic en Siguiente.
  6. En la lista Funciones que se instalarán, siga estos pasos. NOTA: haga clic en el signo más (+) situado a la izquierda de la función para expandirla.

    1. Haga clic para expandir Microsoft Word para Windows.
    2. Haga clic para expandir Asistentes y plantillas.
    3. Haga clic en el icono Más plantillas y macros y, a continuación, haga clic en Ejecutar todo desde mi PC en el menú contextual que aparecerá para activarlo.
  7. : Haga clic en el signo (+) a la izquierda de la función para expandirla.Haga clic en Actualizar para instalar la plantilla Support.dot.


Cómo abrir la plantilla Support.dot

Para abrir la plantilla Support.dot, siga estos pasos:
  1. En el menú Archivo, haga clic en Abrir.
  2. Cambie por Plantillas de documento (*.dot ) el valor del cuadro Tipo de archivos.
  3. Cambie el valor del cuadro Buscar en por la carpeta siguiente:
    C:\Archivos de programa\Microsoft Office\Office10\Macros\
  4. Haga clic en Support.dot para activarlo y, después, haga clic en Abrir.
  5. En la tabla del archivo, en la columna Macro, haga clic en el botón adecuado para ejecutar la macro que desea. Por ejemplo, haga clic enUtilidad para solucionar problemasOpciones del Registro, o bienCopia de seguridad de Autocorrección.


Cómo usar la Utilidad para solucionar problemas

Esta utilidad es una macro suministrada por los Servicios de soporte técnico de Microsoft. Puede ayudarle a automatizar el proceso de solución de problemas en Microsoft Word ya que quita ciertos componentes claves que pueden estar dañados u ocasionar un conflicto con Microsoft Word. Emplee esta Utilidad para deshabilitar los siguientes componentes (en el orden en que aparecen) que se suelen cargar durante el inicio de Word:
  • La clave del Registro Data
  • La plantilla global Normal.dot
  • Complementos y plantillas
  • Complementos COM
  • La clave del Registro Options
Si alguno de esos elementos está dañado o es incompatible, es posible que Word no se inicie o que funcione incorrectamente. Puede omitir de forma temporal estos y otros elementos si inicia Word con el modificador /a.

Iniciar Microsoft Word con el modificador /a

Para iniciar Word con el modificador /a, siga estos pasos:
  1. Haga clic en Inicio y, a continuación, en Ejecutar.
  2. En el cuadro de diálogo Ejecutar, realice una de las acciones siguientes:
    • En el cuadro Abrir, escriba Winword.exe /a.

      O bien
    • Haga clic en Examinar. Busque y seleccione el archivo Winword.exe. Para ello, siga estos pasos:
      1. En la lista Buscar en, seleccione la carpeta que contenga los archivos de programa de Word. Seleccione el archivo Winword.exe y haga clic en Abrir.

        Con este paso se llenará el cuadro Abrir del cuadro de diálogo Ejecutar.
      2. En el cuadro Abrir, mueva el punto de inserción detrás de Winword.exe.

        NOTA: en el cuadro de diálogo Ejecutar, la ruta de acceso del archivo Winword.exe aparece entre comillas. Asegúrese de llevar el punto de inserción a la derecha de las comillas de cierre.
      3. Escriba un espacio en blanco y, después, escriba /a.

        La instrucción del cuadro Abrir debería ser similar a la siguiente:
        "C:\Archivos de programa\Microsoft Office\Office10\Winword.exe" /a
  3. En el cuadro de diálogo Ejecutar, haga clic en Aceptar.
Si Word se inicia y funciona correctamente cuando se usa el modificador /a, el problema se encuentra en alguno de los componentes indicados al principio de la sección "Cómo usar la Utilidad para solucionar problemas", en este artículo. Emplee la Utilidad para solucionar problemas con el fin de determinar qué componente causa el problema. Es posible que para ello tenga que instalar Support.dot.

NOTA: si el problema persiste al iniciar Word con el modificador /a, no necesita usar la Utilidad para solucionar problemas.

Procedimiento paso a paso: Usar la Utilidad para solucionar problemas

Para aislar y quitar el componente que ocasiona el problema en Word, quite cada uno de los componentes siguientes, uno cada vez y en el orden en que aparecen, mediante la Utilidad para solucionar problemas: Paso 1: Eliminar la clave de datos del Registro.

Paso 2: Cambiar el nombre de la plantilla global Normal.dot.

Paso 3: Deshabilitar el complemento Carpeta de inicio de Word

Paso 4: Eliminar la clave de complementos COM del Registro.

Paso 5: Eliminar la clave de opciones del Registro.

Paso 1: Eliminar la clave de datos del Registro

Las opciones que se usan con más frecuencia (haga clic en Opciones en el menú Herramientas) se almacenan en la clave Data. Un paso para la solución de problemas consiste en eliminar la clave Data. La próxima vez que se inicie el programa, se volverá a generar esta clave Data con las opciones predeterminadas.

NOTA: al eliminar la clave Data, varias opciones vuelven a tomar sus valores predeterminados, incluyendo la lista de archivos utilizados más recientemente del menú Archivo y muchas opciones personalizadas del cuadro de diálogo Opciones.

Para eliminar la clave Data, siga estos pasos:
  1. Cierre todos los programas de Office.
  2. Inicie Word con el modificador /a. Para ello, consulte la sección "Iniciar Microsoft Word con el modificador /a" de este artículo.
  3. Abra la plantilla Support.dot. Para ello, consulte la sección"Cómo abrir la plantilla Support.dot" de este artículo.
  4. En la plantilla Support.dot, haga clic en el botón Utilidad para solucionar problemas.
  5. En el cuadro de diálogo Utilidad para solucionar problemas de Microsoft Word, en la lista Seleccionar un elemento, haga clic en Clave de datos del Registro y, después, haga clic en Eliminar.
  6. Haga clic en Aceptar cuando vea el mensaje siguiente:
    HKEY_CURRENT_USER\Software\Microsoft Office\10.0\Word\Data
    El archivo de copia de seguridad está presente en:
    C:\WINDOWS\TEMP\wddata10.0

    La clave del Registro se ha eliminado.
  7. Haga clic en Cerrar.
  8. En el menú Archivo, haga clic en Salir para cerrar Word.
  9. Inicie Word como siempre. No siga el procedimiento de la sección "Iniciar Microsoft Word con el modificador /a" de este artículo.
Si Word se inicia y funciona correctamente, el problema se ha resuelto. El problema se debía a que la clave Data del Registro estaba dañada. Puede que tenga que cambiar algunas opciones de configuración para restaurar sus opciones favoritas en Word.

Si el problema no se ha resuelto, restaure su antigua clave Data del Registro. Para ello, siga estos pasos:
  1. Cierre todos los programas de Office.
  2. Inicie Word con el modificador /a. Para ello, consulte la sección "Iniciar Microsoft Word con el modificador /a" de este artículo.
  3. Abra la plantilla Support.dot. Para ello, consulte la sección"Cómo abrir la plantilla Support.dot" de este artículo.
  4. En la plantilla Support.dot, haga clic en el botón Utilidad para solucionar problemas.
  5. En el cuadro de diálogo Utilidad para solucionar problemas de Microsoft Word, en la lista Seleccionar un elemento, haga clic en Clave de datos del Registro y, después, haga clic en Restaurar.
  6. Haga clic en cuando vea el mensaje siguiente:
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Data

    Esta clave está presente en el Registro.
    ¿Desea sobrescribirla
  7. Haga clic en Aceptar cuando vea el mensaje siguiente:
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Data

    La clave del Registro se ha restaurado correctamente.
  8. Siga uno de estos procedimientos:
Volver al principio de Usar la Utilidad para solucionar problemas

Paso 2: Cambiar el nombre de la plantilla global Normal.dot

Para impedir que el formato, el autotexto y las macros que se almacenan en la plantilla global (Normal.dot) afecten al comportamiento de Microsoft Word y los documentos que se abren, cambie el nombre de la plantilla. El cambio de nombre de este archivo permite determinar rápidamente si la plantilla global es la causa del problema.

NOTA: al cambiar el nombre de la plantilla Normal.dot, varias opciones vuelven a tomar sus valores predeterminados. Entre esas opciones se incluyen los estilos y barras de herramientas personalizados, las macros y los elementos de autotexto. Por esta razón, Microsoft recomienda encarecidamente que no elimine el archivo Normal.dot.

Ciertos tipos de configuraciones pueden crear más de un archivo Normal.dot. Ese caso se da, por ejemplo, cuando hay varias versiones de Word en ejecución en el mismo equipo o cuando hay varias instalaciones de estación de trabajo en el mismo equipo. En estos casos, asegúrese de cambiar el nombre de la copia correcta de Normal.dot.

Para cambiar el nombre del archivo Normal.dot, siga estos pasos:
  1. Cierre todos los programas de Office.
  2. Inicie Word con el modificador /a. Para ello, consulte la sección "Iniciar Microsoft Word con el modificador /a" de este artículo.
  3. Abra la plantilla Support.dot. Para ello, consulte la sección"Cómo abrir la plantilla Support.dot" de este artículo.
  4. En la plantilla Support.dot, haga clic en el botón Utilidad para solucionar problemas.
  5. En el cuadro de diálogo Utilidad para solucionar problemas de Microsoft Word, en la lista Seleccionar un elemento, haga clic en Plantilla global Normal.dot y haga clic en Cambiar nombre.
  6. Cuando reciba el mensaje siguiente, haga clic en Aceptar:
    ruta de acceso\Datos de programa\Microsoft\Templates\Normal.dot
    copiado a
    ruta de acceso\Datos de programa\Microsoft\Templates\10Normal.dot
    NOTA: la ruta de acceso de su archivo Normal.dot puede ser diferente.
  7. Haga clic en Cerrar para cerrar el cuadro de diálogo Utilidad para solucionar problemas de Microsoft Word.
  8. En el menú Archivo, haga clic en Salir para cerrar Word.
  9. Inicie Word como siempre. No siga el procedimiento de la sección "Iniciar Microsoft Word con el modificador /a" de este artículo.
Si Word se inicia correctamente, el problema está resuelto. En este caso, el problema se debía a que el archivo Normal.dot estaba dañado. Puede que tenga que cambiar algunas opciones de configuración para restaurar sus opciones favoritas. Si el archivo Normal.dot que cambió de nombre tiene personalizaciones como estilos, macros o elementos de Autotexto que no se pueden volver a crear fácilmente, quizás pueda copiarlas desde el archivo 10Normal.dot (su antiguo Normal.dot) al nuevo Normal.dot mediante el Organizador.

Para obtener más información acerca de cómo usar el Organizador, haga clic en Ayuda de Microsoft Word en el menú Ayuda, escriba Organizador en el Ayudante de Office o en el Asistente para Ayuda y, a continuación, haga clic en Buscar para ver los temas que se devuelven.

Si el problema no se ha resuelto, restaure su archivo Normal.dot antiguo (10Normal.dot). Para ello, siga estos pasos:
  1. Cierre todos los programas de Office.
  2. Inicie Word con el modificador /a. Para ello, consulte la sección "Iniciar Microsoft Word con el modificador /a" de este artículo.
  3. Abra la plantilla Support.dot. Para ello, consulte la sección"Cómo abrir la plantilla Support.dot" de este artículo.
  4. En la plantilla Support.dot, haga clic en el botón Utilidad para solucionar problemas.
  5. En el cuadro de diálogo Utilidad para solucionar problemas de Microsoft Word, en la lista Seleccionar un elemento, haga clic en Plantilla global Normal.dot y haga clic en Restaurar.
  6. Haga clic en cuando vea el mensaje siguiente:
    ruta de acceso\Datos de programa\Microsoft\Templates\Normal.dot

    La copia de seguridad de este archivo ya existe.

    ¿Desea sobrescribirla
    NOTE: la ruta de acceso de su archivo Normal.dot puede ser diferente.
  7. Cuando reciba el mensaje siguiente, haga clic en Aceptar:
    ruta de acceso\Datos de programa\Microsoft\Templates\10Normal.dot
    copiado a
    ruta de acceso\Templates\Normal.dot
  8. Siga uno de estos procedimientos:
Volver al principio de Usar la utilidad para solucionar problemas

Paso 3: Deshabilitar el complemento Carpeta de inicio de Word

Cuando inicia Word, éste carga automáticamente las plantillas y los complementos que se encuentran en las carpetas de inicio. Los errores de Word pueden deberse a conflictos o problemas con un complemento. Para determinar si un elemento de una carpeta de inicio está causando el problema, puede deshabilitar temporalmente la opción del Registro que señala a estos complementos.

Para deshabilitar temporalmente la clave del Registro correspondiente a los complementos, siga estos pasos:
  1. Cierre todos los programas de Office.
  2. Inicie Word con el modificador /a. Para ello, consulte la sección "Iniciar Microsoft Word con el modificador /a" de este artículo.
  3. Abra la plantilla Support.dot. Para ello, consulte la sección"Cómo abrir la plantilla Support.dot" de este artículo.
  4. En la plantilla Support.dot, haga clic en el botón Utilidad para solucionar problemas.
  5. En el cuadro de diálogo Utilidad para solucionar problemas de Microsoft Word, en la lista Seleccionar un elemento, haga clic en Complementos de la carpeta de inicio de Word y haga clic en Cambiar nombre.
  6. Siga uno de estos procedimientos:
    • Cuando vea el mensaje siguiente, haga clic en Aceptar:
      No se han encontrado archivos a los que cambiar el nombre o restaurar.
      NOTA: si ve este mensaje, no hay complementos que se puedan cargar al iniciar Word. Después de hacer clic en Aceptar, siga con el Paso 4: Eliminar la clave de complementos COM del Registro. de este artículo.

      O bien
    • Cuando vea el mensaje siguiente, haga clic en Aceptar:
      ruta de acceso\Datos de programa\Microsoft\Word\Inicio\nombre de archivo
      copiado a
      ruta de acceso\Datos de programa\Microsoft\Word\Inicio\nombre de archivo

      ruta de acceso\Archivos de programa\Microsoft Office\Office10\Inicio\nombre de archivo
      copiado a
      ruta de acceso\Archivos de programa\Microsoft Office\Office10\Inicio\nombre de archivo
      NOTA: la ruta de acceso y el nombre de los archivos pueden variar en su sistema.
  7. Haga clic en Cerrar para cerrar el cuadro de diálogo Utilidad para solucionar problemas de Microsoft Word.
  8. En el menú Archivo, haga clic en Salir para cerrar Word.
  9. Inicie Word como siempre. No siga el procedimiento de la sección "Iniciar Microsoft Word con el modificador /a" de este artículo.
  10. Siga uno de estos procedimientos:
    • Si ya no puede reproducir el problema y los elementos de la carpeta de inicio se quitaron en el paso 6, ha determinado que la causa del problema es un complemento. Para determinar qué elemento de la carpeta de inicio está ocasionando el problema, siga estos pasos:
      1. Cierre todos los programas de Office.
      2. Inicie Word con el modificador /a. Para ello, consulte la sección "Iniciar Microsoft Word con el modificador /a" de este artículo.
      3. Abra la plantilla Support.dot. Para ello, consulte la sección"Cómo abrir la plantilla Support.dot" de este artículo.
      4. En la plantilla Support.dot, haga clic en el botón Utilidad para solucionar problemas.
      5. En el cuadro de diálogo Utilidad para solucionar problemas de Microsoft Word, en la lista Seleccionar un elemento, haga clic en Complementos de la carpeta de inicio de Word y haga clic en Restaurar.
      6. Cuando vea el mensaje siguiente, haga clic en Aceptar:
        ruta de acceso\Datos de programa\Microsoft\Word\Inicio\nombre de archivo
        copiado a
        ruta de acceso\Datos de programa\Microsoft\Word\Inicio\nombre de archivo

        ruta de acceso\Archivos de programa\Microsoft Office\Office10\Inicio\nombre de archivo
        copiado a
        ruta de acceso\Archivos de programa\Microsoft Office\Office10\Inicio\nombre de archivo
        NOTA: la ruta de acceso y el nombre de los archivos pueden variar en su sistema.
      7. Haga clic en Cerrar para cerrar el cuadro de diálogo Utilidad para solucionar problemas de Microsoft Word.
      8. En el menú Archivo, haga clic en Salir para cerrar Word.
      9. Haga doble clic en Mi PC y abra una de las carpetas que se especificó en el paso f. Por ejemplo:
        ruta de acceso\Datos de programa\Microsoft\Word\Inicio\

        O bien

        ruta de acceso\Archivos de programa\Microsoft Office\Office10\Inicio\
      10. Haga clic con el botón secundario del mouse (ratón) en uno de los archivos que contenga la carpeta y, después, haga clic en Cambiar nombre en el menú contextual.
      11. Escriba otro nombre para el archivo y presione ENTRAR.

        IMPORTANTE: anote el nombre original del archivo porque puede que necesite volver a cambiarlo.
      12. Inicie Word como siempre. No siga el procedimiento de la sección "Iniciar Microsoft Word con el modificador /a" de este artículo.
      Si ya no se reproduce el problema, ha encontrado el elemento específico de complemento que lo causaba. Si necesita las características que proporciona, debe determinar qué complemento de Word incluye dicho elemento específico y ponerse en contacto con su proveedor para que le proporcione una actualización.

      Si el problema no se ha resuelto, vuelva a cambiar el nombre del complemento por el original y repita los pasos del h al i para cada archivo de las carpetas especificadas en los mensajes que se muestran en el paso f.

      O bien

    • Si ya no se reproduce el problema, ha encontrado el elemento del complemento específico que lo causaba. Si necesita las características que proporciona, debe determinar qué complemento de Word incluye dicho elemento específico y ponerse en contacto con su proveedor para que le proporcione una actualización. Si el problema persiste, restaure los elementos del complemento y continúe con el paso siguiente. Para ello, siga estos pasos:
      1. Cierre todos los programas de Office.
      2. Inicie Word con el modificador /a. Para ello, consulte la sección "Iniciar Microsoft Word con el modificador /a" de este artículo.
      3. Abra la plantilla Support.dot. Para ello, consulte la sección"Cómo abrir la plantilla Support.dot" de este artículo.
      4. En la plantilla Support.dot, haga clic en el botón Utilidad para solucionar problemas.
      5. En el cuadro de diálogo Utilidad para solucionar problemas de Microsoft Word, en la lista Seleccionar un elemento, haga clic en Complementos de la carpeta de inicio de Word y haga clic en Restaurar.
      6. Cuando vea el mensaje siguiente, haga clic en Aceptar:
        ruta de acceso\Datos de programa\Microsoft\Word\Inicio\nombre de archivo
        copiado a
        ruta de acceso\Datos de programa\Microsoft\Word\Inicio\nombre de archivo

        ruta de acceso\Archivos de programa\Microsoft Office\Office10\Inicio\nombre de archivo
        copiado a
        ruta de acceso\Archivos de programa\Microsoft Office\Office10\Inicio\nombre de archivo
        NOTA: la ruta de acceso y el nombre de los archivos pueden variar en su sistema.
      7. Continúe con el Paso 4: Eliminar la clave de complementos COM del Registro. de este artículo.
Volver al principio de Usar la utilidad para solucionar problemas

Paso 4: Eliminar la clave de complementos COM del Registro

Los complementos COM pueden instalarse en cualquier ubicación y son instalados por programas que interactúan con Word. Para quitar del Registro de Windows las opciones correspondientes a los complementos COM instalados, siga estos pasos:
  1. Cierre todos los programas de Office.
  2. Inicie Word con el modificador /a. Para ello, consulte la sección "Iniciar Microsoft Word con el modificador /a" de este artículo.
  3. Abra la plantilla Support.dot. Para ello, consulte la sección"Cómo abrir la plantilla Support.dot" de este artículo.
  4. En la plantilla Support.dot, haga clic en el botón Utilidad para solucionar problemas.
  5. En el cuadro de diálogo Utilidad para solucionar problemas de Microsoft Word, en la lista Seleccionar un elemento, haga clic en Clave del Registro de los complementos COM y, después, haga clic en Eliminar.
  6. Haga clic en Aceptar cuando vea el mensaje siguiente:
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Addins
    El archivo de copia de seguridad está presente en:
    C:\Windows\TEMP\wdaddn10.0

    La clave del Registro se ha eliminado.
  7. Haga clic en Cerrar para cerrar el cuadro de diálogo Utilidad para solucionar problemas de Microsoft Word.
  8. En el menú Archivo, haga clic en Salir para cerrar Word.
  9. Inicie Word como siempre. No siga el procedimiento de la sección "Iniciar Microsoft Word con el modificador /a" de este artículo.
  10. Siga uno de estos procedimientos:
    • Si ya no se reproduce el problema, ha determinado que un complemento COM lo causaba. Para determinar cuál es, siga estos pasos:
      1. Cierre todos los programas de Office.
      2. Inicie Word con el modificador /a. Para ello, consulte la sección "Iniciar Microsoft Word con el modificador /a" de este artículo.
      3. Abra la plantilla Support.dot. Para ello, consulte la sección"Cómo abrir la plantilla Support.dot" de este artículo.
      4. En la plantilla Support.dot, haga clic en el botón Utilidad para solucionar problemas.
      5. En el cuadro de diálogo Utilidad para solucionar problemas de Microsoft Word, en la lista Seleccionar un elemento, haga clic en Clave del Registro de los complementos COM y, después, haga clic en Restaurar.
      6. Haga clic en Aceptar cuando vea el mensaje siguiente:
        HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Addins

        La clave del Registro se ha restaurado correctamente.
      7. Haga clic en Cerrar para cerrar el cuadro de diálogo Utilidad para solucionar problemas de Microsoft Word.
      8. En el menú Archivo, haga clic en Salir para cerrar Word.
      9. Inicie Word como siempre. No siga el procedimiento de la sección "Iniciar Microsoft Word con el modificador /a" de este artículo.
      10. En el menú Herramientas, haga clic en Personalizar.
      11. Haga clic en la ficha Comandos. En la lista Categorías, haga clic en Herramientas.
      12. En la lista Comandos, haga clic en Complementos COM y arrastre el comando a una de sus barras de herramientas.
      13. Haga clic en Cerrar para cerrar el cuadro de diálogo Personalizar.
      14. Haga clic en el botón Complementos COM que ha agregado en los pasos del k al m.
      15. En el cuadro de diálogo Complementos COM, si se enumera algún complemento, haga clic en la casilla de verificación del mismo para desactivarla.

        NOTA: si se enumeran varios complementos, haga clic en una casilla de verificación cada vez, para determinar qué complemento causa el problema.
      16. Haga clic en Aceptar para cerrar el cuadro de diálogo Complementos COM.
      17. Haga clic en Saliren el menú Archivo para cerrar Word.
      18. Inicie Word como siempre. No siga el procedimiento de la sección "Iniciar Microsoft Word con el modificador /a" de este artículo.
      19. Siga uno de estos procedimientos:
        • Si ya no se reproduce el problema, ha encontrado el complemento COM que lo causaba. Si necesita las características que proporciona, debe determinar qué complemento de Word incluye dicho elemento específico y ponerse en contacto con su proveedor para que le proporcione una actualización.

          O bien
        • Si el problema no se resuelve, haga clic en el botón Complementos COM que agregó en los pasos del k al m. Haga clic en la casilla de verificación del complemento que desactivó en el paso o para activarla, desactive la casilla de verificación de otro complemento y repita los pasos del p al s. Repita este procedimiento las veces que sean necesarias para determinar qué complemento causa el problema.
      O bien

    • Si el problema persiste, restaure la clave del Registro correspondiente a los complementos COM y continúe con el paso siguiente. Para ello, siga estos pasos:
      1. Cierre todos los programas de Office.
      2. Inicie Word con el modificador /a. Para ello, consulte la sección "Iniciar Microsoft Word con el modificador /a" de este artículo.
      3. Abra la plantilla Support.dot. Para ello, consulte la sección"Cómo abrir la plantilla Support.dot" de este artículo.
      4. En la plantilla Support.dot, haga clic en el botón Utilidad para solucionar problemas.
      5. En el cuadro de diálogo Utilidad para solucionar problemas de Microsoft Word, en la lista Seleccionar un elemento, haga clic en Clave del Registro de los complementos COM y, después, haga clic en Restaurar.
      6. Haga clic en Aceptar cuando vea el mensaje siguiente:
        HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Addins

        La clave del Registro se ha restaurado correctamente.
      7. Haga clic en Cerrar para cerrar el cuadro de diálogo Utilidad para solucionar problemas de Microsoft Word.
      8. En el menú Archivo, haga clic en Salir para cerrar Word.
      9. Continúe con el Paso 5: Eliminar la clave de opciones del Registro. de este artículo.
Volver al principio de Usar la utilidad para solucionar problemas

Paso 5: Eliminar la clave de opciones del Registro

Esta clave almacena las opciones establecidas desde Word, ya sea por cambiar opciones de menú o por ejecutar la macro RegOptions. Es posible modificar estas opciones.

Hay dos grupos de opciones: las predeterminadas y las opcionales. Las opciones predeterminadas se establecen durante la instalación y puede cambiarlas si modifica opciones en Word. Las opcionales no se crean durante la instalación; para agregarlas debe ejecutar la macro RegOptions (que se comenta posteriormente en este artículo).

Para eliminar la clave Options, siga estos pasos:
  1. Cierre todos los programas de Office.
  2. Inicie Word con el modificador /a. Para ello, consulte la sección "Iniciar Microsoft Word con el modificador /a" de este artículo.
  3. Abra la plantilla Support.dot. Para ello, consulte la sección"Cómo abrir la plantilla Support.dot" de este artículo.
  4. En la plantilla Support.dot, haga clic en el botón Utilidad para solucionar problemas.
  5. En el cuadro de diálogo Utilidad para solucionar problemas de Microsoft Word, en la lista Seleccionar un elemento, haga clic en Clave del Registro de opciones y, después, haga clic en Eliminar.
  6. Haga clic en Aceptar cuando vea el mensaje siguiente:
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Options
    El archivo de copia de seguridad está presente en:
    C:\WINDOWS\TEMP\wddata10.0

    La clave del Registro se ha eliminado.
  7. Inicie Word de la forma habitual. No utilice el modificador /a para iniciar Word como se describe en la sección "Iniciar Microsoft Word con el modificador /a" de este artículo.
Si Word se inicia y funciona correctamente, el problema se ha resuelto. El problema se debía a que la clave Options estaba dañada. Puede que tenga que cambiar algunas opciones de configuración para restaurar sus opciones favoritas en Word.

Si el problema no se ha resuelto, cierre Word y agregue de nuevo la información de la clave Options al Registro de Windows. Para ello, siga estos pasos:
  1. Cierre todos los programas de Office.
  2. Inicie Word con el modificador /a. Para ello, consulte la sección "Iniciar Microsoft Word con el modificador /a" de este artículo.
  3. Abra la plantilla Support.dot. Para ello, consulte la sección"Cómo abrir la plantilla Support.dot" de este artículo.
  4. En la plantilla Support.dot, haga clic en el botón Utilidad para solucionar problemas, que se encuentra en la tabla incluida en el archivo.
  5. En el cuadro de diálogo Utilidad para solucionar problemas de Microsoft Word, en la lista Seleccionar un elemento, haga clic en Clave del Registro de opciones y, después, haga clic en Restaurar.
  6. Haga clic en cuando vea el mensaje siguiente:
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Data

    Esta clave está presente en el Registro.
    ¿Desea sobrescribirla
  7. Haga clic en Aceptar cuando vea el mensaje siguiente:
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Options

    La clave del Registro se ha restaurado correctamente.
  8. Haga clic en Cerrar para cerrar el cuadro de diálogo Utilidad para solucionar problemas de Microsoft Word.
  9. En el menú Archivo, haga clic en Salir para cerrar Word.
Volver al principio de Usar la utilidad para solucionar problemas



Cómo usar la macro de opciones del Registro

Puede utilizar la macro RegOptions para examinar y cambiar la configuración de Word en el Registro de Windows. A continuación se enumeran todas las opciones disponibles en la macro y una breve descripción de su función.
Opciones de Word

AutoSave-Path: establece la carpeta donde se guardan los archivos de autorrecuperación.

DOC-Path: carpeta predeterminada para los documentos de Word.

Picture-Path: establece la ruta de acceso predeterminada que se utiliza al seleccionar Imagen en el menú Insertar y hacer clic en Desde archivo.

Startup-Path: establece la ruta de acceso para los archivos de inicio de Word, como las plantillas y los archivos .wml (WLL) que se cargarán al iniciarlo.

Tools-Path: establece la ubicación donde Word busca las herramientas de corrección, los filtros, los convertidores y otros componentes, en caso de que no se hayan registrado correctamente o no se puedan encontrar.

User-Dot-Path: ruta de acceso para las plantillas del usuario. Tenga en cuenta que si cambia este valor de configuración de Word, todos los programas de Microsoft Office se verán afectados.

Workgroup-Dot-Path: ruta de acceso para las plantillas de grupos de trabajo. Puede especificar una ruta UNC.

BAK-Extension: extensión de archivo predeterminada de los archivos de copia de seguridad de Word. La extensión predeterminada es *.wbk.

DOC-Extension: extensión de archivo predeterminada de los documentos de Word. El valor predeterminado es *.doc.

DOT-Extension: extensión de archivo predeterminada de las plantillas de Word. El valor predeterminado es *.dot.

NoFontMRUList: activa y desactiva la lista de fuentes utilizadas más recientemente (MRU, Most Recently Used). Para activar la lista de fuentes MRU, escriba 0 (cero). Para desactivar la lista de fuentes MRU, escriba 1 (uno).

SpellingWavyUnderlineColor: esta opción permite controlar el color del subrayado ondulado que se muestra bajo las palabras escritas incorrectamente.

GrammarWavyUnderlineColor: esta opción permite controlar el color del subrayado ondulado que se muestra bajo las palabras con errores gramaticales.

SmartTagUnderlineColor: esta opción permite controlar el color del subrayado con puntos que se muestra bajo las etiquetas inteligentes.

FormatConsistencyWavyUnderlineColor: esta opción permite controlar el color del subrayado ondulado que se muestra bajo los errores de formato.

OLEDOT: especifica la plantilla de documento que se utiliza al crear un objeto de documento dentro de Word u otra aplicación OLE.
Opciones del Editor de ecuaciones

Appdir: carpeta de programa del Editor de ecuaciones. El Editor de ecuaciones debe instalarse y ejecutarse una vez para que se muestren éste y otros valores de configuración del mismo.

CustomZoom: configuración de zoom personalizado. Sólo tiene efecto si el Editor de ecuaciones se inicia en una ventana independiente mediante la opción ForceOpen.

ForceOpen: obliga a que el Editor de ecuaciones se abra en su propia ventana independiente. Escriba 0 (cero) para abrirlo en la misma ventana o 1 para abrirlo en una ventana independiente.

ShowAll: muestra u oculta los caracteres no imprimibles.

ToolBarDocked: establece si la barra de herramientas se acoplará. Elija Sí (1) o No (0).

ToolBarDockPos: posición de la barra de herramientas del Editor de ecuaciones cuando está acoplada. 1 establece la barra de herramientas al principio de la ventana del Editor de ecuaciones. 2 establece la barra de herramientas al final de la ventana del Editor de ecuaciones.

ToolBarShown: establece si la barra de herramientas se mostrará o no. Elija Sí (1) o No (0).

ToolBarWinPos: posición de la barra de herramientas cuando no está acoplada, especificada en coordenadas X, Y, con la esquina superior izquierda como origen. Las unidades están en píxeles.

Zoom: tamaño de zoom estándar seleccionado en el menú Ver.
. Para utilizar la macro RegOptions, siga estos pasos:
  1. En el menú Archivo, haga clic en Abrir.
  2. Cambie por Plantillas de documento (*.dot ) el valor del cuadro Tipo de archivos.
  3. Cambie el valor del cuadro Buscar en por la carpeta siguiente:
    C:\Archivos de programa\Microsoft Office\Office10\Macros\
  4. Haga clic en Support.dot para activarlo y, después, haga clic en Abrir.
  5. En la columna Macro de la tabla contenida en el archivo, haga clic en el botón Opciones del Registro.
  6. En la ficha Opciones de Word u Opciones del Editor de ecuaciones, haga clic en la opción que desee cambiar, escriba el nuevo valor en el cuadro Valor (o haga clic en Examinar, si está disponible, y haga clic en el valor que desee para seleccionarlo) y, a continuación, haga clic en Cambiar.
  7. Haga clic en Cerrar para cerrar el cuadro de diálogo Establecer opciones del Registro.


Cómo usar la utilidad Copia de seguridad de Autocorrección

Puede usar la utilidad Copia de seguridad de Autocorrección para trasladar entradas de Autocorrección entre equipos. Para obtener información adicional acerca de la utilidad Copia de seguridad de Autocorrección, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
269006 WD2002: Cómo trasladar elementos de Autocorrección entre distintos equipos


Sólo para usuarios avanzados

La información de esta sección no se requiere al usar las macros de la plantilla Support.dot. Esta información sólo se suministra por si desea hacer que estas macros estén disponibles de forma global en Microsoft Word o si desea ver el código de las macros.



Cómo hacer que las macros estén disponibles globalmente

Para hacer que las macros estén disponibles en Microsoft Word, utilice uno de los métodos siguientes.

Método 1: agregarlas a Plantillas globales y complementos

Si piensa utilizar las macros ocasionalmente (o si desea ver lo que hacen antes de decidir hacerlas accesibles de forma sencilla), agregue las plantillas de macro como plantillas globales.

Para agregar una de las plantillas de la sección "Resumen" de este artículo como una plantilla global, siga estos pasos:
  1. En el menú Herramientas, haga clic en Plantillas y complementos.
  2. En Plantillas globales y complementos, haga clic en Agregar.
  3. En el cuadro Buscar en, indique la carpeta que contenga la plantilla de macro de ejemplo. En el cuadro Archivos de tipo, seleccione Todos los archivos (*.*).
  4. Seleccione la plantilla de macro de ejemplo y haga clic en Aceptar.
  5. Cuando la plantilla de macro de ejemplo aparezca en el cuadro de diálogo Plantillas y complementos, asegúrese de que la casilla de verificación de la plantilla esté activada y, a continuación, haga clic en Aceptar.

    IMPORTANTE: cuando se carga una plantilla en Plantillas globales y complementos, la plantilla permanece cargada sólo durante la sesión de Word actual. Si sale y reinicie Word, la plantilla no se vuelve a cargar automáticamente. Debe volver a seleccionar la plantilla que desee utilizar. Para ello, en el menú Herramientas, haga clic en Plantillas y complementos. En el cuadro de diálogo Plantillas y complementos, seleccione la plantilla desde la que desee utilizar las macros y, a continuación, haga clic en Aceptar.
  6. Para ejecutar una macro específica, siga estos pasos:
    1. En el menú Herramientas, seleccione Macro y, a continuación, haga clic en Macros.
    2. En el cuadro de diálogo Macros, cambie el valor del cuadro Macros de por la plantilla que contenga la macro que desee. Por ejemplo, haga clic en Support.dot (plantilla global) para activarla.
    3. En la lista Nombre de la macro, haga clic en la macro que desee para seleccionarla y, a continuación, haga clic en Ejecutar.

Método 2: agregar la plantilla a la carpeta Inicio

Traslade la plantilla a la carpeta Inicio. Microsoft Word tiene acceso automáticamente a las macros de las plantillas que se encuentran en la carpeta siguiente:
C:\Archivos de programa\Microsoft Office\Office10\Inicio
Utilice el Explorador de Microsoft Windows para colocar una copia de la plantilla de macro de ejemplo en la carpeta Inicio.

Al iniciar Word, una plantilla ubicada en la carpeta Inicio se carga como plantilla global y sus macros están disponibles en el cuadro de diálogo Macros. Una desventaja de este método es que Word puede tardar un poco más en iniciarse (cada vez que se inicia Word, carga estas plantillas de forma global).

Para ejecutar una macro específica, siga estos pasos:
  1. En el menú Herramientas, seleccione Macro y, a continuación, haga clic en Macros.
  2. En el cuadro de diálogo Macros, cambie el valor del cuadro Macros de por la plantilla que contenga la macro que desee. Por ejemplo, haga clic en Support.dot (plantilla global) para activarla.
  3. En la lista Nombre de la macro, haga clic en la macro que desee para seleccionarla y, a continuación, haga clic en Ejecutar.

Método 3: copiar la macro en la plantilla Normal

Para ejecutar una macro específica sin abrir su plantilla, cópiela a su plantilla global (Normal.dot). Para ello, siga estos pasos:
  1. Abra la plantilla de macro de ejemplo.
  2. En el menú Herramientas, haga clic en Plantillas y complementos.
  3. En el cuadro de diálogo Plantillas y complementos, haga clic en Organizador.
  4. En el cuadro de diálogo Organizador, haga clic en la ficha Elementos del proyecto macro para seleccionarla.
  5. Las macros de la plantilla de macro de ejemplo aparecen en uno de los laterales del cuadro de diálogo. Su plantilla global (Normal.dot) aparece abierta en el lado opuesto.

    NOTA: si el archivo Normal.dot (plantilla global) no está abierto, haga clic en Cerrar archivo en el lado opuesto. El botón Cerrar archivo cambia a Abrir archivo. Haga clic en Abrir archivo. Haga clic en su archivo de plantilla Normal.dot para seleccionarlo y, a continuación, haga clic en Abrir.
  6. En el lado de la plantilla de macro de ejemplo, haga clic en los elementos de proyecto macro que aparecen en la plantilla de macro de ejemplo para seleccionarlos y, a continuación, haga clic en Copiar.

    NOTA: para seleccionar todos los elementos de la lista, mantenga presionada la tecla CTRL mientras hace clic en cada elemento del proyecto de macro.
  7. Haga clic en Copiar para copiar los elementos del proyecto macro a su plantilla Normal.dot.
  8. Haga clic en Aceptar para cerrar el cuadro de diálogo Organizador.
  9. Para ejecutar una macro específica, siga estos pasos:
    1. En el menú Herramientas, seleccione Macro y, a continuación, haga clic en Macros.
    2. En el cuadro de diálogo Macros, cambie el valor del cuadro Macros de por la plantilla que contenga la macro que desee. Por ejemplo, haga clic en Normal.dot (plantilla global) para seleccionarla.
    3. En la lista Nombre de la macro, haga clic en la macro que desee para seleccionarla y, a continuación, haga clic en Ejecutar.


Cómo ver código de macro

Microsoft proporciona ejemplos de programación con fines ilustrativos únicamente, sin ninguna garantía tanto expresa como implícita, incluyendo, pero sin limitarse a, las garantías implícitas de comerciabilidad e idoneidad para un fin determinado. En este artículo se da por supuesto que ya conoce el lenguaje de programación que se muestra, así como las herramientas empleadas para crear y depurar procedimientos. Los profesionales de soporte técnico de Microsoft pueden explicarle la funcionalidad de un determinado procedimiento, pero no modificarán estos ejemplos para ofrecer mayor funcionalidad ni crearán procedimientos adaptados a sus necesidades específicas. Si tiene poca experiencia en programación, quizá desee ponerse en contacto con un Microsoft Certified Solution Partner o con la línea del servicio de consultoría que se ofrece, mediante pago, llamando al Centro de Atención al Cliente de Microsoft en el número 902 197 198. Para obtener más información acerca de los Certified Partners, consulte el siguiente sitio Web de Microsoft:
http://www.microsoft.com/spain/partner/partnering/mapas/spain.asp
Para obtener más información acerca de las opciones de soporte técnico disponibles y cómo ponerse en contacto con Microsoft, consulte el siguiente sitio Web de Microsoft:
http://support.microsoft.com/default.aspx?scid=fh;ES-ES;CNTACTMS
Para ver el código de una macro de ejemplo, siga estos pasos:
  1. En el menú Archivo, haga clic en Abrir.
  2. En el cuadro de diálogo Abrir, cambie el valor del cuadro Buscar en por la carpeta que contenga la plantilla de macro de ejemplo, cambie el valor del cuadro Archivos de tipo por Todos los archivos (*.*) y, a continuación, haga clic en la plantilla de macro de ejemplo adecuada para seleccionarla.
  3. Mantenga presionada la tecla MAYÚS y haga clic en Abrir.
  4. En el menú Herramientas, seleccione Macro y, a continuación, haga clic en Macros.
  5. En el cuadro de diálogo Macros, cambie el valor del cuadro Macros de por la plantilla de macro de ejemplo recién abierta.
  6. Seleccione la macro adecuada y, a continuación, haga clic en Modificar.

Propiedades

Id. de artículo: 289506 - Última revisión: viernes, 24 de octubre de 2003 - Versión: 1.0
La información de este artículo se refiere a:
  • Microsoft Word 2002 Standard Edition
Palabras clave: 
kbhowto kbhowtomaster kbdta KB289506

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com