COMMENT FAIRE : Installer et utiliser le modèle Support.dot

Traductions disponibles Traductions disponibles
Numéro d'article: 289506 - Voir les produits auxquels s'applique cet article
Ancien nº de publication de cet article : F289506
Agrandir tout | Réduire tout

Sommaire

Résumé

Le modèle Support.dot comporte les macros suivantes créées par les services de Support technique Microsoft :
Macro Nom Description
Utilitaire de dépannage TShoot Cette macro peut être utilisée pour résoudre divers problèmes avec Word. Vous pouvez utiliser cette macro pour renommer votre clé de données et le fichier Normal.dot, ainsi que pour désactiver les compléments Word.

REMARQUE : Vous devez démarrer Word avec le commutateur /a avant d'exécuter cette macro.
Options du registre RegOptions Cette macro peut être utilisée pour modifier les paramètres Word enregistrés dans le registre de Windows.
AutoCorrect Backup AutoCorrectBackup Cette macro sauvegarde dans un fichier la liste de vos corrections automatiques. Vous pouvez transférer ce fichier sur un autre ordinateur et exécuter de nouveau la macro pour restaurer la liste de correction automatique.



Installation du modèle Support.dot

Le modèle Support.dot s'installe au cours d'une installation Complète. Il ne s'installe en revanche pas au cours d'une installation Typique ou de Mise à niveau. Si le modèle Support.dot n'est pas installé, procédez comme suit :
  1. Fermez Microsoft Word et tous les programmes Microsoft Office.
  2. Cliquez sur Démarrer, pointez sur Paramètres, puis cliquez sur Panneau de configuration.
  3. Dans Panneau de configuration, double-cliquez sur Ajout/Suppression de programmes.
  4. Appliquez la méthode appropriée au système d'exploitation de votre ordinateur.
    • Dans Microsoft Windows 98, Windows Millennium Edition ou Microsoft Windows NT 4.0, sélectionnez Microsoft Office XP (Microsoft Word 2002) dans l'onglet Installer/Désinstaller, puis cliquez sur Ajout/Suppression.

      -ou-
    • Dans Microsoft Windows 2000 ou Microsoft Windows XP, cliquez sur Modifier/Supprimer des programmes. Dans la liste Programmes actuellement installés, cliquez sur Microsoft Office XP (Microsoft Word 2002), puis sur Modifier.
  5. Dans le programme d'installation Microsoft Office XP (programme d'installation Microsoft Word 2002), cliquez sur Ajouter/Supprimer des composants, puis cliquez sur Suivant.
  6. Dans la liste Composants à installer, procédez comme suit : REMARQUE : Cliquez sur le signe plus (+) à gauche de la fonction pour développer cette dernière.

    1. Cliquez pour développer Microsoft Word pour Windows.
    2. Cliquez pour développer Assistants et modèles.
    3. Cliquez sur l'icône Autres modèles et macros, puis cliquez sur Tout exécuter à partir du disque dur dans le menu contextuel.
  7. : Cliquez sur le signe plus (+) à gauche de la fonction pour développer cette dernière. Cliquez sur Mettre à jour pour installer le modèle Support.dot.



Ouverture du modèle Support.dot

Pour ouvrir le modèle Support.dot, procédez comme suit :
  1. Dans le menu Fichier, cliquez sur Ouvrir.
  2. Dans la zone Type de fichiers, sélectionnez Modèles de document (*.dot).
  3. Dans la zone Rechercher dans, sélectionnez :
    C:\Program Files\Microsoft Office\Office10\Macros\
  4. Cliquez sur Support.dot, puis cliquez sur Ouvrir.
  5. Dans la colonne Macro du tableau des fichiers, cliquez sur le bouton approprié pour exécuter la macro de votre choix. Par exemple, cliquez sur Utilitaire de dépannage,Options du registre, ou Sauvegarde des corrections automatiques.



Utilisation de l'utilitaire de dépannage

L'utilitaire de dépannage est une macro fournie par les Services de support technique Microsoft. Cette macro peut vous aider à automatiser le processus de dépannage des problèmes rencontrés avec Microsoft Word en supprimant certains composants clé pouvant être endommagés ou pouvant entrer en conflit avec Microsoft Word. Utilisez cet utilitaire pour désactiver (dans l'ordre d'énumération) les composants suivants, chargés au démarrage de Word :
  • Clé du registre Data
  • Modèle global Normal.dot
  • Compléments et modèles
  • Compléments COM
  • Clé du registre Options
Si l'un de ces éléments est endommagé ou incompatible, Word risque de ne pas démarrer ou de ne pas fonctionner correctement. Pour contourner ces composants ou d'autres éléments, lancez Word à l'aide du commutateur /a.


Démarrage de Microsoft Word avec le commutateur /a

Pour démarrer Word à l'aide du commutateur /a, procédez comme suit :
  1. Cliquez sur Démarrer, puis sur Exécuter.
  2. Dans la boîte de dialogue Exécuter, effectuez l'une des opérations suivantes :
    • Dans la zone Ouvrir, tapez Winword.exe /a.

      -ou-
    • Cliquez sur Parcourir. Recherchez et sélectionnez le fichier Winword.exe. Pour cela, procédez comme suit :
      1. Dans la liste Rechercher dans, sélectionnez le dossier contant les fichiers du programme Word. Sélectionnez le fichier Winword.exe, puis cliquez sur Ouvrir.

        Cette étape remplit la zone Ouvrir dans la boîte de dialogue Exécuter.
      2. Dans la zone Ouvrir, déplacez le point d'insertion après Winword.exe.

        REMARQUE : Le chemin d'accès conduisant au fichier Winword.exe dans la boîte de dialogue Exécuter est entre guillemets. Assurez-vous de placer le point d'insertion à la droite du guillemet de clôture.
      3. Tapez un espace, puis /a.

        L'instruction dans le champ Ouvrir devrait être similaire à celle-ci :
        "C:\Program Files\Microsoft Office\Office10\Winword.exe" /a
  3. Dans la boîte de dialogue Exécuter, cliquez sur OK.
Si Word démarre et fonctionne correctement lorsque vous utilisez le commutateur /a, le problème tient à l'un des composants énumérés au début de la section " Utilisation de l'utilitaire de dépannage " de cet article. Faites appel à l'utilitaire de dépannage pour déterminer le composant à l'origine du problème. Pour cela, vous devez peut-être installer Support.dot.

REMARQUE : Si le problème persiste lorsque vous démarrez Word avec le commutateur /a, il n'est pas nécessaire de faire appel à l'utilitaire de dépannage.


Procédure étape par étape : utilisation de l'utilitaire de dépannage

Pour isoler et supprimer le composant qui provoque le problème dans Word, supprimez chacun des composants suivants (un à la fois et dans l'ordre d'énumération) à l'aide de l'utilitaire de dépannage :

Étape 1 : Suppression de la clé de registre Data

Les options les plus fréquemment utilisées (cliquez sur Options dans le menu Outils) sont stockées dans la clé Data. Une étape du dépannage consiste à supprimer la clé Data. Microsoft Word reconstruit cette clé Data en utilisant les paramètres par défaut la prochaine fois que vous démarrez l'application.

REMARQUE : La suppression de la clé Data rétablit les paramètres par défaut de plusieurs options, y compris la liste des derniers fichiers utilisés dans le menu Fichier et de nombreux autres paramètres que vous avez pu personnaliser dans la boîte de dialogue Options.

Pour supprimer la clé Data, procédez comme suit :
  1. Quittez tous les programmes Office.
  2. Démarrez Word en utilisant le commutateur /a Pour démarrer Word à l'aide du commutateur /a, veuillez consulter la section " Démarrage de Microsoft Word avec le commutateur /a " de cet article.
  3. Ouvrez le modèle Support.dot. Pour cela, veuillez consulter la section " Ouverture du modèle Support.dot " de cet article.
  4. Dans le modèle Support.dot, cliquez sur le bouton Utilitaire de dépannage.
  5. Dans la boîte de dialogue Utilitaire de dépannage Microsoft Word, dans la liste Sélectionner un article, cliquez sur Clé de registre Data, puis sur Supprimer.
  6. Cliquez sur OK lorsque le message suivant s'affiche :
    HKEY_CURRENT_USER\Software\Microsoft Office\10.0\Word\Data
    Le fichier de sauvegarde de cette clé de registre se trouve dans :
    C:\WINDOWS\TEMP\wddata10.0

    La clé de registre a été supprimée.
  7. Cliquez sur Fermer.
  8. Dans le menu Fichier, cliquez sur Quitter pour quitter Word.
  9. Démarrez Word comme vous le faites habituellement. N'utilisez pas la procédure de la section " Démarrage de Microsoft Word avec le commutateur /a " de cet article.
Si Word démarre et fonctionne correctement, le problème est donc résolu. Une clé de registre Data endommagée était à l'origine du problème. Vous devrez peut-être modifier quelques paramètres pour restaurer vos options préférées dans Word.

Si le problème n'est pas résolu, restaurez l'ancienne clé de registre Data. Pour cela, procédez comme suit :
  1. Quittez tous les programmes Office.
  2. Démarrez Word en utilisant le commutateur /a Pour démarrer Word à l'aide du commutateur /a, veuillez consulter la section " Démarrage de Microsoft Word avec le commutateur /a " de cet article.
  3. Ouvrez le modèle Support.dot. Pour cela, veuillez consulter la section " Ouverture du modèle Support.dot " de cet article.
  4. Dans le modèle Support.dot, cliquez sur le bouton Utilitaire de dépannage.
  5. Dans la boîte de dialogue Utilitaire de dépannage Microsoft Word, dans la liste Sélectionner un article, cliquez sur Clé de registre Data, puis sur Restaurer.
  6. Cliquez sur Oui lorsque le message suivant s'affiche :
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Data

    Cette clé est présente dans le registre.
    Voulez-vous la remplacer ?
  7. Cliquez sur OK lorsque le message suivant s'affiche :
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Data

    Restauration de la clé de registre réussie.
  8. Effectuez l'une des opérations suivantes :
Retour au début de la section Utilisation de l'utilitaire de dépannage


Étape no 2 : Modification du nom du modèle global Normal.dot.

Pour empêcher que la mise en forme, la fonction d'insertion automatique et les macros stockées dans le modèle global (Normal.dot) affectent le comportement de Word et des documents ouverts, renommez votre modèle global. Le fait de renommer Normal.dot vous permet de déterminer rapidement si ce fichier est à l'origine du problème.

REMARQUE : Renommer le fichier Normal.dot restaure plusieurs options par défaut, notamment les styles personnalisés, les barres d'outils personnalisées, les macros et l'insertion automatique. Microsoft vous recommande donc fortement de ne pas supprimer votre fichier Normal.dot.

Certains types de configuration peuvent créer plusieurs fichiers Normal.dot. C'est le cas notamment lorsque plusieurs versions de Word sont exécutées sur un même ordinateur ou lorsque plusieurs installations de poste de travail existent sur un même ordinateur. Dans ces cas, assurez-vous de renommer la copie adéquate de Normal.dot.

Pour renommer le fichier Normal.dot, procédez comme suit :
  1. Quittez tous les programmes Office.
  2. Démarrez Word en utilisant le commutateur /a Pour démarrer Word à l'aide du commutateur /a, veuillez consulter la section " Démarrage de Microsoft Word avec le commutateur /a " de cet article.
  3. Ouvrez le modèle Support.dot. Pour cela, veuillez consulter la section " Ouverture du modèle Support.dot " de cet article.
  4. Dans le modèle Support.dot, cliquez sur le bouton Utilitaire de dépannage.
  5. Dans la boîte de dialogue Utilitaire de dépannage Microsoft Word, dans la liste Sélectionner un élément, cliquez sur Modèle global Normal.dot, puis cliquez sur Renommer.
  6. Cliquez sur OK lorsque le message suivant s'affiche :
    chemin d'accès\Application Data\Microsoft\Templates\Normal.dot
    Copié(s) vers
    chemin d'accès\Application Data\Microsoft\Templates\10Normal.dot
    REMARQUE : Le chemin d'accès à votre fichier Normal.dot peut être différent.
  7. Cliquez sur Fermer pour fermer la boîte de dialogue Utilitaire de dépannage Microsoft Word.
  8. Dans le menu Fichier, cliquez sur Quitter pour quitter Word.
  9. Démarrez Word comme vous le faites habituellement. N'utilisez pas la procédure de la section " Démarrage de Microsoft Word avec le commutateur /a " de cet article.
Si Word démarre correctement, vous avez résolu le problème. Dans ce cas, un fichier Normal.dot endommagé était à l'origine du problème. Vous devrez peut-être modifier quelques paramètres pour restaurer vos options préférées. Si le fichier Normal.dot que vous avez renommé contenait des personnalisations complexes à recréer, notamment des styles, des macros ou des entrées d'insertion automatique, vous pourrez peut-être les copier à partir de l'ancien fichier 10Normal.dot vers le nouveau fichier Normal.dot, à l'aide de la commande Organiser.

Pour plus d'informations sur l'utilisation de la commande Organiser, cliquez sur Aide sur Microsoft Word dans le menu ? (Aide), tapez utiliser la commande Organiser dans le Compagnon Office ou l'Aide intuitive, puis cliquez sur Rechercher pour afficher les rubriques correspondantes.

Si le problème n'est pas résolu, restaurez l'ancien fichier Normal.dot (10Normal.dot). Pour cela, procédez comme suit :
  1. Quittez tous les programmes Office.
  2. Démarrez Word en utilisant le commutateur /a Pour démarrer Word à l'aide du commutateur /a, veuillez consulter la section " Démarrage de Microsoft Word avec le commutateur /a " de cet article.
  3. Ouvrez le modèle Support.dot. Pour cela, veuillez consulter la section " Ouverture du modèle Support.dot " de cet article.
  4. Dans le modèle Support.dot, cliquez sur le bouton Utilitaire de dépannage.
  5. Dans la boîte de dialogue Utilitaire de dépannage Microsoft Word, dans la liste Sélectionner un élément, cliquez sur Modèle global Normal.dot, puis sur Restaurer.
  6. Cliquez sur Oui lorsque le message suivant s'affiche :
    chemin d'accès\Application Data\Microsoft\Templates\Normal.dot

    La sauvegarde de ce fichier existe déjà.

    Voulez-vous la remplacer ?
    REMARQUE : Le chemin d'accès à votre fichier Normal.dot peut être différent.
  7. Cliquez sur OK lorsque le message suivant s'affiche :
    chemin d'accès\Application Data\Microsoft\Templates\10Normal.dot
    Copié(s) vers
    chemin d'accès\Templates\Normal.dot
  8. Effectuez l'une des opérations suivantes :
Retour au début de la section Utilisation de l'utilitaire de dépannage


Étape 3 : Désactivation des compléments du dossier Démarrage de Word

Lorsque vous démarrez Word, les modèles et les compléments situés dans les dossiers de démarrage sont chargés automatiquement. Les erreurs dans Word peuvent être le résultat de conflits ou de problèmes avec un complément particulier. Pour déterminer si un élément du dossier de démarrage pose problème, vous pouvez temporairement désactiver le paramètre du registre qui pointe vers ces compléments.

Pour désactiver temporairement la clé de registre des compléments, procédez comme suit :
  1. Quittez tous les programmes Office.
  2. Démarrez Word en utilisant le commutateur /a Pour démarrer Word à l'aide du commutateur /a, veuillez consulter la section " Démarrage de Microsoft Word avec le commutateur /a " de cet article.
  3. Ouvrez le modèle Support.dot. Pour cela, veuillez consulter la section " Ouverture du modèle Support.dot " de cet article.
  4. Dans le modèle Support.dot, cliquez sur le bouton Utilitaire de dépannage.
  5. Dans la boîte de dialogue Utilitaire de dépannage Microsoft Word, dans la liste Sélectionner un élément, cliquez sur Compléments du dossier Démarrage de Word, puis sur Renommer.
  6. Effectuez l'une des opérations suivantes :
    • Cliquez sur OK lorsque le message suivant s'affiche :
      Aucun fichier à renommer ou à restaurer.
      REMARQUE : Si ce message s'affiche, aucun complément n'est chargé lorsque vous démarrez Word. Après avoir cliqué sur OK, passez à la section Étape 4 : Suppression de la clé de registre des compléments COM de cet article.

      -ou-
    • Cliquez sur OK lorsque le message suivant s'affiche :
      chemin d'accès\Application Data\Microsoft\Word\Startup\nom de fichier
      Copié(s) vers
      chemin d'accès\Application Data\Microsoft\Word\Startup\nom de fichier

      chemin d'accès\Program Files\Microsoft Office\Office10\Startup\nom de fichier
      Copié(s) vers
      chemin d'accès\Program Files\Microsoft Office\Office10\Startup\nom de fichier
      REMARQUE : Les chemins d'accès et les noms de fichiers de votre système peuvent être différents.
  7. Cliquez sur Fermer pour fermer la boîte de dialogue Utilitaire de dépannage Microsoft Word.
  8. Dans le menu Fichier, cliquez sur Quitter pour quitter Word.
  9. Démarrez Word comme vous le faites habituellement. N'utilisez pas la procédure de la section " Démarrage de Microsoft Word avec le commutateur /a " de cet article.
  10. Effectuez l'une des opérations suivantes :
    • Si vous ne pouvez plus reproduire ce problème et si les éléments de démarrage ont été supprimés à l'étape 6, vous avez déterminé que le problème est provoqué par un élément du complément. Pour déterminer quel est l'élément de démarrage qui provoque le problème, procédez comme suit :
      1. Quittez tous les programmes Office.
      2. Démarrez Word en utilisant le commutateur /a Pour démarrer Word à l'aide du commutateur /a, veuillez consulter la section " Démarrage de Microsoft Word avec le commutateur /a " de cet article.
      3. Ouvrez le modèle Support.dot. Pour cela, veuillez consulter la section " Ouverture du modèle Support.dot " de cet article.
      4. Dans le modèle Support.dot, cliquez sur le bouton Utilitaire de dépannage.
      5. Dans la boîte de dialogue Utilitaire de dépannage Microsoft Word, dans la liste Sélectionner un élément, cliquez sur Compléments du dossier Démarrage de Word, puis sur Restaurer.
      6. Cliquez sur OK lorsque le message suivant s'affiche :
        chemin d'accès\Application Data\Microsoft\Word\Startup\nom de fichier
        Copié(s) vers
        chemin d'accès\Application Data\Microsoft\Word\Startup\nom de fichier

        chemin d'accès\Program Files\Microsoft Office\Office10\Startup\nom de fichier
        Copié(s) vers
        chemin d'accès\Program Files\Microsoft Office\Office10\Startup\nom de fichier
        REMARQUE : Les chemins d'accès et les noms de fichiers de votre système peuvent être différents.
      7. Cliquez sur Fermer pour fermer la boîte de dialogue Utilitaire de dépannage Microsoft Word.
      8. Dans le menu Fichier, cliquez sur Quitter pour quitter Word.
      9. Double-cliquez sur Poste de travail, puis ouvrez un des dossiers spécifiés à l'étape f. Par exemple :
        chemin d'accès\Application Data\Microsoft\Word\Startup\

        -ou-

        chemin d'accès\Program Files\Microsoft Office\Office10\Startup\
      10. Cliquez avec le bouton droit sur l'un des fichiers contenus dans le dossier, puis cliquez sur Renommer dans le menu contextuel.
      11. Tapez le nouveau nom du fichier, puis appuyez sur ENTRÉE.

        IMPORTANT : Notez le nom d'origine du fichier, car vous devrez peut-être le renommer.
      12. Démarrez Word comme vous le faites habituellement. N'utilisez pas la procédure de la section " Démarrage de Microsoft Word avec le commutateur /a " de cet article.
      Si vous ne pouvez plus reproduire le problème, vous avez trouvé l'élément spécifique du complément posant problème. Si vous avez besoin des fonctionnalités fournies par l'élément du complément, vous devez déterminer quel complément Word contient l'élément spécifique et contacter le fournisseur pour vous procurer une mise à jour.

      Si le problème n'est pas résolu, redonnez au complément son nom d'origine, puis répétez les étapes h à i pour chaque fichier contenu dans les dossiers spécifiés dans les messages présentés à l'étape f.

      -ou-

    • Si vous ne pouvez plus reproduire le problème, vous avez trouvé l'élément spécifique du complément posant problème. Si vous avez besoin des fonctionnalités fournies par l'élément du complément, vous devez déterminer quel complément Word contient l'élément spécifique et contacter le fournisseur pour vous procurer une mise à jour. Si le problème n'est pas résolu, restaurez les éléments du complément, puis passez à l'étape suivante. Pour cela, procédez comme suit :
      1. Quittez tous les programmes Office.
      2. Démarrez Word en utilisant le commutateur /a Pour démarrer Word à l'aide du commutateur /a, veuillez consulter la section " Démarrage de Microsoft Word avec le commutateur /a " de cet article.
      3. Ouvrez le modèle Support.dot. Pour cela, veuillez consulter la section " Ouverture du modèle Support.dot " de cet article.
      4. Dans le modèle Support.dot, cliquez sur le bouton Utilitaire de dépannage.
      5. Dans la boîte de dialogue Utilitaire de dépannage Microsoft Word, dans la liste Sélectionner un élément, cliquez sur Compléments du dossier Démarrage de Word, puis sur Restaurer.
      6. Cliquez sur OK lorsque le message suivant s'affiche :
        chemin d'accès\Application Data\Microsoft\Word\Startup\nom de fichier
        Copié(s) vers
        chemin d'accès\Application Data\Microsoft\Word\Startup\nom de fichier

        chemin d'accès\Program Files\Microsoft Office\Office10\Startup\nom de fichier
        Copié(s) vers
        chemin d'accès\Program Files\Microsoft Office\Office10\Startup\nom de fichier
        REMARQUE : Les chemins d'accès et les noms de fichiers de votre système peuvent être différents.
      7. Passez à la section Étape 4 : Suppression de la clé de registre des compléments COM de cet article.
Retour au début de la section Utilisation de l'utilitaire de dépannage


Étape 4 : Suppression de la clé de registre des compléments COM

Les compléments COM peuvent être installés dans n'importe quel emplacement par des programmes qui interagissent avec Word. Pour supprimer les paramètres du registre de Windows pour chaque complément COM installé, procédez comme suit :
  1. Quittez tous les programmes Office.
  2. Démarrez Word en utilisant le commutateur /a Pour démarrer Word à l'aide du commutateur /a, veuillez consulter la section " Démarrage de Microsoft Word avec le commutateur /a " de cet article.
  3. Ouvrez le modèle Support.dot. Pour cela, veuillez consulter la section " Ouverture du modèle Support.dot " de cet article.
  4. Dans le modèle Support.dot, cliquez sur le bouton Utilitaire de dépannage.
  5. Dans la boîte de dialogue Utilitaire de dépannage Microsoft Word, dans la liste Sélectionner un article, cliquez sur Clé de registre Compléments COM, puis sur Supprimer.
  6. Cliquez sur OK lorsque le message suivant s'affiche :
    HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins
    Le fichier de sauvegarde de cette clé de registre se trouve dans :
    C:\Windows\TEMP\wdaddn10.0

    La clé de registre a été supprimée.
  7. Cliquez sur Fermer pour fermer la boîte de dialogue Utilitaire de dépannage Microsoft Word.
  8. Dans le menu Fichier, cliquez sur Quitter pour quitter Word.
  9. Démarrez Word comme vous le faites habituellement. N'utilisez pas la procédure de la section " Démarrage de Microsoft Word avec le commutateur /a " de cet article.
  10. Effectuez l'une des opérations suivantes :
    • Si vous ne pouvez plus reproduire le problème, vous avez trouvé l'élément spécifique du complément COM posant problème. Pour déterminer quel est le composant COM qui provoque le problème, procédez comme suit :
      1. Quittez tous les programmes Office.
      2. Démarrez Word en utilisant le commutateur /a Pour démarrer Word à l'aide du commutateur /a, veuillez consulter la section " Démarrage de Microsoft Word avec le commutateur /a " de cet article.
      3. Ouvrez le modèle Support.dot. Pour cela, veuillez consulter la section " Ouverture du modèle Support.dot " de cet article.
      4. Dans le modèle Support.dot, cliquez sur le bouton Utilitaire de dépannage.
      5. Dans la boîte de dialogue Utilitaire de dépannage Microsoft Word, dans la liste Sélectionner un article, cliquez sur Clé de registre Compléments COM, puis sur Restaurer.
      6. Cliquez sur OK lorsque le message suivant s'affiche :
        HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins

        La clé de registre a été restaurée avec succès.
      7. Cliquez sur Fermer pour fermer la boîte de dialogue Utilitaire de dépannage Microsoft Word.
      8. Dans le menu Fichier, cliquez sur Quitter pour quitter Word.
      9. Démarrez Word comme vous le faites habituellement. N'utilisez pas la procédure de la section " Démarrage de Microsoft Word avec le commutateur /a " de cet article.
      10. Dans le menu Outils, cliquez sur Personnaliser.
      11. Cliquez sur l'onglet Commandes. Dans la liste Catégories, cliquez sur Outils.
      12. Dans la liste Commandes, cliquez sur Compléments COM, puis faites glisser la commande sur l'une de vos barres d'outils.
      13. Cliquez sur Fermer pour quitter la boîte de dialogue Personnaliser.
      14. Cliquez sur le bouton Compléments COM que vous avez ajouté au cours des étapes k à m.
      15. Dans la boîte de dialogue Compléments COM, si un complément est mentionné, désactivez sa case à cocher.

        REMARQUE : Si plusieurs compléments sont répertoriés, cliquez sur un complément à la fois pour déterminer celui qui pose problème.
      16. Cliquez sur OK pour fermer la boîte de dialogue Compléments COM.
      17. Cliquez sur Quitter dans le menu Fichier pour quitter Word.
      18. Démarrez Word comme vous le faites habituellement. N'utilisez pas la procédure de la section " Démarrage de Microsoft Word avec le commutateur /a " de cet article.
      19. Effectuez l'une des opérations suivantes :
        • Si vous ne pouvez plus reproduire le problème, vous avez trouvé le complément COM posant problème. Si vous avez besoin des fonctionnalités fournies par l'élément du complément, vous devez déterminer quel complément Word contient l'élément spécifique et contacter le fournisseur pour vous procurer une mise à jour.

          -ou-
        • Si le problème n'est pas résolu, cliquez sur le bouton Compléments COM que vous avez ajouté au cours des étapes k à m. Activez le complément que vous avez désactivé à l'étape o. Désactivez ensuite un autre complément, et répétez les étapes p à s. Répétez cette procédure autant de fois que nécessaire, pour chaque complément, jusqu'à ce que vous trouviez celui qui pose problème.
      -ou-

    • -ou- Si le problème n'est pas résolu, restaurer la clé de registre Compléments COM, puis passez à l'étape suivante. Pour cela, procédez comme suit :
      1. Quittez tous les programmes Office.
      2. Démarrez Word en utilisant le commutateur /a Pour démarrer Word à l'aide du commutateur /a, veuillez consulter la section " Démarrage de Microsoft Word avec le commutateur /a " de cet article.
      3. Ouvrez le modèle Support.dot. Pour cela, veuillez consulter la section " Ouverture du modèle Support.dot " de cet article.
      4. Dans le modèle Support.dot, cliquez sur le bouton Utilitaire de dépannage.
      5. Dans la boîte de dialogue Utilitaire de dépannage Microsoft Word, dans la liste Sélectionner un article, cliquez sur Clé de registre Compléments COM, puis sur Restaurer.
      6. Cliquez sur OK lorsque le message suivant s'affiche :
        HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins

        Restauration de la clé de registre réussie.
      7. Cliquez sur Fermer pour fermer la boîte de dialogue Utilitaire de dépannage Microsoft Word.
      8. Dans le menu Fichier, cliquez sur Quitter pour quitter Word.
      9. Passez à la section Étape 5 : Suppression de la clé de registre Options de cet article.
Retour au début de la section Utilisation de l'utilitaire de dépannage


Étape 5 : Suppression de la clé de registre Options

La clé Options stocke les options que vous pouvez paramétrer dans Word, soit en modifiant les options des menus, soit en exécutant la macro RegOptions. Il s'agit des options modifiables.

Les paramètres peuvent être répartis en deux groupes : les paramètres par défaut et les paramètres facultatifs. Les paramètres par défaut sont créés lors de l'installation. Vous pouvez les changer en modifiant les options dans Word. Les paramètres facultatifs ne sont pas créés lors de l'installation. Pour les ajouter, exécutez la macro RegOptions (abordée plus loin dans cet article).

Pour supprimer la clé Options, procédez comme suit :
  1. Quittez tous les programmes Office.
  2. Démarrez Word en utilisant le commutateur /a Pour démarrer Word à l'aide du commutateur /a, veuillez consulter la section " Démarrage de Microsoft Word avec le commutateur /a " de cet article.
  3. Ouvrez le modèle Support.dot. Pour cela, veuillez consulter la section " Ouverture du modèle Support.dot " de cet article.
  4. Dans le modèle Support.dot, cliquez sur le bouton Utilitaire de dépannage.
  5. Dans la boîte de dialogue Utilitaire de dépannage Microsoft Word, dans la liste Sélectionner un article, cliquez sur Clé de registre Options, puis sur Supprimer.
  6. Cliquez sur OK lorsque le message suivant s'affiche :
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Options
    Le fichier de sauvegarde de cette clé de registre existe dans :
    C:\WINDOWS\TEMP\wdoptn10.0

    La clé de registre a été supprimée.
  7. Démarrez Word normalement, sans utiliser le commutateur/a tel que décrit à la section " Démarrage de Microsoft Word avec le commutateur /a " de cet article.
Si Word démarre et fonctionne correctement, le problème est résolu. Une clé Options endommagée était à l'origine du problème. Vous devrez peut-être modifier quelques paramètres pour restaurer vos options préférées dans Word.

Si le problème n'est pas résolu, quittez Microsoft Word, puis restaurez les informations de la clé Options dans le registre de Windows. Pour cela, procédez comme suit :
  1. Quittez tous les programmes Office.
  2. Démarrez Word en utilisant le commutateur /a Pour démarrer Word à l'aide du commutateur /a, veuillez consulter la section " Démarrage de Microsoft Word avec le commutateur /a " de cet article.
  3. Ouvrez le modèle Support.dot. Pour cela, veuillez consulter la section " Ouverture du modèle Support.dot " de cet article.
  4. Dans le modèle Support.dot, cliquez sur le bouton Utilitaire de dépannage, qui se trouve dans la table contenue dans le fichier.
  5. Dans la boîte de dialogue Utilitaire de dépannage Microsoft Word, dans la liste Sélectionner un article, cliquez sur Clé de registre Options, puis sur Restaurer.
  6. Cliquez sur Oui lorsque le message suivant s'affiche :
    HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Options

    Cette clé est présente dans le registre.
    Voulez-vous la remplacer ?
  7. Cliquez sur OK lorsque le message suivant s'affiche :
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Options

    Restauration de la clé de registre réussie.
  8. Cliquez sur Fermer pour fermer la boîte de dialogue Utilitaire de dépannage Microsoft Word.
  9. Dans le menu Fichier, cliquez sur Quitter pour quitter Word.
Retour au début de la section Utilisation de l'utilitaire de dépannage




Utilisation de la macro Options du registre

Vous pouvez utiliser la macro RegOptions pour examiner et apporter les modifications aux paramètres Word dans le registre de Windows. La liste qui suit présente chacune des options disponibles dans la macro ainsi qu'une brève description de leur rôle.
Options Word

AutoSave-Path : Définit le dossier dans lequel les enregistrements automatiques ont lieu.

DOC-Path : Indique le dossier par défaut utilisé pour les documents Word.

Picture-Path : Définit le chemin par défaut utilisé lorsque vous pointez sur Image dans le menu Insertion et que vous cliquez ensuite sur À partir du fichier.

Startup-Path : Définit le chemin pour les fichiers de démarrage de Word, tels que les modèles et les fichiers WLL qui sont chargés lors du démarrage de Word.

Tools-Path : Définit l'emplacement des outils de vérification, des filtres, des convertisseurs et autres composants lorsqu'ils ne sont pas répertoriés correctement ou ne figurent pas dans leurs dossiers standard.

User-Dot-Path : Chemin d'accès des modèles utilisateur. Toute modification apportée à ce paramètre de Word affecte toutes les autres applications de Microsoft Office.

Workgroup-Dot-Path : Chemin d'accès des modèles groupe de travail. Vous pouvez indiquer un chemin UNC.

BAK-Extension : Indique l'extension de fichier par défaut utilisée pour les fichiers de sauvegarde Word. L'extension par défaut est *.wbk.

DOC-Extension : Indique l'extension de fichier par défaut utilisée pour les documents Word. L'extension par défaut est *.doc.

DOT-Extension : Indique l'extension de fichier par défaut utilisée pour les modèles Word. L'extension par défaut est *.dot.

NoFontMRUList : Active ou désactive la dernière liste de polices utilisée. Pour activer la liste de polices MRU, tapez 0 (zéro). Pour désactiver la liste de polices MRU, tapez 1.

SpellingWavyUnderlineColor : Permet de contrôler la couleur du soulignement ondulé affiché sous les mots mal orthographiés.

GrammarWavyUnderlineColor : Permet de contrôler la couleur du soulignement ondulé affiché sous les erreurs de grammaire.

SmartTagUnderlineColor : Permet de contrôler la couleur du soulignement en pointillés affiché sous les balises actives.

FormatConsistencyWavyUnderlineColor : Permet de contrôler la couleur du soulignement ondulé affiché sous les erreurs de mise en forme.

OLEDOT : Indique le modèle de document utilisé pour créer un objet de document dans Word ou une autre application OLE.

Options de l'Éditeur d'équations

Appdir : Dossier programme de l'Éditeur d'équations. Il est nécessaire d'installer l'Éditeur d'équations et de l'exécuter au moins une fois pour que ce dossier ainsi que les autres paramètres de l'Éditeur d'équations s'affichent.

CustomZoom : Paramètre de zoom personnalisé. Ce paramètre n'intervient que lorsque vous exécutez l'Éditeur d'équations dans une nouvelle fenêtre à l'aide du paramètre ForceOpen.

ForceOpen : Exécute l'Éditeur d'équations dans une nouvelle fenêtre. Tapez 0(zéro) pour ouvrir dans la fenêtre active, ou 1 pour ouvrir dans une nouvelle fenêtre.

ShowAll : Affiche ou masque les caractères non-imprimables.

ToolBarDocked : Indique si la barre d'outils est verrouillée. Choisissez Oui (1) ou Non (0).

ToolBarDockPos : Position de la barre d'outils Éditeur d'équations lorsqu'elle est verrouillée. 1 positionne la barre d'outils en haut de la fenêtre Éditeur d'équations. 2 positionne la barre d'outils en bas de la fenêtre Éditeur d'équations.

ToolBarShown : Indique si la barre d'outils est affichée. Choisissez Oui (1) ou Non (0).

ToolBarWinPos : Position de la barre d'outils lorsqu'elle n'est pas verrouillée, indiquée en coordonnées X,Y, avec comme point de départ l'angle supérieur gauche de la fenêtre. L'unité de mesure est le pixel.

Zoom : Taille de zoom standard sélectionnée dans le menu Affichage.
Pour utiliser la macro RegOptions, procédez comme suit :
  1. Dans le menu Fichier, cliquez sur Ouvrir.
  2. Dans la zone Type de fichiers, sélectionnez Modèles de document (*.dot).
  3. Dans la zone Rechercher dans, sélectionnez :
    C:\Program Files\Microsoft Office\Office10\Macros\
  4. Sélectionnez Support.dot, puis cliquez sur Ouvrir.
  5. Dans la colonne Macro du tableau contenu dans le fichier, cliquez sur le bouton Options du registre.
  6. Dans l'onglet Options Word ou l'onglet Options de l'Éditeur d'équations, sélectionnez l'option que vous souhaitez modifier, tapez le nouveau paramètre dans la zone Paramètre (ou cliquez sur Parcourir si celle-ci est disponible puis sélectionnez le paramètre souhaité), puis cliquez sur Modifier.
  7. Cliquez sur Fermer pour fermer la boite de dialogue Options de la base de registre.



Utilisation de l'utilitaire de sauvegarde des corrections automatiques

Vous pouvez utiliser l'utilitaire de sauvegarde des corrections automatiques pour transférer des entrées de correction automatique d'un ordinateur à l'autre. Pour plus d'informations sur cet utilitaire, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
269006 WD2002 : Procédure de déplacement d'entrées de correction automatique d'un ordinateur à l'autre



Experts uniquement

Les informations contenues dans cette section ne sont pas requises lorsque vous utilisez les macros dans le modèle Support.dot. Ces informations ne vous sont fournies que si vous souhaitez rendre ces macros disponibles globalement dans Microsoft Word, ou afficher le code de la macro




Procédure pour rendre les macros disponibles globalement

Pour rendre les macros disponibles globalement dans Microsoft Word, utilisez l'une des méthodes suivantes.

Méthode 1 : Ajout aux modèles globaux et aux compléments

Si vous prévoyez de n'utiliser les macros qu'occasionnellement (ou si vous souhaitez connaître leur action avant de les rendre accessibles), ajoutez les modèles de macro en tant que modèles globaux.

Pour ajouter l'un des modèles répertoriés à la section " Résumé " de cet article en tant que modèle global, suivez cette procédure :
  1. Dans le menu Outils, cliquez sur Modèles et compléments.
  2. Sous Modèles globaux et compléments, cliquez sur Ajouter.
  3. Dans la zone Rechercher dans, sélectionnez le dossier contenant l'exemple de modèle de macro. Dans la zone Type de fichiers, sélectionnez Tous les fichiers (*.*).
  4. Sélectionnez l'exemple de modèle de macro, puis cliquez sur OK.
  5. Lorsque l'exemple de modèle de macro s'affiche dans la boîte de dialogue Modèles et compléments, assurez-vous que la case à cocher du modèle est activée, puis cliquez sur OK.

    IMPORTANT : Lorsque vous chargez un modèle dans Modèles et compléments globaux, le modèle reste chargé uniquement pour la session Word active. Si vous fermez Word puis redémarrez le programme, le modèle ne se charge pas automatiquement. Vous devez de nouveau sélectionner le modèle de votrre choix. Pour cela, cliquez sur Modèles et compléments dans le menu Outils. Dans la boîte de dialogue Modèles et compléments, sélectionnez le modèle de macro que vous souhaitez utiliser, puis cliquez sur OK.
  6. Pour exécuter une macro spécifique, procédez comme suit :
    1. Dans le menu Outils, pointez sur Macro, puis cliquez sur Macros.
    2. Dans la boîte de dialogue Macros, dans la zone Macros, sélectionnez le modèle contenant la macro souhaitée. Par exemple, sélectionnez Support.dot (modèle global) ou Batch Conversion Wizard.wiz (modèle global).
    3. Dans la liste Nom de la macro, cliquez sur la macro de votre choix, puis cliquez sur Exécuter.

Méthode 2 : Ajout du modèle au dossier Démarrage

Placez le modèle dans le dossier Démarrage. Word a automatiquement accès à toutes les macros des modèles placés dans le dossier suivant :
C:\Program Files\Microsoft Office\Office10\Startup
Utilisez l'Explorateur Windows pour placer une copie de l'exemple de modèle de la macro dans le dossier Démarrage.

Lorsque vous démarrez Word, un modèle figurant dans le dossier Démarrage est chargé en tant que modèle global et les macros de ce modèle sont disponibles dans la boîte de dialogue Macros. Cette méthode présente toutefois un inconvénient : le démarrage de Word risque en effet d'être un peu plus lent (à chaque démarrage, Word charge ces modèles).

Pour exécuter une macro spécifique, suivez cette procédure :
  1. Dans le menu Outils, pointez sur Macro, puis cliquez sur Macros.
  2. Dans la boîte de dialogue Macros, dans la zone Macros, sélectionnez le modèle contenant la macro de votre choix. Par exemple, sélectionnez Support.dot (modèle global) ou Batch Conversion Wizard.wiz (modèle global).
  3. Dans la liste Nom de la macro, cliquez sur la macro de votre choix, puis cliquez sur Exécuter.

Méthode 3 : Copie de la macro dans le modèle Normal

Pour exécuter une macro spécifique sans ouvrir le modèle dans lequel elle figure, copiez la macro dans votre modèle global (Normal.dot). Pour cela, procédez comme suit :
  1. Ouvrez le modèle de macro exemple.
  2. Dans le menu Outils, cliquez sur Modèles et compléments.
  3. Dans la boîte de dialogue Modèles et compléments, cliquez sur Organiser.
  4. Dans la boîte de dialogue Organiser, cliquez sur l'onglet Macros.
  5. Les macros du modèle de la macro exemple figurent sur un côté de la boîte de dialogue, tandis que votre modèle global (Normal.dot) s'affiche sur le côté opposé.

    REMARQUE : Si le fichier Normal.dot (modèle global) n'est pas ouvert, cliquez sur Fermer le fichier sur le côté opposé. Le bouton Fermer le fichier devient un bouton Ouvrir le fichier. Cliquez sur Ouvrir le fichier. Cliquez sur votre fichier de modèle Normal.dot pour le sélectionner, puis cliquez sur Ouvrir.
  6. Sur le côté de l'exemple de modèle de macro, sélectionnez la macro figurant dans l'exemple de modèle de macro pour le sélectionner, puis cliquez sur Copier.

    REMARQUE : Pour sélectionner tous les éléments de la liste, maintenez la touche CTRL enfoncée tout en cliquant sur chaque macro à sélectionner.
  7. Cliquez sur Copier pour copier les macros dans votre modèle Normal.dot.
  8. Cliquez sur OK pour fermer la boîte de dialogue Organiser.
  9. Pour exécuter une macro spécifique, suivez cette procédure :
    1. Dans le menu Outils, pointez sur Macro, puis cliquez sur Macros.
    2. Dans la boîte de dialogue Macros, dans la zone Macros, sélectionnez le modèle contenant la macro de votre choix. Par exemple, sélectionnez Normal.dot (modèle global).
    3. Dans la liste Nom de la macro, cliquez sur la macro de votre choix, puis cliquez sur Exécuter.



Affichage du code des macros

Microsoft fournit des exemples de programmation à des fins d'illustration uniquement, sans garantie explicite ou implicite, y compris, de manière non limitative, les garanties implicites de qualité marchande et/ou d'adéquation à un usage particulier. Cet article suppose que vous connaissez le langage de programmation présenté et les outils utilisés pour créer et déboguer des procédures. Les techniciens du Support technique Microsoft peuvent vous expliquer les fonctionnalités d'une procédure particulière, mais ils ne peuvent pas modifier les exemples en vue de vous fournir des fonctionnalités supplémentaires ou de créer des procédures répondant à vos besoins spécifiques. Si vous ne maîtrisez que partiellement la programmation, vous pouvez contacter un fournisseur de logiciels agréé Microsoft ou l'assistance téléphonique (payante) de Microsoft au (800) 936-5200 (États-Unis). Pour plus d'informations sur les fournisseurs de logiciels agréés Microsoft, veuillez consulter la page suivante sur le Web :
https://partner.microsoft.com/global/30000104
Pour plus d'informations sur les options de support technique proposées par Microsoft, veuillez consulter la page Web suivante :
http://support.microsoft.com/directory/overview.asp
Pour afficher le code d'un exemple de macro, procédez comme suit:
  1. Dans le menu Fichier, cliquez sur Ouvrir.
  2. Dans la boîte de dialogue Ouvrir, dans la zone Rechercher dans, sélectionnez le dossier contenant l'exemple de modèle de macro. Dans la zone Type de fichiers, sélectionnez Tous les fichiers (*.*), puis sélectionnez l'exemple de modèle de macro.
  3. Maintenez la touche MAJ enfoncée et cliquez sur Ouvrir.
  4. Dans le menu Outils, pointez sur Macro, puis cliquez sur Macros.
  5. Dans la boîte de dialogue Macros, dans la zone Macros, sélectionnez l'exemple de modèle de macro que vous venez d'ouvrir.
  6. Sélectionnez la macro appropriée, puis cliquez sur Modifier.

Propriétés

Numéro d'article: 289506 - Dernière mise à jour: jeudi 23 novembre 2006 - Version: 2.2
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Word 2002 Standard Edition
Mots-clés : 
kbdta kbhowto kbhowtomaster KB289506
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com