De sjabloon Support.dot installeren en gebruiken in Word 2002

Vertaalde artikelen Vertaalde artikelen
Artikel ID: 289506 - Bekijk de producten waarop dit artikel van toepassing is.
Alles uitklappen | Alles samenvouwen

Op deze pagina

Samenvatting

Aan de hand van dit artikel wordt geprobeerd de oorzaak van een probleem vast te stellen wanneer u er via andere methoden niet in geslaagd bent het probleem in Microsoft Word te identificeren of op te lossen. Als u informatie wilt over specifieke problemen, voert u een zoekopdracht in de Microsoft Knowledge Base uit. Hiertoe gaat u naar de volgende website van Microsoft:
http://support.microsoft.com/default.aspx
In dit artikel wordt de sjabloon Support.dot beschreven, met daarin geautomatiseerde methoden met macro?s die zijn ontwikkeld door Microsoft Product Support Services. De sjabloon Support.dot is een sjabloon met speciale code (macro?s) voor het zoeken en oplossen van problemen in Word. U kunt drie typen macro?s gebruiken bij het oplossen van verschillende problemen.

Macro Naam Beschrijving
Troubleshoot Utility TShoot Met deze macro kunt u verschillende problemen met Word oplossen. U kunt de macro gebruiken om de naam te wijzigen van de sleutel Data en het bestand Normal.dot, en om invoegtoepassingen van Word uit te schakelen.

Opmerking U moet Word starten met de parameter /a voordat u deze macro uitvoert.
Register-opties RegOptions Met deze macro kunt u Word-instellingen wijzigen die worden opgeslagen in het Windows-register.
Reservekopie voor Autocorrectie AutoCorrectBackup Met deze macro kunt u een reservekopie maken van de AutoCorrectie-lijst. De kopie kunt u vervolgens overbrengen naar een andere computer, waarna u de lijst kunt herstellen door de macro nogmaals uit te voeren.




De sjabloon Support.dot installeren

De sjabloon Support.dot wordt geïnstalleerd als u de installatieoptie Volledig kiest. De sjabloon wordt niet geïnstalleerd als u de optie Standaard of Nu bijwerken gebruikt. Als de sjabloon Support.dot niet op uw computer is geïnstalleerd, gaat u als volgt te werk:
  1. Sluit Microsoft Word en alle Microsoft Office-toepassingen af.
  2. Klik op Start, wijs Instellingen aan en klik op Configuratiescherm.
  3. Dubbelklik op Software in het Configuratiescherm.
  4. Voer de stappen voor het besturingssysteem van uw computer uit.
    • In Microsoft Windows 98, Microsoft Windows Millennium Edition (ME) of Microsoft Windows NT 4.0: selecteer Microsoft Office XP (Microsoft Word 2002) op het tabblad Installeren en verwijderen en klik op Toevoegen/Verwijderen.

      -of-
    • In Microsoft Windows 2000 of Microsoft Windows XP: klik op Programma?s wijzigen of verwijderen. Klik in de lijst Geïnstalleerde programma?s op Microsoft Office XP (Microsoft Word 2002) en klik op Wijzigen.
  5. Selecteer in Microsoft Office XP Setup (Microsoft Word 2002 Setup) Onderdelen toevoegen/verwijderen en klik op Volgende.
  6. Voer deze stappen uit in de lijst Onderdelen die moeten worden geïnstalleerd.Opmerking Klik op het plusteken (+) links van het onderdeel dat u wilt uitvouwen.

    1. Vouw de optie Microsoft Word voor Windows uit.
    2. Vouw de optie Wizards en sjablonen uit.
    3. Klik op het pictogram voor Meer sjablonen en macro?s en kies Alle onderdelen uitvoeren vanaf deze computer in het snelmenu.
  7. : Klik op het plusteken (+) links van het onderdeel om het uit te vouwen. Klik op Bijwerken om de sjabloon Support.dot te installeren.


De sjabloon Support.dot openen

Ga als volgt te werk om de sjabloon Support.dot te openen:
  1. Kies Openen in het menu Bestand.
  2. Wijzig de inhoud van het vak Bestandstype in Documentsjablonen (*.DOT).
  3. Ga in het vak Zoeken in naar de volgende map:
    C:\Program Files\Microsoft Office\Office10\Macros\
  4. Klik op Support.dot en klik op Openen.
  5. Klik in de kolom Macro van de tabel in het bestand op de knop van de macro die u wilt uitvoeren. Klik bijvoorbeeld op Troubleshoot Utility,Register-opties, of Reservekopie voor Autocorrectie.


Het programma Troubleshoot Utility gebruiken

Het hulpprogramma voor probleemoplossing (Troubleshoot Utility) is een macro die is ontwikkeld door Microsoft Product Support Services. Deze macro kan helpen bij het oplossen van problemen met Microsoft Word door bepaalde belangrijke onderdelen te verwijderen die mogelijk beschadigd zijn of die een conflict met Microsoft Word veroorzaken. Gebruik dit hulpprogramma om (in de aangegeven volgorde) de volgende onderdelen uit te schakelen. Deze onderdelen worden standaard geladen tijdens het starten van Word:
  • de registersleutel Data;
  • de algemene sjabloon Normal.dot;
  • invoegtoepassingen en sjablonen;
  • COM-invoegtoepassingen;
  • de registersleutel Options.
Als een van deze items beschadigd of incompatibel is, kan Word niet worden gestart of werkt het programma niet goed. U kunt deze en andere items tijdelijk uitschakelen door Word te starten met de parameter /a.

Microsoft Word starten met de parameter /a

Ga als volgt te werk om Word te starten met de parameter /a:
  1. Klik op Start en klik op Uitvoeren.
  2. Voer in het dialoogvenster Uitvoeren een van de volgende handelingen uit:
    • Typ Winword.exe /a in het vak Openen.

      -of-
    • Klik op Bladeren. Zoek en selecteer het bestand Winword.exe. Ga hiervoor als volgt te werk:
      1. Selecteer in het vak Zoeken in de map met de programmabestanden van Word. Selecteer het bestand Winword.exe en klik op Openen.

        Het vak Openen in het dialoogvenster Uitvoeren is nu ingevuld.
      2. Plaats de invoegpositie in het vak Openen achter Winword.exe.

        Opmerking Het pad naar het bestand Winword.exe wordt in het dialoogvenster Uitvoeren tussen aanhalingstekens weergegeven. Plaats de invoegpositie rechts naast het aanhalingsteken sluiten.
      3. Typ een spatie en typ /a.

        De regel in het vak Openen moet er als volgt uitzien:
        "C:\Program Files\Microsoft Office\Office10\Winword.exe" /a
  3. Klik in het dialoogvenster Uitvoeren op OK.
Als u Word zonder problemen kunt starten en gebruiken met de parameter /a, wordt het probleem veroorzaakt door een van de onderdelen die worden vermeld aan het begin van de sectie 'Het programma Troubleshoot Utility gebruiken? in dit artikel. Gebruik het programma Troubleshoot Utility om vast te stellen welk onderdeel het probleem veroorzaakt. Mogelijk moet u eerst Support.dot installeren om Troubleshoot Utility te kunnen gebruiken.

Opmerking Als het probleem ook optreedt wanneer u Word start met de parameter /a, hoeft u het programma Troubleshoot Utility niet te gebruiken.

Stapsgewijze procedure voor het programma Troubleshoot Utility

U kunt vaststellen welk onderdeel het probleem veroorzaakt in Word door de volgende onderdelen (één voor één en in de aangegeven volgorde) te verwijderen met het programma Troubleshoot Utility: Stap 1: De registersleutel Data verwijderen

Stap 2: De naam van de algemene sjabloon Normal.dot wijzigen

Stap 3: De invoegtoepassingen in de opstartmap van Word uitschakelen

Stap 4: De registersleutel voor COM-invoegtoepassingen verwijderen

Stap 5: De registersleutel Options verwijderen

Stap 1: De registersleutel Data verwijderen

De meestgebruikte opties (klik op Opties in het menu Extra) worden opgeslagen in de sleutel Data. Een mogelijke oplossing voor het probleem is het verwijderen van de sleutel Data. Wanneer Word de volgende keer wordt gestart, wordt de sleutel Data opnieuw opgebouwd op basis van de standaardinstellingen.

Opmerking Als u de sleutel Data verwijdert, wordt voor diverse opties de standaardinstelling hersteld. Dit geldt onder andere voor de lijst met laatst gebruikte bestanden in het menu Bestand en voor veel opties die u hebt ingesteld in het dialoogvenster Opties.

Ga als volgt te werk om de sleutel Data te verwijderen:
  1. Sluit alle Office-programma's af.
  2. Start Word met de parameter /a. Instructies voor het starten van Word met de parameter /a vindt u in de sectie 'Microsoft Word starten met de parameter /a' van dit artikel.
  3. Open de sjabloon Support.dot. Zie voor instructies de sectie 'De sjabloon Support.dot openen' van dit artikel.
  4. Klik in de sjabloon Support.dot op de knop Troubleshoot Utility.
  5. Klik in het dialoogvenster Hulpprogramma voor probleemoplossing van Microsoft Word op Data Registry Key in de lijst Selecteer een item en klik op Verwijderen.
  6. Klik op OK wanneer het volgende bericht wordt weergegeven:
    HKEY_CURRENT_USER\Software\Microsoft Office\10.0\Word\Data
    Er is een reservekopiebestand voor deze registersleutel aanwezig in:
    C:\WINDOWS\TEMP\wddata10.0

    Registersleutel is verwijderd.
  7. Klik op Sluiten.
  8. Klik in het menu Bestand op Afsluiten om Word af te sluiten.
  9. Start Word op de gebruikelijke manier. Gebruik niet de procedure in de sectie 'Microsoft Word starten met de parameter /a' van dit artikel.
Als Word nu wel op de juiste wijze start en naar behoren werkt, is het probleem opgelost. Blijkbaar was de registersleutel Data beschadigd. Wellicht moet u enkele instellingen wijzigen om uw favoriete opties in Word te herstellen.

Als het probleem niet is opgelost, herstelt u de oude registersleutel Data. Ga hiervoor als volgt te werk:
  1. Sluit alle Office-programma's af.
  2. Start Word met de parameter /a. Instructies voor het starten van Word met de parameter /a vindt u in de sectie 'Microsoft Word starten met de parameter /a' in dit artikel raadplegen.
  3. Open de sjabloon Support.dot. Zie voor instructies de sectie 'De sjabloon Support.dot openen' in dit artikel raadplegen.
  4. Klik in de sjabloon Support.dot op de knop Troubleshoot Utility.
  5. Klik in het dialoogvenster Hulpprogramma voor probleemoplossing van Microsoft Word op Data Registry Key in de lijst Selecteer een item en klik op Herstellen.
  6. Klik op Ja wanneer het volgende bericht wordt weergegeven:
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Data

    Deze sleutel is aanwezig in het register.
    Wilt u deze overschrijven?
  7. Klik op OK wanneer het volgende bericht wordt weergegeven:
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Data

    Registersleutel is teruggezet.
  8. Voer een van de volgende bewerkingen uit:
Terug naar begin van Het programma Troubleshoot Utility gebruiken

Stap 2: De naam van de algemene sjabloon Normal.dot wijzigen

Als u wilt voorkomen dat opmaakkenmerken, AutoTekst-fragmenten en macro's die in de algemene sjabloon (Normal.dot) zijn opgeslagen, de werking van Word of van geopende documenten beïnvloeden, moet u de naam van de algemene sjabloon wijzigen. Door de naam van dit bestand te wijzigen, kunt u snel vaststellen of de algemene sjabloon de oorzaak is van het probleem.

Opmerking Als u de naam van het bestand Normal.dot wijzigt, wordt voor diverse opties de standaardinstelling hersteld. Dit geldt onder andere voor aangepaste opmaakprofielen, aangepaste werkbalken, macro's en AutoTekst-fragmenten. Om die reden is het raadzaam het bestand Normal.dot niet te verwijderen.

Bij bepaalde typen configuraties kunnen meerdere exemplaren van het bestand Normal.dot worden gemaakt, bijvoorbeeld als er meerdere versies van Word of meerdere werkstationinstallaties actief zijn op dezelfde computer. Bij dergelijke configuraties moet u de naam van het juiste exemplaar van het bestand Normal.dot wijzigen.

Ga als volgt te werk om de naam van het bestand Normal.dot te wijzigen:
  1. Sluit alle Office-programma's af.
  2. Start Word met de parameter /a. Instructies voor het starten van Word met de parameter /a vindt u in de sectie 'Microsoft Word starten met de parameter /a' in dit artikel raadplegen.
  3. Open de sjabloon Support.dot. Zie voor instructies de sectie 'De sjabloon Support.dot openen' in dit artikel raadplegen.
  4. Klik in de sjabloon Support.dot op de knop Troubleshoot Utility.
  5. Klik in het dialoogvenster Hulpprogramma voor probleemoplossing van Microsoft Word op Normal.dot Global Template in de lijst Selecteer een item en klik op Naam wijzigen.
  6. Klik op OK wanneer het volgende bericht wordt weergegeven:
    pad\Application Data\Microsoft\Templates\Normal.dot
    Gekopieerd naar
    pad\Application Data\Microsoft\Templates\10Normal.dot
    Opmerking Het is mogelijk dat het bestand Normal.dot op uw computer op een andere locatie is opgeslagen.
  7. Klik op Sluiten om het dialoogvenster Hulpprogramma voor probleemoplossing van Microsoft Word te sluiten.
  8. Klik in het menu Bestand op Afsluiten om Word af te sluiten.
  9. Start Word op de gebruikelijke manier. Gebruik niet de procedure in de sectie 'Microsoft Word starten met de parameter /a' van dit artikel.
Als Word nu wel op de juiste wijze start, hebt u het probleem opgelost. Blijkbaar was het bestand Normal.dot beschadigd. Wellicht moet u enkele instellingen wijzigen om uw favoriete opties te herstellen. Het is mogelijk dat het door u hernoemde bestand Normal.dot aangepaste items bevat die u niet zo snel opnieuw kunt maken, zoals opmaakprofielen, macro's of AutoTekst-fragmenten. U kunt deze items dan met Beheer vanuit het bestand 10Normal.dot (het oude bestand Normal.dot) naar het nieuwe bestand Normal.dot kopiëren.

Als u meer informatie wilt over de functie Beheer, klikt u op Microsoft Word Help in het menu Help, typt u Beheer in de Office-assistent of de antwoordwizard en klikt u vervolgens op Zoeken om de gevonden onderwerpen weer te geven.

Als het probleem niet is opgelost, herstelt u het oude bestand Normal.dot (10Normal.dot). Hiertoe gaat u als volgt te werk:
  1. Sluit alle Office-programma's af.
  2. Start Word met de parameter /a. Instructies voor het starten van Word met de parameter /a vindt u in de sectie 'Microsoft Word starten met de parameter /a' in dit artikel raadplegen.
  3. Open de sjabloon Support.dot. Zie voor instructies de sectie 'De sjabloon Support.dot openen' in dit artikel raadplegen.
  4. Klik in de sjabloon Support.dot op de knop Troubleshoot Utility.
  5. Klik in het dialoogvenster Hulpprogramma voor probleemoplossing van Microsoft Word op Normal.dot Global Template in de lijst Selecteer een item en klik op Herstellen.
  6. Klik op Ja wanneer het volgende bericht wordt weergegeven:
    pad\Application Data\Microsoft\Templates\Normal.dot

    Er bestaat al een reservekopie van dit bestand.

    Wilt u deze overschrijven?
    Opmerking Het is mogelijk dat het bestand Normal.dot op uw computer op een andere locatie is opgeslagen.
  7. Klik op OK wanneer het volgende bericht wordt weergegeven:
    pad\Application Data\Microsoft\Templates\10Normal.dot
    Gekopieerd naar
    pad\Templates\Normal.dot
  8. Voer een van de volgende bewerkingen uit:
Terug naar begin van Het programma Troubleshoot Utility gebruiken

Stap 3: De invoegtoepassingen in de opstartmap van Word uitschakelen

Wanneer u Word start, worden automatisch de sjablonen en invoegtoepassingen uit de opstartmappen geladen. Fouten in Word kunnen het resultaat zijn van conflicten of problemen met een invoegtoepassing. Om vast te stellen of een item in een opstartmap het probleem veroorzaakt, kunt u tijdelijk de registerinstelling uitschakelen die naar deze invoegtoepassingen verwijst.

Voer de volgende stappen uit om de registersleutel voor invoegtoepassingen tijdelijk uit te schakelen:
  1. Sluit alle Office-programma's af.
  2. Start Word met de parameter /a. Instructies voor het starten van Word met de parameter /a vindt u in de sectie 'Microsoft Word starten met de parameter /a' in dit artikel raadplegen.
  3. Open de sjabloon Support.dot. Zie voor instructies de sectie 'De sjabloon Support.dot openen' in dit artikel raadplegen.
  4. Klik in de sjabloon Support.dot op de knop Troubleshoot Utility.
  5. Klik in het dialoogvenster Hulpprogramma voor probleemoplossing van Microsoft Word op Word Startup Folder Addins in de lijst Selecteer een item en klik op Naam wijzigen.
  6. Voer een van de volgende bewerkingen uit:
    • Klik op OK wanneer het volgende bericht wordt weergegeven:
      Geen bestanden gevonden voor het wijzigen van de naam of voor het terugzetten.
      Opmerking Als dit bericht wordt weergegeven, hebt u geen invoegtoepassingen die worden geladen tijdens het starten van Word. Klik op OK en ga verder naar de sectie Stap 4: De registersleutel voor COM-invoegtoepassingen verwijderen in dit artikel raadplegen.

      -of-
    • Klik op OK wanneer het volgende bericht wordt weergegeven:
      pad\Application Data\Microsoft\Word\Startup\bestandsnaam
      Gekopieerd naar
      pad\Application Data\Microsoft\Word\Startup\bestandsnaam

      pad\Program Files\Microsoft Office\Office10\Startup\bestandsnaam
      Gekopieerd naar
      pad\Program Files\Microsoft Office\Office10\Startup\bestandsnaam
      Opmerking Het is mogelijk dat de paden en bestandsnamen op uw computer anders zijn.
  7. Klik op Sluiten om het dialoogvenster Hulpprogramma voor probleemoplossing van Microsoft Word te sluiten.
  8. Klik in het menu Bestand op Afsluiten om Word af te sluiten.
  9. Start Word op de gebruikelijke manier. Gebruik niet de procedure in de sectie 'Microsoft Word starten met de parameter /a' van dit artikel.
  10. Voer een van de volgende bewerkingen uit:
    • Als u het probleem niet meer kunt reproduceren en opstartitems zijn verwijderd in stap 6, hebt u vastgesteld dat het probleem wordt veroorzaakt door een item van een invoegtoepassing. Ga als volgt te werk om vast te stellen door welk item het probleem wordt veroorzaakt:
      1. Sluit alle Office-programma's af.
      2. Start Word met de parameter /a. Instructies voor het starten van Word met de parameter /a vindt u in de sectie 'Microsoft Word starten met de parameter /a' in dit artikel raadplegen.
      3. Open de sjabloon Support.dot. Zie voor instructies de sectie 'De sjabloon Support.dot openen' in dit artikel raadplegen.
      4. Klik in de sjabloon Support.dot op de knop Troubleshoot Utility.
      5. Klik in het dialoogvenster Hulpprogramma voor probleemoplossing van Microsoft Word op Word Startup Folder Addins in de lijst Selecteer een item en klik op Herstellen.
      6. Klik op OK wanneer het volgende bericht wordt weergegeven:
        pad\Application Data\Microsoft\Word\Startup\bestandsnaam
        Gekopieerd naar
        pad\Application Data\Microsoft\Word\Startup\bestandsnaam

        pad\Program Files\Microsoft Office\Office10\Startup\bestandsnaam
        Gekopieerd naar
        pad\Program Files\Microsoft Office\Office10\Startup\bestandsnaam
        Opmerking Het is mogelijk dat de paden en bestandsnamen op uw computer anders zijn.
      7. Klik op Sluiten om het dialoogvenster Hulpprogramma voor probleemoplossing van Microsoft Word te sluiten.
      8. Klik in het menu Bestand op Afsluiten om Word af te sluiten.
      9. Dubbelklik op Deze computer en open een van de mappen uit stap f. Bijvoorbeeld:
        pad\Application Data\Microsoft\Word\Startup\

        -of-

        pad\Program Files\Microsoft Office\Office10\Startup\
      10. Klik met de rechtermuisknop op een van de bestanden in de map en klik op Naam wijzigen in het snelmenu.
      11. Typ een nieuwe naam voor het bestand en druk op ENTER.

        Belangrijk noteer de oorspronkelijke naam van het bestand, zodat u deze naam zo nodig kunt herstellen.
      12. Start Word op de gebruikelijke manier. Gebruik niet de procedure in de sectie 'Microsoft Word starten met de parameter /a' van dit artikel.
      Als u het probleem niet meer kunt reproduceren, hebt u het item gevonden dat het probleem veroorzaakt. Als u de functionaliteit van het item niet kunt missen, moet u vaststellen bij welke Word-invoegtoepassing het item hoort en vraagt u de desbetreffende leverancier om een update.

      Als het probleem niet is opgelost, herstelt u de oorspronkelijke naam van de invoegtoepassing en herhaalt u stap h en i voor elk bestand in de mappen die worden vermeld in de berichten uit stap f.

      -of-

    • Als u het probleem niet meer kunt reproduceren, hebt u het item gevonden dat het probleem veroorzaakt. Als u de functionaliteit van het item niet kunt missen, moet u vaststellen bij welke Word-invoegtoepassing het item hoort en de desbetreffende leverancier vragen om een update. Als het probleem niet is opgelost, herstelt u de items van de invoegtoepassingen en gaat u verder met de volgende stap. Hiertoe gaat u als volgt te werk:
      1. Sluit alle Office-programma's af.
      2. Start Word met de parameter /a. Instructies voor het starten van Word met de parameter /a vindt u in de sectie 'Microsoft Word starten met de parameter /a' in dit artikel raadplegen.
      3. Open de sjabloon Support.dot. Zie voor instructies de sectie 'De sjabloon Support.dot openen' in dit artikel raadplegen.
      4. Klik in de sjabloon Support.dot op de knop Troubleshoot Utility.
      5. Klik in het dialoogvenster Hulpprogramma voor probleemoplossing van Microsoft Word op Word Startup Folder Addins in de lijst Selecteer een item en klik op Herstellen.
      6. Klik op OK wanneer het volgende bericht wordt weergegeven:
        pad\Application Data\Microsoft\Word\Startup\bestandsnaam
        Gekopieerd naar
        pad\Application Data\Microsoft\Word\Startup\bestandsnaam

        pad\Program Files\Microsoft Office\Office10\Startup\bestandsnaam
        Gekopieerd naar
        pad\Program Files\Microsoft Office\Office10\Startup\bestandsnaam
        Opmerking Het is mogelijk dat de paden en bestandsnamen op uw computer anders zijn.
      7. Ga naar de sectie Stap 4: De registersleutel voor COM-invoegtoepassingen verwijderen in dit artikel raadplegen.
Terug naar begin van Het programma Troubleshoot Utility gebruiken

Stap 4: De registersleutel voor COM-invoegtoepassingen verwijderen

COM-invoegtoepassingen kunnen op elke locatie worden geïnstalleerd door programma's die met Word samenwerken. Ga als volgt te werk om de Windows-registerinstellingen te verwijderen voor geïnstalleerde COM-invoegtoepassingen:
  1. Sluit alle Office-programma's af.
  2. Start Word met de parameter /a. Instructies voor het starten van Word met de parameter /a vindt u in de sectie 'Microsoft Word starten met de parameter /a' in dit artikel raadplegen.
  3. Open de sjabloon Support.dot. Zie voor instructies de sectie 'De sjabloon Support.dot openen' in dit artikel raadplegen.
  4. Klik in de sjabloon Support.dot op de knop Troubleshoot Utility.
  5. Klik in het dialoogvenster Hulpprogramma voor probleemoplossing van Microsoft Word op COM-Addins Registry Key in de lijst Selecteer een item en klik op Verwijderen.
  6. Klik op OK wanneer het volgende bericht wordt weergegeven:
    HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins
    Er is een reservekopiebestand voor deze registersleutel aanwezig in:
    C:\Windows\TEMP\wdaddn10.0

    Registersleutel is verwijderd.
  7. Klik op Sluiten om het dialoogvenster Hulpprogramma voor probleemoplossing van Microsoft Word te sluiten.
  8. Klik in het menu Bestand op Afsluiten om Word af te sluiten.
  9. Start Word op de gebruikelijke manier. Gebruik niet de procedure in de sectie 'Microsoft Word starten met de parameter /a' van dit artikel.
  10. Voer een van de volgende bewerkingen uit:
    • Als u het probleem niet meer kunt reproduceren, hebt u vastgesteld dat het probleem wordt veroorzaakt door een COM-invoegtoepassing. Ga als volgt te werk om vast te stellen welke COM-invoegtoepassing dat is:
      1. Sluit alle Office-programma's af.
      2. Start Word met de parameter /a. Instructies voor het starten van Word met de parameter /a vindt u in de sectie 'Microsoft Word starten met de parameter /a' in dit artikel raadplegen.
      3. Open de sjabloon Support.dot. Zie voor instructies de sectie 'De sjabloon Support.dot openen' in dit artikel raadplegen.
      4. Klik in de sjabloon Support.dot op de knop Troubleshoot Utility.
      5. Klik in het dialoogvenster Hulpprogramma voor probleemoplossing van Microsoft Word op COM-Addins Registry Key in de lijst Selecteer een item en klik op Herstellen.
      6. Klik op OK wanneer het volgende bericht wordt weergegeven:
        HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins

        Registersleutel is teruggezet.
      7. Klik op Sluiten om het dialoogvenster Hulpprogramma voor probleemoplossing van Microsoft Word te sluiten.
      8. Klik in het menu Bestand op Afsluiten om Word af te sluiten.
      9. Start Word op de gebruikelijke manier. Gebruik niet de procedure in de sectie 'Microsoft Word starten met de parameter /a' van dit artikel.
      10. Open het menu Extra en klik op Aanpassen.
      11. Open het tabblad Opdrachten. Klik in de lijst Categorieën op Extra.
      12. Klik in de lijst Opdrachten op COM-invoegtoepassingen en sleep de opdracht naar een werkbalk.
      13. Klik op Sluiten om het dialoogvenster Aanpassen te sluiten.
      14. Klik op de knop COM-invoegtoepassingen die u zojuist hebt toegevoegd met de stappen k tot en met m.
      15. Als in het dialoogvenster COM-invoegtoepassingen een toepassing wordt weergegeven, schakelt u het selectievakje van de toepassing uit.

        Opmerking Als meerdere invoegtoepassingen worden weergegeven, schakelt u steeds maar één selectievakje van een toepassing uit om vast te stellen welke toepassing het probleem veroorzaakt.
      16. Klik op OK om het dialoogvenster COM-invoegtoepassingen te sluiten.
      17. Klik in het menu Bestand op Afsluiten om Word af te sluiten.
      18. Start Word op de gebruikelijke manier. Gebruik niet de procedure in de sectie 'Microsoft Word starten met de parameter /a' van dit artikel.
      19. Voer een van de volgende bewerkingen uit:
        • Als u het probleem niet meer kunt reproduceren, hebt u de COM-invoegtoepassing gevonden die het probleem veroorzaakt. Als u de functionaliteit van het item niet kunt missen, moet u vaststellen bij welke Word-invoegtoepassing het item hoort en vraagt u de desbetreffende leverancier om een update.

          -of-
        • Als het probleem niet is opgelost, klikt u op de knop COM-invoegtoepassingen die u hebt toegevoegd met behulp van stap k tot en met m. Schakel het selectievakje in dat u hebt uitgeschakeld in stap o. Schakel vervolgens het selectievakje van een andere invoegtoepassing uit en herhaal stap p tot en met s. Herhaal deze procedure zo vaak als nodig, voor elke invoegtoepassing, totdat u de invoegtoepassing hebt gevonden die het probleem veroorzaakt.
      -of-

    • Als het probleem niet is opgelost, herstelt u de registersleutel voor COM-invoegtoepassingen en gaat u verder met de volgende stap. Hiertoe gaat u als volgt te werk:
      1. Sluit alle Office-programma's af.
      2. Start Word met de parameter /a. Instructies voor het starten van Word met de parameter /a vindt u in de sectie 'Microsoft Word starten met de parameter /a' in dit artikel raadplegen.
      3. Open de sjabloon Support.dot. Zie voor instructies de sectie 'De sjabloon Support.dot openen' in dit artikel raadplegen.
      4. Klik in de sjabloon Support.dot op de knop Troubleshoot Utility.
      5. Klik in het dialoogvenster Hulpprogramma voor probleemoplossing van Microsoft Word op COM-Addins Registry Key in de lijst Selecteer een item en klik op Herstellen.
      6. Klik op OK wanneer het volgende bericht wordt weergegeven:
        HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins

        Registersleutel is teruggezet.
      7. Klik op Sluiten om het dialoogvenster Hulpprogramma voor probleemoplossing van Microsoft Word te sluiten.
      8. Klik in het menu Bestand op Afsluiten om Word af te sluiten.
      9. Ga naar de sectie Stap 5: De registersleutel Options verwijderen in dit artikel raadplegen.
Terug naar begin van Het programma Troubleshoot Utility gebruiken

Stap 5: De registersleutel Options verwijderen

In de registersleutel Options worden de opties opgeslagen die u in Word kunt instellen, door menuopties te wijzigen of door de macro RegOptions uit te voeren. Dit zijn opties die kunnen worden bewerkt.

De instellingen kunnen worden ingedeeld in twee groepen: standaardinstellingen en optionele instellingen. Standaardinstellingen worden aangebracht tijdens Setup. U kunt deze instellingen wijzigen door opties te veranderen in Word. Optionele instellingen worden niet aangebracht tijdens Setup. Deze instellingen kunt u toevoegen door de macro RegOptions uit te voeren. Deze macro wordt verderop in dit artikel besproken.

Ga als volgt te werk om de sleutel Options te verwijderen:
  1. Sluit alle Office-programma's af.
  2. Start Word met de parameter /a. Instructies voor het starten van Word met de parameter /a vindt u in de sectie 'Microsoft Word starten met de parameter /a' in dit artikel raadplegen.
  3. Open de sjabloon Support.dot. Zie voor instructies de sectie 'De sjabloon Support.dot openen' in dit artikel raadplegen.
  4. Klik in de sjabloon Support.dot op de knop Troubleshoot Utility.
  5. Klik in het dialoogvenster Hulpprogramma voor probleemoplossing van Microsoft Word op Options Registry Key in de lijst Selecteer een item en klik op Verwijderen.
  6. Klik op OK wanneer het volgende bericht wordt weergegeven:
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Options
    Er is een reservekopiebestand voor deze registersleutel aanwezig in:
    C:\WINDOWS\TEMP\wdoptn10.0

    Registersleutel is verwijderd.
  7. Start Word op de gebruikelijke manier. Gebruik niet de parameter /a om Word te starten (zoals beschreven in de sectie 'Microsoft Word starten met de parameter /a' in dit artikel raadplegen.
Als Word nu wel op de juiste wijze start en naar behoren werkt, hebt u het probleem opgelost. Blijkbaar was de sleutel Options beschadigd. Wellicht moet u enkele instellingen wijzigen om uw favoriete opties in Word te herstellen.

Als het probleem niet is opgelost, sluit u Word af en voegt u de informatie uit de sleutel Options weer toe aan het Windows-register. Ga hiervoor als volgt te werk:
  1. Sluit alle Office-programma's af.
  2. Start Word met de parameter /a. Instructies voor het starten van Word met de parameter /a vindt u in de sectie 'Microsoft Word starten met de parameter /a' in dit artikel raadplegen.
  3. Open de sjabloon Support.dot. Zie voor instructies de sectie 'De sjabloon Support.dot openen' in dit artikel raadplegen.
  4. Klik in de sjabloon Support.dot op de knop Troubleshoot Utility. De knop vindt u in de tabel in het bestand.
  5. Klik in het dialoogvenster Hulpprogramma voor probleemoplossing van Microsoft Word op Options Registry Key in de lijst Selecteer een item en klik op Herstellen.
  6. Klik op Ja wanneer het volgende bericht wordt weergegeven:
    HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Options

    Deze sleutel is aanwezig in het register.
    Wilt u deze overschrijven?
  7. Klik op OK wanneer het volgende bericht wordt weergegeven:
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Options

    Registersleutel is teruggezet.
  8. Klik op Sluiten om het dialoogvenster Hulpprogramma voor probleemoplossing van Microsoft Word te sluiten.
  9. Klik in het menu Bestand op Afsluiten om Word af te sluiten.
Terug naar begin van Het programma Troubleshoot Utility gebruiken



De macro Register-opties gebruiken

U kunt de macro RegOptions gebruiken om Word-instellingen in het Windows-register te controleren of te wijzigen. Hier volgt een lijst met de opties die beschikbaar zijn in de macro, plus een korte beschrijving van het doel van elke optie:
Word-opties

Pad voor AutoOpslaan: De locatie van de map waar AutoHerstel-bestanden worden opgeslagen.

Pad voor documenten: De standaardmap die wordt gebruikt voor Word-documenten.

Pad voor figuren: Het standaardpad dat wordt gebruikt wanneer u Figuur aanwijst in het menu Invoegen en vervolgens klikt op Uit bestand.

Pad voor opstarten: Het pad voor Word-opstartbestanden, zoals sjablonen en WLL-bestanden (WLL's) die worden geladen tijdens het starten van Word.

Pad voor hulpprogramma's: De locatie waar Word zoekt naar taalprogramma's, filters, conversieprogramma's en andere onderdelen, wanneer deze onderdelen niet juist zijn geregistreerd of niet kunnen worden gevonden.

Pad voor gebruikerssjablonen: Het pad voor gebruikerssjablonen. Als deze instelling wordt gewijzigd voor Word, is de wijziging van invloed op alle Microsoft Office-programma's.

Pad voor werkgroepsjablonen: Het pad voor werkgroepsjablonen. U kunt een UNC-pad opgeven.

BAK-extensie: De standaardbestandsextensie voor reservekopiebestanden van Word. De standaardextensie is *.WBK.

DOC-extensie: De standaardbestandsextensie die wordt gebruikt voor Word-documenten. De standaardwaarde is *.DOC .

DOT-extensie: De standaardbestandsextensie die wordt gebruikt voor Word-sjablonen. De standaardwaarde is *.DOT.

GeenLettertypeMRULijst: De lijst met laatst gebruikte lettertypen in- of uitschakelen. U kunt deze lijst inschakelen door 0 (nul) te typen. U kunt deze lijst uitschakelen door 1 te typen.

SpellingGolvendOnderlijnenKleur: De kleur van de golvende onderstrepingslijn onder foutief gespelde woorden.

GrammaticaGolvendOnderlijnenKleur: De kleur van de golvende onderstrepingslijn onder grammaticale fouten.

InfolabelOnderlijnenKleur: De kleur van de gestippelde onderstrepingslijn onder infolabels.

OpmaakconsistentieGolvendOnderlijnenKleur: De kleur van de golvende onderstrepingslijn onder opmaakfouten.

OLEDOT: De documentsjabloon die wordt gebruikt wanneer u een documentobject maakt binnen Word of een andere OLE-toepassing.
Equation Editor-opties

Appdir: De programmamap van Equation Editor. Deze instelling en andere instellingen van Equation Editor worden alleen weergegeven als Equation Editor is geïnstalleerd en ten minste één keer is uitgevoerd.

AangepastZoomen: De instelling voor aangepast zoomen. Deze instelling heeft pas effect wanneer u Equation Editor via de instelling OpenenForceren start in een afzonderlijk venster.

OpenenForceren: Equation Editor starten in een afzonderlijk venster. Typ 0 (nul) om het programma in het huidige venster te openen en 1 om een nieuw venster te openen en het programma daarin weer te geven.

AllesWeergeven: Alle niet-afdrukbare tekens weergeven of verbergen.

WerkbalkGedokt: Instellen of de werkbalk al dan niet is gedokt. Kies Ja (1) of Nee (0).

WerkbalkDokPos: Positie van de werkbalk van Equation Editor wanneer deze is gedokt. Met 1 wordt de werkbalk boven in het venster van Equation Editor weergegeven. Met 2 wordt de werkbalk onder in het venster van Equation Editor weergegeven.

WerkbalkWeergegeven: Instellen of de werkbalk al dan niet wordt weergegeven. Kies Ja (1) of Nee (0).

WerkbalkWinPos: Positie van de werkbalk wanneer deze niet is gedokt, uitgedrukt in X- en Y-coördinaten, met de linkerbovenhoek als punt van oorsprong. De gebruikte eenheden zijn pixels.

In- en uitzoomen: Het standaardzoomformaat dat is geselecteerd in het menu Beeld.
Ga als volgt te werk om de macro RegOptions te gebruiken:
  1. Klik op Openen in het menu Bestand.
  2. Wijzig de inhoud van het vak Bestandstype in Documentsjablonen (*.DOT).
  3. Ga in het vak Zoeken in naar de volgende map:
    C:\Program Files\Microsoft Office\Office10\Macros\
  4. Klik op Support.dot en klik op Openen.
  5. Klik in de kolom Macro van de tabel in het bestand op de knop Register-opties.
  6. Klik op het tabblad Word-opties of Equation Editor-opties op de optie die u wilt wijzigen, typ de nieuwe instelling in het vak Instelling (of klik op Bladeren, als deze knop beschikbaar is, en klik vervolgens op de gewenste instelling) en klik op Wijzigen.
  7. Klik op Sluiten om het dialoogvenster Registeropties instellen te sluiten.


Het hulpprogramma voor het maken van een AutoCorrectie-reservekopie gebruiken

Met dit hulpprogramma kunt u AutoCorrectie-fragmenten van de ene computer naar de andere kopiëren. Voor meer informatie over het hulpprogramma Reservekopie voor Autocorrectie klikt u op het volgende artikelnummer in de Microsoft Knowledge Base:
269006Procedure: Word AutoCorrectie-fragmenten verplaatsen tussen computers in Word 2002


Alleen voor ervaren gebruikers

De informatie in dit gedeelte is niet relevant wanneer u de macro's in de sjabloon Support.dot gebruikt. Deze informatie hebt u alleen nodig als u deze macro's algemeen beschikbaar wilt stellen in Microsoft Word, of als u de macrocode wilt bekijken.



De macro?s algemeen beschikbaar stellen

Gebruik een van de volgende methoden om de macro's algemeen toegankelijk te maken in Microsoft Word.

Methode 1: de sjabloon toevoegen als algemene sjabloon

Als u van plan bent de macro's regelmatig te gebruiken (of als u wilt zien wat de macro's doen voordat u besluit ze eenvoudig toegankelijk te maken), voegt u de macrosjablonen toe als algemene sjablonen.

Ga als volgt te werk om een sjabloon in de sectie 'Samenvatting' van dit artikel toe te voegen als een algemene sjabloon:
  1. Klik op Sjablonen en invoegtoepassingen in het menu Extra.
  2. Klik onder Algemene sjablonen en invoegtoepassingen op Toevoegen.
  3. Selecteer in het vak Zoeken in de map met de voorbeeld-macrosjabloon. Selecteer in het vak Bestandstype de optie Alle bestanden (*.*).
  4. Selecteer de voorbeeld-macrosjabloon en klik op OK.
  5. Nadat de sjabloon is toegevoegd aan het dialoogvenster Sjablonen en invoegtoepassing, controleert u of het selectievakje van de sjabloon is ingeschakeld. Klik vervolgens op OK.

    Belangrijk wanneer u een sjabloon toevoegt aan het vak Algemene sjablonen en invoegtoepassingen, wordt de sjabloon alleen voor de huidige Word-sessie geladen. Als u Word afsluit en vervolgens opnieuw start, wordt de sjabloon niet automatisch opnieuw geladen. U moet de gewenste sjabloon dan opnieuw selecteren. Kies hiervoor Sjablonen en invoegtoepassingen in het menu Extra. Selecteer in het dialoogvenster Sjablonen en invoegtoepassingen de sjabloon waarvan u macro's wilt gebruiken en klik op OK.
  6. Ga als volgt te werk om een specifieke macro uit te voeren:
    1. Wijs in het menu Extra de optie Macro aan en klik op Macro's.
    2. Selecteer in het vak Macro's in van het dialoogvenster Macro's de sjabloon met de gewenste macro. Selecteer bijvoorbeeld Support.dot (algemene sjabloon).
    3. Selecteer in de lijst Macronaam de gewenste macro en klik op Uitvoeren.

Methode 2: de sjabloon toevoegen aan de opstartmap

Verplaats de sjabloon naar de map Startup. Microsoft Word heeft automatisch toegang tot alle macro's in sjablonen die zijn opgeslagen in de volgende map:
C:\Program Files\Microsoft Office\Office10\Startup
Gebruik Microsoft Windows Verkenner om een kopie van de voorbeeld-macrosjabloon in de opstartmap op te slaan.

Wanneer u Word start, worden sjablonen in de map Startup geladen als algemene sjablonen. De macro's in de sjablonen zijn beschikbaar in het dialoogvenster Macro's. Een nadeel van deze methode is dat het starten van Word misschien iets langer duurt omdat elke keer deze sjablonen moeten worden geladen wanneer Word wordt gestart.

Ga als volgt te werk om een specifieke macro uit te voeren:
  1. Wijs in het menu Extra de optie Macro aan en klik op Macro's.
  2. Selecteer in het vak Macro's in van het dialoogvenster Macro's de sjabloon met de gewenste macro. Selecteer bijvoorbeeld Support.dot (algemene sjabloon).
  3. Selecteer in de lijst Macronaam de gewenste macro en klik op Uitvoeren.

Methode 3: de macro kopiëren naar de sjabloon Normal

Als u een specifieke macro wilt uitvoeren zonder de bijbehorende sjabloon te openen, kopieert u de macro naar de algemene sjabloon (Normal.dot). Hiertoe gaat u als volgt te werk:
  1. Open de voorbeeld-macrosjabloon.
  2. Klik op Sjablonen en invoegtoepassingen in het menu Extra.
  3. Klik in het dialoogvenster Sjablonen en invoegtoepassingen op Beheer.
  4. Open in het dialoogvenster Beheer het tabblad Macro's.
  5. De macro's in de voorbeeld-macrosjabloon worden aan de linkerkant vermeld. De algemene sjabloon (Normal.dot) wordt aan de andere kant weergegeven.

    Opmerking Als Normal.dot (algemene sjabloon) niet is geopend, klikt u aan de andere kant op Bestand sluiten. De knop Bestand sluiten verandert in de knop Bestand openen. Klik op Bestand openen. Selecteer het sjabloonbestand Normal.dot en klik op Openen.
  6. Selecteer in de lijst van de voorbeeld-macrosjabloon de onderdelen in de sjabloon en klik op Kopiëren.

    Opmerking Als u alle onderdelen wilt selecteren, houdt u CTRL ingedrukt terwijl u op de onderdelen klikt.
  7. Klik op Kopiëren om de macro-onderdelen naar de sjabloon Normal.dot te kopiëren.
  8. Klik op OK om het dialoogvenster Beheer te sluiten.
  9. Ga als volgt te werk om een specifieke macro uit te voeren:
    1. Wijs in het menu Extra de optie Macro aan en klik op Macro's.
    2. Selecteer in het vak Macro's in van het dialoogvenster Macro's de sjabloon met de gewenste macro. Selecteer bijvoorbeeld Normal.dot (algemene sjabloon).
    3. Selecteer in de lijst Macronaam de gewenste macro en klik op Uitvoeren.


De macrocode bekijken

Microsoft verstrekt deze code zonder enige expliciete of impliciete garantie, daaronder mede begrepen, maar niet beperkt tot impliciete garanties met betrekking tot de verkoopbaarheid en/of geschiktheid voor een bepaald doel. In dit artikel wordt ervan uitgegaan dat u bekend bent met de programmeertaal VBScript, alsmede met de hulpprogramma's waarmee procedures worden gemaakt en waarmee fouten in procedures worden opgespoord. U kunt desgewenst contact opnemen met Microsoft Product Support Services voor uitleg over de functie van een bepaalde procedure. Microsoft Product Support Services is echter niet bereid de voorbeelden aan te passen om extra functies toe te voegen of om procedures te maken die aan uw specifieke eisen voldoen. Ga als volgt te werk om de macrocode voor een voorbeeldmacro te bekijken:
  1. Klik op Openen in het menu Bestand.
  2. Selecteer in het vak Zoeken in in het dialoogvenster Openen de map met de voorbeeld-macrosjabloon, selecteer in het vak Bestandstype de optie Alle bestanden (*.*) en selecteer vervolgens de gewenste voorbeeld-macrosjabloon.
  3. Houd SHIFT ingedrukt en klik op Openen.
  4. Wijs in het menu Extra de optie Macro aan en klik op Macro's.
  5. Selecteer in het vak Macro's in van het dialoogvenster Macro's de voorbeeld-macrosjabloon die u zojuist hebt geopend.
  6. Selecteer de gewenste macro en klik op Bewerken.

Eigenschappen

Artikel ID: 289506 - Laatste beoordeling: donderdag 16 februari 2006 - Wijziging: 2.1
De informatie in dit artikel is van toepassing op:
  • Microsoft Word 2002 Standard Edition
Trefwoorden: 
kbdta kbhowtomaster KB289506

Geef ons feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com