Como instalar e utilizar o modelo Support.dot no Word 2002

Traduções de Artigos Traduções de Artigos
Artigo: 289506 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Nesta página

Sumário

Este artigo destina para ajudar a determinar onde existe um problema quando não conseguir identificar ou isolar o problema por outros meios no Microsoft Word. Para localizar artigos sobre problemas específicos que poderá tratar-se e problemas, consulte consultar na Microsoft Knowledge Base. Para o fazer, consulte o seguinte Web site da Microsoft:
http://support.microsoft.com/default.aspx
Este artigo passo a passo descreve o modelo Support.dot, que inclui métodos automatizados utilizando macros criadas pelo suporte técnico da Microsoft. O modelo Support.dot é um modelo que contém código especial (macros) para ajudar na resolução de problemas e resolução de problemas no Word. Existem três tipos de macros ajudar na resolução de problemas. vários problemas.

Macro Name Description
Troubleshoot Utility TShoot This macro can be used to troubleshoot various problems with Word. You can use the macro to rename your data key and Normal.dot file and to turn off Word add-ins.

NOTE: You must start Word with the /a switch before you run this macro.
Registry Options RegOptions This macro can be used to modify Word settings that are stored in the Windows registry.
AutoCorrect Backup AutoCorrectBackup This macro backs up your AutoCorrect list to a file. You can take this file to another computer and run the macro again to restore your AutoCorrect list.




Como instalar o modelo Support.dot

O modelo Support.dot é instalado com uma configuração completa . Não é instalado com uma típica ou Actualizar agora programa de configuração. Se o modelo Support.dot não estiver instalado, siga estes passos:
  1. Saia do Microsoft Word e Microsoft Office todos os programas.
  2. Clique em Iniciar , aponte para definições e, em seguida, clique em Painel de controlo .
  3. No Painel de controlo , faça duplo clique em Adicionar/remover programas .
  4. Siga os passos para o sistema operativo do seu computador.
    • No Microsoft Windows 98, Microsoft Windows Millennium Edition (Me) ou Microsoft Windows NT 4.0, clique para seleccionar Microsoft Office XP ( Microsoft Word 2002 ) no separador Instalar/desinstalar e, em seguida, clique em Adicionar/remover .

      - ou -
    • No Microsoft Windows 2000 ou Microsoft Windows XP, clique para seleccionar alterar ou remover programas . Na lista Programas actualmente instalados , clique em Microsoft Office XP ( Microsoft Word 2002 ) e, em seguida, clique em alterar .
  5. O programa de configuração do Microsoft Office XP ( Programa de configuração do Microsoft Word 2002 ), clique para seleccionar Adicionar ou remover e, em seguida, clique em seguinte .
  6. Na lista de funcionalidades a instalar , siga estes passos. Nota : clique no sinal de adição (+) à esquerda da funcionalidade para expandi-lo.

    1. Clique para expandir Microsoft Word para Windows .
    2. Clique para expandir assistentes e modelos .
    3. Clique no ícone de mais modelos e macros e, em seguida, clique para seleccionar Executar tudo a partir do meu computador no menu de atalho.
  7. : Clique no sinal de adição (+) à esquerda da funcionalidade para expandir it.Click Update para instalar o modelo Support.dot.


Como abrir o modelo Support.dot

Para abrir o modelo Support.dot, siga estes passos:
  1. No menu ficheiro , clique em Abrir .
  2. Altere a caixa ficheiros do tipo para modelos de documento (* .dot) .
  3. Altere a caixa Procurar em para a seguinte pasta:
    C:\Program Files\Microsoft Office\Office10\Macros\
  4. Clique para seleccionar o ficheiro Support.dot e, em seguida, clique em Abrir .
  5. Na tabela contida no ficheiro, na coluna macro , clique no botão apropriado para executar a macro que pretende. Por exemplo, clique em Troubleshoot Utility,Registry Options,ou AutoCorrect Backup.


Como utilizar o utilitário de resolução de problemas

O utilitário para resolução de problemas é uma macro fornecida pelo técnico da Microsoft dos serviços de suporte. Esta macro pode ajudar a automatizar o processo de resolução de problemas Microsoft Word removendo determinados componentes chave que pode estar danificado ou que podem causar um conflito com o Microsoft Word. Utilize este utilitário para desactivar (pela ordem listada) dos seguintes componentes que normalmente são carregados durante o arranque do Word:
  • A chave de registo de Data
  • O modelo global Normal.dot
  • Os suplementos e modelos
  • Suplementos COM
  • A chave de registo de Opções
Se qualquer um destes itens estiver danificado ou incompatível, o Word poderá não conseguir iniciar ou poderá não conseguir funcionar correctamente. Pode ignorar temporariamente estes itens e outros itens iniciando o Word com o parâmetro /a .

Iniciar o Microsoft Word com o parâmetro /a

Para iniciar o Word utilizando o parâmetro /a , siga estes passos:
  1. Clique em Iniciar e clique em Executar .
  2. Na caixa de diálogo Executar , efectue um dos seguintes procedimentos:
    • Na caixa Abrir , escreva Winword.exe /a .

      - ou -
    • Clique em Procurar . Localize e seleccione o ficheiro Winword.exe . Para o fazer, siga estes passos:
      1. Na lista Procurar em , seleccione a pasta que contém os ficheiros de programa do Word. Seleccione o ficheiro Winword.exe e, em seguida, clique em Abrir .

        Este passo preenche a caixa Abrir na caixa de diálogo Executar .
      2. Na caixa Abrir , mova o ponto de inserção após Winword.exe.

        Nota : O caminho para o ficheiro Winword.exe na caixa de diálogo Executar está escrito entre aspas. Não se esqueça de mover o ponto de inserção para a direita das aspas de fecho.
      3. Introduza um espaço e, em seguida, escreva /a .

        A instrução existente na caixa Abrir deve ter um aspecto semelhante ao seguinte:
        "C:\Programas\Microsoft Office\Office10\Winword.exe" /a
  3. Na caixa de diálogo Executar , clique em OK .
Se o Word é iniciado e funciona correctamente quando utiliza o parâmetro /a , o problema reside dos componentes listados no início da secção "Como para utilizar a resolução de problemas utilitário" deste artigo. Utilize o utilitário para resolução de problemas para determinar o componente que está a causar o problema. Para utilizar o utilitário para resolução de problemas, poderá ser necessário instalar o support.dot.

Nota : Se o problema ainda ocorre quando inicia o Word com o parâmetro /a , não é necessário utilizar o utilitário para resolução de problemas.

Passo a passo: Utilizar o utilitário de resolução de problemas

Para isolar e remover o componente que está a causar o problema no Word, remova cada um dos seguintes componentes (um cada vez e pela ordem listada), utilizando o utilitário para resolução de problemas: Step 1: Delete the Data Registry Key

Step 2: Rename the Normal.dot Global Template

Step 3: Disable the Word Startup Folder Add-Ins

Step 4: Delete the COM Add-Ins Registry Key

Step 5: Delete the Options Registry Key

Passo 1: Eliminar a chave de registo de dados

Opções frequentemente utilizadas (clique em Opções no menu Ferramentas ) são armazenadas na chave Data . Um passo de resolução de problemas é eliminar a chave Data . O Word recria esta chave de dados , utilizando as predefinições da próxima vez que o programa for iniciado.

Nota : a eliminação da chave ' Data ' repõe as predefinições de várias opções, incluindo o mais recentemente lista ficheiros utilizados no menu ficheiro e muitas das definições personalizadas na caixa de diálogo Opções .

Para eliminar a chave Data , siga estes passos:
  1. Saia de todos os programas do Office.
  2. Inicie o Word utilizando o parâmetro /a . Para iniciar o Word com o parâmetro /a , consulte o "Starting Microsoft Word with the /a Switch"secção deste artigo.
  3. Abra o modelo Support.dot. Para efectuar este procedimento, consulte o "How to Open the Support.dot Template"secção deste artigo.
  4. No modelo Support.dot, clique no botão Troubleshoot Utility .
  5. No Microsoft Word Troubleshooting Utility caixa de diálogo, na lista Seleccione um item , clique em Chave de registo de dados e, em seguida, clique em Eliminar .
  6. Clique em OK quando vir a seguinte mensagem:
    HKEY_CURRENT_USER\Software\Microsoft Office\10.0\Word\Data
    Ficheiro cópia de segurança para esta chave de registo estiver presente no:
    C:\WINDOWS\TEMP\wddata10.0

    Chave de registo foi eliminado.
  7. Clique em Fechar .
  8. No menu ficheiro , clique em Sair para sair do Word.
  9. Inicie o Word da forma habitual. Fazer não utilize o procedimento na secção "Iniciar o Microsoft Word com o parâmetro /a" deste artigo.
Se o Word inicia e funciona correctamente, significa que o problema foi resolvido. O problema era uma chave de registo de dados danificada. Poderá ter de alterar algumas definições para restaurar as suas opções preferidas no Word.

Se o problema não ficar resolvido, restaura a chave do registo dados antigo. Para o fazer, siga estes passos:
  1. Saia de todos os programas do Office.
  2. Inicie o Word utilizando o parâmetro /a . Para iniciar o Word com o parâmetro /a , consulte o "Starting Microsoft Word with the /a Switch"secção deste artigo.
  3. Abra o modelo Support.dot. Para efectuar este procedimento, consulte o "How to Open the Support.dot Template"secção deste artigo.
  4. No modelo Support.dot, clique no botão Troubleshoot Utility .
  5. No Microsoft Word Troubleshooting Utility caixa de diálogo, na lista Seleccione um item , clique em Chave de registo de dados e, em seguida, clique em Restaurar .
  6. Clique em Sim quando visualizar a seguinte mensagem:
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Data

    Esta chave existir no registo.
    Substituí-lo?
  7. Clique em OK quando vir a seguinte mensagem:
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Data

    Registo restauro chave com êxito.
  8. Efectue um dos seguintes procedimentos:
Back to Top of Using the Troubleshoot Utility

Passo 2: Mudar o nome do modelo Global Normal.dot

Para impedir que a formatação, texto automático e as macros guardadas no modelo global (normal.dot) afectem o comportamento do Word e documentos que abrir, mude o nome do modelo global. Mudar o nome deste ficheiro permite-lhe rapidamente determinar se o modelo global está a causar o problema.

Nota : mudar o nome do ficheiro Normal.dot repõe várias opções as respectivas predefinições, incluindo estilos personalizados, barras de ferramentas personalizadas, macros e entradas de texto automático. Por este motivo, a Microsoft recomenda vivamente que não elimine o ficheiro Normal.dot.

Alguns tipos de configurações podem criar mais do que um ficheiro Normal.dot. Estas situações incluem casos em que várias versões do Word em execução no mesmo computador ou casos em que existem várias instalações de estação de trabalho no mesmo computador. Nestas situações, deve mudar o nome da cópia correcta do normal.dot.

Para mudar o nome do ficheiro Normal.dot, siga estes passos:
  1. Saia de todos os programas do Office.
  2. Inicie o Word utilizando o parâmetro /a . Para iniciar o Word com o parâmetro /a , consulte o "Starting Microsoft Word with the /a Switch"secção deste artigo.
  3. Abra o modelo Support.dot. Para efectuar este procedimento, consulte o "How to Open the Support.dot Template"secção deste artigo.
  4. No modelo Support.dot, clique no botão Troubleshoot Utility .
  5. No Microsoft Word Troubleshooting Utility caixa de diálogo, na lista Seleccione um item , clique em Modelo Global Normal.dot e, em seguida, clique em Mudar o nome .
  6. Clique em OK quando receber a seguinte mensagem:
    path\Application Data\Microsoft\Modelos\Normal.dot
    Copiar para
    path\Application Data\Microsoft\Modelos\10Normal.dot
    Nota : O caminho para o ficheiro Normal.dot poderá ser diferente.
  7. Clique em Fechar para fechar o Microsoft Word Troubleshooting Utility caixa de diálogo.
  8. No menu ficheiro , clique em Sair para sair do Word.
  9. Inicie o Word da forma habitual. Fazer não utilize o procedimento na secção "Iniciar o Microsoft Word com o parâmetro /a" deste artigo.
Se o Word for iniciado correctamente, significa que o problema foi resolvido. Neste caso, o problema é um ficheiro Normal.dot danificado. Poderá ter de alterar algumas definições para restaurar as suas opções preferidas. Se o ficheiro Normal.dot cujo nome foi mudado contiver personalizações, tais como estilos, macros ou entradas de texto automático que não sejam facilmente criar novamente, poderá conseguir copiar estas personalizações do ficheiro 10Normal.dot (o normal.dot antigo) para o novo ficheiro Normal.dot, utilizando o organizador.

Para obter mais informações sobre como utilizar o organizador, clique em Ajuda do Microsoft Word no menu de Ajuda escreva Organizador no Assistente do Office ou no Assistente de respostas e, em seguida, clique em Procurar para visualizar os tópicos devolvidos.

Se o problema não ficar resolvido, restaure o ficheiro Normal.dot antigo (10Normal.dot). Para o fazer, siga estes passos:
  1. Saia de todos os programas do Office.
  2. Inicie o Word utilizando o parâmetro /a . Para iniciar o Word com o parâmetro /a , consulte o "Starting Microsoft Word with the /a Switch"secção deste artigo.
  3. Abra o modelo Support.dot. Para efectuar este procedimento, consulte o "How to Open the Support.dot Template"secção deste artigo.
  4. No modelo Support.dot, clique no botão Troubleshoot Utility .
  5. No Microsoft Word Troubleshooting Utility caixa de diálogo, na lista Seleccione um item , clique em Normal.dot Global Template e, em seguida, clique em Restaurar .
  6. Clique em Sim quando visualizar a seguinte mensagem:
    path\Application Data\Microsoft\Modelos\Normal.dot

    Já existe uma cópia de segurança deste ficheiro.

    Substituí-lo?
    Nota : O caminho para o ficheiro Normal.dot poderá ser diferente.
  7. Clique em OK quando vir a seguinte mensagem:
    path\Application Data\Microsoft\Modelos\10Normal.dot
    Copiar para
    path\Modelos\Normal.dot
  8. Efectue um dos seguintes procedimentos:
Back to Top of Using the Troubleshoot Utility

Passo 3: Desactivar os suplementos a pasta de arranque do Word

Quando inicia o Word, este carrega automaticamente modelos e suplementos localizados nas pastas Startup. Os erros no Word poderão ser provocados por conflitos ou problemas com um suplemento. Para determinar se um item de uma pasta de arranque está a causar o problema, pode desactivar temporariamente a definição do registo que aponta para estes suplementos.

Para desactivar temporariamente a chave de registo de suplementos, siga estes passos:
  1. Saia de todos os programas do Office.
  2. Inicie o Word utilizando o parâmetro /a . Para iniciar o Word com o parâmetro /a , consulte o "Starting Microsoft Word with the /a Switch"secção deste artigo.
  3. Abra o modelo Support.dot. Para efectuar este procedimento, consulte o "How to Open the Support.dot Template"secção deste artigo.
  4. No modelo Support.dot, clique no botão Troubleshoot Utility .
  5. No Microsoft Word Troubleshooting Utility caixa de diálogo, na lista Seleccione um item , clique em Pasta de arranque do Word Add-Ins e, em seguida, clique em Mudar o nome .
  6. Efectue um dos seguintes procedimentos:
    • Clique em OK quando vir a seguinte mensagem:
      Não foram encontrados para mudar o nome/restaurar ficheiros.
      Nota : Se receber esta mensagem, dispõe de não adicionar-ins que são carregados quando inicia o Word. Depois de clicar em OK , avance para o Step 4: Delete the COM Add-Ins Registry Keysecção deste artigo.

      - ou -
    • Clique em OK quando vir a seguinte mensagem:
      path\Application Data\Microsoft\Word\Startup\ file name
      Copiar para
      path\Application Data\Microsoft\Word\Startup\ file name

      path\Program Files\Microsoft Office\Office10\Startup\ file name
      Copiar para
      path\Program Files\Microsoft Office\Office10\Startup\ file name
      Nota : os caminhos e nomes de ficheiro no sistema podem ser diferentes.
  7. Clique em Fechar para fechar o Microsoft Word Troubleshooting Utility caixa de diálogo.
  8. No menu ficheiro , clique em Sair para sair do Word.
  9. Inicie o Word da forma habitual. Fazer não utilize o procedimento na secção "Iniciar o Microsoft Word com o parâmetro /a" deste artigo.
  10. Efectue um dos seguintes procedimentos:
    • Se não conseguir reproduzir o problema e itens de arranque removidos no passo 6, determinou que o problema é causado por um suplemento do item. Para determinar o item de arranque está a causar o problema, siga estes passos:
      1. Saia de todos os programas do Office.
      2. Inicie o Word utilizando o parâmetro /a . Para iniciar o Word com o parâmetro /a , consulte o "Starting Microsoft Word with the /a Switch"secção deste artigo.
      3. Abra o modelo Support.dot. Para efectuar este procedimento, consulte o "How to Open the Support.dot Template"secção deste artigo.
      4. No modelo Support.dot, clique no botão Troubleshoot Utility .
      5. No Microsoft Word Troubleshooting Utility caixa de diálogo, na lista Seleccione um item , clique em Word Startup Folder Addins e, em seguida, clique em Restaurar .
      6. Clique em OK quando vir a seguinte mensagem:
        path\Application Data\Microsoft\Word\Startup\ file name
        Copiar para
        path\Application Data\Microsoft\Word\Startup\ file name

        path\Program Files\Microsoft Office\Office10\Startup\ file name
        Copiar para
        path\Program Files\Microsoft Office\Office10\Startup\ file name
        Nota : os caminhos e nomes de ficheiro no sistema podem ser diferentes.
      7. Clique em Fechar para fechar o Microsoft Word Troubleshooting Utility caixa de diálogo.
      8. No menu ficheiro , clique em Sair para sair do Word.
      9. Clique duas vezes no Meu computador e, em seguida, abra uma das pastas especificada no passo f. Por exemplo:
        path\Application Data\Microsoft\Word\Startup\

        - ou -

        path\Program Files\Microsoft Office\Office10\Startup\
      10. Clique com o botão direito do rato dos ficheiros existentes na pasta e, em seguida, clique em Mudar o nome no menu de atalho.
      11. Escreva um novo nome para o ficheiro e, em seguida, prima ENTER.

        importante : Tome nota do nome original do ficheiro, porque poderá necessita de mudar o nome de ficheiro com o nome original.
      12. Inicie o Word da forma habitual. Fazer não utilize o procedimento na secção "Iniciar o Microsoft Word com o parâmetro /a" deste artigo.
      Se já não pode reproduzir o problema, tiver encontrado o suplemento item específico que está a causar o problema. Se necessitar de funcionalidades que são fornecidas pelo suplemento - item, tem de determinar que suplemento do Word - in inclui o produto específico e contacte o fabricante para obter uma actualização.

      Se o problema não ficar resolvido, mude o nome do suplemento novamente para o nome original e, em seguida, repita os passos h através de i para cada ficheiro nas pastas especificadas nas mensagens apresentadas no passo f.

      - ou -

    • Se já não pode reproduzir o problema, tiver encontrado o suplemento item específico que está a causar o problema. Se necessitar de funcionalidades que são fornecidas pelo suplemento - item, tem de determinar que suplemento do Word - in inclui o produto específico e contacte o fabricante para obter uma actualização. Se o problema não ficar resolvido, restaure os itens do suplemento e, em seguida, avance para o passo seguinte. Para o fazer, siga estes passos:
      1. Saia de todos os programas do Office.
      2. Inicie o Word utilizando o parâmetro /a . Para iniciar o Word com o parâmetro /a , consulte o "Starting Microsoft Word with the /a Switch"secção deste artigo.
      3. Abra o modelo Support.dot. Para efectuar este procedimento, consulte o "How to Open the Support.dot Template"secção deste artigo.
      4. No modelo Support.dot, clique no botão Troubleshoot Utility .
      5. No Microsoft Word Troubleshooting Utility caixa de diálogo, na lista Seleccione um item , clique em Word Startup Folder Addins e, em seguida, clique em Restaurar .
      6. Clique em OK quando vir a seguinte mensagem:
        path\Application Data\Microsoft\Word\Startup\ file name
        Copiar para
        path\Application Data\Microsoft\Word\Startup\ file name

        path\Program Files\Microsoft Office\Office10\Startup\ file name
        Copiar para
        path\Program Files\Microsoft Office\Office10\Startup\ file name
        Nota : os caminhos e nomes de ficheiro no sistema podem ser diferentes.
      7. Avance para o Step 4: Delete the COM Add-Ins Registry Keysecção deste artigo.
Back to Top of Using the Troubleshoot Utility

Passo 4: Eliminar a chave de registo suplementos COM

Suplementos COM podem ser instalados em qualquer localização e são instalados por programas que interagem com o Word. Para remover as definições de registo do Windows para quaisquer suplementos COM instalados, siga estes passos:
  1. Saia de todos os programas do Office.
  2. Inicie o Word utilizando o parâmetro /a . Para iniciar o Word com o parâmetro /a , consulte o "Starting Microsoft Word with the /a Switch"secção deste artigo.
  3. Abra o modelo Support.dot. Para efectuar este procedimento, consulte o "How to Open the Support.dot Template"secção deste artigo.
  4. No modelo Support.dot, clique no botão Troubleshoot Utility .
  5. No Microsoft Word Troubleshooting Utility caixa de diálogo, na lista Seleccione um item , clique em Suplementos COM chave de registo e, em seguida, clique em Eliminar .
  6. Clique em OK quando vir a seguinte mensagem:
    HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins
    Ficheiro cópia de segurança para esta chave de registo estiver presente no:
    C:\Windows\TEMP\wdaddn10.0

    Chave de registo foi eliminado.
  7. Clique em Fechar para fechar o Microsoft Word Troubleshooting Utility caixa de diálogo.
  8. No menu ficheiro , clique em Sair para sair do Word.
  9. Inicie o Word normalmente. Fazer não utilize o procedimento na secção "Iniciar o Microsoft Word com o parâmetro /a" deste artigo.
  10. Efectue um dos seguintes procedimentos:
    • Se não conseguir reproduzir o problema, determinou que um suplemento está a causar o problema. Para determinar qual COM suplementos está a causar o problema, siga estes passos:
      1. Saia de todos os programas do Office.
      2. Inicie o Word utilizando o parâmetro /a . Para iniciar o Word com o parâmetro /a , consulte o "Starting Microsoft Word with the /a Switch"secção deste artigo.
      3. Abra o modelo Support.dot. Para efectuar este procedimento, consulte o "How to Open the Support.dot Template"secção deste artigo.
      4. No modelo Support.dot, clique no botão Troubleshoot Utility .
      5. No Microsoft Word Troubleshooting Utility caixa de diálogo, na lista Seleccione um item , clique em Suplementos COM chave de registo e, em seguida, clique em Restaurar .
      6. Clique em OK quando vir a seguinte mensagem:
        HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins

        Registo restauro chave com êxito.
      7. Clique em Fechar para fechar o Microsoft Word Troubleshooting Utility caixa de diálogo.
      8. No menu ficheiro , clique em Sair para sair do Word.
      9. Inicie o Word da forma habitual. Fazer não utilize o procedimento na secção "Iniciar o Microsoft Word com o parâmetro /a" deste artigo.
      10. No menu Ferramentas , clique em Personalizar .
      11. Clique no separador de comandos . Na lista de categorias , clique em Ferramentas .
      12. Na lista de comandos , clique em Suplementos COM e, em seguida, arraste o comando a uma das barras de ferramentas.
      13. Clique em Fechar para fechar a caixa de diálogo Personalizar .
      14. Clique no botão Suplementos COM que adicionou em passos k através de m.
      15. Na caixa de diálogo Suplementos COM , se um suplemento estiver listado, clique para desmarcar a caixa de verificação add-in.

        Nota : Se o mais suplemento estiver listado, clique para limpar apenas um suplemento de caixa de verificação cada vez, para determinar o suplemento está a causar o problema.
      16. Clique em OK para fechar a caixa de diálogo Suplementos COM .
      17. Clique em Sair no menu ' ficheiro ' para sair do Word.
      18. Inicie o Word da forma habitual. Fazer não utilize o procedimento na secção "Iniciar o Microsoft Word com o parâmetro /a" deste artigo.
      19. Efectue um dos seguintes procedimentos:
        • Se já não pode reproduzir o problema, tiver encontrado o suplemento que está a causar o problema. Se tiver as funcionalidades fornecidas pelo item suplemento, tem de determinar o suplemento do Word inclui o produto específico e contacte o fornecedor para obter uma actualização.

          - ou -
        • Se o problema não ficar resolvido, clique no botão Suplementos COM que adicionou em passos k através de m. Clique para seleccionar a suplemento caixa de verificação que desmarcou no passo o. Em seguida, clique para desmarcar a caixa de verificação do suplemento diferente e repita os passos p através de s. repetir este procedimento as vezes que for necessário, para cada suplemento, até determinar o suplemento está a causar o problema.
      - ou -

    • - ou - se o problema não ficar resolvido, restaure o COM suplementos registo chave e, em seguida, avance para o passo seguinte. Para o fazer, siga estes passos:
      1. Saia de todos os programas do Office.
      2. Inicie o Word utilizando o parâmetro /a . Para iniciar o Word com o parâmetro /a , consulte o "Starting Microsoft Word with the /a Switch"secção deste artigo.
      3. Abra o modelo Support.dot. Para efectuar este procedimento, consulte o "How to Open the Support.dot Template"secção deste artigo.
      4. No modelo Support.dot, clique no botão Troubleshoot Utility .
      5. No Microsoft Word Troubleshooting Utility caixa de diálogo, na lista Seleccione um item , clique em Suplementos COM chave de registo e, em seguida, clique em Restaurar .
      6. Clique em OK quando vir a seguinte mensagem:
        HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins

        Registo restauro chave com êxito.
      7. Clique em Fechar para fechar o Microsoft Word Troubleshooting Utility caixa de diálogo.
      8. No menu ficheiro , clique em Sair para sair do Word.
      9. Avance para o Step 5: Delete the Options Registry Keysecção deste artigo.
Back to Top of Using the Troubleshoot Utility

Passo 5: Eliminar a chave de registo opções

A chave de registo Options armazena as opções que pode definir a partir do Word, seja alterando opções de menu ou executando a macro RegOptions. Estas são as opções editáveis.

As definições enquadram-se dois grupos: predefinição definições e definições opcionais. As predefinições são estabelecidas durante o programa de configuração e pode alterar os modificando opções no Word. Definições opcionais não são criadas durante o programa de configuração; para adicioná-los tem de executar a macro RegOptions (discutida posteriormente neste artigo).

Para eliminar a chave ' Options , siga estes passos:
  1. Saia de todos os programas do Office.
  2. Inicie o Word utilizando o parâmetro /a . Para iniciar o Word com o parâmetro /a , consulte o "Starting Microsoft Word with the /a Switch"secção deste artigo.
  3. Abra o modelo Support.dot. Para efectuar este procedimento, consulte o "How to Open the Support.dot Template"secção deste artigo.
  4. No modelo Support.dot, clique no botão Troubleshoot Utility .
  5. No Microsoft Word Troubleshooting Utility caixa de diálogo, na lista Seleccione um item , clique em Opções de chave de registo e, em seguida, clique em Eliminar .
  6. Clique em OK quando vir a seguinte mensagem:
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Options
    Ficheiro cópia de segurança para esta chave de registo estiver presente no:
    C:\WINDOWS\TEMP\wdoptn10.0

    Chave de registo foi eliminado.
  7. Inicie o Word da forma habitual. Não utilize o parâmetro /a para iniciar o Word como descrito no "Starting Microsoft Word with the /a Switch"secção deste artigo.
Se o Word for correctamente iniciado e funcionar correctamente, o problema foi resolvido. O problema era uma chave de Opções danificada. Poderá ter de alterar algumas definições para restaurar as suas opções preferidas no Word.

Se o problema não ficar resolvido, saia do Word e, em seguida, adicionar as informações chaves de Opções para o registo do Windows. Para o fazer, siga estes passos:
  1. Saia de todos os programas do Office.
  2. Inicie o Word utilizando o parâmetro /a . Para iniciar o Word com o parâmetro /a , consulte o "Starting Microsoft Word with the /a Switch"secção deste artigo.
  3. Abra o modelo Support.dot. Para efectuar este procedimento, consulte o "How to Open the Support.dot Template"secção deste artigo.
  4. No modelo Support.dot, clique no botão Troubleshoot Utility , que está localizado na tabela que está contida no ficheiro.
  5. No Microsoft Word Troubleshooting Utility caixa de diálogo, na lista Seleccione um item , clique em Opções de chave de registo e, em seguida, clique em Restaurar .
  6. Clique em Sim quando visualizar a seguinte mensagem:
    HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Options

    Esta chave existir no registo.
    Substituí-lo?
  7. Clique em OK quando vir a seguinte mensagem:
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Options

    Registo restauro chave com êxito.
  8. Clique em Fechar para fechar o Microsoft Word Troubleshooting Utility caixa de diálogo.
  9. No menu ficheiro , clique em Sair para sair do Word.
Back to Top of Using the Troubleshoot Utility



Como utilizar a Macro Opções do registo

Pode utilizar a macro RegOptions para examinar e efectuar alterações às definições do Word no registo do Windows. Segue-se uma lista de opções disponibilizadas na macro e uma breve descrição do objectivo de cada opção:
Opções do Word

Guardar automaticamente-Path : define a pasta onde estão guardados ficheiros de recuperação automática.

DOC-Path : A pasta predefinida utilizada para documentos do Word.

Imagem-Path : define o caminho predefinido que é utilizado quando aponte para imagem no menu Inserir e, em seguida, clique em Do ficheiro .

Caminho de arranque : define o caminho para ficheiros de arranque do Word, tais como modelos e ficheiros .wll (WLLs) que são carregados quando inicia o Word.

Ferramentas-Path : define uma localização em que o Word procura de ferramentas de verificação, filtros, conversores e outros componentes, no caso de não estão correctamente registados ou não não possível encontrar.

Utilizador-Dot-Path : caminho para modelos do utilizador. Repare que quando esta definição é alterada para o Word, a alteração afecta todos os programas do Microsoft Office.

Grupo de trabalho-Dot-Path : caminho para modelos de grupo de trabalho. Pode especificar um caminho UNC.

BAK-Extension : A extensão de ficheiro predefinido que é utilizada para ficheiros de cópia de segurança do Word. A extensão de predefinição é *.wbk.

DOC-Extension : A extensão de ficheiro predefinido que é utilizada para documentos do Word. A predefinição é *. doc.

DOT-Extension : A extensão de ficheiro predefinido que é utilizada para modelos do Word. A predefinição é * .dot.

NoFontMRUList : activa ou desactiva a lista de tipos de letra recentemente utilizados (MRU, Most Recently Used). Para activar a lista de tipos de letra MRU, escreva 0 (zero). Para desactivar a MRU lista de tipos de letra, escreva 1 .

SpellingWavyUnderlineColor : permite-lhe controlar a cor do sublinhado é apresentado em palavras com erros ortográficos.

GrammarWavyUnderlineColor : permite-lhe controlar a cor do sublinhado é apresentado em erros de gramática.

SmartTagUnderlineColor : permite-lhe controlar a cor do sublinhado pontilhado que é apresentado em etiquetas inteligentes.

FormatConsistencyWavyUnderlineColor : permite-lhe controlar a cor do sublinhado é apresentado em erros de formatação.

OLEDOT : Especifica o modelo de documento que é utilizado quando cria um objecto de documento no Word ou noutra aplicação OLE.
Opções do Editor de equações

Appdir : Editor de equações a pasta do programa. Editor de equações deve ser instalado e executado uma vez, na ordem para esta e outras definições do Editor de equações para ser apresentado.

CustomZoom : definição personalizar o zoom. Esta definição só tem efeito quando inicia o Editor de equações numa janela separada através da definição ForceOpen.

ForceOpen : força o Editor de equações para abrir numa janela separada. Escreva 0 (zero) para abrir no local ou tipo 1 para abrir numa janela separada.

ShowAll : Mostra ou oculta caracteres de não impressão.

ToolBarDocked : Define se a barra de ferramentas é ancorada. Escolha ' Sim ' ( 1 ) ou não ( 0 ).

ToolBarDockPos : posição da barra de ferramentas Editor de equações quando está ancorado. 1 define a barra de ferramentas na parte superior da janela do Editor de equações. 2 define a barra de ferramentas na parte inferior da janela do Editor de equações.

ToolBarShown : Define se a barra de ferramentas é apresentada. Escolha ' Sim ' ( 1 ) ou não ( 0 ).

ToolBarWinPos : posição da barra de ferramentas quando este não está ancorado, especificado no X, Y coordenadas, com o canto superior esquerdo como a origem. As unidades são em pixels.

Zoom : O tamanho de zoom padrão que está seleccionado no menu Ver .
Para utilizar a macro RegOptions, siga estes passos:
  1. No menu ficheiro , clique em Abrir .
  2. Altere a caixa ficheiros do tipo para modelos de documento (* .dot) .
  3. Altere a caixa Procurar em para a seguinte pasta:
    C:\Program Files\Microsoft Office\Office10\Macros\
  4. Clique para seleccionar o ficheiro Support.dot e, em seguida, clique em Abrir .
  5. Na coluna da tabela contida no ficheiro de macro , clique no botão Opções do registo .
  6. No separador Opções do Word ou no separador Opções do Editor de equações , clique para seleccionar a opção que pretende alterar, escreva a nova definição na caixa definições (ou clique em Procurar , se estiver disponível e, em seguida, clique para seleccionar a definição que pretende) e, em seguida, clique em alterar .
  7. Clique em Fechar para fechar a caixa de diálogo Definir opções de registo .


Como utilizar o utilitário de cópia de segurança de correcção automática

Pode utilizar o utilitário de cópia de segurança de correcção automática para mover a correcção automática entries between computers. Para obter informações adicionais sobre o utilitário de cópia de segurança de correcção automática, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
269006COMO: Mover entradas de correcção automática do Word entre computadores no Word 2002


Apenas utilizadores avançados

As informações nesta secção não são necessárias quando utilizar as macros no modelo Support.dot. Esta informação é fornecida apenas se pretende efectuar estas macros disponível globalmente no Microsoft Word ou se pretende visualizar o código de macro.



Como disponibilizar as macros global

Para disponibilizar as macros global no Microsoft Word, utilize um dos seguintes métodos.

Método 1: Adicionar os modelos globais e suplementos

Se pretender utilizar as macros ocasionalmente (ou se pretender ver o que fazer as macros antes de decide torná-las facilmente acessíveis), adicione os modelos de macros como modelos globais.

Para adicionar um dos modelos listados na secção "Sumário" deste artigo como um modelo global, siga estes passos:
  1. No menu Ferramentas , clique em modelos e suplementos .
  2. Em modelos globais e suplementos , clique em Adicionar .
  3. Altere a caixa Procurar em para a pasta que contém o modelo de macro de exemplo. Na caixa ficheiros do tipo , seleccione todos os ficheiros (*. *) .
  4. Seleccione o modelo de macro de exemplo e, em seguida, clique em OK .
  5. Depois do modelo de macro de exemplo apresentado na caixa de diálogo modelos e suplementos , certifique-se de que a caixa de verificação para o modelo está seleccionada e, em seguida, clique em OK .

    importante : quando carregar um modelo global modelos e suplementos , o modelo permanece carregado para apenas a sessão actual do Word. Se sair e, em seguida, reinicie o Word, o modelo não é automaticamente carregado. Tem de seleccionar novamente o modelo que pretende utilizar. Para tal, clique em modelos e suplementos no menu Ferramentas . Na caixa de diálogo modelos e suplementos , clique para seleccionar o modelo que pretende utilizar macros do e, em seguida, clique em OK .
  6. Para executar uma macro específica, siga estes passos:
    1. No menu Ferramentas , aponte para macro e, em seguida, clique em macros .
    2. Na caixa de diálogo macros , altere a caixa macros em para o modelo que contém a macro que pretende. Por exemplo, clique para seleccionar o ficheiro Support.dot (modelo global) .
    3. Na lista nome da macro , clique para seleccionar a macro que pretende e, em seguida, clique em Executar .

Método 2: Adicionar o modelo para a pasta de arranque

Mova o modelo para a pasta de arranque. Microsoft Word tem automaticamente acesso a macros em modelos que são colocados na seguinte pasta:
C:\Programas\Microsoft Office\Office10\Startup
Utilize o Microsoft Windows Explorer para colocar uma cópia do modelo de macro de exemplo para a pasta arranque.

Quando inicia o Word, um modelo localizado na pasta de arranque é carregado como um modelo global e as macros do modelo estão disponíveis na caixa de diálogo macros . Uma desvantagem deste método é que pode demorar um pouco mais a iniciar o Word (Word inicia cada vez, o Word carrega estes modelos globalmente).

Para executar uma macro específica, siga estes passos:
  1. No menu Ferramentas , aponte para macro e, em seguida, clique em macros .
  2. Na caixa de diálogo macros , altere a caixa macros em para o modelo que contém a macro que pretende. Por exemplo, clique para seleccionar o ficheiro Support.dot (modelo global) .
  3. Na lista nome da macro , clique para seleccionar a macro que pretende e, em seguida, clique em Executar .

Método 3: Copiar a macro no modelo normal

Para executar uma macro específica sem ter de abrir o modelo, copie a macro no modelo global (normal.dot). Para o fazer, siga estes passos:
  1. Abra o modelo de macro de exemplo.
  2. No menu Ferramentas , clique em modelos e suplementos .
  3. Na caixa de diálogo modelos e suplementos , clique em Organizador .
  4. Na caixa de diálogo Organizador , clique para seleccionar o separador de Itens do projecto de macro .
  5. As macros no modelo de macro de exemplo estão listadas dos lados da caixa de diálogo. O modelo global (normal.dot) aparece aberto no lado oposto.

    Nota : Se o ficheiro Normal.dot (modelo global) não estiver aberto, clique em Fechar ficheiro no lado oposto. O botão de Fechar ficheiro muda para um botão de Abrir um ficheiro . Clique em Abrir ficheiro . Clique para seleccionar o ficheiro de modelo Normal.dot e, em seguida, clique em Abrir .
  6. No lado do modelo de macro de exemplo, clique para seleccionar os itens de projecto de macro que estão listados no modelo de macro de exemplo e, em seguida, clique em Copiar .

    Nota : para seleccionar todos os itens listados, mantenha a tecla CTRL premida enquanto clica em cada item de projecto de macro.
  7. Clique em Copiar para copiar os itens de projecto de macro para o normal.dot modelo.
  8. Clique em OK para fechar a caixa de diálogo Organizador .
  9. Para executar uma macro específica, siga estes passos:
    1. No menu Ferramentas , aponte para macro e, em seguida, clique em macros .
    2. Na caixa de diálogo macros , altere a caixa macros em para o modelo que contém a macro que pretende. Por exemplo, clique para seleccionar Normal.dot (modelo global) .
    3. Na lista nome da macro , clique para seleccionar a macro que pretende e, em seguida, clique em Executar .


Como visualizar o código de macro

A Microsoft fornece exemplos de programação apenas, para fins sem garantia expressa ou implícita. Isto inclui, mas não está limitado a, as garantias implícitas de comercialização ou adequação a um fim específico. Este artigo pressupõe que está familiarizado com a linguagem de programação apresentada e as ferramentas que são utilizadas para criar e depurar procedimentos. Os técnicos de suporte da Microsoft podem ajudar a explicar a funcionalidade de um determinado procedimento, mas não modificarão estes exemplos para proporcionarem funcionalidades adicionais nem criarão procedimentos adaptados às necessidades específicas do utilizador. Para ver o código de macro de uma macro de exemplo, siga estes passos:
  1. No menu ficheiro , clique em Abrir .
  2. Na caixa de diálogo Abrir , altere a caixa Procurar em para a pasta que contém o modelo de macro de exemplo, altere a caixa ficheiros do tipo para todos os ficheiros (*. *) e, em seguida, clique para seleccionar o modelo de macro de exemplo adequado.
  3. Mantenha premida a tecla SHIFT e clique em Abrir .
  4. No menu Ferramentas , aponte para macro e, em seguida, clique em macros .
  5. Na caixa de diálogo macros , altere a caixa de macros em para o modelo de macro de exemplo que acabou de abrir.
  6. Seleccione a macro adequada e, em seguida, clique em Editar .

Propriedades

Artigo: 289506 - Última revisão: 27 de julho de 2006 - Revisão: 2.2
A informação contida neste artigo aplica-se a:
  • Microsoft Word 2002 Standard Edition
Palavras-chave: 
kbmt kbdta kbhowtomaster KB289506 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 289506

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com