Como instalar e utilizar o modelo Support.dot no Word 2002

Traduções deste artigo Traduções deste artigo
ID do artigo: 289506 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

Sumário

A intenção deste artigo é ajudá-lo a determinar onde existe o problema quando você não conseguir identificar ou isolar esse problema por outros meios no Microsoft Word. Para encontrar os problemas e artigos sobre problemas específicos que você esteja tendo, por favor, consulte na Base de Dados de Conhecimento Microsoft. Para fazer isso, consulte o seguinte site da Microsoft na Web:
http://support.microsoft.com/default.aspx
Este artigo descreve detalhadamente o modelo Support.dot, que inclui métodos automatizados usando macros criadas pelo Atendimento Microsoft. O modelo Support.dot contém código especial (macros) para ajudar na solução de problemas dentro do Word. Há três tipos de macro disponíveis para ajudar na solução de vários problemas.

Macro Nome Descrição
Utilitário de Solução de Problemas TShoot Esta macro pode ser usada para solicionar diversos problemas com o Word. Você pode usar a macro para renomear sua chave Data e o arquivo Normal.dot e desativar os suplementos do Word.

OBSERVAÇÃO: Você deve iniciar o Word com a opção /a antes de executar essa macro.
Opções do Registro RegOptions Esta macro pode ser usada para modificar configurações do Word armazenada no registro do Windows.
Backup de Correção Automática AutoCorrectBackup Esta macro faz o backup de sua lista de Correção Automática para um arquivo. Você pode levar esse arquivo a outro computador e executar a macro novamente para restaurar sua lista de Correção Automática.




Como Instalar o Modelo Support.dot

O modelo Support.dot é instalado com a Instalação Completa. Ele não é instalado com a Instalação Típica ou Atualizar Agora. Se o modelo Support.dot não estiver instalado, execute essas etapas:
  1. Feche o Microsoft Word e todos os programas do Microsoft Office.
  2. Clique em Iniciar, aponte para Configurações e clique em Painel de controle.
  3. No Painel de controle, clique duas vezes em Adicionar ou remover programas.
  4. Execute as etapas para o sistema operacional do seu computador.
    • No Microsoft Windows 98, Microsoft Windows Millennium Edition (Me) ou Microsoft Windows NT 4.0, selecione Microsoft Office XP (Microsoft Word 2002) na guia Instalar/Desinstalar, e então clique em Adicionar/Remover.

      -ou-
    • No Microsoft Windows 2000 ou Microsoft Windows XP, selecione Alterar ou remover programas. Na lista Programas instalados, clique em Microsoft Office XP (Microsoft Word 2002), e então clique em Alterar.
  5. Em Instalação do produto Microsoft Office XP (Instalação do Microsoft Word 2002), selecione Adicionar ou Remover Recursos, e então clique em Avançar.
  6. Na lista Recursos a serem instalados, execute essas etapas. OBSERVAÇÃO: Clique no sinal de mais (+) no lado esquerdo do recurso para expandi-lo.

    1. Clique para expandir Microsoft Word for Windows.
    2. Clique para expandir Assistentes e modelos.
    3. Clique no ícone Mais modelos e macros, e então selecione Executar todos do meu computador no menu de atalho.
  7. : Clique no sinal de mais (+) à esquerda do recurso para expandi-lo.Clique em Atualizar para instalar o modelo Support.dot.


Como Abrir o Modelo Support.dot

Para abrir o modelo Support.dot, execute essas etapas:
  1. No menu Arquivo, clique em Abrir.
  2. Altere a caixa Arquivos do tipo para Modelo de documento (*.dot).
  3. Altere a caixa Examinar para a seguinte seguinte pasta:
    C:\Arquivos de programas\Microsoft Office\Office10\Macros\
  4. Selecione Support.dot, e então clique em Abrir.
  5. Na tabela contida no arquivo, na coluna Macro, clique no botão apropriado para executar a macro que desejar. Por exemplo, clique emUtilitário de Solução de Problemas,Opções do Registro, ouBackup de Correção Automática.


Como Usar o Utilitário de Solução de Problemas

Utilitário de Solução de Problemas é uma macro fornecida pelo Atendimento Microsoft. Essa macro pode ajudar a automatizar o processo de solução de problemas do Microsoft Word removendo certos componentes da chave que possam estar danificados ou possam causar um conflito com o Microsoft Word. Use esse utilitário para desativar (na ordem listada) os seguintes componentes que normalmente são carregados durante a inicialização do Word:
  • A chave de registro Dados
  • O modelo global Normal.dot
  • Suplementos e modelos
  • Suplementos COM
  • A chave de registro Opções
Se qualquer um desses itens estiver danificado ou não for compatível, o Word pode não iniciar ou não funcionar corretamente. É possível ignorar temporariamente esses itens e outros itens iniciando o Word com a chave /a.

Iniciar o Microsoft Word com a Chave /a

Para iniciar o Word usando a chave /a, execute essas etapas:
  1. Clique em Iniciar e em Executar.
  2. Na caixa de diálogo Executar, execute uma das seguintes ações:
    • Na caixa Abrir, digite Winword.exe /a.

      -ou-
    • Clique em Procurar. Localize e selecione o arquivo Winword.exe. Para fazer isto, execute as seguintes etapas:
      1. Na lista Examinar, selecione a pasta que contém os arquivos de programa do Word. Selecione o arquivo Winword.exe e em Abrir.

        Esta etapa preenche a caixa Abrir na caixa de diálogo Executar.
      2. Na caixa Abrir, mova o ponto de inserção depois do Winword.exe.

        OBSERVAÇÃO: O caminho para o arquivo Winword.exe na caixa de diálogo Executar fica entre aspas. Certifique-se de mover o ponto de inserção para a direita do fechamento de aspas.
      3. Digite um espaço e digite /a.

        A sentença na caixa Abrir deve ser similar à seguinte:
        "C:\Program Files\Microsoft Office\Office10\Winword.exe" /a
  3. Na caixa de diálogo Executar, clique em OK.
Se o Word iniciar e operar corretamente ao usar a chave /a, o problema está com um dos componentes listados no início da seção "Como Usar o Utilitário de Solução de Problemas" deste artigo. Use o Utilitário de Solução de Problemas para determinar qual componente está causando o problema. Para usar o Utilitário de Solução de Problemas, você pode precisar instalar o Support.dot.

OBSERVAÇÃO: Se o problema ainda ocorrer ao iniciar o Word com a chave /a, não é preciso usar o Utilitário de Solução de Problemas.

Passo a passo: Uso do Utilitário de Solução de Problemas

Para isolar e remover o componente que está causando o problema no Word, remova cada um dos seguintes componentes (um de cada vez e na ordem listada) usando o Utilitário de Solução de Problemas: Etapa 1: Excluir a Chave de Registro de Dados

Etapa 2: Renomear o Modelo Global Normal.dot

Etapa 3: Desativar os Suplementos da Pasta de Inicialização do Word

Etapa 4: Excluir a Chave de Registro de suplementos COM

Etapa 5: Excluir a Chave de Registro de Opções

Etapa 1: Exclua a Chave de Registro de Dados

As opções usadas com mais freqüência (clique em Opções no menu Ferramentas) estão armazenadas na chave Dados. Uma etapa para solucionar o problema é excluir a chave Dados. O Word recria essa chave Dados usando as configurações padrão na próxima vez em que o programa for iniciado.

OBSERVAÇÃO: Excluir a chave Dados redefine várias opções de volta a suas configurações padrão, incluindo a lista de arquivos usada recentemente no menu Arquivo e muitas configurações que você personaliza na caixa de diálogo Opções.

Para excluir a chave Dados, execute essas etapas:
  1. Feche todos os programas do Office.
  2. Inicie o Word usando a chave /a. Para iniciar o Word com a chave /a, por favor, consulte a seção "Iniciar o Microsoft Word com a chave /a" deste artigo.
  3. Abra o modelo Support.dot. Para fazer isso, por favor, consulte a seção "Como Abrir o Modelo Support.dot" deste artigo.
  4. No modelo Support.dot, clique no botão Utilitário de Solução de Problemas.
  5. Na caixa de diálogo Utilitário de Solução de Problemas do Microsoft Word, na lista Selecionar um item, clique em Chave do registro de dados, e então clique em Excluir.
  6. Clique em OK ao ver a seguinte mensagem:
    HKEY_CURRENT_USER\Software\Microsoft Office\10.0\Word\Data
    O arquivo de backup para essa chave do registro está em:
    C:\WINDOWS\TEMP\wddata10.0

    A chave do registro foi excluída.
  7. Clique em Fechar.
  8. No menu Arquivo, clique em Sair para fechar o Word.
  9. Inicie o Word da maneira que faz geralmente. Não use o procedimento na seção "Iniciar o Microsoft Word com a chave /a" deste artigo.
Se o Word iniciar e funcionar corretamente, o problema foi resolvido. O problema era uma chave do registro de Dados danificada. Talvez seja preciso alterar algumas configurações para restaurar suas opções favoritas no Word.

Se o problema não estiver resolvido, restaure sua chave do registro de Dados antiga. Para fazer isto, execute as seguintes etapas:
  1. Feche todos os programas do Office.
  2. Inicie o Word usando a chave /a. Para iniciar o Word com a chave /a, por favor, consulte a seção "Iniciar o Microsoft Word com a chave /a" deste artigo.
  3. Abra o modelo Support.dot. Para fazer isso, por favor, consulte a seção "Como Abrir o Modelo Support.dot" deste artigo.
  4. No modelo Support.dot, clique no botão Utilitário de Solução de Problemas.
  5. Na caixa de diálogo Utilitário de Solução de Problemas do Microsoft Word, na lista Selecionar um item, clique em Chave do registro de dados, e então clique em Restaurar.
  6. Clique em Sim Ao ver a seguinte mensagem:
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Data

    A chave está presente no registro.
    Deseja substituí-la?
  7. Clique em OK ao ver a seguinte mensagem:
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Data

    A restauração da chave do registro obteve êxito.
  8. Execute um dos seguintes procedimentos:
voltar ao início de Uso do Utilitário de Solução de Problemas

Etapa 2: Renomear o Modelo Global Normal.dot

Para evitar que a formatação, as macros e o AutoTexto armazenados no modelo global (Normal.dot) afetem o comportamento do Word e de documentos que abrir, renomeie seu modelo global. Renomear este arquivo permite que você determine rapidamente se o modelo global está causando o problema.

OBSERVAÇÃO: Renomear o arquivo Normal.dot redefine diversas opções de volta a suas configurações padrão, incluindo estilos personalizados, barra de ferramentas personalizada, macros e entradas de AutoTexto. Por esse motivo, a Microsoft recomenda que você não exclua o arquivo Normal.dot.

Certos tipos de configurações podem criar mais de um arquivo Normal.dot. Essas situações incluem casos em que diversas versões do Word estejam em execução no mesmo computador ou diversas instalações de estações de trabalho existam no mesmo computador. Nessas situações, certifique-se de renomear a cópia correta do Normal.dot.

Para renomear o arquivo Normal.dot, execute essas etapas:
  1. Feche todos os programas do Office.
  2. Inicie o Word usando a chave /a. Para iniciar o Word com a chave /a, por favor, consulte a seção "Iniciar o Microsoft Word com a chave /a" deste artigo.
  3. Abra o modelo Support.dot. Para fazer isso, por favor, consulte a seção "Como Abrir o Modelo Support.dot" deste artigo.
  4. No modelo Support.dot, clique no botão Utilitário de Solução de Problemas.
  5. Na caixa de diálogo Utilitário de Solução de Problemas do Microsoft Word, na lista Selecionar um item, clique em Modelo Global Normal.dot, e então clique em Renomear.
  6. Clique em OK ao receber a seguinte mensagem:
    caminho\Application Data\Microsoft\Templates\Normal.dot
    Copiado para
    caminho\Application Data\Microsoft\Templates\10Normal.dot
    OBSERVAÇÃO: O caminho para seu arquivo Normal.dot pode ser diferente.
  7. Clique em Fechar para fechar a caixa de diálogo Utilitário de solução de problemas do Microsoft Word.
  8. No menu Arquivo, clique em Sair para fechar o Word.
  9. Inicie o Word da maneira que você faz geralmente. Não use o procedimento na seção "Iniciar o Microsoft Word com a chave /a" deste artigo.
Se o Word iniciar corretamente, o problema foi resolvido. Nesse caso, o problema é um arquivo Normal.dot danificado. Pode ser necessário alterar algumas configurações para restaurar suas opções favoritas. Se o arquivo Normal.dot renomeado apresentar personalizações, como estilos, macros e entradas de AutoTexto, que não podem ser recriadas facilmente, é possível copiar essas personalizações a partir do arquivo 10Normal.dot (antes Normal.dot) para o novo arquivo Normal.dot usando o Organizador.

Para obter mais informações sobre o uso do Organizador, clique em Ajuda do Microsoft Word no menu Ajuda, digite Organizador no Assistente do Office ou no Assistente de Resposta, e então clique em Pesquisar para exibir os tópicos retornados.

Se o problema não estiver resolvido, restaure seu arquivo Normal.dot antigo (10Normal.dot). Para fazer isto, execute as seguintes etapas:
  1. Feche todos os programas do Office.
  2. Inicie o Word usando a chave /a. Para iniciar o Word com a chave /a, por favor, consulte a seção "Iniciar o Microsoft Word com a chave /a" deste artigo.
  3. Abra o modelo Support.dot. Para fazer isso, por favor, consulte a seção "Como Abrir o Modelo Support.dot" deste artigo.
  4. No modelo Support.dot, clique no botão Utilitário de solução de problemas.
  5. Na caixa de diálogo Utilitário de Solução de Problemas do Microsoft Word, na lista Selecionar um item, clique em Modelo Global Normal.dot, e então clique em Restaurar.
  6. Clique em Sim ao ver a seguinte mensagem:
    caminho\Application Data\Microsoft\Templates\Normal.dot

    O backup desse arquivo já existe.

    Deseja substituí-lo?
    OBSERVAÇÃO: O caminho para seu arquivo Normal.dot pode ser diferente.
  7. Clique em OK ao ver a seguinte mensagem:
    caminho\Application Data\Microsoft\Templates\10Normal.dot
    Copiado para
    caminho\Templates\Normal.dot
  8. Execute um dos seguintes procedimentos:
voltar ao início de Uso do Utilitário de Solução de Problemas

Etapa 3: Desative os Suplementos da Pasta de Inicialização do Word

Ao iniciar o Word, ele automaticamente carrega modelos e suplementos localizados nas pastas de Inicialização. Os erros no Word podem ser o resultado de conflitos ou problemas com o suplemento. Para determinar se um item em uma pasta de Inicialização está causando o problema, é possível desativar temporariamente a configuração do registro que aponta para esses suplementos.

Para desativar temporariamente a chave do registro de suplementos, execute essas etapas:
  1. Feche todos os programas do Office.
  2. Inicie o Word usando a chave /a. Para iniciar o Word com a chave /a, por favor, consulte a seção "Iniciar o Microsoft Word com a chave /a" deste artigo.
  3. Abra o modelo Support.dot. Para fazer isso, por favor, consulte a seção "Como Abrir o Modelo Support.dot" deste artigo.
  4. No modelo Support.dot, clique no botão Utilitário de Solução de Problemas.
  5. Na caixa de diálogo Utilitário de Solução de Problemas do Microsoft Word, na lista Selecionar um item, clique em Suplementos da pasta de inicialização do Word, e então clique em Renomear.
  6. Execute um dos seguintes procedimentos:
    • Clique em OK ao ver a seguinte mensagem:
      Não foi encontrado nenhum arquivo a ser renomeado/restaurado.
      OBSERVAÇÃO: Se esta mensagem for exibida, significa que você não possui suplementos que são carregados ao iniciar o Word. Após clicar em OK, vá até a seção Etapa 4: Excluir a Chave de Registro de Suplementos COM deste artigo.

      -ou-
    • Clique em OK ao ver a seguinte mensagem:
      caminho\Application Data\Microsoft\Word\Startup\nome_do_arquivo
      Copiado para
      caminho\Application Data\Microsoft\Word\Startup\nome_do_arquivo

      caminho\Arquivos de Programas\Microsoft Office\Office10\Startup\nome_do_arquivo
      Copiado para
      caminho\Arquivos de Programas\Microsoft Office\Office10\Startup\nome_do_arquivo
      OBSERVAÇÃO: Os nomes dos caminhos e arquivos em seu sistema podem ser diferentes.
  7. Clique em Fechar para fechar a caixa de diálogo Utilitário de solução de problemas do Microsoft Word.
  8. No menu Arquivo, clique em Sair para fechar o Word.
  9. Inicie o Word da maneira que faz geralmente. Não use o procedimento na seção "Iniciar o Microsoft Word com a chave /a" deste artigo.
  10. Execute um dos seguintes procedimentos:
    • Se não conseguir mais reproduzir o problema, e os itens de inicialização foram removidos na etapa 6, você determinou que o problema é causado por um item do suplemento. Para determinar qual item da inicialização está causando o problema, execute essas etapas:
      1. Feche todos os programas do Office.
      2. Inicie o Word usando a chave /a. Para iniciar o Word com a chave /a, por favor, consulte a seção "Iniciar o Microsoft Word com a chave /a" deste artigo.
      3. Abra o modelo Support.dot. Para fazer isso, por favor, consulte a seção"Como Abrir o Modelo Support.dot" deste artigo.
      4. No modelo Support.dot, clique no botão Utilitário de Solução de Problemas.
      5. Na caixa de diálogo Utilitário de Solução de Problemas do Microsoft Word, na lista Selecionar um item, clique em Suplementos da pasta de inicialização do Word, e então clique em Restaurar.
      6. Clique em OK ao ver a seguinte mensagem:
        caminho\Application Data\Microsoft\Word\Startup\nome_do_arquivo
        Copiado para
        caminho\Application Data\Microsoft\Word\Startup\nome_do_arquivo

        caminho\Arquivos de Programas\Microsoft Office\Office10\Startup\nome_do_arquivo
        Copiado para
        caminho\Arquivos de Programas\Microsoft Office\Office10\Startup\nome_do_arquivo
        OBSERVAÇÃO: Os nomes dos caminhos e arquivos em seu sistema podem ser diferentes.
      7. Clique em Fechar para fechar a caixa de diálogo Utilitário de solução de problemas do Microsoft Word.
      8. No menu Arquivo, clique em Sair para fechar o Word.
      9. Clique duas vezes em Meu computador, e então abra uma das pastas especificadas na etapa f, Por exemplo:
        caminho\Application Data\Microsoft\Word\Startup\

        -ou-

        caminho\Arquivos de Programas\Microsoft Office\Office10\Startup\
      10. Clique com o botão direito do mouse em um dos arquivos contidos na pasta, e então clique em Renomear no menu de atalho.
      11. Digite um novo nome para o arquivo e pressione ENTER.

        IMPORTANTE: Anote o nome original do arquivo, porque talvez seja preciso renomear o arquivo de volta ao nome original.
      12. Inicie o Word da maneira que faz geralmente. Não use o procedimento na seção "Iniciar o Microsoft Word com a chave /a" deste artigo.
      Se não conseguir mais reproduzir o problema, você descobriu que o problema é causado por um item específico do suplemento. Se precisar dos recursos fornecidos por um item do suplemento, será necessário determinar qual suplemento do Word inclui o item específico e entrar em contato com o fornecedor para obter uma atualização.

      Se o problema não foi resolvido, renomeie o suplemento de volta ao nome origina e repita as etapas do h ao i para cada arquivo nas pastas que estão especificadas nas mensagens exibidas na etapa f.

      -ou-

    • Se não conseguir mais reproduzir o problema, você descobriu que o problema é causado por um item específico do suplemento. Se precisar dos recursos fornecidos por um item do suplemento, será necessário determinar qual suplemento do Word inclui o item específico e entrar em contato com o fornecedor para obter uma atualização. Se o problema não foi resolvido, restaure os itens do suplemento e então vá para próxima etapa. Para fazer isto, execute as seguintes etapas:
      1. Feche todos os programas do Office.
      2. Inicie o Word usando a chave /a. Para iniciar o Word com a chave /a, por favor, consulte a seção "Iniciar o Microsoft Word com a chave /a" deste artigo.
      3. Abra o modelo Support.dot. Para fazer isso, por favor, consulte a seção"Como Abrir o Modelo Support.dot" deste artigo.
      4. No modelo Support.dot, clique no botão Utilitário de Solução de Problemas.
      5. Na caixa de diálogo Utilitário de Solução de Problemas do Microsoft Word, na lista Selecionar um item, clique em Suplementos da pasta de inicialização do Word, e então clique em Restaurar.
      6. Clique em OK ao ver a seguinte mensagem:
        caminho\Application Data\Microsoft\Word\Startup\nome_do_arquivo
        Copiado para
        caminho\Application Data\Microsoft\Word\Startup\nome_do_arquivo

        caminho\Arquivos de Programas\Microsoft Office\Office10\Startup\nome_do_arquivo
        Copiado para
        caminho\Arquivos de Programas\Microsoft Office\Office10\Startup\nome_do_arquivo
        OBSERVAÇÃO: Os nomes dos caminhos e arquivos em seu sistema podem ser diferentes.
      7. Vá até a seçãoEtapa 4: Excluir a Chave de Registro de Suplementos COM deste artigo.
voltar ao início de Uso do Utilitário de Solução de Problemas

Etapa 4: Excluir a Chave de Registro de Suplementos COM

Os suplementos COM podem ser instalados em qualquer local e são instalados por programas que interagem com o Word. Para remover as configurações de registro do Windows para qualquer suplemento COM instalado, execute essas etapas:
  1. Feche todos os programas do Office.
  2. Inicie o Word usando a chave /a. Para iniciar o Word com a chave /a, por favor, consulte a seção "Iniciar o Microsoft Word com a chave /a" deste artigo.
  3. Abra o modelo Support.dot. Para fazer isso, por favor, consulte a seção "Como Abrir o Modelo Support.dot" deste artigo.
  4. No modelo Support.dot, clique no botão Utilitário de Solução de Problemas.
  5. Na caixa de diálogo Utilitário de Solução de Problemas do Microsoft Word, na lista Selecionar um item, clique em Chave do registro de suplementos COM, e então clique em Excluir.
  6. Clique em OK ao ver a seguinte mensagem:
    HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins
    O arquivo de backup para essa chave do registro está em:
    C:\Windows\TEMP\wdaddn10.0

    A chave do registro foi excluída.
  7. Clique em Fechar para fechar a caixa de diálogo Utilitário de solução de problemas do Microsoft Word.
  8. No menu Arquivo, clique em Sair para fechar o Word.
  9. Inicie o Word da maneira que faz geralmente. Não use o procedimento na seção "Iniciar o Microsoft Word com a chave /a" deste artigo.
  10. Execute um dos seguintes procedimentos:
    • Se não conseguir mais reproduzir o problema, você determinou que o problema é causado por um suplemento COM. Para determinar qual suplemento COM está causando o problema, execute essas etapas:
      1. Feche todos os programas do Office.
      2. Inicie o Word usando a chave /a. Para iniciar o Word com a chave /a, por favor, consulte a seção "Iniciar o Microsoft Word com a chave /a" deste artigo.
      3. Abra o modelo Support.dot. Para fazer isso, por favor, consulte a seção"Como Abrir o Modelo Support.dot" deste artigo.
      4. No modelo Support.dot, clique no botão Utilitário de Solução de Problemas.
      5. Na caixa de diálogo Utilitário de Solução de Problemas do Microsoft Word, na lista Selecionar um item, clique em Chave do registro de suplementos COM e clique em Restaurar.
      6. Clique em OK ao ver a seguinte mensagem:
        HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins

        A restauração da chave do registro obteve êxito.
      7. Clique em Fechar para fechar a caixa de diálogo Utilitário de solução de problemas do Microsoft Word.
      8. No menu Arquivo, clique em Sair para fechar o Word.
      9. Inicie o Word da maneira que faz geralmente. Não use o procedimento na seção "Iniciar o Microsoft Word com a chave /a" deste artigo.
      10. No menu Ferramentas, clique em Personalizar.
      11. Clique na guia Comandos. Na lista Categorias, clique em Ferramentas.
      12. Na lista Comandos, clique em Suplementos de COM e arraste o comando para uma das barras de ferramentas.
      13. Clique em Fechar para fechar a caixa de diálogo Personalizar.
      14. Clique no botão Suplementos COM que você acabou de adicionar nas etapas de k a m.
      15. Na caixa de diálogo Suplementos COM, se um suplemento estiver listado, desmarque a caixa de seleção desse suplemento.

        OBSERVAÇÃO: Se mais de um suplemento estiver listado, desmarque uma caixa de seleção do suplemento por vez para determinar qual suplemento está causando o problema.
      16. Clique em OK para fechar a caixa de diálogo Suplementos COM.
      17. Clique em Sair no menu Arquivo para fechar o Word.
      18. Inicie o Word da maneira que faz geralmente. Não use o procedimento na seção "Iniciar o Microsoft Word com a chave /a" deste artigo.
      19. Execute um dos seguintes procedimentos:
        • Se não conseguir mais reproduzir o problema, você descobriu que o problema é causado por um suplemento COM. Se precisar dos recursos fornecidos por um item do suplemento, será necessário determinar qual suplemento do Word inclui o item específico e entrar em contato com o fornecedor para obter uma atualização.

          -ou-
        • Se o problema não foi resolvido, clique no botão Suplementos COM que você adicionou nas etapas de k a m. Marque a caixa de seleção do suplemento que você desmarcou na etapa o. Em seguida, desmarque a caixa de seleção de um suplemento diferente, e repita as etapas de p a s. Repita esse procedimento quantas vezes forem necessárias, para cada suplemento, até determinar qual deles está causando o problema.
      -ou-

    • Se o problema não foi resolvido, restaure a chave do registro de suplementos COM e então vá para a próxima etapa. Para fazer isto, execute as seguintes etapas:
      1. Feche todos os programas do Office.
      2. Inicie o Word usando a chave /a. Para iniciar o Word com a chave /a, por favor, consulte a seção "Iniciar o Microsoft Word com a chave /a" deste artigo.
      3. Abra o modelo Support.dot. Para fazer isso, por favor, consulte a seção"Como Abrir o Modelo Support.dot" deste artigo.
      4. No modelo Support.dot, clique no botão Utilitário de Solução de Problemas.
      5. Na caixa de diálogo Utilitário de Solução de Problemas do Microsoft Word, na lista Selecionar um item, clique em Chave do registro de suplementos COM e clique em Restaurar.
      6. Clique em OK ao ver a seguinte mensagem:
        HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins

        A restauração da chave do registro obteve êxito.
      7. Clique em Fechar para fechar a caixa de diálogo Utilitário de solução de problemas do Microsoft Word.
      8. No menu Arquivo, clique em Sair para fechar o Word.
      9. Vá até a seçãoEtapa 5: Excluir a Chave de Registro de Opções deste artigo.
voltar ao início de Uso do Utilitário de Solução de Problemas

Etapa 5: Excluir a Chave do Registro de Opções

A chave do registro Opções armazena as opções que você pode definir a partir do Word, alterando as opções do menu ou executando a macro RegOptions. Essas são as opções editáveis.

As configurações dividem-se em dois grupos: configurações padrão e opcionais. As configurações padrão são estabelecidas durante a Instalação, e é possível alterá-las modificando as opções no Word. As configurações opcionais não são criadas durante a Instalação; para adicioná-las, você deve executar a macro RegOptions (abordada anteriormente neste artigo).

Para excluir a chave Dados, execute essas etapas:
  1. Feche todos os programas do Office.
  2. Inicie o Word usando a chave /a. Para iniciar o Word com a chave /a, por favor, consulte a seção "Iniciar o Microsoft Word com a chave /a" deste artigo.
  3. Abra o modelo Support.dot. Para fazer isso, por favor, consulte a seção "Como Abrir o Modelo Support.dot" deste artigo.
  4. No modelo Support.dot, clique no botão Utilitário de Solução de Problemas.
  5. Na caixa de diálogo Utilitário de Solução de Problemas do Microsoft Word, na lista Selecionar um item, clique em Chave do registro de opções, e então clique em Excluir.
  6. Clique em OK ao ver a seguinte mensagem:
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Options
    O arquivo de backup para essa chave do registro está em:
    C:\WINDOWS\TEMP\wdoptn10.0

    A chave do registro foi excluída.
  7. Inicie o Word da maneira que faz geralmente. Não use a opção /a para iniciar o Word conforme descrito na seção "Iniciar o Microsoft Word com a chave /a" deste artigo.
Se o Word iniciar e funcionar corretamente, o problema foi resolvido. O problema era uma chave Opções danificada. Talvez seja preciso alterar algumas configurações para restaurar suas opções favoritas no Word.

Se o problema não foi resolvido, feche o Word e então adicione a informação da chave Opções de volta ao registro do Windows. Para fazer isto, execute as seguintes etapas:
  1. Feche todos os programas do Office.
  2. Inicie o Word usando a chave /a. Para iniciar o Word com a chave /a, por favor, consulte a seção "Iniciar o Microsoft Word com a chave /a" deste artigo.
  3. Abra o modelo Support.dot. Para fazer isso, por favor, consulte a seção "Como Abrir o Modelo Support.dot" deste artigo.
  4. No modelo Support.dot, clique no botão Utilitário de Solução de Problemas, que está localizado na tabela contida no arquivo.
  5. Na caixa de diálogo Utilitário de Solução de Problemas do Microsoft Word, na lista Selecionar um item, clique em Chave do registro de opções, e então clique em Restaurar.
  6. Clique em Sim ao ver a seguinte mensagem:
    HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Options

    A chave está presente no registro.
    Deseja substituí-la?
  7. Clique em OK ao ver a seguinte mensagem:
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Options

    A restauração da chave do registro obteve êxito.
  8. Clique em Fechar para fechar a caixa de diálogo Utilitário de solução de problemas do Microsoft Word.
  9. No menu Arquivo, clique em Sair para fechar o Word.
voltar ao início de Uso do Utilitário de Solução de Problemas



Como Usar a Macro de Opções do Registro

É possível usar a macro RegOptions para examinar e fazer alterações nas configurações do Word no registro do Windows. A seguir temos uma lista das opções disponíveis na macro e uma breve descrição da finalidade de cada opção:
Word Options

AutoSave-Path: Define a pasta onde os arquivos de AutoRecuperação são salvos.

DOC-Path: Pasta padrão utilizada para os documentos do Word.

Picture-Path: Define o caminho padrão utilizado ao apontar para a Figura no menu Inserir e em seguida clique em Do arquivo .

Startup-Path : Define o caminho para os arquivos de inicialização do Word, como os modelos e arquivos .wll (WLLs) que são carregados quando você inicia o Word.

Tools-Path : Define um local no qual o Word procura ferramentas de verificação, filtros, conversores e outros componentes, no caso de eles não estarem registrados corretamente ou não poderem ser encontrados.

User-Dot-Path : O caminho para modelos do usuário. Observe que quando esta configuração for alterada para o Word, a mudança afeta todos os programas do Microsoft Office.

Workgroup-Dot-Path : O caminho para modelos do grupo de trabalho. É possível especificar um caminho UNC.

BAK-Extension: Extensão de arquivo padrão utilizada para os arquivos de backup do Word. A extensão padrão é *.wbk.

DOC-Extension : A extensão de pasta padrão utilizada para os documentos do Word. O padrão é *.doc.

DOT-Extension: A extensão de arquivo padrão utilizada para os modelos do Word. O padrão é *.dot.

NoFontMRUList : Ativa ou desativa a lista de fontes mais utilizada recentemente (MRU). Para ativar a lista de fontes MRU, digite 0 (zero). Para desativar a lista de fontes MRU, digite 1.

SpellingWavyUnderlineColor : Permite que você controle a cor do sublinhado ondulado que é exibido sob as palavras com erros ortográficos.

GrammarWavyUnderlineColor: Permite que você controle a cor do sublinhado ondulado que é exibido sob as palavras com erros gramaticais.

SmartTagUnderlineColor : Permite que você controle a cor do sublinhado pontilhado que é exibido sob marcas inteligentes.

FormatConsistencyWavyUnderlineColor : Permite que você controle a cor do sublinhado ondulado que é exibido sob os erros de formatação.

OLEDOT: Especifica o modelo de documento utilizado quando você cria um objeto de documento no Word ou em outro aplicativo OLE.
Opções do Editor de Equação

Appdir: A pasta do programa Equation Editor. O Equation Editor deve ser instalado e executado uma vez, para que as configurações dele e de outros Equation Editor sejam exibidas.

CustomZoom: A configuração de Zoom Personalizado. Essa configuração apenas tem efeito quando você inicia o Equation Editor em uma janela separada por meio da configuração ForceOpen.

ForceOpen: Força o Equation Editor a abrir em sua própria janela separada. Digite 0 (zero) para abrir no lugar, ou digite 1 para abrir em uma janela separada.

ShowAll: Exibe ou oculta caracteres não-imprimíveis.

ToolBarDocked: Define se a barra de ferramentas está encaixada. Escolha Sim (1) ou Não (0).

ToolBarDockPos: Posição da barra de ferramentas do Equation Editor quando ela estiver encaixada. 1 define a barra de ferramentas na parte superior da janela do Equation Editor. 2 define a barra de ferramentas na parte inferior da janela do Equation Editor.

ToolBarShown: Define se a barra de ferramentas é exibida. Escolha Sim (1) ou Não (0).

ToolBarWinPos: Posição da barra de ferramentas quando ela não estiver encaixada, especificado em coordenadas X, Y, com o canto superior esquerdo como a origem. As unidades estão em píxels.

Zoom: O tamanho de zoom padrão selecionado no menu Exibir.
Para utilizar a macro RegOptions, execute essas etapas:
  1. No menu Arquivo, clique em Abrir.
  2. Altere a caixa Arquivos do tipo para Modelo de documento (*.dot).
  3. Altere a caixa Examinar para a seguinte seguinte pasta:
    C:\Arquivos de programas\Microsoft Office\Office10\Macros\
  4. Selecione Support.dot, e então clique em Abrir.
  5. Na coluna Macro da tabela apresentada no arquivo, clique no botão Opções do Registro.
  6. Na guia Opções do Word ou Opções do Equation Editor, selecione a opção que deseja alterar, digite uma nova configuração na caixa Configuração (ou clique em Procurar, se disponível, e então selecione a configuração que você deseja), e então clique em Alterar.
  7. Clique em Fechar para fechar a caixa de diálogo Definir opções do Registro.


Como Usar o Utilitário de Backup de Correção Automática

É possível usar o utilitário de Backup de Correção Automática para mover entradas de Correção Automática entre computadores. Para obter informações adicionais sobre o utilitário de Backup de Correção Automática, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
269006 ?Como Mover entradas de correção automática do Word entre computadores no Word 2002


Somente Usuários Avançados

A informação nesta seção não é necessária ao usar as macros no modelo Support.dot. Esta informação é fornecida somente se desejar que essas macros estejam disponíveis globalmente no Microsoft Word, ou se desejar visualizar o código da macro.



Como Fazer com que as Macros estejam Disponíveis Globalmente

Para fazer com que as macros estejam disponíveis globalmente no Microsoft Word, use um dos seguintes métodos.

Método 1: Adicionar aos Modelos Globais e Suplementos

Se planeja usar as macros ocasionalmente (ou se deseja ver o que as macros fazem antes de decidir disponibilizá-las), adicione os modelos de macro como modelos globais.

Para adicionar um dos modelos listados na seção "Sumário" deste artigo como um modelo global, execute essas etapas:
  1. No menu Ferramentas, clique em Modelos e suplementos.
  2. Em Modelos globais e suplementos, clique em Adicionar.
  3. Altere a caixa Examinar para a pasta que contém o modelo da macro. Na caixa Arquivos do tipo, selecione Todos os arquivos (*.*).
  4. Selecione o modelo da macro e depois clique em OK.
  5. Quando o modelo da macro aparecer na caixa de diálogo Modelos e suplementos, certifique-se de marcar a caixa de seleção para o modelo, e então clique em OK.

    IMPORTANTE: Ao carregar um modelo em Modelos globais e suplementos, o modelo permanece carregado apenas para a sessão atual do Word. Ao fechar e então reiniciar o Word, o modelo não será carregado automaticamente. Você deve selecionar novamente o modelo que deseja usar. Para fazer isso, clique em Modelos e suplementos no menu Ferramentas. Na caixa de diálogo Modelos e suplementos, selecione o modelo de onde deseja usar as macros, e então clique em OK.
  6. Para executar uma macro específica, execute essas etapas:
    1. No menu Ferramentas, aponte para Macro e clique em Macros.
    2. Na caixa de diálogo Macros, altere a caixa Macros em para o modelo que contém a macro que deseja. Por exemplo, selecione Support.dot (modelo global).
    3. Na lista Nome da macro, selecione a macro que deseja, e então clique em Executar.

Método 2: Adicionar o Modelo à Pasta de Inicialização

Mova o modelo para a pasta de Inicialização. O Microsoft Word tem acesso automático a quaisquer macros em modelos localizados na seguinte pasta:
C:\Program Files\Microsoft Office\Office10\Startup
Use o Microsoft Windows Explorer para localizar uma cópia do modelo da macro de amostra na pasta Inicializar.

Ao iniciar o Word, um modelo localizado na pasta de Inicialização como um modelo global e as macros no modelo estão disponíveis na caixa de diálogo Macros. Uma desvantagem para esse método é o fato de o Word demorar um pouco mais para iniciar (cada vez que o Word inicia, ele carrega esses modelos globalmente).

Para executar uma macro específica, execute essas etapas:
  1. No menu Ferramentas, aponte para Macro e clique em Macros.
  2. Na caixa de diálogo Macros, altere a caixa Macros em para o modelo que contém a macro que deseja. Por exemplo, selecione Support.dot (modelo global).
  3. Na lista Nome da macro, selecione a macro que deseja, e então clique em Executar.

Método 3: Copiar a Macro para o Modelo Normal

Para executar uma macro específica sem precisar abrir seu modelo, copie a macro para seu modelo global (Normal.dot). Para fazer isto, execute as seguintes etapas:
  1. Abra o modelo da macro.
  2. No menu Ferramentas, clique em Modelos e suplementos.
  3. Na caixa de diálogo Modelos e Suplementos, clique em Organizador.
  4. Na caixa de diálogo Organizador, selecione a guia Macros.
  5. As macros no modelo estão listadas em um lado da caixa de diálogo. Seu modelo global (Normal.dot) aparece aberto no lado oposto.

    OBSERVAÇÃO: Se o seu Normal.dot (modelo global) não estiver aberto, clique em Fechar arquivo no lado oposto. O botão Fechar arquivo muda para um botão Abrir arquivo. Clique em Abrir arquivo. Selecione seu arquivo de modelo Normal.dot, e então clique em Abrir.
  6. No lado do modelo da macro, selecione as macros listadas no modelo, e então clique em Copiar.

    OBSERVAÇÃO: Para selecionar todos os itens listado, mantenha a tecla CTRL pressionada enquanto clica em cada macro.
  7. Clique em Copiar para copiar as macros para o seu modelo Normal.dot.
  8. Clique em OK para fechar a caixa de diálogo Organizador.
  9. Para executar uma macro específica, execute essas etapas:
    1. No menu Ferramentas, aponte para Macro e clique em Macros.
    2. Na caixa de diálogo Macros, altere a caixa Macros em para o modelo que contém a macro que deseja. Por exemplo, selecione Normal.dot (modelo global).
    3. Na lista Nome da macro, selecione a macro que deseja, e então clique em Executar.


Como visualizar o código da macro

A Microsoft fornece exemplos de programação apenas por questões ilustrativas, sem garantias expressas ou implícitas. Isso inclui, mas não está limitado a, garantias implícitas de comercialização ou adequação a um determinado propósito. Este artigo pressupõe que você conhece a linguagem de programação demonstrada e também as ferramentas usadas para criar e depurar procedimentos. Os engenheiros de suporte da Microsoft podem ajudá-lo, fornecendo a explicação da funcionalidade de um determinado procedimento, mas não modificarão estes exemplos para fornecer funcionalidades adicionais ou construir procedimentos específicos para atender às suas necessidades específicas. Para visualizar o código da macro para uma macro de exemplo, execute essas etapas:
  1. No menu Arquivo, clique em Abrir.
  2. Na caixa de diálogo Abrir, altere a caixa Examinar para a pasta que contém o modelo da macro, altere a caixa Arquivos do tipo para Todos os arquivos (*.*), e então selecione o modelo da macro apropriado.
  3. Mantenha a tecla SHIFT pressionada e clique em Abrir.
  4. No menu Ferramentas, aponte para Macro e clique em Macros.
  5. Na caixa de diálogo Macros, altere a caixa Macros em para o modelo que da macro que acabou de abrir.
  6. Selecione a macro apropriada, e então clique em Editar.

Propriedades

ID do artigo: 289506 - Última revisão: sexta-feira, 19 de janeiro de 2007 - Revisão: 2.2
A informação contida neste artigo aplica-se a:
  • Microsoft Word 2002 Standard Edition
Palavras-chave: 
kbdta kbhowtomaster KB289506

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com