Установка и использование шаблона Support.dot в Microsoft Word 2002

Переводы статьи Переводы статьи
Код статьи: 289506 - Vizualiza?i produsele pentru care se aplic? acest articol.
Развернуть все | Свернуть все

В этой статье

Аннотация

Эта статья предназначена для определения места Существует проблема, когда вы не смогли идентификации или изолировать проблему другими средствами Microsoft Word. Чтобы найти вопросы и статьи, посвященные конкретным проблемы наблюдаются, пожалуйста запросов в статьях базы знаний Майкрософт. Чтобы это сделать, см. веб-узел корпорации Майкрософт:
http://support.Microsoft.com/default.aspx
В данной статье описывается шаблон Support.dot включая автоматизированные методы, с помощью макросов, созданных корпорацией Майкрософт Службы технической поддержки. Шаблон Support.dot — это шаблон, который содержит специальный код (Макросы) для помощи в устранении неполадок и решения проблем в Microsoft Word. Для помощи в устранении неполадок доступны три типа макросов. различные проблемы.

Macro Name Description
Troubleshoot Utility TShoot This macro can be used to troubleshoot various problems with Word. You can use the macro to rename your data key and Normal.dot file and to turn off Word add-ins.

NOTE: You must start Word with the /a switch before you run this macro.
Registry Options RegOptions This macro can be used to modify Word settings that are stored in the Windows registry.
AutoCorrect Backup AutoCorrectBackup This macro backs up your AutoCorrect list to a file. You can take this file to another computer and run the macro again to restore your AutoCorrect list.




Установка шаблона Support.dot

Шаблон Support.dot устанавливается вместе с Завершить Программа установки. Она не устанавливается вместе с Типичный -или- Обновить сейчас Программа установки. Если шаблон Support.dot не установлена, выполните следующие действия:
  1. Завершите работу всех приложений Microsoft Office и Microsoft Word программы.
  2. Нажмите кнопку Начало, выберите пункт Параметры, а затем нажмите кнопку Панель управления.
  3. В Панель управления, дважды щелкните значок Установка и удаление программ.
  4. Выполните действия для используемой операционной системе.
    • В Microsoft Windows 98, Microsoft Windows Millennium Edition (Me) или Microsoft Windows NT 4.0, установите Microsoft Office XP (Microsoft Word 2002) на Установка и удаление программ вкладки, а затем нажмите кнопку Добавление и удаление.

      -ИЛИ-
    • В Microsoft Windows 2000 или Microsoft Windows XP, Выберите вариант Изменение или удаление программ. В Установленные программы Выберите Microsoft Office XP (Microsoft Word 2002), а затем нажмите кнопку Изменение.
  5. В Программа установки Microsoft Office XP (Программа установки Microsoft Word 2002), установите Добавить или удалить компоненты, и Нажмите кнопку Далее.
  6. В Компоненты для установки список, выполните следующие действия.ПРИМЕЧАНИЕ: Щелкните знак «плюс» (+) слева позволяет развернуть его.

    1. Разверните узел Microsoft Word для Windows.
    2. Разверните узел Мастеры и шаблоны.
    3. Щелкните значок Дополнительные шаблоны и макросыи затем выберите Выполнения все с моего Компьютер в контекстном меню.
  7. : Щелкните знак «плюс» (+) слева от функции Разверните узел.Нажмите кнопку Обновление для установки шаблона Support.dot.


Открытие шаблона Support.dot

Чтобы открыть шаблон Support.dot, выполните следующие действия.
  1. На Файл меню, нажмите кнопку Открыть.
  2. Изменение Тип файлов ЧтобыШаблоны документов (* .dot).
  3. Изменение Искать в поле ниже папки:
    C:\Program Files\Microsoft Office\Office10\Macros\
  4. Выберите Support.dot, а затем нажмите кнопку Открыть.
  5. В таблице, содержащейся в файле, в Макрос столбец, нажмите соответствующую кнопку для запуска макроса, которые хотите. Например нажмите кнопку Troubleshoot Utility,Registry Options, -или- AutoCorrect Backup.


Практическое использование программы устранения неполадок

Программы устранения неполадок является макросом, предоставляемые корпорации Майкрософт Техническая поддержка. Этот макрос может помочь автоматизировать процесс устранения неполадок Microsoft Word проблем посредством удаления некоторых ключевых компонентов, которые могут быть повреждены или, может привести к конфликту с Microsoft Word. Используйте эту программу для отключения (в порядке в списке) следующие компоненты, которые обычно загружаются во время Запуск Word:
  • В Данные Раздел реестра
  • Общий шаблон Normal.dot
  • Надстройки и шаблоны
  • Надстройки COM
  • В Параметры Раздел реестра
Если любой из этих элементов, поврежденными или несовместимыми, Word не сможет Чтобы запустить или не сможет правильно работать. Они временно обход элементы и другие элементы при запуске Word с /a коммутатор.

Запуск Microsoft Word с помощью параметра /a

Чтобы запустить Word с помощью /a Переключение, выполните следующие действия:
  1. Нажмите кнопку Начало и выберите команду Запустить.
  2. В Запустить диалоговое окно, выполните одно из следующих:
    • В Открыть поле типа Winword.exe /a.

      -ИЛИ-
    • Нажмите кнопку Обзор. Найдите и выберите Winword.exe файл. Чтобы сделать это, выполните следующие действия.
      1. В Искать в список, выберите папку, содержащую файлы программы Word. Выберите Winword.exe файл, а затем нажмите кнопку Открыть.

        Заполняет этот шаг Открыть в поле Запустить диалоговое окно.
      2. В Открыть поля, поместите точку вставки Winword.exe.

        ПРИМЕЧАНИЕ: Путь к файлу Winword.exe в Запустить диалоговое окно заключены в кавычки. Убедитесь в том, что перемещение курсор справа от закрывающей кавычки.
      3. Введите пробел, а затем /a.

        В инструкции Открыть поле должен выглядеть примерно следующим:
        /A «C:\Program files\microsoft Office\Office10\Winword.exe»
  3. В Запустить диалоговое окно, нажмите кнопку ОК.
Если Word запускается и работает правильно, при использовании /a коммутатор, неполадка связана с одним из компонентов, перечисленных в Начало раздела «Как для использования Программа устранения неполадок» данной статьи. Использование программы устранения неполадок для определения, какой компонент является причиной проблема. Использование программы устранения неполадок, может потребоваться установка Support.dot.

ПРИМЕЧАНИЕ: Если проблема возникает при запуске Word с /a коммутатор, использование программы устранения неполадок не требуется.

Пошаговые: Использование программы устранения неполадок

Чтобы обнаружить и удалить компонент, который вызывает проблему в Microsoft Word, удалить все следующие компоненты (один за один раз и в порядке) с помощью программы устранения неполадок: Step 1: Delete the Data Registry Key

Step 2: Rename the Normal.dot Global Template

Step 3: Disable the Word Startup Folder Add-Ins

Step 4: Delete the COM Add-Ins Registry Key

Step 5: Delete the Options Registry Key

Шаг 1: Удаление раздела реестра Data

Наиболее часто используемые параметры (нажмите Параметры В меню Сервис меню), хранятся в Данные ключ. Одним вариантом является использование для удаления Данные ключ. Восстанавливает это Данные — Программа ключа с использованием параметров по умолчанию в следующий раз запущена.

ПРИМЕЧАНИЕ: Удаление Данные ключ восстанавливает значения некоторых параметров к значениям по умолчанию включая наиболее часто используемых список файлов в Файл меню и различных параметров, которые можно настроить в Параметры диалоговое окно.

Для удаления Данные ключ, выполните следующие действия:
  1. Закройте все программы Office.
  2. Запуск Word с помощью /a коммутатор. Чтобы запустить Word с /a Переключение, пожалуйста, ознакомьтесь с "Starting Microsoft Word with the /a Switch"в разделе данной статьи.
  3. Откройте шаблон Support.dot. Чтобы это сделать, см."How to Open the Support.dot Template"в разделе данной статьи.
  4. В шаблон Support.dot, нажмите кнопку Программы устранения неполадок Нажатие кнопки.
  5. В Устранение неполадок Microsoft Word Служебная программа диалоговое окно, в Выберите элемент Выберите Данные реестра, а затем нажмите кнопку Удалить.
  6. Нажмите кнопку ОК Когда появится следующее сообщение:
    HKEY_CURRENT_USER\Software\Microsoft Office\10.0\Word\Data
    В файл резервной копии для данного раздела реестра:
    C:\WINDOWS\TEMP\wddata10.0

    Удален раздел реестра.
  7. Нажмите кнопку Закрыть.
  8. На Файл меню, нажмите кнопку Выход для выхода из программы Word.
  9. Запустите программу Word способом, обычно. Нет не Используйте процедуру, описанную в "запуск Microsoft Word с /a Переключение» данной статьи.
Если Word запускается и работает правильно, вы решить проблема. Проблема была повреждена Данные раздел реестра. Может потребоваться изменить некоторые настройки для восстановления Выбранные настройки в Microsoft Word.

Если проблема не устранена, Восстановление старой Данные раздел реестра. Чтобы сделать это, выполните следующие действия.
  1. Закройте все программы Office.
  2. Запуск Word с помощью /a коммутатор. Чтобы запустить Word с /a Переключение, пожалуйста, ознакомьтесь с "Starting Microsoft Word with the /a Switch"в разделе данной статьи.
  3. Откройте шаблон Support.dot. Чтобы это сделать, см."How to Open the Support.dot Template"в разделе данной статьи.
  4. В шаблон Support.dot, нажмите кнопку Программы устранения неполадок Нажатие кнопки.
  5. В Устранение неполадок Microsoft Word Служебная программа диалоговое окно, в Выберите элемент Выберите Данные реестра, а затем нажмите кнопку Восстановление.
  6. Нажмите кнопку Да Когда появится следующее сообщение:
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Data

    Этот ключ присутствует в реестре.
    Перезаписать его?
  7. Нажмите кнопку ОК Когда появится следующее сообщение:
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Data

    Реестр ключа успешно восстановлен.
  8. Выполните одно из следующих действий.
    • Перейдите к разделу Step 2: Rename the Normal.dot Global Templateв разделе данной статьи.

      -ИЛИ-
    • Нажмите кнопку Закрыть Чтобы закрыть Устранение неполадок Microsoft Word Служебная программа диалоговое окно поле, а затем закройте Word.
Back to Top of Using the Troubleshoot Utility

Шаг 2: Переименование глобального шаблона Normal.dot

Чтобы форматирование, автотекст и макросы, хранящиеся в общий шаблон (Normal.dot) влияли на поведение Word и открываемые документы, переименование глобального шаблона. Изменение имени этого файла позволяет можно определить, является ли причиной проблемы глобального шаблона.

ПРИМЕЧАНИЕ: Переименование сбрасывает файл Normal.dot, несколько вариантов к началу статьи значениями по умолчанию, в том числе пользовательских стилей, панелей инструментов, макросов, и Элементы автотекста. По этой причине корпорация Майкрософт настоятельно рекомендует не удалять файл Normal.dot.

Некоторые виды конфигураций можно Создание более одного файла Normal.dot. К таким ситуациям относятся случаи, в котором на одном компьютере или случаев, в котором работают несколько версий Word Существует несколько установок рабочих станций на одном компьютере. В этих ситуации, не забудьте переименовать правильную копию файла Normal.dot.

Для Переименуйте файл Normal.dot, выполните следующие действия:
  1. Закройте все программы Office.
  2. Запуск Word с помощью /a коммутатор. Чтобы запустить Word с /a Переключение, пожалуйста, ознакомьтесь с "Starting Microsoft Word with the /a Switch"в разделе данной статьи.
  3. Откройте шаблон Support.dot. Чтобы это сделать, см."How to Open the Support.dot Template"в разделе данной статьи.
  4. В шаблон Support.dot, нажмите кнопку Программы устранения неполадок Нажатие кнопки.
  5. В Устранение неполадок Microsoft Word Служебная программа диалоговое окно, в Выберите элемент Выберите Глобальный шаблон Normal.dot, а затем нажмите кнопку Переименование.
  6. Нажмите кнопку ОК Когда появится следующее сообщение:
    Путь\Application Data\Microsoft\Templates\Normal.dot
    Скопировать
    Путь\Application Data\Microsoft\Templates\10Normal.dot
    ПРИМЕЧАНИЕ: Путь для файла Normal.dot могут отличаться.
  7. Нажмите кнопку Закрыть Чтобы закрыть Устранение неполадок Microsoft Word Служебная программа диалоговое окно.
  8. На Файл меню, нажмите кнопку Выход для выхода из программы Word.
  9. Запустите программу Word способом, обычно. Нет не Используйте процедуру, описанную в "запуск Microsoft Word с /a Переключение» данной статьи.
Корректный запуск Microsoft Word, решить проблему. В этом так, проблема имеет поврежденный файл Normal.dot. Может потребоваться восстановить некоторые параметры, выбранные настройки. Если файл Normal.dot, Переименование содержит пользовательские настройки, например стили, макросы или записи автотекста которые не могут быть легко восстановлены, можно скопировать эти настройки из файла 10Normal.dot (старый Normal.dot) в новый файл Normal.dot с помощью организатора.

Для получения дополнительных сведения об использовании организатора, нажмите кнопку Справка по Microsoft Word В меню Справка Тип меню Организатор в офисе Помощника или мастера ответов и нажмите кнопку Поиск Чтобы просмотреть найденные разделы.

Если проблема не решена, восстановления старого файла Normal.dot (10Normal.dot). Для этого Это, выполните следующие действия:
  1. Закройте все программы Office.
  2. Запуск Word с помощью /a коммутатор. Чтобы запустить Word с /a Переключение, пожалуйста, ознакомьтесь с "Starting Microsoft Word with the /a Switch"в разделе данной статьи.
  3. Откройте шаблон Support.dot. Чтобы это сделать, см."How to Open the Support.dot Template"в разделе данной статьи.
  4. В шаблон Support.dot, нажмите кнопку Программы устранения неполадок Нажатие кнопки.
  5. В Устранение неполадок Microsoft Word Служебная программа диалоговое окно, в Выберите элемент Выберите Глобальный шаблон Normal.dot, а затем нажмите кнопку Восстановление.
  6. Нажмите кнопку Да Когда появится следующее сообщение:
    Путь\Application Data\Microsoft\Templates\Normal.dot

    Резервная копия данного файла уже существует.

    Перезаписать его?
    ПРИМЕЧАНИЕ: Путь для файла Normal.dot могут отличаться.
  7. Нажмите кнопку ОК Когда появится следующее сообщение:
    Путь\Application Data\Microsoft\Templates\10Normal.dot
    Скопировать
    Путь\Templates\Normal.dot
  8. Выполните одно из следующих действий.
    • Перейдите к разделу Step 3: Disable the Word Startup Folder Add-Insв разделе данной статьи.

      -ИЛИ-
    • Нажмите кнопку Закрыть Чтобы закрыть Устранение неполадок Microsoft Word Служебная программа диалоговое окно поле, а затем закройте Word.
Back to Top of Using the Troubleshoot Utility

Шаг 3: Отключение надстроек папку автозагрузки Word

При запуске Word автоматически загружает шаблоны и надстройки, расположенные в папках автозапуска. Возможно, ошибки в Word Результатом конфликтов или проблем с надстройкой. Чтобы определить, является ли элемент в папка автозагрузки вызывает проблему, можно временно отключить параметр реестра, указывающий на этих надстроек.

Чтобы временно отключить раздел реестра надстройки, выполните следующие действия:
  1. Закройте все программы Office.
  2. Запуск Word с помощью /a коммутатор. Чтобы запустить Word с /a Переключение, пожалуйста, ознакомьтесь с "Starting Microsoft Word with the /a Switch"в разделе данной статьи.
  3. Откройте шаблон Support.dot. Чтобы это сделать, см."How to Open the Support.dot Template"в разделе данной статьи.
  4. В шаблон Support.dot, нажмите кнопку Программы устранения неполадок Нажатие кнопки.
  5. В Устранение неполадок Microsoft Word Служебная программа диалоговое окно, в Выберите элемент Выберите В приложении Word запуска надстроек, а затем нажмите кнопку Переименование.
  6. Выполните одно из следующих действий.
    • Нажмите кнопку ОК Когда появится следующее сообщение:
      Не найдены файлы для переименования и обновления.
      ПРИМЕЧАНИЕ: Если это сообщение, у вас нет надстройки, которые загружаются При запуске Word. После нажатия кнопки ОК, перейдите к разделу Step 4: Delete the COM Add-Ins Registry Keyв разделе данной статьи.

      -ИЛИ-
    • Нажмите кнопку ОК Когда появится следующее сообщение:
      Путь\Application Data\Microsoft\Word\Startup\Имя файла
      Скопировать
      Путь\Application Data\Microsoft\Word\Startup\Имя файла

      Путь\Program Files\Microsoft Office\Office10\Startup\Имя файла
      Скопировать
      Путь\Program Files\Microsoft Office\Office10\Startup\Имя файла
      ПРИМЕЧАНИЕ: Может быть пути и имена файлов в системе другой.
  7. Нажмите кнопку Закрыть Чтобы закрыть Устранение неполадок Microsoft Word Служебная программа диалоговое окно.
  8. На Файл меню, нажмите кнопку Выход для выхода из программы Word.
  9. Запустите программу Word способом, обычно. Нет не Используйте процедуру, описанную в "запуск Microsoft Word с /a Переключение» данной статьи.
  10. Выполните одно из следующих действий.
    • Если не перестанет отображаться проблемы и запуска элементы были удалены на шаге 6, известно, что причиной проблемы является элемент надстройки. Чтобы определить, какие из элементов автозагрузки вызывает проблему, выполните следующие действия:
      1. Закройте все программы Office.
      2. Запуск Word с помощью /a коммутатор. Чтобы запустить Word с /a Переключение, пожалуйста, ознакомьтесь с "Starting Microsoft Word with the /a Switch"в разделе данной статьи.
      3. Откройте шаблон Support.dot. Чтобы сделать это, пожалуйста см. "How to Open the Support.dot Template"в разделе данной статьи.
      4. В шаблон Support.dot, нажмите кнопку Программы устранения неполадок Нажатие кнопки.
      5. В Устранение неполадок Microsoft Word Служебная программа диалоговое окно, в Выберите элемент Выберите Папка автозагрузки Word, а затем нажмите кнопку Восстановление.
      6. Нажмите кнопку ОК Когда появится следующее сообщение:
        Путь\Application Data\Microsoft\Word\Startup\Имя файла
        Скопировать
        Путь\Application Data\Microsoft\Word\Startup\Имя файла

        Путь\Program Files\Microsoft Office\Office10\Startup\Имя файла
        Скопировать
        Путь\Program Files\Microsoft Office\Office10\Startup\Имя файла
        ПРИМЕЧАНИЕ: Может быть пути и имена файлов в системе другой.
      7. Нажмите кнопку Закрыть Чтобы закрыть Устранение неполадок Microsoft Word Служебная программа диалоговое окно.
      8. На Файл меню, нажмите кнопку Выход для выхода из программы Word.
      9. Дважды щелкните значок Мой компьютер, а затем откройте одну из папок, указанных в пункте f. Например:
        Путь\Application Data\Microsoft\Word\Startup\

        -ИЛИ-

        Путь\Program Files\Microsoft Office\Office10\Startup\
      10. Щелкните правой кнопкой мыши один из файлов, содержащихся в папка, а затем нажмите кнопку Переименование в контекстном меню.
      11. Введите новое имя для файла и нажмите клавишу ВВОД.

        ВАЖНЫЕ: Запишите исходное имя файла, поскольку необходимо Чтобы переименовать файл исходного имени.
      12. Запустите программу Word способом, обычно. Нет не Используйте процедуру, описанную в "запуск Microsoft Word с /a Переключение» данной статьи.
      Если больше не может воспроизвести проблему, найти надстройки элемент, вызывающий неполадки. Если необходимо возможности, предоставляемые элемента, необходимо определить, какие слова надстройка включает в определенной номенклатуры и контакт поставщикам за обновлением.

      Если проблема не устранена, переименуйте назад надстройки для его исходное имя, а затем повторите шаги h до i для каждого файла в папках который указан в сообщениях, показанный в пункте f.

      -ИЛИ-

    • Если больше не может воспроизвести проблему, найти надстройки элемент, вызывающий неполадки. Если необходимо возможности, предоставляемые элемента, необходимо определить, какие слова надстройка включает в определенной номенклатуры и контакт поставщикам за обновлением. Если проблема не решена, восстановление элементов расширения и перейдите к Следующий шаг. Чтобы сделать это, выполните следующие действия.
      1. Закройте все программы Office.
      2. Запуск Word с помощью /a коммутатор. Чтобы запустить Word с /a Переключение, пожалуйста, ознакомьтесь с "Starting Microsoft Word with the /a Switch"в разделе данной статьи.
      3. Откройте шаблон Support.dot. Чтобы сделать это, пожалуйста см. "How to Open the Support.dot Template"в разделе данной статьи.
      4. В шаблон Support.dot, нажмите кнопку Программы устранения неполадок Нажатие кнопки.
      5. В Устранение неполадок Microsoft Word Служебная программа диалоговое окно, в Выберите элемент Выберите Папка автозагрузки Word, а затем нажмите кнопку Восстановление.
      6. Нажмите кнопку ОК Когда появится следующее сообщение:
        Путь\Application Data\Microsoft\Word\Startup\Имя файла
        Скопировать
        Путь\Application Data\Microsoft\Word\Startup\Имя файла

        Путь\Program Files\Microsoft Office\Office10\Startup\Имя файла
        Скопировать
        Путь\Program Files\Microsoft Office\Office10\Startup\Имя файла
        ПРИМЕЧАНИЕ: Может быть пути и имена файлов в системе другой.
      7. Перейдите к разделу Step 4: Delete the COM Add-Ins Registry Keyв разделе данной статьи.
Back to Top of Using the Troubleshoot Utility

Шаг 4: Удаление раздела реестра для надстроек COM

Надстройки COM могут быть установлены в любом месте и устанавливаются по программы, взаимодействующие с Word. Чтобы удалить параметры реестра Windows все надстройки COM, которые установлены, выполните следующие действия.
  1. Закройте все программы Office.
  2. Запуск Word с помощью /a коммутатор. Чтобы запустить Word с /a Переключение, пожалуйста, ознакомьтесь с "Starting Microsoft Word with the /a Switch"в разделе данной статьи.
  3. Откройте шаблон Support.dot. Чтобы это сделать, см."How to Open the Support.dot Template"в разделе данной статьи.
  4. В шаблон Support.dot, нажмите кнопку Программы устранения неполадок Нажатие кнопки.
  5. В Устранение неполадок Microsoft Word Служебная программа диалоговое окно, в Выберите элемент Выберите Раздел реестра надстройки COM, а затем нажмите кнопку Удалить.
  6. Нажмите кнопку ОК Когда появится следующее сообщение:
    HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins
    В файл резервной копии для данного раздела реестра:
    C:\Windows\TEMP\wdaddn10.0

    Удален раздел реестра.
  7. Нажмите кнопку Закрыть Чтобы закрыть Устранение неполадок Microsoft Word Служебная программа диалоговое окно.
  8. На Файл меню, нажмите кнопку Выход для выхода из программы Word.
  9. Запустите программу Word так же, как обычно. Нет не Используйте процедуру, описанную в "запуск Microsoft Word с /a Переключение» данной статьи.
  10. Выполните одно из следующих действий.
    • Если больше не может воспроизвести проблему, определить, что надстройка COM вызывает проблему. Чтобы определить, какой COM надстройка вызывает проблему, выполните следующие действия:
      1. Закройте все программы Office.
      2. Запуск Word с помощью /a коммутатор. Чтобы запустить Word с /a Переключение, пожалуйста, ознакомьтесь с "Starting Microsoft Word with the /a Switch"в разделе данной статьи.
      3. Откройте шаблон Support.dot. Чтобы сделать это, пожалуйста см. "How to Open the Support.dot Template"в разделе данной статьи.
      4. В шаблон Support.dot, нажмите кнопку Программы устранения неполадок Нажатие кнопки.
      5. В Устранение неполадок Microsoft Word Служебная программа диалоговое окно, в Выберите элемент Выберите Раздел реестра надстройки COM, а затем нажмите кнопку Восстановление.
      6. Нажмите кнопку ОК Когда появится следующее сообщение:
        HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins

        Реестр ключа успешно восстановлен.
      7. Нажмите кнопку Закрыть Чтобы закрыть Устранение неполадок Microsoft Word Служебная программа диалоговое окно.
      8. На Файл меню, нажмите кнопку Выход для выхода из программы Word.
      9. Запустите программу Word способом, обычно. Нет не Используйте процедуру, описанную в "запуск Microsoft Word с /a Переключение» данной статьи.
      10. На Сервис меню, нажмите кнопку Настройка.
      11. Нажмите кнопку Команды Вкладка. В Категории Выберите Сервис.
      12. В Команды Выберите Надстройки COM, а затем перетащите команды на одну из панелей инструментов.
      13. Нажмите кнопку Закрыть Чтобы закрыть Настройка диалоговое окно.
      14. Нажмите кнопку Надстройки COM кнопки Вы только что добавили в действия k-m.
      15. В Надстройки COM диалоговое окно, если в списке, снимите флажок «надстройки».

        ПРИМЕЧАНИЕ: Если в списке более одного расширения щелкните, чтобы снять только один добавить флажок одновременно, чтобы определить, какая надстройка вызывает проблема.
      16. Нажмите кнопку ОК Чтобы закрыть Надстройки COM диалоговое окно.
      17. Нажмите кнопку Выход В меню Файл меню для выхода из программы Word.
      18. Запустите программу Word способом, обычно. Нет не Используйте процедуру, описанную в "запуск Microsoft Word с /a Переключение» данной статьи.
      19. Выполните одно из следующих действий.
        • Если больше не может воспроизвести проблему, вы найдено надстройки COM, которая вызывает проблему. Если требуются возможности предоставляемый элементом надстройки необходимо определить, какие слова надстройка включает определенной номенклатуры и контакт поставщикам за обновлением.

          -ИЛИ-
        • Если проблема не устранена, нажмите кнопку Надстройки COM Кнопка, которая была добавлена в k действия через m. Установите добавить флажок, снятых при выполнении шага o. Снимите флажок различные расширения и повторите шаги p через s. повторить эту процедуру, как столько раз, сколько необходимо для каждой надстройки, пока определить, какие расширения Причиной проблемы.
      -ИЛИ-

    • - или -если проблема не устранена, восстановить ваши COM реестра надстройки ключа, а затем переходите к следующему шагу. Чтобы сделать это, выполните следующие действия:
      1. Закройте все программы Office.
      2. Запуск Word с помощью /a коммутатор. Чтобы запустить Word с /a Переключение, пожалуйста, ознакомьтесь с "Starting Microsoft Word with the /a Switch"в разделе данной статьи.
      3. Откройте шаблон Support.dot. Чтобы сделать это, пожалуйста см. "How to Open the Support.dot Template"в разделе данной статьи.
      4. В шаблон Support.dot, нажмите кнопку Программы устранения неполадок Нажатие кнопки.
      5. В Устранение неполадок Microsoft Word Служебная программа диалоговое окно, в Выберите элемент Выберите Раздел реестра надстройки COM, а затем нажмите кнопку Восстановление.
      6. Нажмите кнопку ОК Когда появится следующее сообщение:
        HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins

        Реестр ключа успешно восстановлен.
      7. Нажмите кнопку Закрыть Чтобы закрыть Устранение неполадок Microsoft Word Служебная программа диалоговое окно.
      8. На Файл меню, нажмите кнопку Выход для выхода из программы Word.
      9. Перейдите к разделу Step 5: Delete the Options Registry Keyв разделе данной статьи.
Back to Top of Using the Troubleshoot Utility

Шаг 5: Удалить параметры раздела реестра

В Параметры раздел реестра хранятся те параметры, которые можно задать в Word, либо путем изменения параметров меню или макроса RegOptions. Эти Изменяемые параметры.

Параметры делятся на две группы: по умолчанию Необязательные параметры и настройки. По умолчанию устанавливаются в процессе установки и их можно изменить путем изменения параметров в программе Word. Необязательные параметры не создан во время установки; для их добавления необходимо запустить макрос RegOptions (обсуждается Далее в этой статье).

Для удаления Параметры ключ, выполните следующие действия:
  1. Закройте все программы Office.
  2. Запуск Word с помощью /a коммутатор. Чтобы запустить Word с /aПереключение, пожалуйста, ознакомьтесь с "Starting Microsoft Word with the /a Switch"в разделе данной статьи.
  3. Откройте шаблон Support.dot. Чтобы это сделать, см."How to Open the Support.dot Template"в разделе данной статьи.
  4. В шаблон Support.dot, нажмите кнопку Программы устранения неполадок Нажатие кнопки.
  5. В Устранение неполадок Microsoft Word Служебная программа диалоговое окно, в Выберите элемент Выберите Параметры реестра, а затем нажмите кнопку Удалить.
  6. Нажмите кнопку ОК Когда появится следующее сообщение:
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Options
    В файл резервной копии для данного раздела реестра:
    C:\WINDOWS\TEMP\wdoptn10.0

    Удален раздел реестра.
  7. Запустите программу Word способом, обычно. Не используйте /a коммутатор для запуска Word, как описано в разделе "Starting Microsoft Word with the /a Switch"в разделе данной статьи.
Если Word запускается правильно и работает правильно, у вас есть проблема решена. Проблема была повреждена Параметры ключ. Может потребоваться изменить некоторые настройки, чтобы восстановить ваши предпочтительные параметры в Microsoft Word.

Если проблема не устранена, закройте Word а затем добавить Параметры данные ключа в реестре Windows. Чтобы сделать это, выполните следующие действия:
  1. Закройте все программы Office.
  2. Запуск Word с помощью /aкоммутатор. Чтобы запустить Word с /a Переключение, пожалуйста, ознакомьтесь с "Starting Microsoft Word with the /a Switch"в разделе данной статьи.
  3. Откройте шаблон Support.dot. Чтобы это сделать, см."How to Open the Support.dot Template"в разделе данной статьи.
  4. В шаблон Support.dot, нажмите кнопку Программы устранения неполадок Кнопка, которая расположена в таблице, содержащейся в файл.
  5. В Устранение неполадок Microsoft Word Служебная программа диалоговое окно, в Выберите элемент Выберите Параметры реестра, а затем нажмите кнопку Восстановление.
  6. Нажмите кнопку Да Когда появится следующее сообщение:
    HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Options

    Этот ключ присутствует в реестре.
    Перезаписать его?
  7. Нажмите кнопку ОК Когда появится следующее сообщение:
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Options

    Реестр ключа успешно восстановлен.
  8. Нажмите кнопку Закрыть Чтобы закрыть Устранение неполадок Microsoft Word Служебная программа диалоговое окно.
  9. На Файл меню, нажмите кнопку Выход для выхода из программы Word.
Back to Top of Using the Troubleshoot Utility



Как использовать макрос параметров реестра

Можно использовать для проверки и внесения изменений в макрос RegOptions Параметры Word в реестре Windows. Ниже приведен список параметров доступны в макрос и краткое описание каждого параметра Назначение:
Параметры Word

Путь автосохранения: Задает папку, в которой сохраняются файлы автосохранения.

Путь К ДОКУМЕНТУ: Папка по умолчанию, используемое для документов Word.

Рисунок путь: Задает путь по умолчанию, используемый при наведении указателя мыши Рисунок В меню Вставка меню и нажмите кнопку Из файла.

Путь запуска: Задает путь к файлам, такие как шаблоны и .wll файлы (файлы WLL), которые загружаются при запуске Word.

Сервис путь: Задает расположение, в котором поиск средств проверки правописания фильтры, конвертеры и других компонентов, в случае, если они не неверно зарегистрирован или не найден.

Путь точки пользователя: Путь к пользовательским шаблонам. Обратите внимание, что если этот параметр установлен в изменено для Word, изменение повлияет на все приложения Microsoft Office.

Путь К точка рабочей группы: Путь к шаблонам рабочей группы. Можно указать путь в формате UNC.

Расширение BAK: Расширение файла по умолчанию, используемый для резервного копирования файлов Word. По умолчанию используется расширение *.wbk.

Расширение DOC: Расширение файла по умолчанию, используемое для документов Word. В по умолчанию используется значение *. doc.

ТОЧКА расширения: Расширение файла по умолчанию, используемый для шаблонов Word. В по умолчанию используется * .dot.

NoFontMRUList: Включает и отключает список последних использованных шрифтов (MRU). Чтобы включить в списке последних Использованных шрифтов введите 0 (ноль). Чтобы отключить MRU Список шрифтов, введите 1.

SpellingWavyUnderlineColor: Позволяет контролировать цвета волнистой линией, т.е. отображается в списке слов с ошибками.

GrammarWavyUnderlineColor: Позволяет контролировать цвета волнистой линией, т.е. отображается в списке грамматических ошибок.

SmartTagUnderlineColor: Позволяет управлять цветом пунктирное подчеркивание, которое является отображаться в области смарт-теги.

FormatConsistencyWavyUnderlineColor: Позволяет контролировать цвета волнистой линией, т.е. отображаются в списке ошибок форматирования.

OLEDOTДля указания шаблона документа, который используется при создании объект документа в Word или другое приложение OLE.
Редактор формул

Appdir: Папка редактора формул. Должен быть редактора формул установить и запустить один раз, в порядке для данного и других Equation Editor параметров отобразить.

CustomZoom: Пользовательский параметр масштаба. Этот параметр только принимает эффект, когда вы Запуск редактора формул в отдельном окне через параметр ForceOpen.

ForceOpen: Редактор формул силы открытие в собственном отдельном окне. Тип 0 (ноль) для открытия на месте или тип 1 Чтобы открыть в отдельном окне.

ShowAll: Отображение и скрытие непечатаемых знаков.

ToolBarDocked: Устанавливает ли закрепленной панели инструментов. Выберите "Да")1) или нет ()0).

ToolBarDockPos: Положение Редактор формул закрепленной панели инструментов. 1 Задает панели инструментов в верхней части окна редактора формул. 2 Задает панели инструментов в нижней части окна редактора формул.

ToolBarShown: Задает способ отображения панели инструментов. Выберите "Да")1) или нет ()0).

ToolBarWinPos: Положение панели инструментов, когда она не закреплена, указанный в поля x и y координаты с левого верхнего угла началом координат. Значения указываются в пикселах.

Изменение масштаба: Стандартный масштаб, выбранной на Представление меню.
Чтобы использовать макрос RegOptions, выполните следующие действия:
  1. На Файл меню, нажмите кнопку Открыть.
  2. Изменение Тип файлов ЧтобыШаблоны документов (* .dot).
  3. Изменение Искать в поле ниже папки:
    C:\Program Files\Microsoft Office\Office10\Macros\
  4. Выберите Support.dot, а затем нажмите кнопку Открыть.
  5. В Макрос столбец таблицы, содержащиеся в файле, нажмите кнопку Параметры реестра Нажатие кнопки.
  6. На Параметры Word Вкладка или Редактор формул Вкладка, выберите параметр, который требуется изменить, введите новое значение Параметр (или выберите команду Обзор, если он доступен и затем выберите параметр, хотите), а затем нажмите кнопку Изменение.
  7. Нажмите кнопку Закрыть Чтобы закрыть Изменение параметров системного реестра диалоговое окно.


Использование средства автозамены

Средство автозамены можно использовать для перемещения автозамены операции между компьютерами. Для получения дополнительных сведений о средстве автозамены щелкните следующий номер статьи номер статьи базы знаний Майкрософт:
269006ПРАКТИЧЕСКОЕ руководство: Перенос элементов автозамены слова между компьютерами в Word 2002


Только опытным пользователям.

Сведения данного раздела не требуется при использовании макросы в шаблон Support.dot. Эта информация предоставляется только, если вы требуется сделать доступными глобально в Microsoft Word эти макросы или если требуется Чтобы просмотреть код макроса.



Как сделать макросы глобально

К макросам глобально в Microsoft Word, воспользуйтесь одним из приведенных ниже способов.

Метод 1: Добавьте общие шаблоны и надстройки

Если вы планируете использовать макросы, время от времени (или если вы хотите увидеть какие макросы этого прежде чем сделать их легко доступными), добавление шаблоны макрос как общие шаблоны.

Чтобы добавить один из шаблонов в списке в разделе «Аннотация» данной статьи, как глобальный шаблон, выполните следующие действия:
  1. На Сервис меню, нажмите кнопку Шаблоны и надстройки.
  2. В группе Глобальные шаблоны и надстройки, нажмите кнопку Добавить.
  3. Изменение Искать в поле в папку, содержит образец шаблона макроса. В Тип файлов поле Select Все файлы (*. *).
  4. Выберите образец макроса шаблона и нажмите кнопку ОК.
  5. После пример макроса шаблон появится в Шаблоны и надстройки диалоговом окне убедитесь, что флажок для шаблона а затем нажмите кнопку ОК.

    ВАЖНЫЕ: При загрузке шаблона в Общие шаблоны и Надстройки, шаблон остается загруженной в текущем сеансе Microsoft Word только. Если завершить работу и перезапустите Word шаблона не автоматически перезагружен. Необходимо повторно выбрать шаблон, который требуется использовать. Чтобы сделать это, Нажмите кнопку Шаблоны и надстройки В меню Сервис меню. В Шаблоны и надстройки диалоговое окно, Выберите шаблон, который требуется использовать макросы из и нажмите кнопку ОК.
  6. Для выполнения указанного макроса, выполните следующие действия.
    1. На Сервис Выберите пункт Макрос, а затем нажмите кнопку Макросы.
    2. В Макросы диалоговое окно, изменение Макросы в поле шаблон, содержащий макрос, который требуется. Например щелкните для выбора Support.dot (общий шаблон).
    3. В Имя макроса Щелкните в списке Выберите макрос и нажмите кнопку Запустить.

Способ 2: Добавьте шаблон в папке «Автозагрузка»

Переместите шаблон в папку «Автозагрузка». Microsoft Word автоматически имеет доступ ко всем макросам в шаблонах, которые размещаются в следующие папки:
C:\Program Files\Microsoft Office\Office10\Startup
С помощью проводника Windows скопируйте образец макрос шаблон в папке «Автозагрузка».

При запуске Word, загружен шаблон, расположенный в папке «Автозагрузка» как глобальный шаблон и макросы в шаблоне, доступны в Макросы диалоговое окно. Недостаток этого метода заключается в том, Microsoft Word может занять немного больше времени для запуска (при каждом запуске Microsoft Word, Microsoft Word загружает эти шаблоны глобально).

Для выполнения указанного макроса, выполните следующие действия.
  1. На Сервис Выберите пункт Макрос, а затем нажмите кнопку Макросы.
  2. В Макросы диалоговое окно, изменение Макросы в поле шаблон, содержащий макрос, который требуется. Например щелкните для выбораSupport.dot (общий шаблон).
  3. В Имя макроса список, выберите макрос и нажмите кнопку Запустить.

Способ 3: Скопируйте макросов в шаблон Normal.dot

Для выполнения указанного макроса без необходимости открывать его шаблона, копирование макрос в общий шаблон (Normal.dot). Чтобы сделать это, выполните следующие действия:
  1. Открытие шаблона образца макроса.
  2. На Сервис меню, нажмите кнопку Шаблоны и надстройки.
  3. В Шаблоны и надстройки диалоговое окно, Нажмите кнопку Организатор.
  4. В Организатор диалоговое окно, выберите Макросы Вкладка.
  5. Макросы в шаблоне образец макроса, перечислены на одном стороны диалогового окна. В общем шаблоне (Normal.dot) появится в противоположные стороны.

    ПРИМЕЧАНИЕ: Если ваш Normal.dot (общий шаблон) не отображается, нажмите кнопку Закрытие файла на противоположной стороне. В Закрытие файла Кнопка изменения Открыть файл Нажатие кнопки. Нажмите кнопку Открыть файл. Выберите свой Normal.dot файл шаблона, а затем нажмите кнопку Открыть.
  6. Со стороны пример макроса шаблона нажмите кнопку для выбора макросы, указанные в образец макроса шаблона, а затем Нажмите кнопку Копировать.

    ПРИМЕЧАНИЕ: Чтобы выбрать все элементы, перечисленные, удерживайте клавишу CTRL во время Щелкните каждый элемент проекта макроса.
  7. Нажмите кнопку Копировать Чтобы скопировать макросы в Normal.dot шаблон.
  8. Нажмите кнопку ОК Чтобы закрыть Организатор диалоговое окно.
  9. Для выполнения указанного макроса, выполните следующие действия.
    1. На Сервис Выберите пункт Макрос, а затем нажмите кнопку Макросы.
    2. В Макросы диалоговое окно, изменение Макросы в поле шаблон, содержащий макрос, который требуется. Например щелкните для выбора Normal.dot (общий шаблон).
    3. В Имя макроса Щелкните в списке Выберите макрос и нажмите кнопку Запустить.


Инструкции по просмотру кода макросов

Корпорация Майкрософт предлагает примеры программного кода только для иллюстрации Это включает, но не ограничивается, подразумеваемые гарантии товарности или пригодности для определенной цели. В данной статье предполагается, что вы знакомы с языком программирования предложенном и с помощью средств, которые используются для создания и отладки. Сотрудники службы поддержки Майкрософт могут пояснить конкретной процедуры, но они будут изменять примеры для реализации дополнительных возможностей или удовлетворения конкретных требований. Чтобы просмотреть код макроса образец макроса, выполните следующие действия:
  1. На Файл меню, нажмите кнопку Открыть.
  2. В Открыть диалоговое окно, изменение Искать в поле в папку который содержит образец шаблона макрос, изменение Файлы TYPE Чтобы Все файлы (*. *)и затем выберите соответствующий пример макроса шаблон.
  3. Удерживайте клавишу «SHIFT» и нажмите кнопку Открыть.
  4. На Сервис Выберите пункт Макрос, а затем нажмите кнопку Макросы.
  5. В Макросы диалоговое окно, изменение Макросы в поле Образец шаблона макрос, только что открыли.
  6. Выберите соответствующий макрос и нажмите кнопку Редактирование.

Свойства

Код статьи: 289506 - Последний отзыв: 18 сентября 2011 г. - Revision: 9.0
Информация в данной статье относится к следующим продуктам.
  • Microsoft Word 2002 Standard Edition
Ключевые слова: 
kbdta kbhowtomaster kbmt KB289506 KbMtru
Переведено с помощью машинного перевода
ВНИМАНИЕ! Перевод данной статьи был выполнен не человеком, а с помощью программы машинного перевода, разработанной корпорацией Майкрософт. Корпорация Майкрософт предлагает вам статьи, переведенные как людьми, так и средствами машинного перевода, чтобы у вас была возможность ознакомиться со статьями базы знаний KB на родном языке. Однако машинный перевод не всегда идеален. Он может содержать смысловые, синтаксические и грамматические ошибки, подобно тому как иностранец делает ошибки, пытаясь говорить на вашем языке. Корпорация Майкрософт не несет ответственности за неточности, ошибки и возможный ущерб, причиненный в результате неправильного перевода или его использования. Корпорация Майкрософт также часто обновляет средства машинного перевода.
Эта статья на английском языке:289506

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com