如何安装和使用 Word 2002 中的 Support.dot 模板

文章翻译 文章翻译
文章编号: 289506 - 查看本文应用于的产品
展开全部 | 关闭全部

本文内容

概要

本文旨在通过其他方式在 Word 中以帮助您确定问题所在时未进行标识,或找出您的问题。若要查找的问题,您可能遇到的特定问题有关的文章,请查询 Microsoft 知识库中。 若要这样做,请参阅下面的 Microsoft 网站:
http://support.microsoft.com/default.aspx
本分步指南介绍了包括使用宏创建的 Microsoft 产品支持服务的自动的方法在 Support.dot 模板。Support.dot 模板是包含在 Word 的特殊代码 (宏) 来帮助进行故障排除和解决问题的模板。三种类型的宏都可以帮助进行故障诊断。各种问题。

Macro Name Description
Troubleshoot Utility TShoot This macro can be used to troubleshoot various problems with Word. You can use the macro to rename your data key and Normal.dot file and to turn off Word add-ins.

NOTE: You must start Word with the /a switch before you run this macro.
Registry Options RegOptions This macro can be used to modify Word settings that are stored in the Windows registry.
AutoCorrect Backup AutoCorrectBackup This macro backs up your AutoCorrect list to a file. You can take this file to another computer and run the macro again to restore your AutoCorrect list.




如何安装 Support.dot 模板

完成 安装程序安装 Support.dot 模板。尚未安装与 典型现在升级 安装。如果未安装 Support.dot 模板,则请按照下列步骤操作:
  1. 退出 Word 和所有 Office 程序。
  2. 单击 开始,指向 设置,然后单击 控制面板
  3. 控制面板 中,双击 $ 添加/删除程序
  4. 按照您的计算机操作系统的步骤。
    • 在 Microsoft Windows 98,Microsoft Windows Millennium 版 (Me) 或 Microsoft Windows NT 4.0 中,单击以选中在 安装/卸载 选项卡上的 Microsoft Office XPMicrosoft Word 2002),然后单击 添加/删除

      -或者-
    • 在 Microsoft Windows 2000 或 Microsoft Windows XP 中单击以选中 更改或删除程序当前安装的程序 列表中单击 Microsoft Office XP (Microsoft Word 2002),然后单击 更改
  5. Microsoft Office XP 安装Microsoft Word 2002 安装程序),单击以选中 添加或删除功能,然后单击 下一步
  6. 要安装的功能 列表中按照: 单击左侧的功能以将其展开的加号 (+)。 这些步骤。

    1. 单击以展开 windows 的 Microsoft Word
    2. 单击以展开 向导和模板
    3. 其他模板和宏,单击图标,然后单击快捷菜单上选择 所有从本机运行
  7. : 单击加号 (+) 以展开 it.Click 更新 以安装 Support.dot 模板功能的左侧。


如何打开 Support.dot 模板

要打开 Support.dot 模板,请按照下列步骤操作:
  1. 文件 菜单上单击 打开
  2. 若要将 文件类型 框更改 文档模板 (*.dot)
  3. 更改 查找范围 框中为以下文件夹:
    是 Files\Microsoft Office\Office10\Macros\
  4. 单击以选中 Support.dot,然后单击 打开
  5. 列中的该文件中包含表中单击相应的按钮来运行所需的宏。例如对于单击Troubleshoot Utility,Registry Options,AutoCorrect Backup.


如何使用该诊断工具

疑难解答实用工具是宏提供的 Microsoft 产品支持服务。此宏有助于自动进行 Word 问题疑难解答通过删除某些关键的组件可能已损坏,或使用 Microsoft Word,可能会引起冲突的过程。使用此实用程序禁用 (按顺序列出),通常在 Word 启动过程中加载以下组件:
  • 数据 注册表键
  • Normal.dot 共用模板
  • 加载项和模板
  • COM 加载项
  • 选项 注册表项
如果这些项目中的任何一项已损坏或不兼容,Word 可能无法启动,或者可能无法正常工作。通过 使用/a 开关启动 Word,您可以暂时忽略这些项目和其他项目。

使用/a 开关启动 Word

要通过 使用/a 开关启动 Word,请按照下列步骤操作:
  1. 单击 开始,然后单击 运行
  2. 运行 对话框执行以下任一操作:
    • 打开 框中键入 winword.exe/a

      -或者-
    • 单击 浏览。查找并选择 Winword.exe 文件。若要这样做,请按照下列步骤操作:
      1. 查找范围 列表中选择 Word 程序文件所在的文件夹。 选择 Winword.exe 文件,然后单击 打开

        运行 对话框中的 打开 框中填充此步骤。
      2. 打开 框中将插入点移动 Winword.exe 之后。

        : 在 运行 对话框中 Winword.exe 文件的路径括在引号内。一定要将插入点移动到右侧的右引号。
      3. 键入一个空格,然后键入 / a

        打开 框中的该语句应该看起来类似于以下内容:
        "是 Files\Microsoft Office\Office10\Winword.exe"/ a
  3. 运行 对话框中单击 确定
如果 Word 启动并正确地运行,当您 使用/a 开关时,问题是与本文"如何对使用疑难解答实用工具"一节的开始处列出的组件之一。 使用疑难解答实用工具来确定哪一个组件引发了该问题。若要使用疑难解答实用工具,您可能需要安装 Support.dot。

: 如果问题仍然出现在 使用/a 开关启动 Word 时,您不需要使用疑难解答实用工具解决。

分步: 使用该诊断工具

要隔离,并删除在 Word 中引起问题的组件删除以下组件 (一个一次和按顺序) 的每个使用疑难解答实用工具: Step 1: Delete the Data Registry Key

Step 2: Rename the Normal.dot Global Template

Step 3: Disable the Word Startup Folder Add-Ins

Step 4: Delete the COM Add-Ins Registry Key

Step 5: Delete the Options Registry Key

第 1 步: 删除数据的注册表项

最常用的选项 (在 工具 菜单单击 选项) 存储在 数据 键。若要删除 数据 键是一个故障排除步骤。Word 通过使用下一次启动程序的默认设置重建此 数据 键。

: 删除会将该 数据 密钥几个选项重的置为其默认设置,包括最近使用的文件列表在 文件 菜单和自定义 选项 对话框中的许多设置。

若要删除 数据 键,请按照下列步骤操作:
  1. 请退出所有 Office 程序。
  2. 通过 使用/a 开关启动 Word。若要 使用/a 开关启动 Word,请参阅在"Starting Microsoft Word with the /a Switch"本文一节。
  3. 打开 Support.dot 模板。若要这样做,请参阅在 "How to Open the Support.dot Template"本文一节。
  4. Support.dot 模板中单击 疑难解答实用工具 按钮。
  5. 在该 Microsoft Word 疑难解答实用工具 对话框在 选择项 列表中的单击 数据的注册表项,然后单击 删除
  6. 当您看到以下消息时,请单击 确定
    HKEY_CURRENT_USER\Software\Microsoft Office\10.0\Word\Data
    对此注册表项的备份文件是在:
    C:\WINDOWS\TEMP\wddata10.0

    注册表项已被删除。
  7. 单击 关闭
  8. 文件 菜单上单击 退出 以退出 Word。
  9. 您通常执行的方式启动 Word。是否 使用在"使用 /a/a 开关启动 Microsoft Word"部分中,这篇文章的过程
如果 Word 启动,并且工作正常,您解决了问题。问题已损坏的 数据 注册表项。您可能需要更改少数设置来还原自己喜欢的选项,在 Word 中。

如果不解决此问题恢复您的旧 数据 注册表项。若要这样做,请按照下列步骤操作:
  1. 请退出所有 Office 程序。
  2. 通过 使用/a 开关启动 Word。若要 使用/a 开关启动 Word,请参阅在"Starting Microsoft Word with the /a Switch"本文一节。
  3. 打开 Support.dot 模板。若要这样做,请参阅在 "How to Open the Support.dot Template"本文一节。
  4. Support.dot 模板中单击 疑难解答实用工具 按钮。
  5. 在该 Microsoft Word 疑难解答实用工具 对话框在 选择项 列表中的单击 数据的注册表项,然后单击 还原
  6. 当您看到以下消息时,请单击 $
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Data

    在注册表中有此项。
    覆盖它吗?
  7. 当您看到以下消息时,请单击 确定
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Data

    还原注册表键操作成功。
  8. 请执行以下任一操作:
Back to Top of Using the Troubleshoot Utility

步骤 2: 重命名 Normal.dot 全局模板

若要防止格式,自动图文集,和从影响行为的 Word 和文档打开时,将存储在共用模板 (Normal.dot) 中的宏重命名全局模板。重命名此文件,可以快速确定共用模板是否引起该问题。

: 将重命名 Normal.dot 文件几个选项重置为它们包括自定义样式、 自定义工具栏、 宏,和自动图文集词条的默认设置。由于这个原因 Microsoft 强烈建议您不要删除 Normal.dot 文件。

某些类型的配置可以创建多个 Normal.dot 文件。这些情况包括在其中运行的 Word 的多个版本在同一计算机的情况下或在同一台计算机上装有多个工作站。在这种情况下一定要重命名 Normal.dot 的正确副本。

若要重命名 Normal.dot 文件,请按照下列步骤操作:
  1. 请退出所有 Office 程序。
  2. 通过 使用/a 开关启动 Word。若要 使用/a 开关启动 Word,请参阅在"Starting Microsoft Word with the /a Switch"本文一节。
  3. 打开 Support.dot 模板。若要这样做,请参阅在 "How to Open the Support.dot Template"本文一节。
  4. Support.dot 模板中单击 疑难解答实用工具 按钮。
  5. 在该 Microsoft Word 疑难解答实用工具 对话框在 选择项 列表中的单击 Normal.dot 全局模板,然后单击 重命名
  6. 当您收到以下消息时,请单击 确定
    path\Application Data\Microsoft\Templates\Normal.dot
    复制到
    path\Application Data\Microsoft\Templates\10Normal.dot
    : 您 Normal.dot 文件的路径可能会有所不同。
  7. 单击 关闭 以关闭该 Microsoft Word 疑难解答实用工具 对话框。
  8. 文件 菜单上单击 退出 以退出 Word。
  9. 您通常执行的方式启动 Word。是否 使用在"使用 /a/a 开关启动 Microsoft Word"部分中,这篇文章的过程
如果 Word 的正确启动您解决了问题。在这种情况下问题是 Normal.dot 文件损坏。您可能需要更改少数设置来还原自己喜欢的选项。如果您重命名 Normal.dot 文件包含如样式、 宏,或不能被轻松地重新创建的自动图文集词条的自定义您可以将这些自定义设置从 10Normal.dot 文件 (您的旧 Normal.dot) 复制到新的 Normal.dot 文件,使用管理器。

有关使用管理器的详细信息的 帮助 菜单上单击 Microsoft Word 帮助、 在 Office 助手或应答向导中,键入 管理器,然后单击 搜索 以查看返回的主题。

如果不解决此问题还原旧的 Normal.dot 文件 (10Normal.dot)。若要这样做,请按照下列步骤操作:
  1. 请退出所有 Office 程序。
  2. 通过 使用/a 开关启动 Word。若要 使用/a 开关启动 Word,请参阅在"Starting Microsoft Word with the /a Switch"本文一节。
  3. 打开 Support.dot 模板。若要这样做,请参阅在 "How to Open the Support.dot Template"本文一节。
  4. Support.dot 模板中单击 疑难解答实用工具 按钮。
  5. 在该 Microsoft Word 疑难解答实用工具 对话框在 选择项 列表中的单击 Normal.dot 全局模板,然后单击 还原
  6. 当您看到以下消息时,请单击 $
    path\Application Data\Microsoft\Templates\Normal.dot

    此文件的备份已经存在。

    覆盖它吗?
    : 您 Normal.dot 文件的路径可能会有所不同。
  7. 当您看到以下消息时,请单击 确定
    path\Application Data\Microsoft\Templates\10Normal.dot
    复制到
    path\Templates\Normal.dot
  8. 请执行以下任一操作:
Back to Top of Using the Troubleshoot Utility

步骤 3: 禁用 Word 启动文件夹加载

当您在启动 Word 时 Word 将自动加载模板和加载项位于启动文件夹中。在 Word 中的错误可能是冲突或外接程序的问题而引起的。若要确定是否由启动文件夹中的项目引起该问题,您可以暂时禁用指向这些加载项的注册表设置。

若要暂时禁用加载项注册表项,请按照下列步骤操作:
  1. 请退出所有 Office 程序。
  2. 通过 使用/a 开关启动 Word。若要 使用/a 开关启动 Word,请参阅在"Starting Microsoft Word with the /a Switch"本文一节。
  3. 打开 Support.dot 模板。若要这样做,请参阅在 "How to Open the Support.dot Template"本文一节。
  4. Support.dot 模板中单击 疑难解答实用工具 按钮。
  5. 在该 Microsoft Word 疑难解答实用工具 对话框在 选择项 列表中的单击 Word 启动文件夹加载,然后单击 重命名
  6. 请执行以下任一操作:
    • 当您看到以下消息时,请单击 确定
      未找到重命名/恢复的文件。
      : 如果您收到此消息,您有没有加载在启动 Word 时加载的项。单击 确定 后,继续执行,Step 4: Delete the COM Add-Ins Registry Key本文一节。

      -或者-
    • 当您看到以下消息时,请单击 确定
      path\Application Data\Microsoft\Word\Startup\ file name
      复制到
      path\Application Data\Microsoft\Word\Startup\ file name

      path\Program Files\Microsoft Office\Office10\Startup\ file name
      复制到
      path\Program Files\Microsoft Office\Office10\Startup\ file name
      : 的路径和文件名,在您的系统上可能会有所不同。
  7. 单击 关闭 以关闭该 Microsoft Word 疑难解答实用工具 对话框。
  8. 文件 菜单上单击 退出 以退出 Word。
  9. 您通常执行的方式启动 Word。是否 使用在"使用 /a/a 开关启动 Microsoft Word"部分中,这篇文章的过程
  10. 请执行以下任一操作:
    • 如果可以不再重现该问题,并在第 6 步中已删除的启动项目您可以确定问题由加载项引起。若要确定哪个启动项导致问题,请按照下列步骤操作:
      1. 请退出所有 Office 程序。
      2. 通过 使用/a 开关启动 Word。若要 使用/a 开关启动 Word,请参阅在"Starting Microsoft Word with the /a Switch"本文一节。
      3. 打开 Support.dot 模板。若要这样做,请参阅在"How to Open the Support.dot Template"本文一节。
      4. Support.dot 模板中单击 疑难解答实用工具 按钮。
      5. 在该 Microsoft Word 疑难解答实用工具 对话框在 选择项 列表中的单击 Word 启动文件夹 Addins,然后单击 还原
      6. 当您看到以下消息时,请单击 确定
        path\Application Data\Microsoft\Word\Startup\ file name
        复制到
        path\Application Data\Microsoft\Word\Startup\ file name

        path\Program Files\Microsoft Office\Office10\Startup\ file name
        复制到
        path\Program Files\Microsoft Office\Office10\Startup\ file name
        : 的路径和文件名,在您的系统上可能会有所不同。
      7. 单击 关闭 以关闭该 Microsoft Word 疑难解答实用工具 对话框。
      8. 文件 菜单上单击 退出 以退出 Word。
      9. 双击 我的电脑,然后打开在步骤 f 中指定的文件夹之一。 例如:
        path\Application Data\Microsoft\Word\Startup\

        -或者-

        path\Program Files\Microsoft Office\Office10\Startup\
      10. 用鼠标右键单击任何一个在文件夹中包含的文件,然后单击快捷菜单上的 重命名
      11. 键入该文件的新名称,然后按 ENTER 键。

        重要: 因为您可能需要返回到其原始名称重命名文件生成注释文件的原始名称。
      12. 您通常执行的方式启动 Word。是否 使用在"使用 /a/a 开关启动 Microsoft Word"部分中,这篇文章的过程
      如果您不再可以重现该问题,您已找到特定加载项的项导致该问题的原因。如果需要,通过添加-在项目中提供的功能,您必须确定操作时的 Word 加载-中包括特定物料和有关的更新,请与供应商联系。

      如果不解决此问题该加载项重命名为原来的名称,然后重复步骤 h 通过 i 步骤 f 中所示消息中指定的文件夹中的每个文件。

      -或者-

    • 如果您不再可以重现该问题,您已找到特定加载项的项导致该问题的原因。如果需要,通过添加-在项目中提供的功能,您必须确定操作时的 Word 加载-中包括特定物料和有关的更新,请与供应商联系。如果不解决此问题还原您外接程序项,然后再继续下一步。若要这样做,请按照下列步骤操作:
      1. 请退出所有 Office 程序。
      2. 通过 使用/a 开关启动 Word。若要 使用/a 开关启动 Word,请参阅在"Starting Microsoft Word with the /a Switch"本文一节。
      3. 打开 Support.dot 模板。若要这样做,请参阅在"How to Open the Support.dot Template"本文一节。
      4. Support.dot 模板中单击 疑难解答实用工具 按钮。
      5. 在该 Microsoft Word 疑难解答实用工具 对话框在 选择项 列表中的单击 Word 启动文件夹 Addins,然后单击 还原
      6. 当您看到以下消息时,请单击 确定
        path\Application Data\Microsoft\Word\Startup\ file name
        复制到
        path\Application Data\Microsoft\Word\Startup\ file name

        path\Program Files\Microsoft Office\Office10\Startup\ file name
        复制到
        path\Program Files\Microsoft Office\Office10\Startup\ file name
        : 的路径和文件名,在您的系统上可能会有所不同。
      7. 继续执行,Step 4: Delete the COM Add-Ins Registry Key本文一节。
Back to Top of Using the Troubleshoot Utility

第 4 步: 删除 COM 加载项注册表项

COM 加载项可以安装在任何位置,并由与 Word 进行交互的程序安装。若要去安装的任何 COM 加载项的 Windows 注册表设置,请按照下列步骤操作:
  1. 请退出所有 Office 程序。
  2. 通过 使用/a 开关启动 Word。若要 使用/a 开关启动 Word,请参阅在"Starting Microsoft Word with the /a Switch"本文一节。
  3. 打开 Support.dot 模板。若要这样做,请参阅在 "How to Open the Support.dot Template"本文一节。
  4. Support.dot 模板中单击 疑难解答实用工具 按钮。
  5. 在该 Microsoft Word 疑难解答实用工具 对话框在 选择项 列表中的单击 COM Addins 注册表项,然后单击 删除
  6. 当您看到以下消息时,请单击 确定
    HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins
    对此注册表项的备份文件是在:
    C:\Windows\TEMP\wdaddn10.0

    注册表项已被删除。
  7. 单击 关闭 以关闭该 Microsoft Word 疑难解答实用工具 对话框。
  8. 文件 菜单上单击 退出 以退出 Word。
  9. 您通常执行的操作的方式启动 Word。是否 使用在"使用 /a/a 开关启动 Microsoft Word"部分中,这篇文章的过程
  10. 请执行以下任一操作:
    • 如果您不再可以重现该问题,确定的 COM 加载项导致该问题的原因。若要确定哪个 COM 加载项导致该问题的原因,请按照下列步骤:
      1. 请退出所有 Office 程序。
      2. 通过 使用/a 开关启动 Word。若要 使用/a 开关启动 Word,请参阅在"Starting Microsoft Word with the /a Switch"本文一节。
      3. 打开 Support.dot 模板。若要这样做,请参阅在"How to Open the Support.dot Template"本文一节。
      4. Support.dot 模板中单击 疑难解答实用工具 按钮。
      5. 在该 Microsoft Word 疑难解答实用工具 对话框在 选择项 列表中的单击 COM Addins 注册表项,然后单击 还原
      6. 当您看到以下消息时,请单击 确定
        HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins

        还原注册表键操作成功。
      7. 单击 关闭 以关闭该 Microsoft Word 疑难解答实用工具 对话框。
      8. 文件 菜单上单击 退出 以退出 Word。
      9. 您通常执行的方式启动 Word。是否 使用在"使用 /a/a 开关启动 Microsoft Word"部分中,这篇文章的过程
      10. 工具 菜单上单击 自定义
      11. 单击 命令 选项卡。在 类别 列表中单击 工具
      12. 命令 列表中单击 COM 加载项,然后将命令拖到您的工具栏。
      13. 单击 关闭 关闭 自定义 对话框。
      14. 单击您刚才添加的步骤 k m 通过在 COM 加载项 按钮。
      15. COM 加载项 对话框中列出了外接程序,如果单击以清除加载宏复选框。

        : 如果列出了多个加载项,单击以清除一个加载项复选框在要确定哪个加载项导致问题的时间。
      16. 单击 确定 以关闭 COM 加载项 对话框。
      17. 单击 退出文件 菜单上以退出 Word。
      18. 您通常执行的方式启动 Word。是否 使用在"使用 /a/a 开关启动 Microsoft Word"部分中,这篇文章的过程
      19. 请执行以下任一操作:
        • 如果您不再可以重现该问题,您已找到 COM 加载项导致该问题的原因的。如果需要提供该加载项的功能,您必须确定哪个 Word 加载项包括特定的项目,请与供应商联系以更新。

          -或者-
        • 如果不解决此问题单击您在步骤 k 通过 m.单击它可在步骤 o 中选择加载宏复选框已清除的中添加 COM 加载项 按钮。然后单击以清除在不同加载项的复选框,并重复步骤 p s.通过重复此过程按所需的每个加载项,直到您确定哪个加载项导致问题的次数。
      -或者-

    • -或-如果不解决此问题还原您的 COM 加载项注册表键,然后再继续下一步。若要这样做,请按照下列步骤操作:
      1. 请退出所有 Office 程序。
      2. 通过 使用/a 开关启动 Word。若要 使用/a 开关启动 Word,请参阅在"Starting Microsoft Word with the /a Switch"本文一节。
      3. 打开 Support.dot 模板。若要这样做,请参阅在"How to Open the Support.dot Template"本文一节。
      4. Support.dot 模板中单击 疑难解答实用工具 按钮。
      5. 在该 Microsoft Word 疑难解答实用工具 对话框在 选择项 列表中的单击 COM Addins 注册表项,然后单击 还原
      6. 当您看到以下消息时,请单击 确定
        HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins

        还原注册表键操作成功。
      7. 单击 关闭 以关闭该 Microsoft Word 疑难解答实用工具 对话框。
      8. 文件 菜单上单击 退出 以退出 Word。
      9. 继续执行,Step 5: Delete the Options Registry Key本文一节。
Back to Top of Using the Troubleshoot Utility

步骤 5: 删除选项注册表项

选项 注册表项存储,您可以通过更改菜单选项或通过运行 RegOptions 宏从 Word,设置这些选项。这些是可编辑的选项。

设置分为两组: 默认设置和可选设置。默认设置建立,在安装过程中,您可以通过修改在 Word 中的选项来对其进行更改。可选的设置不在安装过程中创建的 ; 您必须将它们添加运行 RegOptions 宏 (本文内下文中讨论)。

若要删除 选项 键,请按照下列步骤操作:
  1. 请退出所有 Office 程序。
  2. 通过 使用/a 开关启动 Word。若要 使用/a 开关启动 Word,请参阅在"Starting Microsoft Word with the /a Switch"本文一节。
  3. 打开 Support.dot 模板。若要这样做,请参阅在 "How to Open the Support.dot Template"本文一节。
  4. Support.dot 模板中单击 疑难解答实用工具 按钮。
  5. 在该 Microsoft Word 疑难解答实用工具 对话框在 选择项 列表中的单击 选项注册表项,然后单击 删除
  6. 当您看到以下消息时,请单击 确定
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Options
    对此注册表项的备份文件是在:
    C:\WINDOWS\TEMP\wdoptn10.0

    注册表项已被删除。
  7. 按照通常的方法的方式启动 Word。不要 使用/a 开关启动 Word,如中所述,"Starting Microsoft Word with the /a Switch"本文一节。
如果 Word 正确启动,并且工作正常,问题已经解决。问题已损坏的 选项 键。您可能需要更改少数设置来还原自己喜欢的选项,在 Word 中。

如果不解决此问题退出 Word,然后返回到 Windows 注册表中添加 选项 关键信息。若要这样做,请按照下列步骤操作:
  1. 请退出所有 Office 程序。
  2. 通过 使用/a 开关启动 Word。若要 使用/a 开关启动 Word,请参阅在"Starting Microsoft Word with the /a Switch"本文一节。
  3. 打开 Support.dot 模板。若要这样做,请参阅在 "How to Open the Support.dot Template"本文一节。
  4. Support.dot 模板中单击位于文件中包含的表中的 疑难解答实用工具 按钮。
  5. 在该 Microsoft Word 疑难解答实用工具 对话框在 选择项 列表中的单击 选项注册表项,然后单击 还原
  6. 当您看到以下消息时,请单击 $
    HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Options

    在注册表中有此项。
    覆盖它吗?
  7. 当您看到以下消息时,请单击 确定
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Options

    还原注册表键操作成功。
  8. 单击 关闭 以关闭该 Microsoft Word 疑难解答实用工具 对话框。
  9. 文件 菜单上单击 退出 以退出 Word。
Back to Top of Using the Troubleshoot Utility



如何使用注册表选项宏

您可以使用 RegOptions 宏检查,并对 Word 设置在 Windows 注册表中所做的更改。以下是用途的可在宏选项的列表和每个选项的简短说明:
Word 选项

自动保存路径: 设置自动恢复文件保存位置文件夹。

DOC 路径: 用于 Word 文档的默认文件夹。

图片路径: 设置,当您在 插入 菜单上指向 图片,然后单击 来自文件 时,将使用默认路径。

启动路径: 设置如模板和 $ 在启动 Word 时加载.wll 文件 (wll) 的 Word 启动文件的路径。

工具路径: 设置查找时 Word 所指向的校对工具、 筛选、 转换器,和其他的组件,它们没有正确注册或找不到一个位置。

用户-点-路径: 用户模板的路径。请注意此设置更改为 Word 时, 该更改会影响所有 Office 程序。

工作组-点-路径: 用于工作组模板的路径。您可以指定 UNC 路径。

BAK 扩展: 用于 Word 的备份文件的默认文件扩展名。 默认扩展名是 *.wbk。

DOC 扩展: 用于 Word 文档的默认文件扩展名。默认值是 * 文档。

DOT 扩展: 用于 Word 模板的默认文件扩展名。默认值是 *.dot。

NoFontMRUList: 打开或关闭最近使用 (过的 MRU) 字体列表。若要打开 MRU 字体列表,键入 0 (零)。若要关闭该 MRU 字体列表中,键入 1

SpellingWavyUnderlineColor: 允许您控制在拼错的单词下显示的波浪下划线的颜色。

GrammarWavyUnderlineColor: 允许您控制语法错误下显示的波浪下划线的颜色。

SmartTagUnderlineColor: 允许您控制显示在智能标记下的点式下划线的颜色。

FormatConsistencyWavyUnderlineColor: 允许您控制将显示在格式错误的波浪下划线的颜色。

OLEDOT: 指定当您创建文档对象在 Word 或其他 OLE 应用程序中的时,将使用的文档模板。
公式编辑器选项

Appdir: 在公式编辑器程序文件夹。公式编辑器必须安装并运行一次,这和其他公式编辑器设置为要显示的顺序。

CustomZoom: 的自定义显示比例设置。当您在通过 ForceOpen 设置单独的窗口中启动公式编辑器时,此设置只会生效。

ForceOpen: 强制公式编辑器可以在其自己单独的窗口中打开。在位置,或打开在单独的窗口中键入 1 中键入 0 (零) 来打开。

ShowAll: 显示或隐藏非打印字符。

ToolBarDocked: 设置是否停靠工具栏。选择是 (1) 或无 (0)。

ToolBarDockPos公式编辑器 工具栏时它停靠的位置。1 设置在公式编辑器窗口的顶部的工具栏。2 设置底部的公式编辑器窗口工具栏。

ToolBarShown: 设置是否显示了工具栏。选择是 (1) 或无 (0)。

ToolBarWinPos: 位置的工具栏不停放,指定在 X,Y,与相协调原点为左上角。该单位是以像素为单位)。

缩放: 在 视图 菜单上的所选标准的显示比例大小。
若要用于 RegOptions 宏,请按照下列步骤操作:
  1. 文件 菜单上单击 打开
  2. 若要将 文件类型 框更改 文档模板 (*.dot)
  3. 更改 查找范围 框中为以下文件夹:
    是 Files\Microsoft Office\Office10\Macros\
  4. 单击以选中 Support.dot,然后单击 打开
  5. 在文件中包含表的 列中单击 注册表选项 按钮。
  6. Word 选项 选项卡或 公式编辑器选项 选项卡中,单击以选中您要更改、 设置 框中键入新的设置 (或单击 浏览,如果可用,然后单击以选择所需的设置),选项,然后单击 更改
  7. 单击 关闭 关闭 设置注册表选项 对话框。


如何使用自动更正备份实用程序

您可以使用自动更正备份实用程序来移动自动更正条目的计算机之间。有关自动更正备份实用程序的其他信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
269006如何: 在 Word 2002 中的计算机之间移动 Word 自动更正项


只有高级的用户

在 Support.dot 模板中使用宏时,则不需要在此部分信息。仅当您希望使这些宏全局在 Microsoft Word 中可用,或者如果您要查看宏代码提供了此信息。



如何使宏的位置可用的全局

若要使宏在 Word 中全局可用,请使用下列方法之一。

方法 1: 添加到全局模板和加载项

如果您打算偶尔使用宏 (或如果您希望查看宏执行操作之前您决定以使其更易于访问),添加宏模板作为共用模板。

若要添加的模板作为共用模板本文"概要"一节中列出的其中一个,请按照下列步骤操作:
  1. 工具 菜单上单击 模板和加载宏
  2. 全局模板和加载宏,下单击 添加
  3. 查找范围 框中更改的示例宏模板所在的文件夹。在 文件类型 框中选择 所有文件 (* *)
  4. 选择示例的宏模板,然后单击 确定
  5. 示例宏模板出现在 模板和加载宏 对话框后,请确保已选中模板复选框,然后单击 确定

    重要提示: 当您加载模板在 全局模板和加载宏 时,模板的保持加载状态只在当前 Word 会话。如果退出然后重新启动 Word 模板不会自动重新加载。您必须重新选择您要使用的模板。若要执行此操作单击在 工具 菜单上的 模板和加载宏。在 模板和加载宏 对话框中单击以选择您要使用来自,宏的模板,然后单击 确定
  6. 若要进行一个特定的宏,请按照下列步骤操作:
    1. 工具 菜单上指向 ,然后单击
    2. 对话框中更改 的位置框中包含所需的宏的模板。例如对于单击以选中 Support.dot (共用模板)
    3. 宏名 列表中单击以选择所需的宏,然后单击 运行

方法 2: 将模板添加到启动文件夹

将模板移到启动文件夹中。Word 会自动在位于以下文件夹中的模板中有权访问的任何宏:
是 Files\Microsoft Office\Office10\Startup
使用 Windows 资源管理器,将示例宏模板的副本放到启动文件夹。

当您启动 Word,模板位于启动文件夹中时作为一个全局模板加载,并在模板中的宏在 对话框中都可用。此方法的缺点是 Word 可能要花费更长的一点时间开始 (每次启动 Word 时,Word 加载这些模板全局范围内)。

若要进行一个特定的宏,请按照下列步骤操作:
  1. 工具 菜单上指向 ,然后单击
  2. 对话框中更改 的位置框中包含所需的宏的模板。例如对于单击以选中 Support.dot (共用模板)
  3. 宏名 列表中单击以选择所需的宏,然后单击 运行

方法 3: 将该宏复制到 Normal 模板

要运行一个特定的宏,而无需打开它的模板,请将宏复制到您共用模板 (Normal.dot) 中。若要这样做,请按照下列步骤操作:
  1. 打开示例宏模板。
  2. 工具 菜单上单击 模板和加载宏
  3. 模板和加载宏 对话框中单击 管理器
  4. 组织程序 对话框中单击以选择 宏方案项 选项卡。
  5. 该宏的示例宏模板中列出对话框中的一侧。打开另一侧,将显示您共用模板 (Normal.dot)。

    : 如果不打开您 Normal.dot (共用模板) 在另一侧上单击 关闭文件关闭文件 按钮更改为是 打开文件 按钮。单击 打开文件。单击此处,选择您的 Normal.dot 模板文件,然后单击 打开
  6. 示例宏模板的侧边上单击以选中中的示例宏模板,列出的宏项目项,然后单击 复制

    注意: 要选择所有列出的项,按住 CTRL 的同时单击每个宏项目项。
  7. 单击 复制,将宏项目项复制到您 Normal.dot 模板。
  8. 单击 确定 以关闭 管理器 对话框。
  9. 若要进行一个特定的宏,请按照下列步骤操作:
    1. 工具 菜单上指向 ,然后单击
    2. 对话框中更改 的位置框中包含所需的宏的模板。例如对于单击以选中 Normal.dot (共用模板)
    3. 宏名 列表中单击以选择所需的宏,然后单击 运行


如何查看宏代码

Microsoft 提供的编程示例只,用于说明不附带任何明示或暗示保证。这包括,但不限于对适销性或针对特定用途的适用性的暗示的担保。本文假定您熟悉演示了正在使用的编程语言以及用于创建和调试过程的工具。Microsoft 支持工程师可以帮助解释某个特定过程的功能,但他们不会修改这些示例以提供额外的功能或构建过程来满足您的具体要求。若要访问的示例宏在宏代码,请按照下列步骤操作:
  1. 文件 菜单上单击 打开
  2. 打开 对话框中更改文件夹包含的示例宏模板的 查找范围 框中,更改 文件类型 框中的以 所有文件 (* *),然后单击以选择适当的示例宏模板。
  3. 按住 SHIFT,然后单击 打开
  4. 工具 菜单上指向 ,然后单击
  5. 对话框中更改您刚刚打开的示例宏模板 的位置框中。
  6. 选择相应的宏,然后单击 编辑

属性

文章编号: 289506 - 最后修改: 2006年7月27日 - 修订: 2.2
这篇文章中的信息适用于:
  • Microsoft Word 2002 标准版
关键字:?
kbmt kbdta kbhowtomaster KB289506 KbMtzh
机器翻译
注意:这篇文章是由无人工介入的微软自动的机器翻译软件翻译完成。微软很高兴能同时提供给您由人工翻译的和由机器翻译的文章, 以使您能使用您的语言访问所有的知识库文章。然而由机器翻译的文章并不总是完美的。它可能存在词汇,语法或文法的问题,就像是一个外国人在说中文时总是可能犯这样的错误。虽然我们经常升级机器翻译软件以提高翻译质量,但是我们不保证机器翻译的正确度,也不对由于内容的误译或者客户对它的错误使用所引起的任何直接的, 或间接的可能的问题负责。
点击这里察看该文章的英文版: 289506
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。

提供反馈

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com