HOW TO:在 Microsoft Word 2002 中安裝並使用 Support.dot 範本

文章翻譯 文章翻譯
文章編號: 289506 - 檢視此文章適用的產品。
全部展開 | 全部摺疊

在此頁中

結論

本文將告訴您,當 Microsoft Word 無法使用其他方法找出或隔離問題時,如何判斷問題所在。 如果要找出有關可能遇到的特定問題之議題與文件,請查詢 Microsoft Knowledge Base。如果要執行這項操作,請至下列 Microsoft 網站:
http://support.microsoft.com/default.aspx
本文將逐步告訴您 Support.dot 範本,它包含了使用「Microsoft 技術支援部」所建立巨集的自動化方法。 Support.dot 範本包含了特殊程式碼 (巨集),可以支援疑難排解並解決 Word 問題。 有三種巨集可以協助您疑難排解不同的問題。

巨集 名稱 說明
疑難排解公用程式 TShoot 此巨集可以疑難排解各種 Word 問題。 您可以使用此巨集重新命名您的資料機碼與 Normal.dot 檔,以及關閉 Word 增益集。

注意: 您必須在執行巨集之前,先使用 /a 參數啟動 Word。
登錄選項 RegOptions 此巨集可以用來修改儲存在 Windows 登錄中的 Word 設定。
自動校正備份 AutoCorrectBackup 此巨集可以將您的自動校正清單備份到檔案。 並且可以將此檔案帶到另一台電腦中,再次執行巨集以恢復您的自動校正清單。




如何安裝 Support.dot 範本

您可以使用「完整安裝」安裝 Support.dot 範本。 而不使用「一般安裝」或「立即升級安裝」進行安裝。 如果沒有安裝 Support.dot 範本,請依照下列步驟:
  1. 結束 Microsoft Word 與所有 Microsoft Office 程式。
  2. 按一下 [開始],指向 [設定],再按一下 [控制台]
  3. [控制台] 中按兩下 [新增/移除程式]
  4. 依照電腦的作業系統,執行下列步驟。
    • Microsoft Windows 98、Microsoft Windows Millennium Edition (Me) 或 Microsoft Windows NT 4.0 使用者,請按一下以選取 [安裝/解除安裝] 索引標籤上的 [Microsoft Office XP] (Microsoft Word 2002),然後按一下 [新增/移除]

      - 或者 -
    • Microsoft Windows 2000 或 Microsoft Windows XP 使用者,請按一下以選取 [變更或移除程式]。 在 [目前安裝的程式] 清單中,按一下 [Microsoft Office XP] (Microsoft Word 2002),再按一下 [變更]
  5. [Microsoft Office XP 安裝程式] (Microsoft Word 2002 安裝程式) 中,按一下以選取 [新增或移除功能],然後按一下 [下一步]
  6. [要安裝的功能] 清單中,依照下列步驟執行。注意: 按一下功能左側的加號 (+),將之展開。

    1. 按一下以展開 [Microsoft Word for Windows]
    2. 按一下以展開 [精靈和範本]
    3. 按一下 [其它的範本和巨集] 圖示,再按一下以選取捷徑功能表上的 [全部從我的電腦執行]
  7. : 按一下功能左側的加號 (+),將之展開它。按一下 [立即更新],以便安裝 Support.dot 範本。


如何開啟 Support.dot 範本

如果要開啟 Support.dot 範本,請依照下列步驟:
  1. [檔案] 功能表上按一下 [開啟]
  2. [檔案類型] 方塊變更為 [文件範本 (*.dot)]
  3. [查詢] 方塊變更為下列資料夾:
    C:\Program Files\Microsoft Office\Office10\Macros\
  4. 按一下以選取 [Support.dot],再按一下 [開啟]
  5. 在檔案所包含的表格中,在 [巨集] 列中按一下適當的按鈕,以執行想要的巨集。 例如,按一下疑難排解公用程式登錄選項,或自動校正備份。


如何使用疑難排解公用程式

「疑難排解公用程式」是「Microsoft 技術支援部」所提供的巨集。 此巨集可以藉由移除可能毀損或與 Microsoft Word 發生衝突的特定機碼元件,以自動化疑難排解 Microsoft Word 問題的程序。 請使用此公用程式停用 (以下列順序列出) 通常在 Word 啟動時所載入的下列元件:
  • [資料] 登錄機碼
  • Normal.dot 共用範本
  • 增益集與範本
  • COM 增益集
  • [選項] 登錄機碼
如果有任何項目毀損或不相容,Word 將無法啟動或無法正常地運作。 您可以使用 /a 參數啟動 Word,以便暫時略過這些項目與其他項目。

使用 /a 參數啟動 Microsoft Word

如果要使用 /a 參數啟動 Word,請依照下列步驟:
  1. 按一下 [開始],再按一下 [執行]
  2. [執行] 對話方塊中,執行下列操作之一:
    • [開啟] 方塊中輸入 Winword.exe /a

      - 或者 -
    • 按一下 [瀏覽]。 找出並選取 Winword.exe 檔。 如果要執行此項操作,請依照下列步驟:
      1. [查詢] 清單中選取包含 Word 程式檔的資料夾。選取 Winword.exe 檔案,再按一下 [開啟]

        此步驟會將檔案名稱填入 [執行] 對話方塊中的 [開啟] 方塊。
      2. [開啟] 方塊中,將插入點移到 Winword.exe 後面。

        注意: 在 [執行] 對話方塊中,Winword.exe 檔的路徑會用引號括住。 請確定將插入點移到結束引號的右側。
      3. 輸入一個空格,然後再輸入 /a

        [開啟] 方塊中的陳述式應該會與下列類似:
        "C:\Program Files\Microsoft Office\Office10\Winword.exe" /a
  3. [執行] 對話方塊中按一下 [確定]
當您使用 /a 參數時,如果 Word 可以正常地開啟和運作,則問題就是本文中<如何使用疑難排解公用程式>一節開頭所列出的元件之一。 使用「疑難排解公用程式」來判斷導致問題的元件。 如果要使用「疑難排解公用程式」,您必須安裝 Support.dot。

注意: 如果使用 /a 參數開啟 Word 時,還是會發生問題,則不需使用「疑難排解公用程式」。

逐步說明: 使用疑難排解公用程式

如果要隔離並移除導致 Word 發生問題的元件,請使用「疑難排解公用程式」移除下列每個元件 (一次一個,以字母順序排列): 步驟 1: 刪除資料登錄機碼

步驟 2: 重新命名 Normal.dot 共用範本

步驟 3: 停用 Word 啟動資料夾增益集

步驟 4: 刪除 COM 增益集登錄機碼

步驟 5: 刪除選項登錄機碼

步驟 1: 刪除資料登錄機碼

最常使用的選項 (按一下 [工具] 功能表上的 [選項]) 是儲存在 [資料] 機碼中。 疑難排解步驟就是刪除 [資料] 機碼。 Word 會在下次啟動程式時,使用預設設定值重建此 [資料] 機碼。

注意: 刪除 [資料] 機碼,以便將數個選項重設為其預設設定,包括 [檔案] 功能表上最近使用過的檔案清單,以及您在 [選項] 對話方塊中所自訂的許多設定。

如果要刪除 [資料] 機碼,請遵循這些步驟:
  1. 結束所有 Office 程式。
  2. 使用 /a 參數啟動 Word。 如果要使用 /a 參數啟動 Word,請參閱本文中<使用 /a 參數啟動 Microsoft Word>一節。
  3. 開啟 Support.dot 範本。 如果要執行此項操作,請參閱本文中<如何開啟 Support.dot 範本>一節。
  4. 在 Support.dot 範本中,按一下 [疑難排解公用程式] 按鈕。
  5. [Microsoft Word 疑難排解公用程式] 對話方塊中的 [選取項目] 清單中按一下 [資料登錄機碼],再按一下 [刪除]
  6. 當您看見下列訊息時,按一下 [確定]
    HKEY_CURRENT_USER\Software\Microsoft Office\10.0\Word\Data
    此登錄鍵的備份檔位於:
    C:\WINDOWS\TEMP\wddata10.0

    已經刪除登錄鍵。
  7. 按一下 [結束]
  8. [檔案] 功能表上按一下 [結束],以關閉 Word。
  9. 以正常方式開啟 Word。請不要 使用本文中<使用 /a 參數啟動 Microsoft Word>一節的程序。
如果 Word 可以正常啟動及運作,表示這個問題已經解決了。而問題是發生在 [資料] 登錄機碼受損。您可能需要變更一些設定值,才能將 Word 恢復成您喜愛的選項。

如果問題沒有解決,請還原舊的 [資料] 登錄機碼。如果要執行這項操作,請依照以下步驟:
  1. 結束所有 Office 程式。
  2. 使用 /a 參數啟動 Word。 如果要使用 /a 參數啟動 Word,請參閱本文中<使用 /a 參數啟動 Microsoft Word>一節。
  3. 開啟 Support.dot 範本。 如果要執行此項操作,請參閱本文中<如何開啟 Support.dot 範本>一節。
  4. 在 Support.dot 範本中,按一下 [疑難排解公用程式] 按鈕。
  5. [Microsoft Word 疑難排解公用程式] 對話方塊中,在 [選取項目] 清單上按一下 [資料登錄機碼],再按一下 [還原]
  6. 當您看見下列訊息時,按一下 [是]
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Data

    這個鍵值位於登錄中。
    要覆寫嗎?
  7. 當您看見下列訊息時,按一下 [確定]
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Data

    登錄鍵還原成功。
  8. 執行下列操作之一:
回到使用疑難排解公用程式頁首

步驟 2:重新命名 Normal.dot 共用範本

如果要避免格式、自動圖文集與儲存在共用範本 (Normal.dot) 的巨集影響您開啟 Word 及文件的動作,請重新命名共用範本。重新命名此檔案後,您就可以馬上得知共用範本是否為造成問題的原因。

注意:重新命名 Normal.dot 檔案會使數個選項重新設定為預設值,包括自訂格式、自訂工具列、巨集與自動圖文集項目。因此,Microsoft 強烈建議您請勿刪除您的 Normal.dot 檔案。

某些設定可能會產生一個以上的 Normal.dot 檔案。這些情形包括了在同一部電腦上執行 Word 多重版本,或者同一部電腦上有數個工作站安裝程式。 在這些情況下,請確定重新命名的是 Normal.dot 的正確複本。

如果要重新命名 Normal.dot 檔案,請依照下列步驟:
  1. 結束所有 Office 程式。
  2. 使用 /a 參數啟動 Word。 如果要使用 /a 參數啟動 Word,請參閱本文中<使用 /a 參數啟動 Microsoft Word>一節。
  3. 開啟 Support.dot 範本。 如果要執行此項操作,請參閱本文中<如何開啟 Support.dot 範本>一節。
  4. 在 Support.dot 範本中,按一下 [疑難排解公用程式] 按鈕。
  5. [Microsoft Word 疑難排解公用程式] 對話方塊,在 [選取項目] 清單中按一下 [Normal.dot 共用範本],再按一下 [重新命名]
  6. 當您收到下列訊息時,按一下 [確定]
    path\Application Data\Microsoft\Templates\Normal.dot
    複製到
    path\Application Data\Microsoft\Templates\10Normal.dot
    注意: 指向 Normal.dot 檔案的路徑可能有所不同。
  7. 按一下[關閉],以關閉 [Microsoft Word 疑難排解公用程式] 對話方塊。
  8. [檔案] 功能表上按一下 [結束],以離開 Word。
  9. 以正常方式啟動 Word。請不要使用本文中<使用 /a 參數啟動 Microsoft Word>一節中的程序。
如果可以正確地開啟 Word,表示問題已經解決。此情形下,造成此問題的原因就是 Normal.dot 檔案受損。您可能需要變更一些設定值,才能將 Word 恢復成您喜愛的選項。如果您所重新命名的 Normal.dot 檔案包含難以重新建立的自訂值,例如格式、巨集或自動圖文集項目等,則可以使用「組合管理」,從 10Normal.dot 檔案 (舊的 Normal.dot 檔案) 將這些自訂值複製到新的 Normal.dot 檔案。

如需有關使用「組合管理」的詳細資訊,請按一下 [說明] 功能表上的 [Microsoft Word 說明],在「Office 小幫手」或「解答精靈」中輸入:組合管理,然後按一下 [搜尋],檢視所傳回的主題。

如果問題仍未解決,請還原舊的 Normal.dot 檔案 (10Normal.dot)。如果要執行這項操作,請依照以下步驟:
  1. 結束所有 Office 程式。
  2. 使用 /a 參數啟動 Word。 如果要使用 /a 參數啟動 Word,請參閱本文中<使用 /a 參數啟動 Microsoft Word>一節。
  3. 開啟 Support.dot 範本。 如果要執行此項操作,請參閱本文中<如何開啟 Support.dot 範本>一節。
  4. 在 Support.dot 範本中,按一下 [疑難排解公用程式] 按鈕。
  5. [Microsoft Word 疑難排解公用程式] 對話方塊,在 [選取項目] 清單中按一下 [Normal.dot 共用範本],再按一下 [還原]
  6. 當您收到下列訊息時,按一下 [是]
    path\Application Data\Microsoft\Templates\Normal.dot

    這個檔的備份已經存在。

    要覆寫嗎?
    注意: 指向 Normal.dot 檔的路徑可能有所不同。
  7. 當您看見下列訊息時,按一下 [確定]
    path\Application Data\Microsoft\Templates\10Normal.dot
    複製到
    path\Templates\Normal.dot
  8. 執行下列操作之一:
回到使用疑難排解公用程式頁首

步驟 3: 停用 Word 啟動資料夾增益集

當您啟動 Word 時,Word 會自動載入位於 [啟動] 資料夾中的範本與增益集。 Word 的錯誤可能會導致與增益集發生衝突或問題。如果要判斷是否為 [啟動] 資料夾的項目而導致此問題,您可以暫時停用指向這些增益集的登錄設定。

如果要暫時停用增益集登錄機碼,請依照下列步驟:
  1. 結束所有 Office 程式。
  2. 使用 /a 參數啟動 Word。 如果要使用 /a 參數啟動 Word,請參閱本文中<使用 /a 參數啟動 Microsoft Word>一節。
  3. 開啟 Support.dot 範本。 如果要執行此項操作,請參閱本文中<如何開啟 Support.dot 範本>一節。
  4. 在 Support.dot 範本中,按一下 [疑難排解公用程式] 按鈕。
  5. [Microsoft Word 疑難排解公用程式] 對話方塊中,在 [選取項目] 清單上按一下 [Word 啟動資料夾增益集],再按一下 [重新命名]
  6. 請執行下列操作之一:
    • 當您看見下列訊息時,按一下 [確定]
      找不到可供重新命名/還原的檔案。
      注意: 如果收到此訊息,當您啟動 Word 時,並不會載入任何增益集。 按一下 [確定] 之後,繼續本文中<步驟 4: 刪除 COM 增益集登錄機碼>一節。

      - 或者 -
    • 當您看見下列訊息時,按一下 [確定]
      path\Application Data\Microsoft\Word\Startup\file name
      複製到
      path\Application Data\Microsoft\Word\Startup\file name

      path\Program Files\Microsoft Office\Office10\Startup\file name
      複製到
      path\Program Files\Microsoft Office\Office10\Startup\file name
      注意: 系統上的路徑與檔名可能有所不同。
  7. 按一下 [關閉],以關閉 [Microsoft Word 疑難排解公用程式] 對話方塊。
  8. [檔案] 功能表上按一下 [結束],以關閉 Word。
  9. 以正常方式啟動 Word。請不要使用本文中<使用 /a 參數啟動 Microsoft Word>一節中的程序。
  10. 請執行下列操作之一:
    • 如果您再也沒有發生此問題,而啟動項目也在步驟 6 中加以移除,表示您已判斷出造成問題的原因是增益集項目。 如果要判斷導致問題的啟動項目,請依照下列步驟:
      1. 結束所有 Office 程式。
      2. 使用 /a 參數啟動 Word。 如果要使用 /a 參數啟動 Word,請參閱本文中<使用 /a 參數啟動 Microsoft Word>一節。
      3. 開啟 Support.dot 範本。 如果要執行此項操作,請參閱本文中<如何開啟 Support.dot 範本>一節。
      4. 在 Support.dot 範本中,按一下 [疑難排解公用程式] 按鈕。
      5. [Microsoft Word 疑難排解公用程式] 對話方塊,在 [選取項目] 清單中按一下 [Word 啟動資料夾增益集],再按一下 [還原]
      6. 當您收到下列訊息時,按一下 [確定]
        path\Application Data\Microsoft\Word\Startup\file name
        複製到
        path\Application Data\Microsoft\Word\Startup\file name

        path\Program Files\Microsoft Office\Office10\Startup\file name
        複製到
        path\Program Files\Microsoft Office\Office10\Startup\file name
        注意: 系統上的路徑與檔名可能有所不同。
      7. 按一下 [關閉],以關閉 [Microsoft Word 疑難排解公用程式] 對話方塊。
      8. [檔案] 功能表上按一下 [結束] 以關閉 Word。
      9. 按兩下 [我的電腦],然後開啟步驟 f 中所指定的資料夾之一。例如:
        path\Application Data\Microsoft\Word\Startup\

        - 或者 -

        path\Program Files\Microsoft Office\Office10\Startup\
      10. 在資料夾中的一個檔案上按一下滑鼠右鍵,再按一下捷徑功能表上的 [重新命名]
      11. 輸入新的檔名,再按下 ENTER。

        重要: 請記住檔案的原始名稱,因為您可能需要將檔案重新命名為原始名稱。
      12. 以正常方式啟動 Word。請不要使用本文中<使用 /a 參數啟動 Microsoft Word>一節中的程序。
      如果您再也沒有發生此問題,表示您已找出造成問題的特定增益集項目了。 如果您需要增益集項目所提供的功能,則必須找出包含特定項目的增益集,並且與供應商聯絡取得更新。

      如果問題仍未解決,請將增益集重新命名為原始名稱,然後為步驟 f 訊息所顯示特定資料夾中的每個檔案,重複步驟 h 到 i。

      - 或者 -

    • 如果您再也沒有發生此問題,表示您已找出造成問題的特定增益集項目了。 如果您需要增益集項目所提供的功能,則必須找出包含特定項目的增益集,並且與供應商聯絡取得更新。 如果問題仍未解決,請還原您的增益集項目,再繼續下一個步驟。 如果要執行此項操作,請依照下列步驟:
      1. 結束所有 Office 程式。
      2. 使用 /a 參數啟動 Microsoft Word。 如果要使用 /a 參數啟動 Word,請參閱本文中<使用 /a 參數啟動 Microsoft Word>一節。
      3. 開啟 Support.dot 範本。 如果要執行此項操作,請參閱本文中<如何開啟 Support.dot 範本>一節。
      4. 在 Support.dot 範本中,按一下 [疑難排解公用程式] 按鈕。
      5. [Microsoft Word 疑難排解公用程式] 對話方塊,在 [選取項目] 清單中按一下 [Word 啟動資料夾增益集],再按一下 [還原]
      6. 當您收到下列訊息時,按一下 [確定]
        path\Application Data\Microsoft\Word\Startup\file name
        複製到
        path\Application Data\Microsoft\Word\Startup\file name

        path\Program Files\Microsoft Office\Office10\Startup\file name
        複製到
        path\Program Files\Microsoft Office\Office10\Startup\file name
        注意: 系統上的路徑與檔名可能有所不同。
      7. 繼續本文中<步驟 4: 刪除 COM 增益集登錄機碼>一節。
回到使用疑難排解公用程式頁首

步驟 4: 刪除 COM 增益集登錄機碼

COM 增益集可以安裝在任何位置,並且能夠使用任何可與 Word 互動的程式來安裝。 如果要移除已安裝 COM 增益集的 Windows 登錄設定,請依照下列步驟:
  1. 結束所有 Office 程式。
  2. 使用 /a 參數啟動 Word。 如果要使用 /a 參數啟動 Word,請參閱本文中<使用 /a 參數啟動 Microsoft Word>一節。
  3. 開啟 Support.dot 範本。 如果要執行此項操作,請參閱本文中<如何開啟 Support.dot 範本>一節。
  4. 在 Support.dot 範本中,按一下 [疑難排解公用程式] 按鈕。
  5. [Microsoft Word 疑難排解公用程式] 對話方塊中的 [選取項目] 清單中按一下 [COM 增益集登錄機碼],再按一下 [刪除]
  6. 當您看見下列訊息時,按一下 [確定]
    HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins
    此登錄鍵的備份檔位於:
    C:\Windows\TEMP\wdaddn10.0

    已經刪除登錄鍵。
  7. 按一下 [關閉],以關閉 [Microsoft Word 疑難排解公用程式] 對話方塊。
  8. [檔案] 功能表上按一下 [結束] 以關閉 Word。
  9. 以正常方式啟動 Word。請不要使用本文中<使用 /a 參數啟動 Microsoft Word>一節中的程序。
  10. 請執行下列操作之一:
    • 如果您再也沒有發生此問題,表示您已判斷出造成問題的原因是 COM 增益集。 如果要判斷導致問題的 COM 增益集,請依照下列步驟:
      1. 結束所有 Office 程式。
      2. 使用 /a 參數啟動 Word。 如果要使用 /a 參數啟動 Word,請參閱本文中<使用 /a 參數啟動 Microsoft Word>一節。
      3. 開啟 Support.dot 範本。 如果要執行此項操作,請參閱本文中<如何開啟 Support.dot 範本>一節。
      4. 在 Support.dot 範本中,按一下 [疑難排解公用程式] 按鈕。
      5. [Microsoft Word 疑難排解公用程式] 對話方塊中的 [選取項目] 清單中按一下 [COM 增益集登錄機碼],再按一下 [還原]
      6. 當您看見下列訊息時,按一下 [確定]
        HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins

        登錄鍵還原成功。
      7. 按一下 [關閉],以關閉 [Microsoft Word 疑難排解公用程式] 對話方塊。
      8. [檔案] 功能表上按一下 [結束],以關閉 Word。
      9. 以正常方式啟動 Word。請不要使用本文中<使用 /a 參數啟動 Microsoft Word>一節中的程序。
      10. [工具] 功能表上按一下 [自訂]
      11. 按一下 [指令] 索引標籤。 在 [類別] 清單中按一下 [工具]
      12. [指令] 清單中按一下 [COM 增益集],再將指令拖曳到其中一個工具列中。
      13. 按一下 [關閉],以關閉 [自訂] 對話方塊。
      14. 按一下您先前在步驟 k 到 m 中所新增的 [COM 增益集] 按鈕。
      15. [COM 增益集] 對話方塊中,如果已列出增益集,請按一下以清除增益集核取方塊。

        注意: 如果列出一個以上的增益集,請一次清除一個增益集核取方塊,以判斷哪個是造成問題的增益集。
      16. 按一下[確定],以關閉 [COM 增益集] 對話方塊。
      17. 按一下 [檔案] 功能表上的 [結束],以關閉 Word。
      18. 以正常方式啟動 Word。請不要使用本文中<使用 /a 參數啟動 Microsoft Word>一節中的程序。
      19. 請執行下列操作之一:
        • 如果您再也沒有發生此問題,表示您已找出造成問題的 COM 增益集。 如果您需要增益集項目所提供的功能,則必須找出包含特定項目的增益集,並且與供應商聯絡取得更新。

          - 或者 -
        • 如果問題仍未解決,按一下您在步驟 k 到 m 中所新增的 [COM 增益集] 按鈕。按一下以選取您在步驟 o 中清除的核取方塊。然後按一下以清除不同增益集的核取方塊,再重複步驟 p 到 s。視您的需求,對各個增益集重複此步驟,直到您找出導致問題的增益集。
      - 或者 -

    • - 或者 -如果問題仍未解決,請還原您的 COM 增益集登錄機碼,再繼續下一個步驟。 如果要執行此項操作,請依照下列步驟:
      1. 結束所有 Office 程式。
      2. 使用 /a 參數啟動 Microsoft Word。 如果要使用 /a 參數啟動 Word,請參閱本文中<使用 /a 參數啟動 Microsoft Word>一節。
      3. 開啟 Support.dot 範本。 如果要執行此項操作,請參閱本文中<如何開啟 Support.dot 範本>一節。
      4. 在 Support.dot 範本中,按一下 [疑難排解公用程式] 按鈕。
      5. [Microsoft Word 疑難排解公用程式] 對話方塊中的 [選取項目] 清單中按一下 [COM 增益集登錄機碼],再按一下 [還原]
      6. 當您看見下列訊息時,按一下 [確定]
        HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins

        登錄鍵還原成功。
      7. 按一下 [關閉],以關閉 [Microsoft Word 疑難排解公用程式] 對話方塊。
      8. [檔案] 功能表上按一下 [結束],以關閉 Word。
      9. 繼續本文中<步驟 5: 刪除選項登錄機碼>一節。
回到使用疑難排解公用程式頁首

步驟 5: 刪除選項登錄機碼

[選項] 登錄機碼會儲存您在 Word 中變更功能表選項或執行 RegOptions 巨集所設定的一些選項。 這些都是可編輯的選項。

這些設定分成兩個群組: 預設設定與選擇性設定。 預設設定是在安裝時所建立的,您可以修改 Word 中的選項,以變更預設設定。 選擇性設定並非在安裝時建立的;如果要新增這些設定,您必須執行 RegOptions 巨集 (將在本文稍後章節中討論)。

如果要刪除 [選項] 機碼,請遵循這些步驟:
  1. 結束所有 Office 程式。
  2. 使用 /a 參數啟動 Word。 如果要使用 /a 參數啟動 Word,請參閱本文中<使用 /a 參數啟動 Microsoft Word>一節。
  3. 開啟 Support.dot 範本。 如果要執行此項操作,請參閱本文中<如何開啟 Support.dot 範本>一節。
  4. 在 Support.dot 範本中,按一下 [疑難排解公用程式] 按鈕。
  5. [Microsoft Word 疑難排解公用程式] 對話方塊中的 [選取項目] 清單中按一下 [選項登錄機碼],再按一下 [刪除]
  6. 當您看見下列訊息時,按一下 [確定]
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Options
    此登錄鍵的備份檔位於:
    C:\WINDOWS\TEMP\wdoptn10.0

    已經刪除登錄鍵。
  7. 以正常方式啟動 Word。請不要使用 /a 參數啟動 Microsoft Word,如本文中<使用 /a 參數啟動 Microsoft Word>一節所描述。
如果 Word 可以正確啟動和運作,表示您已經解決問題。而問題是發生在 [選項] 機碼受損。您可能需要變更一些設定值,才能將 Word 恢復成您喜愛的選項。

如果問題仍未解決,結束 Word,然後將 [選項] 機碼資訊新增回 Windows 登錄中。如果要執行這項操作,請依照以下步驟:
  1. 結束所有 Office 程式。
  2. 使用 /a 參數啟動 Word。 如果要使用 /a 參數啟動 Word,請參閱本文中<使用 /a 參數啟動 Microsoft Word>一節。
  3. 開啟 Support.dot 範本。 如果要執行此項操作,請參閱本文中<如何開啟 Support.dot 範本>一節。
  4. 在 Support.dot 範本中,按一下 [疑難排解公用程式] 按鈕,其位於檔案中所包含的表格中。
  5. [Microsoft Word 疑難排解公用程式] 對話方塊中的 [選取項目] 清單中按一下 [選項登錄機碼],再按一下 [還原]
  6. 當您看見下列訊息時,按一下 [是]
    HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Options

    這個鍵值位於登錄中。
    要覆寫嗎?
  7. 當您看見下列訊息時,按一下 [確定]
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Options

    登錄鍵還原成功。
  8. 按一下 [關閉],以關閉 [Microsoft Word 疑難排解公用程式] 對話方塊。
  9. [檔案] 功能表上按一下 [結束],以關閉 Word。
回到使用疑難排解公用程式頁首



如何使用登錄選項巨集

您可以使用 RegOptions 巨集檢查並變更 Windows 登錄中的 Word 設定。 下列列出巨集中所提供的各個選項及其用途簡介:
Word 選項

AutoSave-Path: 可以設定用來儲存自動回復檔案的資料夾。

DOC-Path: Word 文件所使用的預設資料夾。

Picture-Path: 可以設定當您指向 [插入] 功能表上的 [圖片],並按一下 [從檔案] 時所使用的預設路徑。

Startup-Path: 可以設定 Word 安裝檔案 (例如啟動 Word 時所載入的範本與 .wll 檔案 (WLL)) 的路徑。

Tools-Path: 可以設定校對工具、篩選器、轉換器與其他元件無法正確登錄或找不到時,Word 搜尋它們的位置。

User-Dot-Path: 使用者範本的路徑。 請注意,當 Word 中的此設定被變更時,會影響所有的 Microsoft Office 程式。

Workgroup-Dot-Path: 工作群組範本的路徑。 您可以指定 UNC 路徑。

BAK-Extension: Word 文件所使用的預設副檔名。 預設副檔名為 *.wbk。

DOC-Extension: Word 文件所使用的預設副檔名。 預設副檔名為 *.doc。

DOT-Extension: Word 範本所使用的預設副檔名。 預設副檔名為 *.dot。

NoFontMRUList: 開啟或關閉最近使用過的 (MRU) 字型清單。 如果要開啟 MRU 字型清單,請輸入 0 (零)。 如果要關閉 MRU 字型清單,請輸入 1

SpellingWavyUnderlineColor: 此選項可以讓您控制顯示在拼字錯誤下波浪狀底線的顏色。

GrammarWavyUnderlineColor: 此選項可以讓您控制顯示在文法錯誤下波浪狀底線的顏色。

SmartTagUnderlineColor: 此選項可以讓您控制顯示在智慧標籤下點狀底線的顏色。

FormatConsistencyWavyUnderlineColor: 此選項可以讓您控制顯示在格式錯誤下波浪狀底線的顏色。

OLEDOT: 可以指定當文件物件在 Word 或其他 OLE 程式中建立時所使用的文件範本。
方程式編輯器選項

Appdir: 方程式編輯器程式資料夾。 您必須為此編輯器及其他所顯示的方程式編輯器設定,安裝方程式編輯器並執行一次。

CustomZoom: 自訂縮放設定。 當「方程式編輯器」使用 ForceOpen 設定在另一個視窗啟動時才會生效。

ForceOpen: 強制「方程式編輯器」在自己的另一個視窗中啟動。 輸入 0 (零),以直接啟動,或者輸入 1,在另一個視窗中啟動。

ShowAll: 顯示或隱藏非列印字元。

ToolBarDocked: 可以設定是否停駐工具列。 選取 [是] (1) 或 [否] (0)。

ToolBarDockPos[方程式編輯器] 工具列停駐時的位置。 1 會將工具列設為位於 [方程式編輯器] 視窗頂端。 2 會將工具列設為位於 [方程式編輯器] 視窗底端。

ToolBarShown: 可以設定是否顯示工具列。 選取 [是] (1) 或 [否] (0)。

ToolBarWinPos: 工具列未停駐時的位置,以 X、Y 座標而指定,左上角為起點。 單位為像素。

顯示比例: 在 [檢視] 功能表中所選取的標準縮放比例。
如果要使用 RegOptions 巨集,請依照下列步驟執行:
  1. [檔案] 功能表上按一下 [開啟]
  2. [檔案類型] 方塊變更為 [文件範本 (*.dot)]
  3. [查詢] 方塊變更為:
    C:\Program Files\Microsoft Office\Office10\Macros\
  4. 按一下以選取 [Support.dot],再按一下 [開啟]
  5. 在檔案中所包含表格的 [巨集] 欄上,按一下 [登錄選項] 按鈕。
  6. [Word 選項] 索引標籤或 [方程式編輯器選項] 索引標籤上,按一下您想要變更的選項,在 [設定] 方塊中輸入新的設定 (或者按一下 [瀏覽],如果有的話,然後再按一下您想要變更的設定),再按一下 [變更]
  7. 按一下 [關閉],以關閉 [設定登錄選項] 對話方塊。


如何使用自動校正備份公用程式

您可以使用「自動校正備份」公用程式在電腦之間移動自動校正項目。如需有關「自動校正備份」公用程式的詳細資訊,請按一下下面的文件編號,檢視「Microsoft 知識庫」中的文件:
269006 WD2002:如何在電腦之間移動文字自動校正項目


僅適用於進階使用者

當您使用 Support.dot 範本中的巨集時,並不需要此章節中的資訊。 當您想要在 Microsoft Word 中共用這些巨集,或者想要檢視巨集程式碼時,才適合使用此資訊。



如何使巨集成為共用

如果要使巨集在 Microsoft Word 中共用,請使用下列方法之一。

方法 1: 新增至共用範本與增益集

如果您想要偶爾使用巨集 (或者想在決定是否輕易地存取巨集之前,先觀察巨集的行動),請新增巨集範本做為共用範本。

如果要將本文<摘要>一節中所列的範本新增為共用範本,請依照下列步驟:
  1. [工具] 功能表上按一下 [範本與增益集]
  2. [共用範本與增益集] 下按一下 [新增]
  3. [查詢] 方塊變更為包含範例巨集範本的資料夾。 在 [檔案類型] 方塊中選取 [所有檔案 (*.*)]
  4. 選取範例巨集範本,再按一下 [確定]
  5. 範例巨集範本出現在 [範本與增益集] 對話方塊中之後,請確定已選取此範本的核取方塊,然後按一下 [確定]

    重要: 當您載入 [共用範本與增益集] 中的範本時,範本只會載入目前的 Word 工作階段。 如果您結束並重新啟動 Word,範本就不會自動地重新載入。 您必須重新選取想要使用的範本。 如果要執行此項操作,請按一下 [工具] 功能表上的 [範本與增益集]。 在 [範本與增益集] 對話方塊中,按一下以選取您想要使用巨集的範本,再按一下 [確定]
  6. 如果要執行特定巨集,請依照下列步驟:
    1. [工具] 功能表上,指向 [巨集],再按一下 [巨集]
    2. [巨集] 對話方塊中,將 [巨集作用於] 方塊變更為包含您想要使用之巨集的範本。 例如,按一下以選取 [Support.dot (共用範本)]
    3. [巨集名稱] 清單中,按一下您想要的巨集,再按一下 [執行]

方法 2: 將範本新增至啟動資料夾

將範本移動到啟動資料夾中。 Microsoft Word 可以自動地存取至下列資料夾中範本的任何巨集:
C:\Program Files\Microsoft Office\Office10\Startup
使用 Microsoft [Windows 檔案總管],將範列巨集範本的複本放入啟動資料夾中。

當您啟動 Word 時,[啟動]資料夾中的範本會以共用範本載入,範本中的巨集也會出現在 [巨集] 對話方塊中,供您使用。 此方法的缺點是,Word 可能需要花費較長的時間才能啟動 (每次啟動,Word 都會載入這些共用範本)。

如果要執行一個特定巨集,請遵循下列步驟:
  1. [工具] 功能表上,指向 [巨集],再按一下 [巨集]
  2. [巨集] 對話方塊中,將 [巨集作用於] 方塊變更為包含您想要使用之巨集的範本。 例如,按一下以選取 [Support.dot (共用範本)]
  3. [巨集名稱] 清單中,按一下您想要的巨集,再按一下 [執行]

方法 3: 將巨集複製到一般範本中

如果想要在不需開啟範本的情況下執行特定巨集,請將巨集複製到您的共用範本 (Normal.dot) 中。如果要執行這項操作,請依照以下步驟:
  1. 開啟範例巨集範本
  2. [工具] 功能上按一下 [範本與增益集]
  3. [範本與增益集] 對話方塊中按一下 [組合管理]
  4. [組合管理] 對話方塊中,按一下以選取 [巨集專案項目] 索引標籤。
  5. 在範例巨集範本中的巨集會列在對話方塊的一側。 您的共用範本 (Normal.dot) 會在另一側顯示開啟。

    注意: 如果您的 Normal.dot (共用範本) 沒有開啟,請按一下相反側的 [關閉檔案][關閉檔案] 按鈕會變更為 [開啟檔案] 按鈕。按一下 [開啟檔案]。 按一下以選取您的 Normal.dot 範本檔,再按一下 [開啟]
  6. 在範例巨集範本側,按一下以選取列在範例巨集範本的巨集專案項目,然後按一下 [複製]

    注意: 如果要選取所列出的所有項目,在您按一下每個巨集專案項目的同時,也按住 CTRL。
  7. 按一下 [複製],以便將巨集專案項目複製到您的 Normal.dot 範本。
  8. 按一下 [確定],以關閉 [組合管理] 對話方塊。
  9. 如果要執行特定巨集,請依照下列步驟:
    1. [工具] 功能表上,指向 [巨集],再按一下 [巨集]
    2. [巨集] 對話方塊中,將 [巨集作用於] 方塊變更為包含您想要使用之巨集的範本。 例如,按一下以選取 [Normal.dot (共用範本)]
    3. [巨集名稱] 清單上,按一下以選取您想要的巨集,再按一下 [執行]


如何檢視巨集程式碼

Microsoft 提供之程式設計範例僅供說明之用,Microsoft 並不提供任何明示或默示之擔保,其中包括但不限於適售性以及適合某特定用途之默示責任擔保。本文假設您已熟悉我們所示範的程式設計語言,以及建立和偵錯程序所用的工具。Microsoft 支援人員可以解釋特定程序的功能,但不負責修改這些範例,以配合您的需求而提供其他功能或建構程序。若您的程式設計經驗有限,可以連絡 Microsoft Certified Partner,或 Microsoft 付費顧問專線 (800) 936-5200。如需有關 Microsoft Certified Partner 的詳細資訊,請造訪下列 Microsoft 全球資訊網網頁:
https://partner.microsoft.com/global/30000104
如需關於可使用的支援選項和如何聯絡 Microsoft 的詳細資訊,請造訪下列的 Microsoft 網站:
http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS
如果要檢視範例巨集的巨集程式碼,請依照下列步驟:
  1. [檔案] 功能表上按一下 [開啟舊檔]
  2. [開啟舊檔] 對話方塊中,將 [查詢] 方塊變更為包含範例巨集範本的資料夾,將 [檔案類型] 方塊變更為 [所有檔案 (*.*)],然後按一下以選取適當的範例巨集範本。
  3. 按著 SHIFT 並按一下 [開啟]
  4. [工具] 功能表中,指向 [巨集],再按一下 [巨集]
  5. [巨集] 對話方塊中,將 [巨集作用於] 方塊變更為您剛才所開啟的範例巨集範本。
  6. 選取適當的巨集,再按一下 [編輯]

屬性

文章編號: 289506 - 上次校閱: 2006年11月23日 - 版次: 1.1
這篇文章中的資訊適用於:
  • Microsoft Word 2002 Standard Edition
關鍵字:?
kbdta kbhowto kbhowtomaster KB289506
Microsoft及(或)其供應商不就任何在本伺服器上發表的文字資料及其相關圖表資訊的恰當性作任何承諾。所有文字資料及其相關圖表均以「現狀」供應,不負任何擔保責任。Microsoft及(或)其供應商謹此聲明,不負任何對與此資訊有關之擔保責任,包括關於適售性、適用於某一特定用途、權利或不侵權的明示或默示擔保責任。Microsoft及(或)其供應商無論如何不對因或與使用本伺服器上資訊或與資訊的實行有關而引起的契約、過失或其他侵權行為之訴訟中的特別的、間接的、衍生性的損害或任何因使用而喪失所導致的之損害、資料或利潤負任何責任。

提供意見

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com