Opening a Library in Windows Explorer gives error that it is no longer working

Article ID: 2895090 - View products that this article applies to.
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Symptoms

Consider the following scenario:
  • You have a PC running Windows 7 or Windows 8.
  • In Windows Explorer, you try to open a Library such as Documents, Music, Pictures or Videos.

In this scenario, when trying to open a library, you may encounter an error stating that that the is no longer working.  For example, accessing the Documents folder would cause the following error to appear:

Documents.library-ms is no longer working.
This library can be safely deleted from your computer.  Folders that have been included will not be affected.

Cause

The link to the library has become corrupt.

Resolution

To resolve this issue, follow the steps below.

NOTE: Following these steps to delete and recreate the libraries will not affect any of the data in your libraries.
  1. Open Windows Explorer.
  2. On the left-hand pane, find Libraries and select it. If you do not see Libraries listed, click on View on the menu at the top of the screen. Then click on the "Navigation pane" drop down and make sure that "Show libraries" has a check next to it.
  3. Highlight all of the libraries (Documents, Pictures, Music and Videos), right-click and choose Delete.
  4. On the left-hand pane, select Libraries, right-click and choose "Restore default libraries".
The libraries are then recreated and all of your data in the library folders should now be accessible again through the Windows Explorer Libraries.
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Properties

Article ID: 2895090 - Last Review: October 8, 2013 - Revision: 2.0
Applies to
  • Windows 7 Enterprise
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Ultimate
  • Windows 8
  • Windows 8 Pro
  • Windows 8 Enterprise
Keywords: 
KB2895090

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