Problemi di accesso alla posta elettronica in una distribuzione ibrida di Exchange con archivio basato sul cloud

Numero KB originale: 2901386

Nota

La configurazione guidata ibrida inclusa nel Exchange Management Console in Microsoft Exchange Server 2010 non è più supportata. Pertanto, non è più consigliabile usare la configurazione guidata ibrida precedente. Usare invece la procedura guidata configurazione ibrida di Microsoft 365 disponibile nella procedura guidata di configurazione ibrida di Microsoft 365. Per altre informazioni, vedere Configurazione guidata ibrida di Microsoft 365 per Exchange 2010.

Problema

Si riscontrano i sintomi seguenti in una distribuzione ibrida di Microsoft Exchange Server e Exchange Online locali in Microsoft 365:

  • Quando gli utenti locali provano a inviare messaggi di posta elettronica a un utente che dispone di un archivio basato sul cloud, ricevono un report non recapitario contenente il messaggio di errore seguente:

    554 5.2.0 STOREDRV. Deliver.Exception:UserWithoutFederatedProxyAddressException;

    Impossibile elaborare il messaggio a causa di un'eccezione permanente con il messaggio L'utente non ha alcun indirizzo proxy SMTP da un dominio federato.

    UserWithoutFederatedProxyAddressException: l'utente non ha alcun indirizzo proxy SMTP da un dominio federato. ##

  • Un utente che dispone di un archivio basato sul cloud non può accedere alla posta elettronica in Outlook o Outlook sul web (in precedenza noto come Outlook Web App [OWA]). L'utente riceve il messaggio di errore seguente in Outlook sul web:

    URL: <https://mail.contoso.com:443/owa/auth.owaOWA> versione: 14.3.146.0

    Tipo ExceptionException: messaggio eccezione System.NullReferenceException: riferimento all'oggetto non impostato su un'istanza di un oggetto.

Causa

Questo problema si verifica se i criteri degli indirizzi di posta elettronica hanno un dominio predefinito che non è un dominio federato. In questo modo, l'indirizzo SMTP predefinito nella cassetta postale di arbitrato federata usa un dominio che non può ottenere un token di delega.

Soluzione

  1. Verificare che si stia verificando questo problema:

    1. Aprire Exchange Management Shell nel server Exchange 2013 locale o nel server Exchange 2010.

    2. Eseguire il seguente cmdlet:

      Get-Mailbox -arbitration |fl PrimarySMTPAddress
      
    3. Nell'output prendere nota del dominio SMTP specificato per la cassetta postale FederatedEmail.

      Di seguito è riportato un esempio dell'output:

      Screenshot che mostra un esempio dell'output, che prende nota del dominio S M T P specificato per la cassetta postale FederatedEmail.

    4. Eseguire il seguente cmdlet:

      get-FederatedOrganizationIdentifier |fl Domains
      
    5. Controllare se il dominio annotato nel passaggio 1C è elencato. Se il dominio non è elencato, è stato verificato che si stia verificando questo problema. Andare al passaggio 2.

  2. Per risolvere il problema, eseguire una delle operazioni seguenti:

    • Federate il dominio SMTP associato alla cassetta postale di arbitrato

      A tale scopo, usare l'interfaccia di amministrazione di Exchange o il Exchange Management Console per aggiungere il nome di dominio all'attendibilità federativa esistente.

      Per altre informazioni su come eseguire questa operazione, vedere Gestire un trust federativo.

    • Modificare l'indirizzo SMTP della cassetta postale di arbitrato e il contenitore delle impostazioni di trasporto in Active Directory

      Modificare l'indirizzo di posta elettronica della cassetta postale di arbitrato federata per usare un dominio federato. Modificare anche l'indirizzo di posta elettronica del contenitore delle impostazioni di trasporto in modo che corrisponda all'indirizzo di posta elettronica della cassetta postale di arbitrato federata.

      Avviso

      Questa procedura richiede active directory service interfaces Editor (ADSI Edit). L'uso non corretto di ADSI Edit può causare gravi problemi che potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non può garantire che i problemi derivanti dall'uso non corretto di ADSI Edit possano essere risolti. Usare ADSI Edit a proprio rischio.

      A tal fine, attenersi alla seguente procedura:

      1. Aprire MODIFICA ADSI e connettersi al contenitore del contesto di denominazione del dominio.

      2. In Contesto di denominazione predefinito aprire le proprietà della cassetta postale di arbitrato federata nel contenitore Utente .

      3. Modificare il valore dell'attributo proxyAddress in modo che l'indirizzo SMTP primario (l'indirizzo in cui SMTP è in lettere maiuscole) usi un dominio federato.

      4. Connettersi al contenitore di configurazione e quindi individuare il contenitore delle impostazioni di trasporto nel percorso seguente:

        Configurazione \ Servizi \ Microsoft Exchange \ <nome> organizzazione

      5. Aprire le proprietà del contenitore delle impostazioni di trasporto e quindi modificare il valore dell'attributo MSExchOrgFederatedMailbox nell'indirizzo SMTP specificato nel passaggio 3.