기술 자료 문서 Office XP 프로그램 예제 코드를 실행하는 방법

기술 자료 번역 기술 자료 번역
기술 자료: 290140 - 이 문서가 적용되는 제품 보기.
이 문서에서는 Microsoft Office 2000 버전에 212536 참조하십시오.
Microsoft Office 97용 이 문서의 버전 173707 참조하십시오.
있는 Microsoft Office 2001년에 대해 Mac이 이 문서의 버전에 대한 274703 참조하십시오.
이 문서에서는 Microsoft Office 98 Macintosh 버전 버전에 181058 참조하십시오.
모두 확대 | 모두 축소

이 페이지에서

요약

Microsoft 기술 자료 샘플 코드를 VBA 응용 매크로를 포함할 문서 수를 포함합니다. 이러한 매크로는 많은 다양한 Office XP 프로그램에 대해 Visual Basic에서 프로그래밍의 기본 개념을 보여 줍니다. 이 문서에서는 새 매크로를 만들 수 있는 예제 코드를 사용하는 방법 및 해당 매크로를 실행하는 방법에 대한 지침이 들어 있습니다.

추가 정보

Microsoft는 묵시적인 보증 없이 목적으로만 프로그래밍 예제를 제공합니다. 이 포함되지만, 상품성 또는 특정 목적에의 적합성에 대한 묵시적인된 보증이 제한되지 않습니다. 이 문서에서는 만들려면 및 프로시저를 디버깅하는 데 사용되는 도구 및 여기서 설명하는 프로그래밍 언어에 익숙한 사용자를 대상으로 합니다. Microsoft 지원 엔지니어는 사용자에게 도움이 되도록 특정 절차에 대한 기능을 설명할 수 있지만 추가 기능을 제공하거나 특정 요구 사항에 맞도록 프로시저를 구성하지는 이 예제를 수정하지 않습니다. 기술 자료 문서 샘플 코드를 사용하려면 새 VBA 매크로 (추가하거나 합니다 기존 매크로를 선택합니다). 이 매크로는 다음 방법 중 하나를 사용하여 코드 복사 및 붙여넣기 또는 형식 샘플은 다음 작업을 수행할 수 있습니다.

새 매크로 만들기

  1. 열 또는 사용 중인 Office 프로그램에서 서식 파일을 만듭니다.
  2. 도구 메뉴에서 매크로 를 가리킨 다음 매크로 클릭하십시오.
  3. Word 매크로 위치 목록에서 선택한 서식 파일이나 문서에서 원하는 매크로를 저장합니다.
  4. 매크로 이름 상자에서 매크로 이름을 입력하십시오.
  5. VBA 편집기를 열려면 만들기 클릭하십시오.
  6. 다음 중 하나를 실행하십시오.
    • End Sub 줄이 Sub Macroname() 줄 사이의 매크로 코드를 입력하십시오.
      Sub macroname()
          Type your macro code here
      End Sub
      							
      -or-
    • 다음 이 단계를 수행하여 매크로 샘플 코드에 붙여 넣을:
      Sub macroname()
       
      End Sub
      						
      1. Microsoft Internet Explorer 같은 Microsoft 기술 자료 문서 보는 데 사용하는 프로그램을 전환하십시오.
      2. 샘플 코드를 선택하려면 Ctrl 키를 누른 채 및 다음 코드 단일 클릭하십시오.
      3. 편집 메뉴에서 복사 를 클릭하십시오.
      4. Visual Basic 편집기로 전환하십시오.
      5. Visual Basic 편집기에서 Sub Macroname() 매크로의 End Sub 위해 기존 코드 텍스트를 선택하십시오.
      6. 편집 메뉴에서 붙여넣기 를 클릭하십시오.

        참고: 붙여넣을 때 기존 코드를 텍스트 기술 자료 복사한 코드가 대체됩니다.
  7. 입력 또는 매크로 코드를 붙여 후 닫고 돌아가기 Microsoft program파일 메뉴에서 사용 중인 Microsoft Office XP 프로그램에서 program 위치 클릭하십시오.


참고: 텍스트를 들여쓰려면 Tab 키를 사용합니다. 아포스트로피 (') 로 시작하는 줄은 주석이며 매크로를 실행할 필요가 없습니다. 그러나 해당 매크로를 이해하기 쉽게 입력합니다 할 수 있습니다.

예제 코드를 사용하여 모듈 추가

모듈에 코드를 추가하려면 기존 모듈을 없거나 새 모듈을 만들어야 합니다. 이렇게 하려면 다음과 같이 하십시오.
  1. 열 또는 사용 중인 Office 프로그램에서 서식 파일을 만듭니다.
  2. 도구 메뉴에서 매크로 를 가리킨 다음 Visual Basic Editor 를 클릭하십시오.
  3. 프로젝트 창 중 Visual Basic Editor (기본적으로 왼쪽 위 때문입니다) 에서 서식 파일이나 문서에 같은 이름 가진 프로젝트 아이콘을 클릭하십시오. 서식 파일이나 문서를 저장하지 않은 경우 프로젝트 이름을 Project(Document1) 또는 TemplateProject(Template1) 비슷할 것입니다.

    참고 FOR WORD 사용자: 기본 전역 서식 파일에 Normal.dot, 매크로를 저장하도록 하려면 기본 프로젝트를 두 번 클릭합니다.
  4. 클릭하면 프로젝트 모듈 아래에 폴더가 없으면 삽입 메뉴에서 모듈 을 클릭하십시오.
  5. 만들려는 모듈 코드 창의 아무 곳이나 클릭하십시오. 일반적으로 코드 창에 다음 Visual Basic Editor의 오른쪽 위 모퉁이에 있습니다.
  6. Sub Macroname() 및 End Sub 줄이 비롯하여 기술 자료 문서 정확히 있는 예제 코드를 입력하거나 붙여 넣습니다.

    참고: 입력하거나 매크로 코드를 붙여 넣는 방법에 대한 자세한 내용은 이 문서의 "대상 만들기 위한 새 매크로" 단원을 참조하십시오.
입력하거나 해당 매크로 코드를 붙여 후, [파일] 메뉴에서 [닫고 돌아가기 Microsoft program 을 클릭하십시오

program

매크로 실행

  1. 도구 메뉴에서 매크로 를 가리킨 다음 매크로 클릭하십시오.
  2. 매크로 이름 목록에서 매크로 이름을 선택하고 실행 을 클릭하십시오.

참조

각 Office 프로그램에 대한 Microsoft 도움말을 매크로로 작업하는 방법에 대한 여러 항목이 들어 있습니다. Visual Basic 도움말 코드를 직접 작성하는 방법에 대한 정보가 들어 있습니다.

속성

기술 자료: 290140 - 마지막 검토: 2007년 5월 7일 월요일 - 수정: 3.5
본 문서의 정보는 다음의 제품에 적용됩니다.
  • Microsoft Excel 2002 Standard Edition
  • Microsoft Outlook 2002 Standard Edition
  • Microsoft PowerPoint 2002 Standard Edition
  • Microsoft Word 2002 Standard Edition
키워드:?
kbmt kbfaq kbhowto kbmacro kbprogramming KB290140 KbMtko
기계 번역된 문서
중요: 본 문서는 전문 번역가가 번역한 것이 아니라 Microsoft 기계 번역 소프트웨어로 번역한 것입니다. Microsoft는 번역가가 번역한 문서 및 기계 번역된 문서를 모두 제공하므로 Microsoft 기술 자료에 있는 모든 문서를 한글로 접할 수 있습니다. 그러나 기계 번역 문서가 항상 완벽한 것은 아닙니다. 따라서 기계 번역 문서에는 마치 외국인이 한국어로 말할 때 실수를 하는 것처럼 어휘, 구문 또는 문법에 오류가 있을 수 있습니다. Microsoft는 내용상의 오역 또는 Microsoft 고객이 이러한 오역을 사용함으로써 발생하는 부 정확성, 오류 또는 손해에 대해 책임을 지지 않습니다. Microsoft는 이러한 문제를 해결하기 위해 기계 번역 소프트웨어를 자주 업데이트하고 있습니다.

피드백 보내기

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com