Jak spustit ukázkový kód v aplikacích sady Office XP z článků znalostní báze Knowledge Base

Překlady článku Překlady článku
ID článku: 290140 - Produkty, které se vztahují k tomuto článku.
Microsoft Office 2000 verzi tohoto článku v tématu 212536.
Aplikace Microsoft Office 97 verzi tohoto článku v tématu 173707.
Microsoft Office 2001 pro Mac verzi tohoto článku v tématu 274703.
Microsoft Office 98 Macintosh Edition verzi tohoto článku v tématu 181058.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Souhrn

Znalostní báze Microsoft Knowledge Base obsahuje několik článků obsahujících ukázkový kód pro jazyk Visual Basic pro makra aplikace. Mnohé z těchto maker znázorňují základní koncepty programování v jazyce Visual Basic různých aplikacích sady Office XP. Tento článek obsahuje pokyny, jak použití ukázkového kódu, chcete-li vytvořit nové makro a jak tato makra spustit.

Další informace

Společnost Microsoft poskytuje ukázky programování pouze pro ilustraci bez žádné záruky výslovně uvedené nebo mlčky. To zahrnuje, ale není omezen pouze na předpokládaných záruk vztahujících se k obchodovatelnosti nebo vhodnosti pro určitý účel. Tento článek předpokládá, že jste je obeznámen s programovacím jazykem, který je předmětem ukázky a s nástroji, které slouží k vytvoření a ladění skriptu. Pracovníci technické podpory společnosti Microsoft mohou vysvětlit funkce určitého postupu však nemohou tyto příklady přidány funkce nebo vytvářet postupy podle svých specifických požadavků. Chcete-li použít ukázkový kód z Knowledge Base v článku, musíte přidat nové makro v jazyce Visual Basic (nebo vyberte existující makro). Můžete pak typ vzorku nebo kopírování a vkládání kódu do toto makro pomocí následujících metod.

Vytvoření nového makra

  1. Otevřete nebo vytvořte šablonu v aplikaci sady Office, kterou používáte.
  2. V nabídce Nástroje přejděte na příkaz makro a klepněte na příkaz makra.
  3. Aplikace Word vyberte v seznamu maker v šabloně nebo dokumentu, kam chcete makro uložit.
  4. Do pole Název makra zadejte název makra.
  5. Klepnutím na tlačítko vytvořit otevřete Editor jazyka Visual Basic.
  6. Proveďte jednu z následujících akcí:
    • Zadejte kód makra mezi řádkem Sub Macroname() a řádku End Sub.
      Sub macroname()
          Type your macro code here
      End Sub
      							
      -or-
    • Zkopírujte a vložte ukázkový kód makra pomocí následujícího postupu:
      Sub macroname()
       
      End Sub
      						
      1. Přepněte do programu, který používáte k zobrazení článku znalostní báze Microsoft Knowledge Base, jako je například Microsoft Internet Explorer.
      2. Vyberte ukázkový kód, podržte klávesu CTRL a potom klepnutí kód.
      3. V nabídce Úpravy klepněte na příkaz Kopírovat.
      4. Přepněte do editoru jazyka Visual Basic.
      5. V editoru jazyka Visual Basic vyberte existující kód znění Sub Macroname() k End Sub makra.
      6. V nabídce Úpravy klepněte na příkaz Vložit.

        Poznámka: Když vložíte, existující kód se nahrazuje kódem, který jste zkopírovali z článku znalostní báze Knowledge Base.
  7. Po zadáním nebo vložením kód makra, klepněte na příkaz Close and Return to Microsoft program v nabídce soubor kde program je aplikace Microsoft Office XP, kterou používáte.


Poznámka: text odsadíte pomocí klávesy TAB. Řádky začínající apostrof (') jsou komentáře a nejsou nutná ke spuštění makra. Chcete však zadejte je usnadnit pochopení makro.

Ukázkový kód přidání do modulu

Chcete-li modul přidat kód, musíte buď mít existující modul nebo vytvořte nový modul. Chcete-li to provést, postupujte takto:
  1. Otevřete nebo vytvořte šablonu v aplikaci sady Office, kterou používáte.
  2. V nabídce Nástroje přejděte na příkaz makro a potom klepněte na příkaz Editor jazyka Visual Basic.
  3. V okně projektu z editoru jazyka Visual Basic (ve výchozím nastavení v levém horním rohu) klepněte na ikonu projekt se stejným názvem jako šablonu nebo dokument. Pokud jste dosud neuložili šablonu nebo dokument, bude název projektu podobný Project(Document1) nebo TemplateProject(Template1).

    Poznámka pro uživatele WORD: Chcete-li uložit makro v výchozí globální šablonu Normal.dot, poklepejte na Normální projektu.
  4. Pokud projekt, který jste klepli na možnost neobsahuje složku s názvem moduly pod ním, klepněte na příkaz Module v nabídce Vložit.
  5. Klepněte na libovolné místo v okně kódu modulu, který chcete vytvořit. Okno kód je obvykle v pravém horním rohu editoru jazyka Visual Basic.
  6. Zadejte nebo vložte ukázkový kód přesně tak, jak je uveden v článku znalostní báze Knowledge Base, včetně řádků Sub Macroname() a End Sub.

    Poznámka: Další informace o zadání nebo vložení kódu makra, prosím získáte v části "Na vytvoření nového makra" v tomto článku.
Po zadání nebo vložení kód makra, Zavřít a návrat do Microsoft program nabídce klepněte na příkaz soubor

kde program je aplikace Microsoft Office XP, kterou používáte.

Pro spuštění makra

  1. V nabídce Nástroje přejděte na příkaz makro a klepněte na příkaz makra.
  2. Vyberte v seznamu Název makra název makra a klepněte na příkaz Spustit.

Odkazy

Nápovědy pro každou aplikaci sady Office obsahuje mnoho témata o práci s makry. Nápověda pro Visual Basic obsahuje podrobné informace o psaní vlastního kódu.

Vlastnosti

ID článku: 290140 - Poslední aktualizace: 7. května 2007 - Revize: 3.5
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Excel 2002 Standard Edition
  • Microsoft Outlook 2002 Standard Edition
  • Microsoft PowerPoint 2002 Standard Edition
  • Microsoft Word 2002 Standard Edition
Klíčová slova: 
kbmt kbfaq kbhowto kbmacro kbprogramming KB290140 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:290140

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com