Como executar o código de exemplo para programas do Office XP a partir de artigos da Base de dados de Conhecimento

Traduções deste artigo Traduções deste artigo
ID do artigo: 290140 - Exibir os produtos aos quais esse artigo se aplica.
Para uma versão deste artigo do Microsoft Office 2000, consulte 212536.
Para um Microsoft Office 97 versão deste artigo, consulte 173707.
Para um Microsoft Office 2001 para Mac versão deste artigo, consulte 274703.
Para uma versão deste artigo do Microsoft Office 98 Macintosh Edition, consulte 181058.
Expandir tudo | Recolher tudo

Neste artigo

Sumário

Base de dados de Conhecimento contém um número de artigos que incluem o código de exemplo para o Visual Basic para aplicativos macros. Muitas dessas macros ilustram os conceitos básicos da programação no Visual Basic para os vários programas do Office. Este artigo contém instruções sobre como usar o código de exemplo para criar uma nova macro e como executar a macro.

Mais Informações

Microsoft fornece exemplos de programação apenas para ilustração, sem garantia expressa ou implícita. Isso inclui, mas não está limitado a, garantias implícitas de comercialização ou adequação para uma finalidade específica. Este artigo presume que você está familiarizados com a linguagem de programação que está sendo demonstrada e com as ferramentas que são usadas para criar e depurar procedimentos. Engenheiros de suporte podem ajudar a explicar a funcionalidade de um determinado procedimento, mas eles não modificarão esses exemplos para fornecer funcionalidades adicionais ou construir procedimentos para atender às suas necessidades. Para usar o código de exemplo de um artigo do Knowledge Base, você deve adicionar uma nova macro do Visual Basic (ou selecione uma macro existente). Você pode então copiar-e-colar ou tipo o exemplo de código para essa macro usando qualquer um dos seguintes métodos.

Para criar uma nova macro

  1. Abra ou crie um modelo no programa do Office que você está usando.
  2. No menu Ferramentas , aponte para macro e, em seguida, clique em macros .
  3. Na lista macros em , selecione a palavra modelo ou documento onde deseja salvar a macro.
  4. Na caixa Nome da macro , digite um nome para a macro.
  5. Clique em criar para abrir o Editor do Visual Basic.
  6. Siga um destes procedimentos:
    • Digite o código de macro entre a linha macroname() sub e a linha End Sub.
      Sub macroname()
          Type your macro code here
      End Sub
      							
      -or-
    • Copie e cole o código de exemplo para sua macro seguindo estas etapas:
      Sub macroname()
       
      End Sub
      						
      1. Alterne para o programa que você está usando para ler o artigo Microsoft Knowledge Base, como o Microsoft Internet Explorer.
      2. Para selecionar o código de exemplo, mantenha pressionada a tecla CTRL e, em seguida, clique único o código.
      3. No menu Editar , clique em Copiar .
      4. Alterne para o Editor do Visual Basic.
      5. No Editor do Visual Basic, selecione o texto existente do código da sub macroname() para End Sub da macro.
      6. No menu Editar , clique em Colar .

        Observação: Quando você cola, o texto de código existente será substituído com o código que você copiou do artigo da Base de dados de Conhecimento.
  7. Depois de digitar ou colar o código para sua macro, clique em Fechar e voltar para Microsoft program no menu arquivo no qual é program Microsoft Office XP que você está usando.


Observação : Use a tecla TAB para recuar o texto. Linhas que começam com um apóstrofo (') são comentários e não são necessários para executar a macro. No entanto, convém digitá-los para facilitar a entender a macro.

Para adicionar o código de exemplo para um módulo

Para adicionar código a um módulo, você deve ter um módulo existente ou crie um novo módulo. Para fazer isso, execute as seguintes etapas:
  1. Abra ou crie um modelo no programa do Office que você está usando.
  2. No menu Ferramentas , aponte para macro e, em seguida, clique em Editor do Visual Basic .
  3. Na janela de projeto do Visual Basic Editor (por padrão que isso fica no canto superior esquerdo), clique no ícone projeto com o mesmo nome de seu modelo ou documento. Se você ainda não tiver salvo o modelo ou documento, o nome do projeto será semelhante a Project(Document1) ou TemplateProject(Template1).

    Observação para o WORD USERS : se você deseja armazenar a macro no modelo global padrão, normal.dot, clique duas vezes no projeto normal .
  4. Se o projeto que você clicou não contiver uma pasta chamada módulos abaixo dele, clique em módulo no menu Inserir .
  5. Clique em qualquer lugar da janela de código do módulo que você deseja criar. A janela de código geralmente está no canto superior direito do Editor do Visual Basic.
  6. Digite ou cole o código de exemplo exatamente como ele aparece no artigo do Knowledge Base, incluindo linhas macroname() sub e End Sub.

    Observação : para obter mais informações sobre digitando ou colando o código da macro, consulte a seção "Para criar uma nova macro" neste artigo.
Depois de digitar ou colar o código para sua macro, clique em Fechar e retornar ao program no menu arquivo

onde é program.

Para executar a macro

  1. No menu Ferramentas , aponte para macro e, em seguida, clique em macros .
  2. Selecione o nome da macro na lista Nome da macro e, em seguida, clique em Executar .

Referências

Ajuda do Microsoft para cada programa do Office contém vários tópicos sobre como trabalhar com macros. Ajuda do Visual Basic contém informações abrangentes sobre como escrever seu próprio código.

Propriedades

ID do artigo: 290140 - Última revisão: segunda-feira, 7 de maio de 2007 - Revisão: 3.5
A informação contida neste artigo aplica-se a:
  • Microsoft Excel 2002 Standard Edition
  • Microsoft Outlook 2002 Standard Edition
  • Microsoft PowerPoint 2002 Standard Edition
  • Microsoft Word 2002 Standard Edition
Palavras-chave: 
kbmt kbfaq kbhowto kbmacro kbprogramming KB290140 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 290140

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com