パスワードのリセット後に証明書の EFS、資格情報、秘密キーが使用できなくなる

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文書番号: 290260 - 対象製品
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目次

現象

ワークグループに参加している Microsoft Windows XP ベースのコンピュータで、アカウントのパスワードをリセットした後、そのユーザーに関する以下の情報やファイルにアクセスできなくなることがあります。
  • Web ページの資格情報
  • ファイル共有の資格情報
  • EFS で暗号化されたファイル
  • 秘密キーを含む証明書 (署名付きまたは暗号化された電子メール)

原因

この問題は、ユーザー自身が変更していないパスワードを管理者または所有者が強制的にリセットした場合に発生する可能性があります。

解決方法

: 以下の解決方法はいずれも、ユーザーの元のアカウントとプロファイルが存在し、ユーザーが最後にデータにアクセスしてからプロファイルが変更されていない場合に有効です。

すべてのデータを回復するには、以下のいずれかが必要です。
  • 元のパスワード。これは、ユーザーが最後にログオンに成功し、資格情報およびファイルにアクセスできたときに使用したパスワードです。
  • パスワード リセット ディスク (PRD)。ユーザーがファイルにアクセスできていたときに、このパスワード リセット ディスクが作成済みである必要があります。

元のパスワードを使用して完全に回復する

  1. リセット後のパスワードを使用してコンピュータにログオンします。
  2. [スタート] ボタンをクリックし、[コントロール パネル] をクリックします。
  3. [ユーザー アカウント] をクリックします。
  4. [作業を選びます] の [アカウントの変更] をクリックします。
  5. 使用しているユーザー名をクリックします。
  6. [パスワードを変更する] をクリックします。
  7. 表示される指示に従って、パスワードを変更して元のパスワードに戻します。
  8. コンピュータを再起動します。

パスワード リセット ディスクを使用して完全に回復する

  1. コンピュータにログオンしている場合は、ログオフします。
  2. 誤ったパスワードでコンピュータにログオンを試みます。
  3. [パスワード リセット ディスクを使う] をクリックします。
  4. ウィザードの指示に従います。
  5. ログオンし、ファイルにアクセスできることを確認します。

EFS で暗号化されたデータへのアクセスを回復する

暗号化ファイル システム (EFS) を使用していくつかのファイルを暗号化した場合は、これらの暗号化ファイルへのアクセスを回復するための追加オプションがあります。以下の方法は EFS で暗号化されたファイルにのみ適用されます。以下の方法を実行しても、保存された資格情報や証明書へのアクセスは回復されません。

以前にユーザーのアカウントからユーザーの EFS 秘密キーをエクスポートしている場合は、このキーをアカウントにインポートし直して、暗号化ファイルへのアクセスを回復することができます。

秘密キーをエクスポートしておらず、ファイルを暗号化する前にデータ回復エージェント (DRA) を定義してある場合は、データ回復エージェントとして EFS ファイルへのアクセスを回復することができます。 このような事例でのデータ回復方法に関連する情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
255742 Methods for Recovering Encrypted Data Files
上記の回復方法に必要なファイルや情報がない場合、データは暗号化されたままになり、回復できません。

状況

この動作は仕様です。

詳細

この資料に記載されている動作は、ユーザーの個人情報のセキュリティを保護するためのセキュリティ対策です。ユーザーのパスワードをリセットしてユーザーのアカウントにアクセスすることが可能な、悪意のある管理者が、ユーザーの許可なく無断で暗号化ファイルや認証資料にアクセスすることはできません。

パスワードのリセットが許可される前に、コンピュータの管理者または所有者には、以下のメッセージが表示されます。
  • このパスワードをリセットすることにより復元できない情報の損失が発生する場合があります。セキュリティのため、Windows の機能により、パスワードがリセットされた場合に特定の情報へのアクセスを不可能にすることにより、その情報を保護します。

    このデータ損失は、ユーザーの次回ログオフ時に発生します。

    ユーザーがパスワードを忘れて、さらにパスワード リセット ディスクが無い場合にだけこのコマンドを使用してください。ユーザーがパスワード リセット ディスクを作成している場合には、ユーザーがそのディスクを使ってパスワードを設定してください。

    ユーザーがパスワードを知っていて変更する場合は、ユーザーがログオンしてから、コントロール パネルの [ユーザー アカウント] を使ってパスワードを変更する必要があります。
  • ユーザー名 のパスワードをリセットしようとしています。リセットすると、ユーザー名 は EFS で暗号化されたファイル、Web サイトやネットワーク リソースのための個人証明書や保存しているパスワードをすべて失います。

    ユーザー名 がパスワードを忘れた場合は、パスワード リセット ディスクを使うことができます。
今後、パスワードのリセットによってデータを失わないようにするには、パスワードをリセットするためのパスワード リセット ディスクを作成し、ユーザーがログオンしている間にユーザー自身でパスワードを変更します。

パスワード リセット ディスクを作成するには、次の手順を実行します。
  1. [スタート] ボタンをクリックし、[コントロール パネル] をクリックします。
  2. [ユーザー アカウント] をクリックします。
  3. [作業を選びます] の [アカウントの変更] をクリックします。
  4. 使用しているユーザー名をクリックします。
  5. [関連した作業] の [パスワードを忘れないようにする] をクリックし、ウィザードの指示に従います。
  6. ディスクを安全な場所に格納します。
: ドメインに参加しているコンピュータでは、[パスワードを忘れないようにする] およびパスワード リセット ディスクの機能を使用できません。

EFS 関連の情報

241201 暗号化ファイル システムの秘密キーをバックアップする方法
DPAPI によるデータの保護方法の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
309408 DPAPI (データ保護 API) のトラブルシューティング

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 290260 (最終更新日 2003-04-28) を基に作成したものです。

プロパティ

文書番号: 290260 - 最終更新日: 2005年12月19日 - リビジョン: 2.0
この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
キーワード:?
kbenv kberrmsg kbprb kbtool KB290260
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