IDENTIFICADOR de suceso 54 cuando se Detener depuración de un programa que utiliza la API de DirectX

Seleccione idioma Seleccione idioma
Id. de artículo: 290312 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

Síntomas

Cuando detenga la depuración un programa que utiliza la interfaz de programación de aplicaciones (API) de DirectX en Developer Studio, puede parecer que el programa deja de responder (se bloquea) durante varios minutos. Durante este tiempo, no puede terminar la tarea de programa en el Administrador de tareas, ni puede iniciar una nueva instancia del programa.

Después de varios minutos, Visor de sucesos registra varias instancias de los siguientes mensajes:
No se encuentra la descripción para el identificador del suceso (54) en el origen (wdmaud). El equipo local no tiene la información de registro necesaria o los archivos DLL de mensajes para mostrar mensajes desde un equipo remoto.

Causa

Este comportamiento se produce porque el controlador de audio de modelo de controlador de Windows (WDM) (WDMAUD.sys) no proporciona una rutina de cancelación de paquetes de solicitud de E/s (IRP).

Solución

Para resolver este problema, obtenga el Service Pack más reciente de Windows 2000. Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
260910Cómo obtener el Service Pack más reciente para Windows 2000

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:" de este artículo.

Este problema se corrigió por primera vez en el Service Pack 2 de Windows 2000.




Propiedades

Id. de artículo: 290312 - Última revisión: miércoles, 31 de enero de 2007 - Versión: 3.2
La información de este artículo se refiere a:
  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Professional SP1
Palabras clave: 
kbmt kbbug kbenv kbfix kbprogramming kbwin2000presp2fix KB290312 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 290312

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com