Verbindungsfehler des Terminaldiensteclients 0xC000035B bei Verwendung von LmCompatibility

Dieser Artikel bietet eine Lösung für einen Fehler 0xC000035B, der auftritt, wenn eine Terminaldienste-Clientverbindung, die RDP 8.0 (Remotedesktopprotokoll) verwendet, um eine Verbindung über einen Windows Server 2012 RD-Gatewayserver herzustellen.

Gilt für: Windows Server 2012 R2
Ursprüngliche KB-Nummer: 2903333

Symptome

Eine Terminaldienste-Clientverbindung, die RDP 8.0 (Remotedesktopprotokoll) verwendet, um eine Verbindung über einen Windows Server 2012 RD-Gatewayserver herzustellen, schlägt fehl und generiert die folgende Fehlermeldung:

Dieser Computer kann keine Verbindung mit dem Remotecomputer herstellen.

Darüber hinaus wird Ereignis 4625 in der Sicherheitsanmeldung auf dem Gatewayserver protokolliert und meldet einen 0xC000035B Fehler.

Protokollname: Sicherheit
Quelle: Microsoft-Windows-Security-Auditing
Date: <DateTime>
Ereignis-ID: 4625
Aufgabenkategorie: Anmeldung
Ebene: Informationen
Schlüsselwörter: Überwachungsfehler
Benutzer: Nicht zutreffend
Computer: RDGW.CONTOSO.COM
Beschreibung:
Ein Konto konnte sich nicht anmelden.

Betreff:
Sicherheits-ID: NULL SID
Kontoname: -
Kontodomäne: -
Anmelde-ID: 0x0
Anmeldetyp: 3
Konto, für das die Anmeldung fehlgeschlagen ist:
Sicherheits-ID: NULL SID
Kontoname: Myuser
Kontodomäne: Contoso
Fehlerinformationen:
Fehlerursache: Während der Anmeldung ist ein Fehler aufgetreten.
Status: 0xC000035B
Unterstatus: 0x0

Ursache

Dieses Problem tritt auf, wenn der LmCompatibility-Registrierungswert so konfiguriert ist, dass das System NTLMv1 verwendet. Ein LmCompatibility-Wert von weniger als 3 zwingt das System, NTLMv1 zu verwenden.

Standardmäßig erzwingt Windows Server 2012 Kanalbindungen in RDP 8.0. Da diese Bindungen nicht gesendet werden, wenn NTLMv1 verwendet wird, schlägt die Authentifizierung fehl und generiert die 0xC000035B Fehlermeldung "Vom Client bereitgestellte SSPI-Kanalbindungen (Security Support Provider Interface) waren falsch". Es gibt an, dass die Kanalbindungen ungültig sind.

Lösung

Wichtig

Führen Sie die in diesem Abschnitt beschriebenen Schritte sorgfältig aus. Durch eine fehlerhafte Bearbeitung der Registrierung können schwerwiegende Probleme verursacht werden. Aufgrund dieser Probleme kann eine Neuinstallation des Betriebssystems erforderlich sein. Microsoft gibt keinerlei Garantien dafür ab, dass diese Probleme behoben werden können. Das Ändern der Registrierung erfolgt auf eigenes Risiko. Bevor Sie sie ändern, erfahren Sie, wie Sie die Registrierung in Windows sichern und wiederherstellen , falls Probleme auftreten.

Informationen zum Bearbeiten der Registrierung finden Sie im Hilfethema "Ändern von Schlüsseln und Werten" im Registrierungs-Editor.

Verwenden Sie eine der folgenden Methoden, um das Problem zu beheben.

Methode 1

Passen Sie den Registrierungswert LmCompatibility auf dem Client so an, dass NTLMv1 nicht erzwungen wird, indem Sie ihn auf einen Wert von 3 oder höher festlegen. Weitere Informationen zum LmCompatibility-Registrierungswert finden Sie unter LmCompatibilityLevel.

Methode 2

Legen Sie den Registrierungswert EnforceChannelBinding auf 0 (null) fest, um fehlende Kanalbindungen auf dem Gatewayserver zu ignorieren. Suchen Sie dazu den folgenden Registrierungsunterschlüssel, und verwenden Sie die angegebenen Spezifikationen:

HKLM\Software\Microsoft\Windows NT\CurrentVersion\TerminalServerGateway\Config\Core
Typ: REG_DWORD
Name: EnforceChannelBinding
Wert: 0 (Dezimal)

Hinweis

Standardmäßig ist der Wert EnforceChannelBinding nicht auf dem Gatewayserver vorhanden. Sie müssen diesen Wert erstellen.