Erro de conexão do cliente dos Serviços terminais 0xC000035B quando você usa LmCompatibility

Este artigo fornece uma solução para um erro 0xC000035B que ocorre quando uma conexão de cliente dos Serviços de Terminal que usa o RDP (Protocolo de Área de Trabalho Remota) 8.0 para se conectar por meio de um servidor do Gateway de RD Windows Server 2012.

Aplica-se a: Windows Server 2012 R2
Número de KB original: 2903333

Sintomas

Uma conexão de cliente dos Serviços de Terminal que usa o RDP (Protocolo de Área de Trabalho Remota) 8.0 para se conectar por meio de uma Windows Server 2012 servidor do Gateway de RD falha e gera a seguinte mensagem de erro:

Esse computador não pode se conectar ao computador remoto.

Além disso, o Evento 4625 é registrado no logon de segurança no servidor gateway e relata um erro 0xC000035B.

Nome do log: Segurança
Fonte: Microsoft-Windows-Security-Auditing
Data: <DateTime>
ID do evento: 4625
Categoria da Tarefa: Logon
Nível: Informações
Palavras-chave: Falha de auditoria
Usuário: N/A
Computador: RDGW.CONTOSO.COM
Descrição:
Falha ao fazer logon em uma conta.

Assunto:
ID de segurança: SID NULL
Nome da conta: -
Domínio da Conta: -
ID do logon: 0x0
Tipo de logon: 3
Conta para qual logon falhou:
ID de segurança: SID NULL
Nome da conta: Myuser
Domínio da Conta: Contoso
Informações sobre falha:
Motivo da falha: ocorreu um erro durante o Logon.
Status: 0xC000035B
Sub Status: 0x0

Motivo

Esse problema ocorre quando o valor do registro LmCompatibility é configurado para forçar o sistema a usar o NTLMv1. Um valor LmCompatibility de menos de 3 força o sistema a usar o NTLMv1.

Por padrão, Windows Server 2012 impõe associações de canal no RDP 8.0. Como essas associações não são enviadas quando o NTLMv1 é usado, a autenticação falha e gera 0xC000035B a mensagem de erro "As associações de canal SSPI (Interface do Provedor de Suporte de Segurança) fornecidas pelo cliente estavam incorretas". Ele indica que as associações de canal não são válidas.

Resolução

Importante

Siga as etapas nesta seção com cuidado. Sérios problemas poderão ocorrer caso você modifique o Registro incorretamente. Talvez seja necessária a reinstalação do sistema operacional. A Microsoft não pode garantir que esses problemas possam ser resolvidos. Modifique o Registro a seu próprio risco. Antes de modificá-lo, como fazer backup e restaurar o registro no Windows caso ocorram problemas.

Para obter informações sobre como editar o registro, consulte o tópico ajuda "Alterando chaves e valores" no Registro Editor.

Para resolver esse problema, use um dos métodos a seguir.

Método 1

Ajuste o valor do registro LmCompatibility no cliente para não forçar o NTLMv1 definindo-o como um valor 3 ou maior. Para obter mais informações sobre o valor do registro LmCompatibility , consulte LmCompatibilityLevel.

Método 2

Defina o valor do registro EnforceChannelBinding como 0 (zero) para ignorar as associações de canal ausentes no servidor gateway. Para fazer isso, localize a seguinte subchave de registro e use as especificações fornecidas:

HKLM\Software\Microsoft\Windows NT\CurrentVersion\TerminalServerGateway\Config\Core
Tipo: REG_DWORD
Nome: EnforceChannelBinding
Valor: 0 (Decimal)

Observação

Por padrão, o valor EnforceChannelBinding não existe no servidor gateway. Você deve criar esse valor.