Identificativo articolo: 290684 - Ultima modifica: lunedì 3 dicembre 2007 - Revisione: 8.0

Le impostazioni di memorizzazione della password non vengono mantenute in Outlook o Outlook Express

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Sintomi

Quando si effettua la connessione al provider di servizi Internet (ISP) per recuperare messaggi dal server POP3 (Post Office Protocol 3), la password non viene mantenuta anche se si è scelto di salvarla. Il problema non viene risolto neanche immettendo nuovamente la password corretta.

Cause

Questo problema si verifica per uno dei seguenti motivi:
  • Il profilo di Outlook o l'identità di Outlook Express è danneggiata.
  • Si verificano conflitti con i componenti aggiuntivi o con il software antivirus.
  • Il Registro di sistema contiene informazioni non corrette nella sottochiave Protected Storage System Provider per l'account utente in Windows XP, Windows 2000 e Outlook 2003 o versioni precedenti di Outlook.

Risoluzione

Per risolvere il problema, utilizzare uno dei metodi illustrati di seguito. Il primo metodo è rivolto a tutti gli utenti, inclusi quelli con poca dimestichezza con il computer, gli altri metodi invece richiedono una conoscenza avanzata del computer.

Metodo 1: Creare un nuovo profilo di Outlook o una nuova identità di Outlook Express

In primo luogo è necessario provare a creare un nuovo profilo di Outlook se si utilizza Outlook oppure una nuova identità di Outlook Express se si utilizza Outlook Express. A questo scopo, vedere la sezione "Creazione di un nuovo profilo di Outlook" o "Creazione di una nuova identità di Outlook Express" di seguito in questo articolo.

Creazione di un nuovo profilo di Outlook

Creare un nuovo profilo di Outlook, quindi configurarlo per utilizzare il file delle cartelle personali (con estensione pst) utilizzato dal profilo danneggiato. Per effettuare questa operazione, attenersi alla seguente procedura:
  1. Individuare il file con estensione pst

    Per individuare il file con estensione pst utilizzato dal profilo, attenersi alla procedura corretta per la versione di Outlook in uso.

    Per Microsoft Office Outlook 2007
    1. Avviare Outlook.
    2. Scegliere Impostazioni account dal menu Strumenti.
    3. Nella scheda Posta elettronica fare clic sul proprio account di posta elettronica.
    4. Nella finestra di dialogo Impostazioni account in Con l'account di posta elettronica selezionato i nuovi messaggi vengono recapitati nella posizione seguente sono visualizzati il percorso e il nome del file con estensione pst associato al profilo di posta elettronica. Il formato del percorso e del nome di file potrebbe essere simile al seguente:
      C:\Documents and Settings\nome_utente\Impostazioni locali\Dati applicazioni\Microsoft\Outlook\Cartelle personali(1).pst
    5. Prendere nota del percorso e del nome del file con estensione pst associato al proprio profilo di posta elettronica.

    Per Microsoft Office Outlook 2003 e Microsoft Outlook 2002
    1. Avviare Outlook.
    2. Scegliere Opzioni dal menu Strumenti.
    3. Nella scheda Configurazione della posta fare clic su File di dati.
    4. Prendere nota del percorso e del nome di ogni file con estensione pst associato al proprio profilo di posta elettronica. Il formato del percorso e del nome di file potrebbe essere simile al seguente:
      C:\Documents and Settings\nome_utente\Impostazioni locali\Dati applicazioni\Microsoft\Outlook\Cartelle personali(1).pst
  2. Creare un nuovo profilo di posta elettronica in Outlook

    Dopo aver individuato i file con estensione pst, creare un nuovo profilo di posta elettronica in Outlook. Per eseguire questa operazione, attenersi alla procedura descritta di seguito.

    Per Outlook 2007
    1. Avviare Outlook.
    2. Scegliere Impostazioni account dal menu Strumenti.
    3. Fare clic sulla scheda Posta elettronica, quindi scegliere Nuovo.
    4. Seguire le istruzioni della procedura guidata Aggiunta nuovo account di posta elettronica per creare il nuovo account.
      Nota Se le informazioni richieste dalla procedura guidata Aggiunta nuovo account di posta elettronica non sono disponibili, visualizzare le impostazioni dell'account esistente, facendo clic sull'account nella scheda Posta elettronica all'interno della finestra di dialogo Impostazioni account, quindi scegliendo Cambia. Prendere nota di ogni impostazione presente nella finestra di dialogo Impostazioni posta elettronica Internet.
      Se non si conosce la password dell'account di posta elettronica, rivolgersi al proprio provider di servizi Internet (ISP). In alternativa, se la cassetta postale non è associata all'ISP, contattare l'amministratore di rete del server in cui si trova la cassetta postale per ottenere informazioni sulla password.

    Per Outlook 2003 e Outlook 2002

    Per ulteriori informazioni sulla creazione di un nuovo profilo di posta elettronica in Outlook 2003 e Outlook 2002, fare clic sui numeri degli articoli della Microsoft Knowledge Base riportati di seguito:
    829918  (http://support.microsoft.com/kb/829918/ ) Come creare un nuovo profilo di posta elettronica in Outlook 2003
    287072  (http://support.microsoft.com/kb/287072/ ) Come creare un nuovo profilo di posta elettronica in Outlook 2002
  3. Configurare il nuovo profilo affinché utilizzi il file con estensione pst associato al profilo danneggiato

    Dopo aver creato il nuovo profilo in Outlook, configurarlo per utilizzare il file con estensione pst utilizzato dal profilo danneggiato. A questo scopo, attenersi alla procedura appropriata per la versione di Outlook in uso.

    Per Outlook 2007
    1. Avviare Outlook.
    2. Scegliere Impostazioni account dal menu Strumenti.
    3. Nella scheda Posta elettronica fare clic sul proprio account di posta elettronica.
    4. Fare clic su Cambia cartella in Con l'account di posta elettronica selezionato i nuovi messaggi vengono recapitati nella posizione seguente nella parte inferiore della finestra di dialogo Impostazioni account.
    5. Fare clic su Nuovo file di dati di Outlook, File delle cartelle personali di Office Outlook (.pst) e infine scegliere OK.
    6. Individuare e scegliere il file con estensione pst utilizzato dal profilo danneggiato, quindi fare clic su OK.

    Per Outlook 2003 e Outlook 2002
    1. Avviare Outlook.
    2. Scegliere Opzioni dal menu Strumenti.
    3. Nella scheda Configurazione della posta fare clic su Account di posta elettronica, Visualizza o cambia gli account di posta elettronica esistenti quindi scegliere Avanti.
    4. Fare clic su Nuovo file di dati di Outlook, File delle cartelle personali di Office Outlook (.pst) in Tipi di archiviazione e infine scegliere OK.
    5. Individuare e scegliere il file con estensione pst che si desidera utilizzare, quindi scegliere due volte OK.
      Nota Se si desidera utilizzare più file con estensione pst, ripetere i passaggi 4 e 5 per ogni file con estensione pst che si desidera utilizzare con il nuovo profilo di posta elettronica.
    6. Nell'elenco Consegna nuovi messaggi in fare clic su Cartelle personali, quindi scegliere Fine.
    7. Scegliere OK se viene visualizzato il seguente messaggio:
      Il percorso di recapito predefinito per la posta elettronica è cambiato. Verrà cambiato di conseguenza anche il percorso di Posta in arrivo, del Calendario e di altre cartelle. Le modifiche diventeranno effettive al successivo avvio di Outlook.
    8. Scegliere Esci dal menu File.
    9. Avviare Outlook. Se viene visualizzato il seguente messaggio, fare clic su per aggiornare i collegamenti alla barra di Outlook affinché puntino ai file con estensione pst:
      Il percorso in cui vengono recapitati i messaggi è stato modificato per questo profilo. Per completare l'operazione, copiare il contenuto delle vecchie cartelle di Outlook in quelle nuove. Per informazioni sulla modifica del percorso di recapito della posta, consultare la Guida di Microsoft Outlook. Alcuni collegamenti nel riquadro di spostamento potrebbero non essere più validi. Ricreare i collegamenti?

Creare una nuova identità di Outlook Express

Per creare una nuova identità di Outlook Express, attenersi alla seguente procedura:
  1. Scegliere Identità dal menu File di Outlook Express, quindi Aggiungi nuova identità.

    Oppure
  2. Scegliere Identità dal menu File, quindi Gestione identità e infine Nuova. Verrà visualizzata la finestra di dialogo Nuova identità.
  3. Nella finestra Nuova identità digitare il proprio nome.
  4. Selezionare la casella di controllo Richiedi password se si desidera impostare una password per l'identità, quindi scegliere OK.
  5. Nella finestra di dialogo Identità aggiunta fare clic su . Viene chiesto se si desidera eseguire l'accesso con i dati del nuovo utente. Se si sceglie verranno chieste informazioni sulla connessione Internet. Se si sceglie No l'utente corrente rimarrà connesso.

Risoluzione avanzata dei problemi

I metodi seguenti richiedono una conoscenza avanzata del computer. Se non si ha familiarità con la risoluzione avanzata dei problemi, è consigliabile chiedere aiuto o contattare il supporto tecnico. Per informazioni su come contattare il supporto tecnico, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/select/?target=hub (http://support.microsoft.com/select/?target=hub)

Metodo 2: Avviare Outlook in modalità provvisoria

Per avviare Outlook in modalità provvisoria, attenersi ai passaggi relativi alla versione di Windows in uso.

Per Windows Vista
  1. Fare clic sul pulsante Start, digitare outlook.exe /safe nella casella Inizia ricerca, quindi premere INVIO.

Per Windows XP, Windows Server 2003 o Windows 2000
  1. Fare clic sul pulsante Start, quindi scegliere Esegui.
  2. Nella casella Apri digitare outlook.exe /safe, quindi scegliere OK.

In modalità provvisoria Outlook viene eseguito senza servizi non Microsoft. Se in modalità provvisoria Outlook viene eseguito correttamente, è probabile che il problema sia causato da un servizio di terze parti che interagisce con Outlook, ad esempio componenti aggiuntivi, software antivirus o firewall. In questo caso, può essere necessario contattare il supporto tecnico per identificare il componente aggiuntivo o il servizio di terze parti e quindi collaborare con il rispettivo fornitore. Per informazioni su come contattare il Servizio Supporto Tecnico Clienti Microsoft, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/select/?target=hub (http://support.microsoft.com/select/?target=hub)
Per risolvere gli eventuali problemi causati da componenti aggiuntivi COM, disabilitare tutti i componenti aggiuntivi COM non utilizzati regolarmente, quindi riavviare Outlook. Se il problema non viene risolto, disabilitare un componente aggiuntivo alla volta. Se il problema persiste, disabilitare tutti i componenti aggiuntivi. Per disabilitare i componenti aggiuntivi COM, attenersi alla procedura relativa alla versione di Outlook in uso.

Per Outlook 2007
Per disabilitare i componenti aggiuntivi COM, attenersi alla seguente procedura:
  1. Scegliere Centro protezione dal menu Strumenti di Outlook 2007.
  2. Fare clic su Componenti aggiuntivi, Componenti aggiuntivi COM nell'elenco Gestione, quindi scegliere Vai.
  3. Nella finestra di dialogo Componenti aggiuntivi COM deselezionare le caselle di controllo relative ai componenti aggiuntivi COM da disabilitare.
  4. Dopo aver disabilitato i componenti aggiuntivi, scegliere OK e riavviare Outlook.

Per Outlook 2002 e Outlook 2003
Per disabilitare i componenti aggiuntivi COM, attenersi alla seguente procedura:
  1. In Outlook 2002 o Outlook 2003 scegliere Opzioni dal menu Strumenti.
  2. Fare clic sulla scheda Altro e scegliere Opzioni avanzate.
  3. Fare clic su Gestione componenti aggiuntivi.
  4. Nella finestra di dialogo Gestione componenti aggiuntivi deselezionare le caselle di controllo relative ai componenti aggiuntivi COM da disabilitare e scegliere tre volte OK.
  5. Riavviare Outlook.

Importante In questa sezione, metodo o attività viene illustrato come modificare il Registro di sistema. Tenere presente, tuttavia, che l'errata modifica del Registro di sistema potrebbe causare seri problemi. Attenersi scrupolosamente alla procedura indicata. Per maggiore sicurezza, eseguire una copia di backup del Registro di sistema prima di modificarlo. In questo modo, sarà possibile effettuarne il ripristino in caso di problemi. Per ulteriori informazioni su come eseguire il backup del Registro di sistema e su come ripristinarlo, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
322756  (http://support.microsoft.com/kb/322756/ ) Esecuzione del backup e del ripristino del Registro di sistema in Windows XP e Windows Vista
Utilizzare la risoluzione riportata di seguito solo dopo avere provato tutti gli altri metodi per la risoluzione dei problemi relativi alla password.

Metodo 3: Eseguire il backup del Registro di sistema e rimuovere le informazioni sull'account utente dalla sottochiave Protected Storage System Provider, quindi immettere nuovamente le opzioni relative alla password.

A questo scopo, attenersi alla procedura appropriata per la versione di Windows in uso.

Nota Queste informazioni non sono valide per Windows Vista e Outlook 2007.

Per Windows XP

Eseguire il backup della chiave del Registro di sistema
  1. Fare clic sul pulsante Start, quindi scegliere Esegui.
  2. Nella casella Apri digitare regedit, quindi scegliere OK.
  3. Individuare e fare clic sulla seguente chiave del Registro di sistema:
    HKEY_CURRENT_USER\Software\Microsoft\Protected Storage System Provider
  4. Scegliere Esporta dal menu File.
  5. Nella casella Salva in selezionare un percorso in cui salvare il file con estensione reg.
  6. Nella casella Nome file digitare un nome di file, quindi scegliere Salva.
  7. Scegliere Esci dal menu File.
Rimuovere le informazioni relative all'account utente

Importante Non rimuovere la chiave Protected Storage System Provider principale. Questa chiave non viene rigenerata automaticamente. Se non si verificano problemi relativi alla memorizzazione della password e non si ricorda la propria password, l'eliminazione della sottochiave utente potrebbe impedire il recupero dei messaggi di posta elettronica.

Nota Se si utilizza Windows XP, per modificare il Registro di sistema è necessario disporre delle autorizzazioni di amministratore.
  1. Chiudere tutti i programmi.
  2. Fare clic sul pulsante Start, scegliere Esegui, digitare regedit nella casella Apri, quindi scegliere OK
  3. Individuare e fare clic sulla seguente chiave del Registro di sistema: HKEY_CURRENT_USER\Software\Microsoft\Protected Storage System Provider
  4. Scegliere Autorizzazioni dal menu Modifica.
  5. Fare clic sulla chiave del Registro di sistema per l'utente attualmente connesso e assicurarsi che le autorizzazioni Lettura e Controllo completo siano impostate su Consenti.
  6. Fare clic su Avanzate. Assicurarsi che l'utente attualmente connesso sia selezionato, che nella colonna Autorizzazioni sia indicato Controllo completo e che nella colonna Applica a sia specificato La chiave selezionata e le sottochiavi.
  7. Selezionare la casella di controllo Sostituisci le autorizzazioni su tutti gli oggetti figlio con le autorizzazioni appropriate qui specificate.
  8. Scegliere Applica, quindi per continuare.
  9. Scegliere due volte OK.
  10. Fare doppio clic sulla chiave Protected Storage System Provider per espanderla. Fare clic sulla cartella della sottochiave utente direttamente sotto la chiave Protected Storage System Provider, scegliere Elimina dal menu Modifica, quindi scegliere nella finestra di dialogo del messaggio di avviso.

    La cartella della sottochiave utente avrà un formato analogo al seguente:

    S-1-5-21-124525095-708259637-1543119021-16701

    Nota Per ogni identità di cui si dispone, potrebbe essere presente una sottochiave sotto la chiave Protected Storage System Provider. Per risolvere il problema in tutte le identità, eliminare tutte le cartelle delle sottochiavi utente nella chiave Protected Storage System Provider.
  11. Scegliere Esci dal menu File del Registro di sistema. Riavviare il computer.

Per Microsoft Windows 2000

Come eseguire il backup del Registro di sistema
  1. Fare clic sul pulsante Avvio, quindi scegliere Esegui.
  2. Nella casella Apri digitare regedt32, quindi scegliere OK.
  3. Individuare e fare clic sulla seguente chiave del Registro di sistema:
    HKEY_CURRENT_USER\Software\Microsoft\Protected Storage System Provider
  4. Scegliere Salva chiave dal menu Registro di sistema.
  5. Nella casella Salva in selezionare un percorso in cui salvare il file con estensione reg.
  6. Nella casella Nome file digitare un nome di file, quindi scegliere Salva.
  7. Scegliere Esci dal menu Registro di sistema.
Come rimuovere le informazioni sull'account utente nel Registro di sistema

Importante Non rimuovere la chiave Protected Storage System Provider principale. Questa chiave non viene rigenerata automaticamente. Se non si verificano problemi relativi alla memorizzazione della password e non si ricorda la propria password, l'eliminazione della sottochiave utente potrebbe impedire il recupero dei messaggi di posta elettronica.

Nota Se si utilizza Windows 2000, per modificare il Registro di sistema è necessario disporre delle autorizzazioni di amministratore.
  1. Chiudere tutti i programmi.
  2. Fare clic sul pulsante Start, quindi scegliere Esegui.
  3. Nella casella Apri digitare regedt32, quindi scegliere OK.
  4. Individuare e fare clic sulla seguente chiave del Registro di sistema:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Protected Storage System Provider
  5. Scegliere Autorizzazioni dal menu Protezione
  6. Fare clic sulla chiave del Registro di sistema per l'utente attualmente connesso e assicurarsi che le autorizzazioni Lettura e Controllo completo siano impostate su Consenti.
  7. Fare clic su Avanzate. Assicurarsi che l'utente attualmente connesso sia selezionato, che nella colonna Autorizzazioni sia indicato Controllo completo e che nella colonna Applica a sia specificato La chiave selezionata e le sottochiavi.
  8. Selezionare la casella di controllo Reimposta le autorizzazioni su tutti gli oggetti figlio e abilita la propagazione delle autorizzazioni ereditabili.
  9. Scegliere Applica, quindi quando verrà chiesto se si desidera continuare.
  10. Scegliere due volte OK.
  11. Fare doppio clic sulla chiave Protected Storage System Provider per espanderla. Fare clic sulla cartella della sottochiave utente direttamente sotto la chiave Protected Storage System Provider, scegliere Elimina dal menu Modifica, quindi scegliere nella finestra di dialogo del messaggio di avviso.

    La cartella della sottochiave utente avrà un formato analogo al seguente:

    S-1-5-21-124525095-708259637-1543119021-16701

    Nota Per ogni identità di cui si dispone, potrebbe essere presente una sottochiave sotto la chiave Protected Storage System Provider. Per risolvere il problema in tutte le identità, eliminare tutte le cartelle delle sottochiavi utente nella chiave Protected Storage System Provider.
  12. Scegliere Esci dal menu Registro di sistema, quindi riavviare il computer.

Come immettere di nuovo la password in Outlook 2002 e Outlook 2003

  1. Fare clic sul pulsante Start, scegliere Impostazioni, quindi Pannello di controllo.

    Nota In Windows XP fare clic sul pulsante Start, quindi scegliere Pannello di controllo.
  2. Fare doppio clic sull'icona Posta elettronica oppure Posta e Fax.
  3. Fare clic su Mostra profili, selezionare l'account per il quale si sta effettuando la risoluzione dei problemi, quindi scegliere Proprietà.
  4. Fare clic sul pulsante Account di posta elettronica.
  5. Verificare che la casella di controllo Visualizza o cambia gli account di posta elettronica esistenti sia selezionata, quindi scegliere Avanti.
  6. Nella finestra di dialogo Account di posta elettronica selezionare l'account per il quale si sta effettuando la risoluzione dei problemi, quindi scegliere Cambia.
  7. In Informazioni di accesso digitare la password e selezionare la casella di controllo Memorizza password.
  8. Scegliere Avanti, quindi Fine.
  9. Avviare Outlook.
  10. Utilizzare il comando Invia e Ricevi per verificare se la password è stata mantenuta.

Come immettere di nuovo la password in Outlook 2000 con supporto per Società o gruppo di lavoro (CW)

  1. Fare clic sul pulsante Start, scegliere Impostazioni, quindi Pannello di controllo.

    Nota In Windows XP fare clic sul pulsante Start, quindi scegliere Pannello di controllo.
  2. Fare doppio clic sull'icona Posta elettronica oppure Posta e Fax.
  3. Selezionare Posta elettronica Internet dall'elenco di servizi, quindi scegliere Proprietà.
  4. Immettere la password nella scheda Server, quindi selezionare l'opzione Memorizza password.
  5. Scegliere Applica, quindi OK.
  6. Avviare Outlook.
  7. Scegliere Invia e ricevi dal menu Strumenti per verificare se la password è stata mantenuta.

Come immettere di nuovo la password in Outlook Express

  1. Avviare Outlook Express.

    Nota Se viene visualizzato un errore di accesso, chiudere la finestra di dialogo e continuare.
  2. Scegliere Account dal menu Strumenti.
  3. Fare clic sulla scheda Posta elettronica nella finestra di dialogo Account Internet.
  4. Nella colonna Account selezionare l'account di posta elettronica Internet da modificare, quindi fare clic su Proprietà.
  5. Nella scheda Server digitare la password nella casella Password, quindi selezionare la casella di controllo Memorizza password.
  6. Scegliere OK, quindi Chiudi.
  7. Chiudere e riavviare Outlook Express.
  8. Scegliere Invia e ricevi dal menu Strumenti per verificare se la password è stata mantenuta.
Nota Se altri utenti di Windows 2000 o Windows XP hanno problemi con la memorizzazione della password, reinserire la password, quindi selezionare la casella di controllo Memorizza password per i profili di tali utenti. È possibile che ogni utente debba riconnettersi affinché la password venga mantenuta.

Le informazioni in questo articolo si applicano a
  • Microsoft Office Outlook 2007
  • Microsoft Office Outlook 2003
  • Microsoft Outlook 2002 Standard Edition
  • Microsoft Outlook 2000 Standard Edition
  • Microsoft Outlook Express 6.0
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