Error 3266 o 3013 al realizar una copia de seguridad de base de datos en disco o cinta o una restauración de base de datos desde disco o cinta

En este artículo se proporciona ayuda a resolver el error 3266 o 3013 que se produce al realizar una copia de seguridad de base de datos en disco o cinta o una restauración de base de datos desde disco o cinta.

Se aplica a: Windows Server 2012 R2
Número de KB original: 290787

Síntomas

Al realizar una copia de seguridad de base de datos en disco o cinta, o una restauración desde disco o cinta, puede producirse el siguiente mensaje de error:

SQL Server servidor 7.0:

Msg 3266, Level 16, State 1, Line 1
No se puede leer la base de datos de marcas de archivos temporales de Formato de cinta de Microsoft (MTF) en el dispositivo de copia de seguridad "devicename", lo que impide el acceso aleatorio.
Servidor: Msg 3013, Level 16, State 1, Line 1
La operación de copia de seguridad o restauración termina de forma anómala.

SQL Server 2000 Server:

Msg 3266, Level 16, State 1, Line 1
Los datos de copia de seguridad de "devicename" tienen un formato incorrecto. Las copias de seguridad no se pueden anexar, pero los conjuntos de copia de seguridad existentes pueden seguir siendo utilizables.
Servidor: Msg 3013, Level 16, State 1, Line 1
BACKUP DATABASE termina de forma anómala.

SQL Server 2005 Server:

Msg 3013, Level 16, State 1, Line 1
Los datos de copia de seguridad al final de "devicename" tienen un formato incorrecto. Los conjuntos de copia de seguridad en los medios pueden estar dañados e inutilizables. Para determinar los conjuntos de copia de seguridad en los medios, use RESTORE HEADERONLY. Para determinar la facilidad de uso de los conjuntos de copia de seguridad, ejecute RESTORE VERIFYONLY. Si todos los conjuntos de copia de seguridad están incompletos, vuelva a formatear el medio mediante BACKUP WITH FORMAT, lo que destruye todos los conjuntos de copia de seguridad.
Servidor: Msg 3013, Level 16, State 1, Line 1

BACKUP DATABASE termina de forma anómala.

Causa

No se pudo leer una marca de archivo en el dispositivo de copia de seguridad. Hay muchas razones por las que puede encontrar un error de marca de archivo. Algunos de los motivos son los siguientes:

  • Puede producirse un error multimedia en el dispositivo donde se encuentra la copia de seguridad.

  • Puede producirse un error de escritura durante la creación de la copia de seguridad.

    Por ejemplo, puede producirse una pérdida de conectividad durante una copia de seguridad de red. O bien, puede producirse un error en la ruta de acceso de E/S para vaciar la escritura en el disco después de que la escritura en el disco se notificara a SQL Server como correcta.

Solución alternativa

Para permitir que SQL Server realice nuevas copias de seguridad en el dispositivo de copia de seguridad, debe eliminar o borrar manualmente el dispositivo mediante el siguiente comando:

BACKUP DATABASE mydatabase TO DISK='C:\MyDatabase.bak' with FORMAT

Si el mensaje de error se produce durante una operación de restauración, puede ser posible recuperar otros conjuntos de copia de seguridad del dispositivo especificando el número de archivo. Por ejemplo, si tres (3) copias de seguridad estaban en un (1) dispositivo de copia de seguridad, los conjuntos de copia de seguridad 1 y 2 pueden ser utilizables. Para determinar si hay varios conjuntos de copia de seguridad en un dispositivo, ejecute el código siguiente desde el Analizador de consultas:

RESTORE HEADERONLY FROM DISK='C:\MyDatabase.bak'

Cada conjunto de copia de seguridad tiene una entrada en la salida. Para indicar un conjunto de copia de seguridad específico, use este código:

RESTORE DATABASE mydatabase FROM DISK='C:\MyDatabase.bak' WITH FILE = FileNumber

Nota:

FileNumber es el número de conjunto de copia de seguridad que desea restaurar.

Más información

La lista siguiente contiene notas importantes sobre las copias de seguridad y SQL Server.

  • Después de SQL Server detecta un error de marca de archivo en un dispositivo, SQL Server no escribe información adicional en el dispositivo.

  • SQL Server almacena todas las copias de seguridad en formato de cinta de Microsoft, tanto si la copia de seguridad se realiza en disco como en cinta. El formato de cinta de Microsoft usa marcas de archivo para contener información como el tamaño del bloque y el número de bloques de una copia de seguridad, además de otra información sobre la copia de seguridad. El formato de cinta de Microsoft también usa marcas de archivo para delimitar las copias de seguridad en un dispositivo de copia de seguridad. El hecho de que falta una marca de archivo o está dañada, sugiere que al menos una copia de seguridad en el dispositivo no es válida.

  • Aunque puede restaurar algunos conjuntos de copia de seguridad desde el dispositivo dañado, debe comprobar la integridad de la base de datos restaurada.

  • SQL Server registra los detalles del éxito o del error durante una operación de copia de seguridad o una operación de restauración en el registro de errores de SQL Server y en las tablas del historial de copias de seguridad de la base de datos del sistema msdb.

  • Si experimenta un error 3266 al restaurar un registro de transacciones o una copia de seguridad de base de datos, investigue los registros siguientes para obtener más información:

    • registro de errores de SQL Server
    • Copia de seguridad y restauración de tablas de historial
    • Registro de eventos de aplicación
    • Registro de eventos del sistema

Si no hay detalles del error en estos registros, es posible que haya experimentado un error no notificado. Si necesita ayuda, póngase en contacto con los Servicios de soporte técnico de Microsoft.