Come determinare dove pubblicare un modulo personalizzato di Outlook

Traduzione articoli Traduzione articoli
Identificativo articolo: 290802 - Visualizza i prodotti a cui si riferisce l?articolo.
Per una versione di Microsoft Outlook 97 di questo articolo, vedere 264117.
Per una versione di Microsoft Outlook 98 di questo articolo, vedere 264118.
Per una versione di Microsoft Outlook 2000 di questo articolo, vedere 257796.
Espandi tutto | Chiudi tutto

In questa pagina

Sommario

In questo articolo vengono descritti alcuni degli aspetti da tenere in considerazione se si sta tentando di decidere dove pubblicare un modulo personalizzato di Outlook.

Informazioni

In Outlook, moduli personalizzati vengono in genere pubblicati in una libreria in modo che solo una copia di un modulo viene memorizzata nel computer in uso. I singoli elementi contengono un campo classe messaggio che indica il modulo da utilizzare per visualizzare i dati contenuti nell'elemento. Quando si pubblicano moduli personalizzati in una libreria, computer basati su Microsoft Exchange Server e Outlook utilizzare notevolmente meno larghezza di banda e risorse perchÚ il modulo stesso non deve necessariamente essere memorizzati all'interno di ogni singolo articolo.

Soluzioni di moduli di Outlook possono variare notevolmente, soprattutto perchÚ Outlook dispone di un numero di diversi tipi di moduli standard. Spesso Ŕ difficile determinare la posizione migliore per pubblicare un modulo e vi sono molti i fattori da prendere in considerazione quando si prende la decisione.

Dove Ŕ possibile pubblicare i moduli

Moduli possono essere pubblicati in tre posizioni. Riportate nella tabella riportata di seguito.

Riduci questa tabellaEspandi questa tabella
PosizioneDescrizione
Una cartella (o Libreria moduli della cartella)Per le soluzioni di form basata su pi¨ cartelle, Ŕ possibile pubblicare il modulo nella cartella in modo che sia disponibile quando si utilizza la cartella. Se si pubblica il modulo in una cartella pubblica, il modulo Ŕ disponibile per tutti gli utenti possono accedere alla cartella. Se si pubblica il modulo in una delle cartelle personali, Ŕ disponibile solo per l'utente quando si utilizza tale cartella. Moduli di contatto, Post, attivitÓ e giornale di registrazione sono esempi di tipi di moduli che sono in genere associati a una cartella. Un vantaggio per la pubblicazione di un modulo in una cartella Ŕ che il modulo Ŕ disponibile nel menu Azioni quando trovano nella cartella.
Libreria moduli organizzazioneSe si desidera renderlo disponibile a tutti gli utenti nell'organizzazione un modulo per ferie, pubblicare il modulo alla raccolta. Questa libreria viene spesso utilizzata per i moduli dei messaggi di posta elettronica perchÚ in genere non sono basati su una cartella specifica. Quando si desidera utilizzare lo stesso modulo personalizzato in pi¨ di una cartella, Ŕ possibile pubblicare un modulo nella libreria moduli organizzazione. Quando si esegue questa operazione, Ŕ possibile gestire un solo modulo pubblicato. Moduli pubblicati in questa libreria sono accessibili a tutti gli utenti dell'organizzazione come utenti che dispongono delle autorizzazioni per la libreria dall'amministratore. La libreria Ŕ memorizzata nel computer che esegue Microsoft Exchange Server. L'amministratore deve assegnare le autorizzazioni per la pubblicazione nella libreria moduli organizzazione. Questa autorizzazione viene in genere concessa solo ad alcuni utenti o un reparto che gestisce il computer basato su Exchange Server.
Libreria moduli personaliModuli salvati in questa libreria accessibili solo all'utente. Quando si pubblica un modulo nella libreria moduli personali, il modulo viene memorizzato come elemento nascosto nella cartella principale della cassetta postale o del file delle cartelle personali (pst), ovvero la posizione di recapito di posta elettronica predefinito. Come i moduli vengono memorizzati nella libreria moduli organizzazione, questi moduli possono essere aperti utilizzando il comando Scegli modulo . Salvare il modulo in questa libreria quando si crea un modulo per uso personale, ad esempio un modulo di messaggio di posta elettronica standard Ŕ preindirizzato a destinatari.

╚ inoltre possibile archiviare un modulo di Outlook come file nel file system o come un elemento in una cartella di Outlook. Si consiglia di evitare entrambi questi approcci, tuttavia, poichÚ il modulo sarÓ un modulo one-off. Per ulteriori informazioni sui moduli one-off, fare clic sul numero dell'articolo per visualizzare l'articolo della Microsoft Knowledge Base:
290657 OL2002: Utilizzo di definizioni dei moduli e moduli one-off
╚ possibile salvare un modulo di Outlook nel file System come file modello Outlook (oft). Consente di allegare il modulo a un messaggio di posta elettronica e quindi inviare il modulo a un altro utente. Inoltre, Ŕ possibile utilizzare il file con estensione oft come una copia di backup del modulo. Per salvare un modulo come file OFT:
  1. Scegliere Salva con nomedal menu File .
  2. Nella casella Nome File digitare un nome per il modulo.
  3. Nella casella tipo fare clic su Modello Outlooke quindi fare clic su Salva.
╚ inoltre possibile salvare il modulo come un elemento nella cartella corrente. Tuttavia, Microsoft non consiglia di farlo per i seguenti motivi:
  • ╚ facile eliminare accidentalmente il modulo.
  • Tende a ridurre la distinzione tra moduli ed elementi e il risultato tipico Ŕ una cartella che viene riempita con diversi elementi che contengono versioni diverse dello stesso modulo. Ci˛ in genere non Ŕ consigliabile durante la progettazione di moduli di Outlook.
  • Gli elementi archiviati in una cartella in genere sono dati associati e in genere non si desidera che i dati associati al modulo. Di conseguenza, Microsoft consiglia di non aprire un elemento in una cartella e quindi attivare la modalitÓ di progettazione; Aprire una nuova istanza del modulo e quindi la modalitÓ di progettazione.
  • I moduli vengono memorizzati come elementi sono moduli "one-off" e presentano effetti collaterali indesiderati.
Per salvare un modulo nella cartella corrente, scegliere Salva dal menu File .

Considerazioni per decidere dove pubblicare un modulo

Esistono molte domande da prendere in considerazione quando si decide dove pubblicare un modulo:
  • Il modulo Ŕ basato su una soluzione di cartella o Ŕ un modulo di messaggio di posta elettronica Ŕ stato progettato per essere inviato ai destinatari?
  • Si sta utilizzando un computer basato su Exchange Server? Se si utilizza un computer basato su Exchange Server, Ŕ possibile pubblicare il modulo nella libreria moduli organizzazione o nell'organizzazione sono state definite restrizioni relative ai tipi di form possono essere memorizzati?
  • Quante persone devono poter accedere al modulo?
  • SarÓ possibile aggiornare il modulo spesso, pertanto Ŕ importante avere solo una copia del modulo distribuito in modo centralizzato?
  • Il modulo deve essere disponibile non in linea?
  • Se si tratta di un modulo di messaggio di posta elettronica, verrÓ utilizzata solo all'interno dell'organizzazione o inviato ad altri destinatari esterni all'organizzazione?
  • Come verrÓ aperto il nuovo modulo?

Come decidere dove pubblicare moduli basati su cartella

Quando si crea una soluzione basata su cartella dove l'obiettivo primario del modulo sia per visualizzare gli elementi in una singola cartella, Ŕ consigliabile pubblicare il modulo nella cartella stessa. Quando si pubblica il modulo nella cartella, la cartella Ŕ un'entitÓ indipendente e il modulo Ŕ disponibile nel menu Azioni .

Tuttavia, esistono scenari in cui non Ŕ possibile pubblicare un modulo basato su cartella tipico in una cartella. Se si utilizza un modulo in pi¨ di una cartella e ciascuna cartella utilizza sempre la stessa versione del modulo, Ŕ consigliabile pubblicare il modulo nella libreria moduli organizzazione o nella libreria moduli personali. Quando si esegue questa operazione, Ŕ solo una copia del modulo pubblicato ed Ŕ pi¨ semplice per l'aggiornamento se Ŕ necessario apportare modifiche. Se si Ŕ l'unica persona che deve accedere a questo modulo, pubblicare il modulo nella libreria moduli personali. Se altri utenti devono poter accedere al form e la maschera Ŕ tipica in una cartella pubblica in un computer basato su Exchange Server, provare a utilizzare o meno Ŕ possibile pubblicare il modulo nella libreria moduli organizzazione. Un potenziale svantaggio di questo approccio Ŕ che il modulo non sarÓ disponibile nel menu Azioni a meno che non si Ŕ pubblicato nella cartella. Tuttavia, se il modulo predefinito per la cartella, come avviene in genere, ci˛ non rappresenterÓ una quantitÓ eccessiva di una differenza perchÚ o utenti possono utilizzare un pulsante della barra degli strumenti per aprire nuovi elementi.

Come decidere dove pubblicare moduli basati su messaggi

Se il modulo Ŕ basato su un messaggio di posta elettronica e viene utilizzato da Ŕ e solo un paio di altri utenti, pubblicare il modulo nella libreria moduli personali per tutti gli utenti. Tuttavia, se si desidera creare nuovi elementi basati su questo modulo, Ŕ possibile pubblicarlo nella posta in arrivo, in modo che sia accessibile dal menu Azioni . Se il modulo dovrÓ essere utilizzato da molte persone all'interno di un'organizzazione, pubblicarlo nella libreria moduli organizzazione in modo che solo una copia del modulo per gestire e tutti gli utenti possano accedervi. Questo approccio, tuttavia, pu˛ creare il form pi¨ difficili da aprire.

Considerazioni e opzioni per l'apertura di moduli

La tabella seguente descrive la modalitÓ di apertura standard a seconda di dove sono memorizzati i moduli di Outlook:

Riduci questa tabellaEspandi questa tabella
Tipo di moduloDove deve essere aperta
Moduli della cartellaSe si apre la cartella che contiene i moduli, i moduli sono disponibili nel menu Azioni .
Libreria moduli organizzazione

- e -

Libreria moduli personali
Moduli memorizzati nella libreria moduli organizzazione e Libreria moduli personali sono progettati per essere accessibili tramite la finestra di dialogo Scegli modulo . Per accedere a questi moduli, scegliere Nuovo dal menu File e quindi fare clic su Scegli modulo.

╚ possibile utilizzare i metodi seguenti per rendere pi¨ accessibile agli utenti i moduli.

Aggiungere il comando "Scegli modulo" sulla barra degli strumenti

Per ridurre il numero di passaggi necessari per accedere al comando Scegli modulo , aggiungere il comando alla barra degli strumenti in modo da visualizzare nella finestra di dialogo con un solo clic del mouse.
  1. Dal menu Visualizza , scegliere barre degli strumentie quindi fare clic su Personalizza.
  2. Fare clic sulla scheda comandi nella finestra di dialogo Personalizza .
  3. Nella casella categorie , assicurarsi che il File sia selezionata.
  4. Nella casella comandi , individuare il comando Scegli modulo e quindi trascinarlo nella posizione la barra degli strumenti desiderata.
  5. Fare clic su Chiudi.

Aprire una maschera utilizzando Visual Basic, Applications Edition o un componente aggiuntivo COM

Per ulteriori informazioni sull'utilizzo di Visual Basic, Applications Edition per aprire un modulo da un menu o barra degli strumenti, fare clic sul numero dell'articolo per visualizzare l'articolo della Microsoft Knowledge Base:
290803 OL2002: Come aprire un modulo da un pulsante della barra degli strumenti

Pubblicare il modulo in una cartella

Se un modulo viene pubblicato nella libreria moduli personali o nella libreria moduli organizzazione, Ŕ possibile pubblicarlo in una cartella in modo che venga visualizzato nel menu Azioni . Tuttavia, se la maschera viene aggiornata, assicurarsi che il modulo sia installato in modo da non creare problemi con i moduli di Outlook. Per ulteriori informazioni sulla cache dei moduli, fare clic sui numeri per visualizzare gli articoli della Microsoft Knowledge Base:
290806 Il funzionamento della Cache dei moduli

Salvataggio di un File OFT sul Desktop o Menu Start

Sebbene Microsoft sconsigli in genere salvando un file OFT sul desktop o dal menu di avvio , Ŕ possibile salvare un file modello Outlook (oft) posizione. Gli elementi creati in questo modo contengono moduli "one-off" che generano solitamente effetti collaterali indesiderati in base alla progettazione del form e come utilizzarlo.

Per ulteriori informazioni sui moduli one-off, fare clic sul numero dell'articolo per visualizzare l'articolo della Microsoft Knowledge Base:
290657 OL2002: Utilizzo di definizioni dei moduli e moduli one-off

Riferimenti

Per ulteriori informazioni sulle risorse disponibili e sulle risposte alle domande pi¨ frequenti sulle soluzioni di Microsoft Outlook, fare clic sul numero dell'articolo per visualizzare l'articolo della Microsoft Knowledge Base:
287530 OL2002: Domande relative ai moduli personalizzati e soluzioni Outlook

ProprietÓ

Identificativo articolo: 290802 - Ultima modifica: martedý 19 novembre 2013 - Revisione: 4.0
Le informazioni in questo articolo si applicano a:
  • Microsoft Outlook 2002 Standard Edition
  • Microsoft Office Outlook 2003
Chiavi:á
kbforms kbhowto kbmt KB290802 KbMtit
Traduzione automatica articoli
IMPORTANTE: il presente articolo Ŕ stato tradotto tramite un software di traduzione automatica di Microsoft ed eventualmente revisionato dalla community Microsoft tramite la tecnologia CTF (Community Translation Framework) o da un traduttore professionista. Microsoft offre articoli tradotti manualmente e altri tradotti automaticamente e rivisti dalla community con l?obiettivo di consentire all'utente di accedere a tutti gli articoli della Knowledge Base nella propria lingua. Tuttavia, un articolo tradotto automaticamente, anche se rivisto dalla community, non sempre Ŕ perfetto. Potrebbe contenere errori di vocabolario, di sintassi o di grammatica. Microsoft declina ogni responsabilitÓ per imprecisioni, errori o danni causati da una traduzione sbagliata o dal relativo utilizzo da parte dei clienti. Microsoft aggiorna frequentemente il software e gli strumenti di traduzione automatica per continuare a migliorare la qualitÓ della traduzione.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 290802
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com