Article ID: 290840 - View products that this article applies to.
This article was previously published under Q290840
For a Microsoft Outlook 2000 version of this article, see 197026.
For a Microsoft Outlook 98 version of this article, see 179430.
Expand all | Collapse all

On This Page

SUMMARY

Microsoft Outlook supports the vCard and vCalendar features. These are a powerful new approach to electronic Personal Data Interchange (PDI).

PDI occurs every time individuals communicate in either a business or personal context. These interchanges frequently include the exchange of information, such as business cards, telephone numbers, addresses, dates and times of appointments. The vCard and vCalendar features facilitate PDI electronically.

This article discusses how to implement the vCard feature in Outlook. For information on the vCalendar feature, see the "References" section.

This article discusses the following topics:
  • How to create a vCard
  • How to distribute a vCard
  • How to automatically process a vCard
  • How to store a vCard in a secondary Contacts folder
  • How to include a vCard with your automatic signature
  • How to manually process a vCard as a text file

MORE INFORMATION

vCard serves as an electronic business card. It is a convenient way of exchanging personal information such as name, address, phone number, and e-mail address.

How to create a vCard

Use the following steps to create a vCard:
  1. In a Contact folder, click to select the contact for which you want a vCard.
  2. On the File menu, click Save As.
  3. In the Save file as type box, click to select VCARD Files (*.vcf).
  4. In the Save In box, select the folder where you want to save the vCard file, and then click Save.
This creates a vCard file with the same name as that of the Contact.

How to distribute a vCard

You can distribute a vCard file as you distribute any other computer file. To do this:
  1. Open a new message and address it to the recipient.
  2. On the Insert menu, click File.
  3. Click to select a vCard (.vcf) file, and then click OK.
NOTE: If you want to include Notes with your vCard, you must insert the .vcf file. If the .vcf is attached to your signature, the Notes field (and other fields) are removed prior from the vCard.

How to automatically process a vCard

With Outlook, you can automatically convert a vCard that was received from an external source to an Outlook Contact record. If the vCard arrives as an e-mail attachment, you can double-click the vCard attachment and then click Save And Close to add it to your default Contact folder. Alternatively, you can create a Contact from a vCard by dragging it to the Contacts folder.

NOTE: If the vCard icon appears as a generic Windows icon, it does not open when you double-click the icon, or you may receive an Open With prompt because the vCard File program is not associated with the .vcf file type.

If you receive the vCard in the form of a file on a disk, you can import it into your default Contact folder by using the Outlook "Import and Export Wizard." To do this, follow these steps:
  1. On the File menu, click Import And Export.
  2. Click to select the Import a vCard file (*.vcf) check box, and then click Next.
  3. Click to select the vCard file, and then click Open.
The vCard data is used to create a Contact record in your default Contacts folder.

How to store a vCard in a secondary contacts folder

If you import a vCard file, or if you open and then save a vCard file, it is placed directly into your default Contacts folder in the default message store.

To store the vCard in a Contacts folder other than the default, you can drag the vCard file to the secondary folder or first import it into the default Contacts folder, and copy it to the secondary folder.

How to include a vCard with your automatic signature

To do this, follow these steps:
  1. On the File menu, click Options.
  2. In the Mail section, click Signatures.
  3. Click New to add a new signature.
  4. Enter a name for your signature, and then click Next.
  5. Type the desired signature information in the text window.
  6. In Microsoft Office Outlook 2003 and in earlier versions of Outlook, click New vCard from Contact.

    In Microsoft Office Outlook 2007 and Microsoft Office Outlook 2010, click Business Card, select the contact that you want to add, and then click OK three times.
  7. In the Show Names from the box, select Contacts or another address list.
  8. Click to select the entry for which you want to create a vCard, click OK, click Finish, and then click OK to complete the signature entry.
Note If your vCard contains Notes, UserDefined fields, or Outlook-specific fields, these values are stripped from the vCard that is included with the signature. The Signature Picker specifically includes only those fields in a Contact that are essential to the definition of a vCard.

How to manually process a vCard as a text file

A vCard record is merely a text file. If you do not have an automated facility with which to process vCard records, you can open them with a text editor and then use the information. The contents of a vCard file varies with the information inserted by the file creator. However, a typical file that is created from a Contact record resembles the following file when it is opened in a text editor:
BEGIN:VCARD
VERSION:2.1
N:Doe;John;;;
FN:John Doe
ORG:Doe Company, The;
TITLE: President
NOTE;ENCODING=QUOTED-PRINTABLE: This is a note associated with this
contact=0D=0A
TEL;WORK;VOICE:(987) 123-4567
TEL;HOME;VOICE:(987) 765-4321
TEL;CELL;VOICE:(987) 135-8642
TEL;WORK;FAX:(987) 246-1357
ADR;WORK:;;1234 North Street;Anytown;TX 751234;;United States of America
LABEL;WORK;ENCODING=QUOTED-PRINTABLE:1234 North Street=0D=0AAnytown, TX
751234 =0D=0AUnited States of America
URL:
URL:<WWLINK TYPE="GENERIC"
VALUE="http://www.doeweb.com">http://www.doeweb.com</WWLINK>
EMAIL;PREF;INTERNET:jdoe@nowhere.com
REV:19980114T170559Z
END:VCARD
				
Note Text formatting that is applied to entries in the Notes field is not preserved when the .vcf file is save to your hard disk. The file format is preserved in ASCII text only.

REFERENCES

For more information about the vCalendar feature, click the following article number to view the article in the Microsoft Knowledge Base:
179431 How to use vCalendar in Outlook 98

Properties

Article ID: 290840 - Last Review: May 20, 2010 - Revision: 4.0
APPLIES TO
  • Microsoft Office Outlook 2007
  • Microsoft Office Outlook 2003
  • Microsoft Outlook 2002 Standard Edition
Keywords: 
kbhowto kbmigrate KB290840

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com