Jak lze minimalizovat metadata v aplikaci Word 2002

Překlady článku Překlady článku
ID článku: 290945 - Produkty, které se vztahují k tomuto článku.
Microsoft Word 97 verzi tohoto článku naleznete 223790.

Microsoft Word 2000 verzi tohoto článku naleznete 237361.

Microsoft Word 2003 verzi tohoto článku naleznete 825576.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Souhrn

Tento článek popisuje různé metody, které můžete použít k minimalizaci metadat v dokumentech aplikace Microsoft Word.

Při každém vytvoření, otevření nebo uložení dokumentu v aplikaci Word 2002, může dokument obsahovat obsahu není chtít sdílet s ostatními při elektronické distribuci dokumentu. Tyto informace jsou známy jako metadata. Metadata se používají pro různé účely zvýšit úpravy, zobrazování, archivace a načítání dokumentů sady Microsoft Office.

Některá metadata jsou jednoduše přístupná přes uživatelské rozhraní aplikace Word. Jiná metadata jsou přístupná pouze pomocí speciálních metod, například pomocí otevření dokumentu v nízkoúrovňovém binárním editoru souborů. Následuje několik příkladů metadat, která mohou být v dokumentu uložena:
  • Jméno
  • vaše iniciály,
  • název společnosti nebo organizace,
  • název počítače,
  • název síťového serveru nebo pevného disku, na který jste dokument uložili,
  • další vlastnosti souboru a souhrnné informace,
  • neviditelné části vložených objektů OLE,
  • Názvy předchozí autoři dokumentů
  • revize dokumentu,
  • verze dokumentu,
  • informace o šablonách,
  • Skrytý text
  • komentáře
Metada jsou v dokumentech aplikace Word vytvářena různými způsoby. Výsledkem je, že neexistuje jediná metoda, kterou by bylo možné z dokumentů odebrat veškerý obsah tohoto typu. Následující části popisují oblasti dokumentů aplikace Word, ve kterých mohou být metadata uložena.

Tento článek popisuje různé metody, jejichž použitím lze minimalizovat metadata v dokumentech aplikace Word.


ZŘEKNUTÍ SE PRÁV

Ukázky programů jsou společností Microsoft poskytovány pouze pro ilustraci bez žádné záruky výslovně uvedené ani předpokládané, včetně předpokládaných záruk vztahujících se k obchodovatelnosti nebo vhodnosti pro určitý účel. Tento článek předpokládá, že uživatel je obeznámen s programovacím jazykem, který je předmětem ukázky, a s nástroji použitými pro vytvoření a ladění skriptu. Pracovníci technické podpory společnosti Microsoft mohou vysvětlit funkce určitého postupu, nemohou však následující příklady rozšířit o další funkce nebo konstrukce podle konkrétních požadavků uživatele.
Pokud máte zkušenosti s programováním omezený, můžete kontaktovat partnera s certifikátem Microsoft nebo služby Advisory. Na další informace těchto webech společnosti Microsoft:

Microsoft Certified Partner - https://partner.microsoft.com/global/30000104

Služba Microsoft zpravodaje - http://support.microsoft.com/gp/advisoryservice

Další informace o možnostech podpory, které jsou k dispozici a o možnostech kontaktování společnosti Microsoft na následujícím webu společnosti Microsoft: http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMSDalší informace o způsobu použití ukázkového kódu v tomto článku klepněte na následující číslo článku databáze Microsoft Knowledge Base:
290140OFFXP: Jak spustit ukázkový kód z článků znalostní báze

Jak při uložení dokumentu automaticky odebrat osobní informace

Můžete nyní automaticky odebrat osobní informace z aplikace Word dokumentu při ukládání dokumentu. Chcete-li tuto možnost zapnout, postupujte takto:
  1. V nabídce Nástroje klepněte na tlačítko Možnosti.
  2. Na kartě zabezpečení zaškrtněte políčko odebrat osobní informace z tohoto souboru na uložení ve skupinovém rámečku Možnosti Privacy a klepněte na tlačítko OK.
Poznámka: To je upřednostňovaný metoda odebrání osobních informací při uložení dokumentu aplikace Word 2002.

Jak ručně odebrat z dokumentů své uživatelské jméno

Chcete-li zobrazit nebo změnit uživatelské jméno, postupujte takto:
  1. V nabídce Nástroje klepněte na tlačítko Možnosti a klepněte na položku User informační kartu.

    Zobrazí se následující textová pole:

    Název
    Iniciály
    Poštovní adresa
  2. Všechny tyto informace se zobrazí v dokumentech nechcete, zadejte do příslušných textových polí neidentifikační řetězce nebo mezery a klepněte na tlačítko OK přijmete změny.
Poznámka: Tyto informace namísto výchozích hodnot, které jsou zadány při instalaci sady Office bude obsahovat nové dokumenty, které vytvoříte. Stávající dokumenty ale již tyto informace obsahovat mohou.

Jak ručně odebrat osobní souhrnné informace

Při vytvoření nebo uložení dokumentu v aplikaci Word mohou být v dokumentu uloženy souhrnné informace. Chcete-li získat přístup k těmto informacím, můžete použít několik metod:
  • Otevřete dokument. V nabídce soubor klepněte na tlačítko Vlastnosti.

    Všechny karty Souhrn, Statistika, obsah a Vlastní může obsahovat různé vlastnosti, jako je například vaše jméno, jméno vašeho manažera a název společnosti.
  • V Průzkumníkovi Windows klepněte pravým tlačítkem myši na dokument a klepněte na příkaz Vlastnosti.

    Na kartách v dialogovém okně může obsahovat informace.
  • Můžete použít Microsoft Visual Basic for Applications) makro nebo jiný kód programu číst vlastnosti zobrazené v dialogovém okně Vlastnosti.
Chcete-li ze stávajícího dokumentu nebo šablony vymazat souhrnné informace, postupujte takto:
  1. Otevřete daný dokument nebo šablonu.
  2. V nabídce soubor klepněte na tlačítko Vlastnosti.
  3. Na kartě Souhrn zrušte Autor, správce, Společnost a jakékoli další textová pole, které nechcete distribuovat.
  4. Na kartě Vlastní odstranit vlastnosti obsahující informace, které nechcete distribuovat.
  5. Klepněte na tlačítko OK.

    V nabídce soubor klepněte na tlačítko Uložit a potom klepněte na tlačítko Zavřít.
Po dokončení těchto kroků nebude dokument obsahovat souhrnné informace.

Jak ručně odebrat osobní souhrnné informace při připojení k síti

Pokud jste přihlášeni k síti může vaše síťové uživatelské jméno zobrazí v poli Autor na kartě Souhrn a uložil pole na kartě Statistika při uložení dokumentu. Tento problém může nastat dokonce i v případě, že jste všechny další osobní informace z počítače odebrali.

Chcete-li v prostředí sítě odebrat z dokumentu souhrnné informace, postupujte takto:
  1. Je-li dokument uložený na síťovém serveru, zkopírujte ho na místní pevný disk.
  2. Spuštění počítače, ale proveďte protokolu k síti. Při naleznete v přihlašovacím dialogovém okně Síť klepněte na tlačítko Storno nebo stisknutím klávesy ESC.

    Poznámka: Pokud systém Windows nelze spustit stisknutím klávesy ESC (například počítače se systémem Microsoft Windows NT), tyto kroky nelze pokračovat.
  3. Otevřete dokument.
  4. V nabídce soubor klepněte na tlačítko Vlastnosti.
  5. Na kartě Souhrn zrušte Autor, správce, Společnost a jakékoli další textová pole obsahující informace, které nechcete distribuovat.
  6. Na kartě Vlastní odstranit vlastnosti obsahující informace, které nechcete distribuovat.
  7. Klepněte na tlačítko OK.

    V nabídce soubor klepněte na tlačítko Uložit a potom klepněte na tlačítko Zavřít.
Při přihlášení k síti nelze otevřít soubor. Pokud tak učiníte, vaše síťové uživatelské jméno může být do souboru zapsáno. Pomocí programu Průzkumník Windows však můžete tento soubor zkopírovat na síťový server nebo na disketu.

Jak v dokumentech ručně odebrat komentáře

Aplikace poskytuje možnost přidat komentáře dokumentů. Komentáře v obvyklém případě obsahují jméno osoby, která je vytvořila, takže mohou poskytnout informace o svém autorovi.

Komentáře se obvykle zobrazí jako zvýrazněnou část textu, klepněte pravým tlačítkem myši na komentář a potom klepněte na tlačítko Odstranit komentář.

Nové poznámky, které vytvoříte nebude obsahovat uživatelské jméno, protože jste odebrali z Možnosti dialogové okno, jak je popsáno v tomto článku v části "Jak k ručně odebrat Your User Name z svůj dokumenty".

Jak z dokumentů ručně odebrat záhlaví a zápatí

Záhlaví a zápatí dokumentů mohou obsahovat identifikační informace. Chcete-li odebrat informace ze záhlaví a zápatí, postupujte takto:
  1. V nabídce Zobrazit klepněte na záhlaví a zápatí.
  2. Záhlaví a zápatí se zobrazí nahoře a dole na každé stránce dokumentu.

    Změňte je podle potřeby.
  3. Na panelu nástrojů záhlaví a zápatí klepněte na tlačítko Zavřít.

Jak ručně odebrat revizní značky

Dokumenty mohou obsahovat revizní značky. Revizní značky umožňují určit, kdo provedl konkrétní změny dokumentu. Pokud revizní značky přijmete nebo odmítnete, v dokumentu bude uložen opravený text a revizní značky budou odstraněny.

Chcete-li přijmout nebo odmítnout revize, postupujte takto:
  1. V nabídce Nástroje přejděte na příkaz Sledování změn a potom klepněte na tlačítko Přijmout či zamítnout změny.
  2. V dialogovém okně Přijmout či zamítnout změny pomocí dvou tlačítek Najít vyhledejte konkrétní revize přijmout nebo odmítnout jednotlivě nebo klepněte na tlačítko Přijmout vše nebo Zamítnout vše.
  3. Po dokončení klepněte na tlačítko Zavřít.
Poznámka: Pokud změna nastavení "Zobrazit" na panelu nástrojů Revize revize nejsou odebrány.

Jak vypnout rychlé ukládání

Funkce Rychlé ukládání urychluje proces uložení dokumentu uložením pouze změny provedené v dokumentu.

Vzhledem k tomu, jak je funkce Rychlé ukládání navržena, může ale odstraněný text v dokumentu zůstat dokonce i poté, co dokument uložíte. Pokud máte obavy z toho, že odstraněný text mohl v dokumentech zůstat, postupujte takto:
  1. V nabídce Nástroje klepněte na tlačítko Možnosti.
  2. Klepněte na kartu Uložit.
  3. Klepnutím zrušte zaškrtnutí políčka Povolit rychlé ukládání.

    Klepněte na tlačítko OK.
Další informace o rychlé ukládání klepněte na následující čísla následujících článcích databáze Microsoft Knowledge Base:
290945Jak lze minimalizovat metadata v aplikaci Microsoft Word 2002
291181WD2002: Časté otázky o "Allow rychlého ukládání"

Jak vyhledat a odebrat text, který je naformátován jako skrytý

V dokumentech aplikace Word můžete formátovat text jako skryté. Protože skrytý text může obsahovat informace, které nechcete distribuovat, můžete jej chtít zobrazit a odebrat. Chcete-li v dokumentu odebrat veškerý text naformátovaný jako skrytý, postupujte takto:
  1. V nabídce Nástroje klepněte na tlačítko Možnosti a potom klepněte na tlačítko Zobrazit kartu.
  2. Zaškrtněte políčko skrytý text a potom klepněte na tlačítko OK.
  3. V nabídce Úpravy klepněte na tlačítko Nahradit.
  4. Rozbalte klepnutím na tlačítko Další dialogové okno.
  5. Klepněte do textového pole vedle Najít.
  6. Klepněte na tlačítko Formát a potom klepněte na tlačítko písmo.

    Klepnutím vyberte skrytý zaškrtávací políčko a klepněte na tlačítko OK.
  7. Klepněte na Nahradit vše.
Veškerý skrytý text bude z dokumentu odstraněn. Chcete-li vypnout zobrazení skrytého textu, postupujte takto:
  1. V nabídce Nástroje klepněte na tlačítko Možnosti a potom klepněte na tlačítko Zobrazit kartu.
  2. Klepnutím zrušte zaškrtnutí políčka skrytý text.

    Klepněte na tlačítko OK.

Jak z dokumentů odebrat hypertextové odkazy

Dokumenty mohou obsahovat hypertextové odkazy do jiných dokumentů nebo webových stránek v síti intranet nebo Internet. Hypertextové odkazy se v typickém případě zobrazují jako řetězce modrého podtrženého textu.

Odstranit jeden hypertextový odkaz z dokumentu ručně, klepněte pravým tlačítkem myši na hypertextový odkaz, přejděte na příkaz hypertextový odkaz a klepněte na příkaz Odebrat hypertextový odkaz.

Chcete-li v dokumentu odstranit všechny hypertextové odkazy, můžete použít makro jazyka VBA. Následující ukázkové makro jazyka VBA odebere v dokumentu všechny hypertextové odkazy.

Poznámka: V následující ukázkové makro je odebrána pouze propojení. Text hypertextového odkazu v dokumentu zůstane.

Důležité: Před použít následující příklad makra zkontrolovat Dementi dříve v tomto článku.
Sub RemoveHyperlinks()

   Dim oDoc As Document
   Dim oStory As Range
   Dim oHlink As Hyperlink

   For Each oStory In ActiveDocument.StoryRanges
      For Each oHlink In oStory.Hyperlinks
         oHlink.Delete
      Next
   Next



End Sub
				
Odebrat všechna trasování i na hypertextový odkaz a text hypertextového odkazu z dokumentu, můžete následující ukázkové makro použít místo.
Sub RemoveAllHyperlinks()

   Dim oDoc As Document
   Dim oStory As Range
   Dim oHlink As Hyperlink

   For Each oStory In ActiveDocument.StoryRanges
      For Each oHlink In oStory.Hyperlinks
         oHlink.Range.Delete
      Next
   Next

End Sub
				

Jak z dokumentů odebrat styly

Dokumenty mohou zahrnovat styly obsahující metadata. Tyto styly lze odebrat nebo přejmenovat. Postupujte takto:
  1. Otevřete dokument obsahující styly.
  2. V nabídce Formát klepněte na tlačítko styl.
  3. Vyberte styl, který chcete odstranit nebo přejmenovat.

    Odstranit, klepněte na tlačítko Odstranit styl nebo klepněte na tlačítko změnit ji přejmenovat.

Jak z dokumentů odebrat starší verze souboru

Word zahrnuje funkci verze souboru, který umožňuje uložení více verzí stejného dokumentu ve stejném souboru. Před sdílením dokumentu s jinými uživateli můžete chtít starší verze odstranit.

Chcete-li odstranit jednu nebo více verzí dokumentu, postupujte takto:
  1. V nabídce soubor klepněte na příkaz verze.
  2. Vyberte verzi dokumentu, kterou chcete odstranit.

    Pokud budete během výběru verzí držet stisknutou klávesu CTRL, můžete vybrat více než jednu verzi.
  3. Klepněte na tlačítko Odstranit.
  4. Po odstranění starých verzí dokumentu klepněte na tlačítko Uložit na soubor nabídce.

Jak odebrat propojení z kódů polí

Propojené obrázky a další objekty v dokumentech aplikace Word mohou obsahovat informace o propojení, například cestu propojeného obrázku nebo objektu. Informace o propojení lze z dokumentu odebrat úpravou kódu polí.

Chcete-li zobrazit kódy polí, postupujte takto:
  1. V nabídce Nástroje klepněte na tlačítko Možnosti a potom klepněte na tlačítko Zobrazit kartu.
  2. Klepnutím zaškrtněte políčko kódy polí.

    Klepněte na tlačítko OK.
Poté, co se kódy polí stanou viditelné, je můžete zkontrolovat a zjistit, zda obsahují identifikační informace.

Chcete-li odebrat informace o propojení z propojeného obrázku nebo jiného objektu, postupujte takto:
  1. Vyberte propojený obrázek nebo objekt nebo vyberte kód pole obrázku nebo objektu (pokud jsou kódy polí viditelné).
  2. Stiskněte kombinaci kláves CTRL + SHIFT + F9.
Obrázek nebo objekt je nyní nepropojený. Jestliže propojení obrázku nebo objektu nelze upravit.

Jak odebrat název a umístění šablony

Všechny dokumenty vytvořené v aplikaci Word jsou založeny na šabloně. Ve výchozím nastavení se jedná o soubor šablony Normal.dot umístěný ve složce Šablony. Můžete však vytvořit dokument založený na jiné šabloně v jiném umístění. Cesta a název této šablony jsou uloženy ve vlastnosti v dokumentu.

Zobrazit název šablony a umístění, v nabídce soubor klepněte na příkaz Vlastnosti a klepněte na kartu Souhrn.

Název a umístění šablony v dokumentu zůstává dokonce i v případě, že šablonu neodešlete spolu s dokumentem. Chcete-li změnit název a umístění šablony na hodnoty neumožňující identifikaci, postupujte takto:
  1. V nabídce Nástroje klepněte na příkaz šablony a doplňky.
  2. Klepněte na tlačítko připojit.
  3. Vyberte šablonu, jejíž název a umístění neobsahuje citlivé nebo jedinečné informace.

    Například protože každý počítač má nainstalovaný Word obsahuje Normal.dot, můžete vybrat Normal.dot.
  4. Klepněte na tlačítko Otevřít a potom klepněte na tlačítko OK.
Poznámka: Šablony mohou obsahovat makra, položky autotext, vlastní styly a vlastní panely nástrojů. Změna šablon může způsobit, že se některé z těchto položek stanou pro dokument nedostupné.

Jak odebrat informace o směrovací adrese

Odeslání dokumentu e-mailem pomocí směrovací adresy směrovací informace může být připojené k dokumentu. Chcete-li tyto informace z dokumentu odebrat, je nutné uložit dokument ve formátu, který informace o směrovací adrese neuchovává.

V aplikaci Word uložte dokument buď ve formátu RTF (Rich Text Format), nebo ve formátu HTML. Zavřete dokument a poté znovu otevřete nový soubor. Protože informace o směrovací adrese již nejsou součástí dokumentu, můžete nyní dokument uložit ve formátu aplikace Word.

Lze také provést následující postup:
  1. Vypnout Povolit rychlé ukládání se pomocí pokynů v tomto článku výše.
  2. V nabídce soubor přejděte na příkaz Odeslat a potom klepněte na příkaz Další příjemce směrování.
  3. Klepněte na tlačítko Vymazat odeberete směrovací adresu a klepněte na tlačítko OK.
  4. V nabídce soubor klepněte na tlačítko Uložit.
Dokument je nyní uložen bez jakýchkoli informací o směrovací adrese.

Jak odebrat informace příjemce pošty

Komu, kopie, zachová aplikace Word 2002 a Skrytá e-mailové adresy odeslat dokument pomocí příkazu Odeslat v nabídce soubor a potom klepněte na příkaz Příjemce pošty a záhlaví e-mailu je povolena pro dokument. Informace mohou být odebrány automaticky způsobem popsaným v části "Jak k ručně odebrat Your User Name z svůj dokumenty".

Microsoft Visual Basic for makra (VBA) lze povolit nastavení text odebrat osobní informace ze souboru uložit vlastnosti na ”.

Důležité: Před použít následující příklad makra zkontrolovat Dementi dříve v tomto článku.

Sub RemoveInformation()
ActiveDocument.RemovePersonalInformaation = True
End Sub

Jak odebrat jména předchozí autoři

Aplikace Word ukládá názvy posledních 10 osob, které pracovaly na dokumentu v dokumentu. Toto je automatické funkce, která nelze vypnout.

Názvy posledních 10 autoři můžete z dokumentu odebrat pomocí jedné z následujících metod:
  • Uložte dokument ve formátu nezachová takové informace. Pokud dokument uložíte ve formátu RTF nebo HTML, informace o vytváření obsahu je například ztraceny. Můžete potom zavřete a znovu otevřete dokument RTF nebo HTML a uložit ve formátu aplikace Word.
  • Vytvořit nový dokument a vložit obsah existujícího dokumentu do nového dokumentu. Chcete-li to provést, klepněte na tlačítko Vložit a potom soubor.
  • Pomocí možnosti odebrat osobní informace popsané dříve v článku. Možnost odebrat osobní informace odeberete tyto názvy.
Poznámka: Tyto informace nejsou uloženy podle Word 2003.

Jak odebrat své jméno z kódu jazyka Visual Basic

Důležité: Před použít následující příklad makra zkontrolovat Dementi dříve v tomto článku.

Při záznamu makra VBA v aplikaci Word zaznamenané makro začíná záhlaví je podobná následující:
' Macro1 Macro
' Macro recorded 3/11/1999 by <User Name>
				
odebrání z makra nahraný vaše jméno, postupujte takto:
  1. Otevřete dokument obsahující daná makra.
  2. V nabídce Nástroje přejděte na příkaz makro a klepněte na příkaz Editor jazyka nebo stiskněte klávesy ALT + F11.
  3. V okně projektu poklepejte na modul obsahující makra.
  4. Odeberte z kódu zaznamenaného makra své jméno.
Po dokončení odebrání vaše jméno, stiskněte klávesy ALT + Q vraťte program a v nabídce soubor klepněte na tlačítko Uložit.

Jak odebrat odkazy jazyka Visual Basic na jiné soubory

V editoru jazyka můžete vytvořit odkaz na jiný soubor. Pokud uživatel otevře dokument obsahující odkaz na jiný soubor, může vidět názvy souborů, na které byly vytvořeny odkazy.

Chcete-li tyto odkazy odebrat, postupujte takto:
  1. Otevřete dokument obsahující odkazy.
  2. V nabídce Nástroje přejděte na příkaz makro a klepněte na příkaz Editor jazyka nebo stiskněte klávesy ALT + F11.
  3. V nabídce Nástroje klepněte na odkazy.
  4. Zrušte zaškrtnutí políčka vedle souboru nebo souborů, na které byly vytvořeny odkazy.

    Po dokončení klepněte na tlačítko OK.
  5. Stiskněte klávesy ALT + Q.
  6. V nabídce soubor klepněte na tlačítko Uložit.
Poznámka: Odebrat odkazy na jiné soubory to může nepříznivě ovlivnit schopnost makra v dokumentu pracovat správně.

Jak odebrat informace o síti nebo pevném disku

Při uložení dokumentu na místní pevný disk nebo síťový server informace identifikující místní pevný disk nebo síťový server mohou být napsána v dokumentu.

Chcete-li tyto informace z dokumentu odebrat, postupujte takto:
  1. Otevřete dokument.
  2. V nabídce soubor klepněte na tlačítko Uložit jako.

    Uložte dokument na disketovou jednotku (obvykle jednotka A).
  3. V nabídce soubor klepněte na tlačítko Zavřít.
  4. Vyjměte disketu z disketové jednotky.
Nyní můžete pomocí programu Průzkumník Windows dokument z diskety zkopírovat na libovolný pevný disk nebo síťový server.

Poznámka: Z důvodu omezení prostoru diskety (obvykle 1,44 megabajtů [MB]) nelze tuto metodu použít Pokud velikost souboru dokumentu přesahuje volné místo na disketě.

Objekty vložené do dokumentů mohou obsahovat metadata

Vložení objektu do dokumentu objekt zůstane stále své vlastní vlastnosti, bez ohledu na to, proveďte v dokumentu. Pokud například do dokumentu aplikace Word vložíte sešit aplikace Excel, dokument a sešit mají každý své vlastní vlastnosti.

Odebrat metadata z vloženého objektu, objekt aktivovat, odebrat libovolné metadata popsané v předchozích částech, znovu aktivujte dokument kontejneru a uložit dokument kontejneru.

Poznámka: Při aktivaci vloženého objektu v dokumentu v dokumentu se zobrazí pouze část vložený objekt; objekt může obsahovat další informace, které se nezobrazí. Pokud chcete, aby dokument obsahoval pouze vykreslení vloženého objektu a nikoli skutečný obsah, pomocí příkazu Vyjmout v nabídce Úpravy odstranit objekt a potom pomocí příkazu Vložit jinak vložit objekt do dokumentu pomocí formátu Metafile. Poté již nebude možné vložený objekt upravovat, nebude však obsahovat žádná metadata.

Proměnné dokumentu mohou obsahovat metadata

Důležité: Před použít následující ukázkové makro zkontrolovat Dementi dříve v tomto článku.

Chcete-li odstranit proměnné dokumentu obsažené v dokumentu, použijte následující ukázkové makro:
Sub DeleteDocVars()

   Dim Response
   Dim myVar As Variable

   For Each myVar In ActiveDocument.Variables
      Response = MsgBox("The document variable: " & myVar.Name & vbCr & _
         "Value: " & myVar.Value & vbCr & vbCr & _
         "Do you want to delete the variable from this document?", vbYesNo)
            
      If Response = "6" Then
         ' Delete the variable.
         myVar.Delete
      Else
         End
      End If
   Next myVar
            
   MsgBox "There are no variables in the document."
   
End Sub
				
Další informace o proměnných v editoru jazyka klepněte v nabídce Nápověda pro Microsoft Visual Basic zadejte Vlastnost proměnné v Pomocníkovi Office nebo průvodce a klepněte na tlačítko Hledat zobrazíte příslušné téma.

Jak z dokumentů odebrat vlastnost AdHocReviewCycleID

Při odeslání dokumentu Word 2002 v e-mailovou vlastnost AdHocReviewCycleID přidána do dokumentu a vlastnost je přiřazena náhodně generované hodnota GUID. Při otevření dokumentu s hodnotou AdHocReviewCycleID hodnotu porovnány s GUID dokumenty, které jste dříve vytvořili v počítači. Pokud GUID odpovídá GUID v počítači, zobrazí se výzva s následující dialogové okno:
Chcete sloučit změny provedené v DocumentName do FilePathDocumentName?
Odebrat vlastnost AdHocReviewCycleID, postupujte takto:
  1. Otevřete dokument.
  2. Klepněte na soubor, klepněte na příkaz Vlastnosti a potom klepněte na tlačítko Vlastní kartu.
  3. V okně Vlastnosti v seznamu název záhlaví, klepněte na tlačítko _AdHocReviewCycleID a klepněte na příkaz Odstranit.
  4. Klepněte na tlačítko OK.

Obecná doporučení týkající se zabezpečení

Zde jsou některé obecné návrhy můžete zvýšit úroveň zabezpečení vašeho výpočetního prostředí:
  • Vždy, když nejste u svého počítače, zabezpečte jej pomocí spořiče obrazovky chráněného heslem, heslem pro zapnutí nebo funkcí uzamknutí systému Windows NT.
  • Pokud jsou v počítači libovolné sdílené složky, použijte k jejich ochraně heslo, aby k nim měli přístup pouze oprávnění uživatelé. Ještě lepší zabezpečení pomocí řízení přístupu na úrovni uživatele tak, že řídit přesně, kteří přístup podílů vašeho počítače.
  • Po odstranění souboru ihned vysypte Koš. Můžete zvážit použití nástroje, který soubory po odstranění zcela vymaže nebo přepíše.
  • Při zálohování dat ukládat záložní soubory zabezpečeného umístění, například bezpečné, pole vkladové zabezpečení nebo uzamčená skříňka. Jednu kopii zálohy v zabezpečené off-site umístění úložiště v případě primárního umístění nepoužitelný.
  • Zajistěte, aby důležité dokumenty byly chráněny heslem, takže je budou moci otevřít pouze oprávnění uživatelé. Uchovávejte svá hesla na bezpečném odděleném místě. Všimněte si, že pokud heslo nelze odvolat, žádným způsobem obnovit obsah dokument chráněný heslem.
  • Nedistribuujte dokumenty v elektronické formě. Namísto toho je vytiskněte. Nepoužívejte identifikační prvky, jako jsou charakteristická písma, vodoznaky, loga nebo speciální papíry, není-li to nezbytné (například pro prezentaci).
  • E-mail není anonymní. Neodesílejte e-mailem dokument, pokud se obáváte spojení dokumentu s vaší osobou.
  • Neodesílejte dokument přes Internet pomocí protokolů HTTP nebo FTP (File Transfer Protocol). Informace odeslané přes tyto protokoly je odeslána v "prostého textu,". To znamená, že je technicky možné (však nepravděpodobné) pro něj být zachycen.

Vlastnosti

ID článku: 290945 - Poslední aktualizace: 23. listopadu 2006 - Revize: 2.10
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Word 2002 Standard Edition
Klíčová slova: 
kbmt kbconfig kbdta kbhowtomaster KB290945 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:290945

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com