Comment faire pour réduire les métadonnées dans Word 2002

Traductions disponibles Traductions disponibles
Numéro d'article: 290945 - Voir les produits auxquels s'applique cet article
Pour vous procurer la version Microsoft Word 97 de cet article, reportez-vous à l'article 223790 .

Pour vous procurer la version Microsoft Word 2000 de cet article, reportez-vous à l'article 237361 .

Pour vous procurer la version Microsoft Word 2003 de cet article, reportez-vous à l'article 825576 .
Agrandir tout | Réduire tout

Sommaire

Résumé

Cet article décrit plusieurs méthodes que vous pouvez utiliser pour réduire les métadonnées de vos documents Word.

Lorsque vous créez, ouvrez ou enregistrez un document dans Word 2002, il se peut que le document contienne des informations que vous ne voulez pas partager avec les autres lorsque vous distribuez le document électroniquement. Ces informations sont appelées métadonnées. Les métadonnées sont utilisées à différentes fins pour améliorer l'édition, l'affichage, le classement et la récupération des documents Microsoft Office.

Quelques métadonnées sont facilement accessibles à travers l'interface utilisateur Word. Les autres métadonnées sont seulement accessibles par des moyens peu ordinaires, par exemple en ouvrant un document dans un éditeur de fichier binaire de bas niveau. Voici quelques exemples de métadonnées qui peuvent être stockées dans vos documents :
  • Votre nom
  • Vos initiales
  • Le nom de votre société ou organisation
  • Le nom de votre ordinateur
  • Le nom du serveur réseau ou disque dur sur lequel vous avez enregistré le document
  • D'autres propriétés de fichier et informations de résumé
  • Des parties invisibles d'objets OLE incorporés 
  • Les noms d'auteurs précédents du document
  • Les révisions du document
  • Les versions du document
  • Les informations relatives au modèle
  • Le texte masqué
  • Des commentaires
Les métadonnées sont créées de façons différentes dans les documents Word. En conséquence, il n'existe pas de méthode unique pour supprimer un tel contenu de vos documents. Les sections suivantes décrivent des zones où les métadonnées peuvent être enregistrées dans les documents Word.

Cet article décrit plusieurs méthodes que vous pouvez utiliser pour réduire les métadonnées de vos documents Word.


EXCLUSION DE RESPONSABILITÉ

Microsoft fournit des exemples de programmation à des fins d'illustration uniquement, sans garantie expresse ou implicite, y compris, mais de manière non limitative, les garanties implicites de qualité marchande et/ou d'adéquation à un usage particulier. Cet article suppose que vous connaissez le langage de programmation présenté et les outils utilisés pour créer et déboguer des procédures. Les techniciens du Support technique Microsoft peuvent vous expliquer les fonctionnalités d'une procédure particulière, mais ils ne peuvent pas modifier les exemples en vue de vous fournir des fonctionnalités supplémentaires ou de créer des procédures répondant à vos besoins spécifiques. Si vous ne maîtrisez que partiellement la programmation, vous pouvez contacter un partenaire certifié Microsoft ou le service client Microsoft au 09 70 01 90 90qui pourra transmettre votre demande de consulting aux équipes Microsoft appropriées. Pour plus d'informations sur les partenaires certifiés Microsoft (Microsoft Certified Partners), reportez-vous au site Web de Microsoft à l'adresse suivante (en anglais) :
https://partner.microsoft.com/global/30000104
Pour plus d'informations sur les options de support technique disponibles et la façon de faire pour contacter Microsoft, reportez-vous au site Web de Microsoft à l'adresse suivante :
http://support.microsoft.com/default.aspx?scid=fh;FR-FR;CNTACTMS
Pour plus d'informations sur la procédure à suivre pour utiliser l'exemple de code de cet article, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
290140 OFFXP : Comment faire pour exécuter les exemples de code à partir des articles de la Base de connaissances

Comment faire pour supprimer automatiquement des informations personnelles lorsque vous enregistrez

Vous pouvez maintenant supprimer automatiquement des informations personnelles d'un document Word lorsque vous enregistrez le document. Pour activer cette option, procédez comme suit :
  1. Dans le menu Outils, cliquez sur Options.
  2. Sous l'onglet Sécurité, activez la case à cocher Supprimer les informations personnelles de ce fichier lors de l'enregistrement sous Options de confidentialité, puis cliquez sur OK.
Remarque Il s'agit de la méthode recommandée pour supprimer des informations personnelles lorsque vous enregistrez un document Word 2002.

Comment faire pour supprimer manuellement votre nom d'utilisateur de vos documents

Pour afficher ou modifier votre nom d'utilisateur, procédez comme suit :
  1. Dans le menu Outils, cliquez sur Options, puis sur l'onglet Utilisateur.

    Les zones de texte suivantes apparaissent :

    Nom
    Initiales
    Adresse postale
  2. Si vous ne voulez pas que ces informations apparaissent dans vos documents, introduisez des chaînes ou des espaces sans identification dans les zones de texte appropriées, puis cliquez sur OK pour accepter les modifications.
Remarque Tout nouveau document que vous créez contiendra ces informations au lieu des valeurs par défaut entrées lorsque vous avez installé Office. Toutefois, les documents existants peuvent déjà contenir ces informations.

Comment faire pour supprimer manuellement des informations de résumé personnelles

Lorsque vous créez ou enregistrez un document dans Word, des informations de résumé peuvent être enregistrées dans le document. Il existe plusieurs méthodes pour accéder à ces informations :
  • Ouvrez le document. Dans le menu Fichier, cliquez sur Propriétés.

    Les onglets Résumé, Statistiques, Contenu et Personnalisation peuvent contenir des propriétés telles que votre nom, le nom de votre responsable et celui de votre société.
  • Dans l'Explorateur Microsoft Windows, cliquez avec le bouton droit sur le document, puis cliquez sur Propriétés.

    Les onglets de la boîte de dialogue Propriétés peuvent contenir des informations.
  • Vous pouvez utiliser une macro VBA (Microsoft Visual Basic pour Applications) ou un autre code de programme pour lire les propriétés affichées dans la boîte de dialogue Propriétés.
Pour effacer les informations de résumé d'un document ou d'un modèle existant, procédez comme suit :
  1. Ouvrez le document ou modèle.
  2. Dans le menu Fichier, cliquez sur Propriétés.
  3. Sous l'onglet Résumé, désactivez les zones Auteur, Responsable, Société et toutes les autres zones de texte que vous ne voulez pas distribuer.
  4. Sous l'onglet Personnalisation, supprimez le cas échéant les propriétés contenant des informations que vous ne voulez pas distribuer.
  5. Cliquez sur OK.

    Dans le menu Fichier, cliquez sur Enregistrer, puis sur Fermer.
Une fois ces étapes effectuées, le document ne contiendra pas de propriétés de résumé.

Comment faire pour supprimer manuellement des informations de résumé personnelles lorsque vous êtes connecté à un réseau

Si vous avez ouvert une session sur un réseau, votre nom d'utilisateur réseau peut apparaître dans la zone Auteur sous l'onglet Résumé et dans le champ Dernier enregistrement par sous l'onglet Statistiques lorsque vous enregistrez un document. Ce problème peut se produire même si vous avez supprimé toutes les autres informations personnelles de votre ordinateur.

Pour supprimer des informations de résumé d'un document lorsque vous êtes sur un réseau, procédez comme suit :
  1. Si le document est enregistré sur un serveur réseau, copiez-le sur votre disque dur local.
  2. Démarrez votre ordinateur, mais ne vous connectez pas à votre réseau. Lorsque vous voyez la boîte de dialogue d'ouverture de session réseau, cliquez sur Annuler ou appuyez sur la touche Échap.

    Remarque Si vous ne pouvez pas démarrer Windows en appuyant sur la touche Échap (par exemple, votre ordinateur exécute Microsoft Windows NT), vous ne pouvez pas aller plus loin dans ces étapes.
  3. Ouvrez le document.
  4. Dans le menu Fichier, cliquez sur Propriétés.
  5. Sous l'onglet Résumé, désactivez les zones Auteur, Responsable, Société et toutes les autres zones de texte contenant des informations que vous ne voulez pas distribuer.
  6. Sous l'onglet Personnalisation, supprimez toute propriété qui contient des informations que vous ne voulez pas distribuer.
  7. Cliquez sur OK.

    Dans le menu Fichier, cliquez sur Enregistrer, puis sur Fermer.
Lorsque vous vous connectez au réseau, n'ouvrez pas le fichier. Si vous l'ouvrez, votre nom d'utilisateur réseau peut être écrit dans le fichier. Toutefois, vous pouvez utiliser l'Explorateur Windows pour copier le fichier soit sur un serveur réseau, soit sur une disquette.

Comment faire pour supprimer manuellement des commentaires dans les documents

Word offre la capacité d'ajouter des commentaires aux documents. En général, les commentaires contiennent le nom de la personne qui les a créés, afin de pouvoir savoir qui les a écrits.

Les commentaires apparaissent en général comme une section de texte en surbrillance ; vous pouvez cliquer avec le bouton droit sur le commentaire, puis cliquer sur Supprimer le commentaire.

Tout nouveau commentaire que vous créez ne contiendra pas votre nom d'utilisateur parce que vous l'avez supprimé de la boîte de dialogue Options comme décrit dans la section « Comment faire pour supprimer votre nom d'utilisateur de vos documents » de cet article.

Comment faire pour supprimer manuellement les en-têtes et pieds de page des documents

Les en-têtes et les pieds de page des documents peuvent contenir des données d'identification. Pour supprimer des informations des en-têtes et pieds de page, procédez comme suit :
  1. Dans le menu Affichage, cliquez sur En-tête et pied de page.
  2. L'en-tête et le pied de page apparaissent en haut et en bas de chaque page dans votre document.

    Modifiez-les comme vous le voulez.
  3. Dans la barre d'outils En-tête et pied de page, cliquez sur Fermer.

Comment faire pour supprimer manuellement des marques de révision

Les documents peuvent contenir des marques de révision. Les marques de révision vous permettent de déterminer qui apporte des modifications spécifiques à un document. Lorsque vous acceptez ou rejetez des marques de révision, le texte modifié est enregistré dans le document et les marques de révision sont supprimées.

Pour accepter ou rejeter des révisions, procédez comme suit :
  1. Dans le menu Outils, pointez sur Suivi des modifications, puis cliquez sur Accepter ou refuser les modifications.
  2. Dans la boîte de dialogue Accepter ou refuser les modifications, utilisez les deux boutons de recherche pour localiser les révisions spécifiques à accepter ou refuser ou cliquez sur Accepter tout ou Refuser tout.
  3. Lorsque vous avez terminé, cliquez sur Fermer.
Remarque Si vous modifiez les paramètres d'affichage dans la barre d'outils Révision, les informations de révision ne sont pas supprimées.

Comment faire pour désactiver les enregistrements rapides

La fonctionnalité d?enregistrements rapides accélère le processus d'enregistrement d'un document en enregistrant uniquement les modifications qui y sont apportées.

En raison de la conception de la fonction Enregistrements rapides, le texte que vous supprimez d'un document peut rester dans le document même après l'enregistrement de celui-ci. En cas de doute concernant le texte supprimé restant dans vos documents, procédez comme suit :
  1. Dans le menu Outils, cliquez sur Options.
  2. Cliquez sur l'onglet Enregistrer.
  3. Désactivez la case à cocher Autoriser les enregistrements rapides.

    Cliquez sur OK.
Pour plus d'informations sur les enregistrements rapides, cliquez sur les numéros ci-dessous pour afficher les articles correspondants dans la Base de connaissances Microsoft.
290945 Comment faire pour réduire les métadonnées dans Microsoft Word 2002
291181 WD2002 : Forum Aux Questions concernant l'option « Autoriser les enregistrements rapides »

Comment faire pour rechercher et supprimer du texte mis en forme en tant que texte masqué

Dans les documents Word, vous pouvez mettre en forme du texte en tant que texte masqué. Étant donné que le texte masqué peut contenir des informations que vous pouvez ne pas vouloir distribuer, vous pouvez l'afficher et le supprimer. Pour supprimer tout le texte d'un document qui est mis en forme en tant que texte masqué, procédez comme suit :
  1. Dans le menu Outils, cliquez sur Options, puis sur l'onglet Affichage.
  2. Activez la case à cocher Texte masqué, puis cliquez sur OK.
  3. Dans le menu Edition, cliquez sur Remplacer.
  4. Cliquez sur Plus pour développer la boîte de dialogue.
  5. Cliquez n'importe où dans la zone de texte en regard de Rechercher.
  6. Cliquez sur le bouton Format, puis sur Police.

    Activez la case à cocher Masqué, puis cliquez sur OK.
  7. Cliquez sur Remplacer tout.
Tout le texte masqué est supprimé du document. Pour désactiver l'affichage de texte masqué, procédez comme suit :
  1. Dans le menu Outils, cliquez sur Options, puis sur l'onglet Affichage.
  2. Désactivez la case à cocher Texte masqué.

    Cliquez sur OK.

Comment faire pour supprimer des liens hypertexte des documents

Les documents peuvent contenir des liens hypertexte vers d'autres documents ou pages Web sur un réseau intranet ou Internet. Les liens hypertexte apparaissent, en général, sous forme de chaînes de texte soulignées en bleu.

Pour supprimer manuellement un lien hypertexte unique d'un document, cliquez avec le bouton droit sur le lien hypertexte, pointez sur Lien hypertexte, puis cliquez sur Supprimer un lien hypertexte.

Si vous voulez supprimer tous les liens hypertexte d'un document, vous pouvez utiliser une macro VBA. L'exemple de macro VBA suivant supprime tous les liens hypertexte d'un document.

Remarque Dans l'exemple de macro suivant, seul le lien est supprimé. Le texte du lien hypertexte reste dans le document.

Important Avant que vous n'utilisiez l'exemple de macro suivant, consultez la section relative à l'exclusion de responsabilité plus haut dans cet article.
Sub RemoveHyperlinks()

   Dim oDoc As Document
   Dim oStory As Range
   Dim oHlink As Hyperlink

   For Each oStory In ActiveDocument.StoryRanges
      For Each oHlink In oStory.Hyperlinks
         oHlink.Delete
      Next
   Next



End Sub
				
Pour supprimer toutes les traces du lien hypertexte et du texte du lien hypertexte du document, vous pouvez aussi utiliser l'exemple de macro suivant.
Sub RemoveAllHyperlinks()

   Dim oDoc As Document
   Dim oStory As Range
   Dim oHlink As Hyperlink

   For Each oStory In ActiveDocument.StoryRanges
      For Each oHlink In oStory.Hyperlinks
         oHlink.Range.Delete
      Next
   Next

End Sub
				

Comment faire pour supprimer les styles des documents

Les documents peuvent inclure des styles contenant des métadonnées. Vous pouvez supprimer ces styles ou les renommer. Pour cela, procédez comme suit :
  1. Ouvrez le document qui contient les styles.
  2. Dans le menu Format, cliquez sur Style.
  3. Sélectionnez le style que vous voulez supprimer ou renommer.

    Cliquez sur Supprimer pour supprimer le style ou sur Modifier pour le renommer.

Comment faire pour supprimer les anciennes versions de fichier des documents

Word inclut une fonctionnalité de version de fichier qui vous permet d'enregistrer plusieurs versions du même document dans le même fichier. Vous pouvez vouloir supprimer les anciennes versions du document avant de le partager avec les autres.

Pour supprimer une ou plusieurs versions d'un document, procédez comme suit :
  1. Dans le menu Fichier, cliquez sur Versions.
  2. Sélectionnez la version du document que vous voulez supprimer.

    Vous pouvez sélectionner plusieurs versions en appuyant sur CTRL pendant que vous sélectionnez les versions.
  3. Cliquez sur Supprimer.
  4. Lorsque vous avez terminé de supprimer les anciennes versions du document, cliquez sur Enregistrer dans le menu Fichier.

Comment faire pour supprimer les liens des codes de champ

Les images et autres objets liés des documents Word peuvent contenir des informations de liaison, telles que le chemin d'accès à l'image ou à l'objet lié. Vous pouvez supprimer les informations de liaison de votre document en modifiant les codes de champ.

Pour afficher les codes de champ, procédez comme suit :
  1. Dans le menu Outils, cliquez sur Options, puis sur l'onglet Affichage.
  2. Activez la case à cocher Codes de champ.

    Cliquez sur OK.
Une fois que les codes de champ sont visibles, vous pouvez vérifier si l'un d'eux contient des données d'identification.

Pour supprimer les informations de liaison d'une image liée ou d'un autre objet, procédez comme suit :
  1. Sélectionnez l'image ou l'objet lié ou sélectionnez le code de champ pour l'image ou l'objet si les codes de champ sont visibles.
  2. Appuyez sur Ctrl+Maj+F9.
L'image ou l'objet est maintenant non lié. Lorsqu'une image ou un objet est non lié, vous ne pouvez pas le modifier.

Comment faire pour supprimer le nom et l'emplacement du modèle

Tous les documents qui sont créés dans Word reposent sur un modèle. Par défaut, il s'agit du fichier modèle Normal.dot, situé dans le dossier Modèles. Toutefois, vous pouvez créer un document qui est basé sur un modèle différent à un autre emplacement. Le chemin d'accès et le nom de ce modèle sont enregistrés dans les propriétés du document.

Pour afficher le nom et l'emplacement du modèle, cliquez sur Propriétés dans le menu Fichier, puis cliquez sur l'onglet Résumé.

Même si vous n'envoyez pas le modèle avec le document, le document retient le nom et l'emplacement du modèle. Pour remplacer le nom et l'emplacement du modèle par des valeurs sans identification, procédez comme suit :
  1. Dans le menu Outils, cliquez sur Modèles et compléments.
  2. Cliquez sur Attacher.
  3. Sélectionnez un modèle dont le nom et l'emplacement ne sont pas sensibles ou uniques.

    Par exemple, vous pouvez sélectionner Normal.dot, fichier présent sur chaque ordinateur sur lequel Word est installé.
  4. Cliquez sur Ouvrir, puis sur OK.
Remarque Le modèle peut contenir des macros, des entrées d'insertion automatique, des styles personnalisés et des barres d'outils personnalisées. En modifiant des modèles, vous pouvez rendre quelques-uns de ces éléments non disponibles pour votre document.

Comment faire pour supprimer les informations de bordereau de routage

Si vous envoyez un document par messagerie électronique en utilisant un bordereau de routage, les informations de routage peuvent être jointes au document. Pour supprimer ces informations du document, vous devez enregistrer le document dans un format qui ne retient pas les informations de bordereau de routage.

Dans Word, enregistrez votre document au format RTF (Rich Text Format) ou HTML. Fermez le document, puis rouvrez le nouveau fichier. Étant donné que les informations de bordereau de routage ne sont plus présentes, vous pouvez enregistrer maintenant votre document au format Word.

Vous pouvez également suivre ces étapes :
  1. Désactivez Autoriser les enregistrements rapides en utilisant les instructions précédentes de cet article.
  2. Dans le menu Fichier, pointez sur Envoyer vers, puis cliquez sur Autre destinataire.
  3. Cliquez sur Effacer pour supprimer le bordereau de routage, puis sur OK.
  4. Dans le menu Fichier, cliquez sur Enregistrer.
Le document est maintenant enregistré sans aucune information de bordereau de routage.

Comment faire pour supprimer les informations relatives au destinataire d'un courrier électronique

Word 2002 conserve les adresses électroniques du destinataire et des personnes en copie (CC et Bcc) si vous envoyez un document à l'aide de la commande Envoyer vers du menu Fichier, puis que vous cliquez sur Destinataire et que l'en-tête de courrier électronique est active pour ce document. Ces informations peuvent être supprimées automatiquement comme indiqué dans la section « Comment faire pour supprimer manuellement votre nom d'utilisateur de vos documents ».

Une macro VBA (Microsoft Visual Basic for Applications) peut être utilisée pour activer le paramètre « Supprimer les informations personnelles des propriétés du fichier lors de l'enregistrement ».

Important Avant que vous n'utilisiez l'exemple de macro suivant, consultez la section relative à l'exclusion de responsabilité plus haut dans cet article.

Sub RemoveInformation()
ActiveDocument.RemovePersonalInformaation = True
End Sub

Comment faire pour supprimer le nom des auteurs précédents

Word enregistre dans un document les noms des 10 dernières personnes ayant travaillé sur le document. Il s'agit d'une fonctionnalité automatique qui ne peut pas être désactivée.

Vous pouvez supprimer les noms des 10 derniers auteurs d'un document à l'aide de l'une des méthodes suivantes :
  • Enregistrez le document dans un format qui ne conserve pas ce type d'informations. Par exemple, si vous enregistrez le document au format RTF ou HTML, les informations sur les auteurs sont perdues. Vous pouvez ensuite fermer et rouvrir le document RTF/HTML et l'enregistrer au format Word.
  • Créez un document, puis insérez le contenu du document existant dans le nouveau document. Pour cela, cliquez sur Insérer, puis sur Fichier.
  • Utilisez l'option de suppression des informations personnelles précédemment décrite dans cet article. Cette option supprime ces noms.
Remarque Ces informations ne sont pas stockées par Word 2003.

Comment faire pour supprimer votre nom du code Visual Basic

Important Avant que vous n'utilisiez l'exemple de macro suivant, consultez la section relative à l'exclusion de responsabilité plus haut dans cet article.

Lorsque vous enregistrez une macro VBA dans Word, la macro enregistrée commence avec un en-tête semblable au suivant :
' Macro1 Macro
' Macro recorded 3/11/1999 by <User Name>
				
Pour supprimer votre nom de toutes les macros que vous avez enregistrées, procédez comme suit :
  1. Ouvrez le document qui contient les macros.
  2. Dans le menu Outils, pointez sur Macro, puis cliquez sur Visual Basic Editor ou appuyez sur ALT+F11.
  3. Dans la fenêtre de projet, double-cliquez sur le module qui contient les macros.
  4. Supprimez votre nom du code de macro enregistré.
Une fois votre nom supprimé, appuyez sur ALT+Q pour revenir au programme, puis cliquez sur Enregistrer dans le menu Fichier.

Comment faire pour supprimer les références Visual Basic aux autres fichiers

Dans Visual Basic Editor, vous pouvez créer une référence à un autre fichier. Si un utilisateur ouvre un document qui contient des références aux autres fichiers, il peut voir les noms des fichiers auxquels il est fait référence.

Pour supprimer ces références, procédez comme suit :
  1. Ouvrez le document qui contient les références.
  2. Dans le menu Outils, pointez sur Macro, puis cliquez sur Visual Basic Editor ou appuyez sur ALT+F11.
  3. Dans le menu Outils, cliquez sur Références.
  4. Désactivez la case à cocher située en regard du ou des fichiers auxquels il est fait référence.

    Lorsque vous avez terminé, cliquez sur OK.
  5. Appuyez sur ALT+Q.
  6. Dans le menu Fichier, cliquez sur Enregistrer.
Remarque La suppression de références à d'autres fichiers peut affecter le fonctionnement des macros de votre document.

Comment faire pour supprimer les informations relatives au disque dur ou au réseau

Lorsque vous enregistrez un document sur votre disque dur local ou sur un serveur réseau, les informations qui identifient le disque dur local ou le serveur réseau peuvent être écrites dans le document.

Pour supprimer ces informations du document, procédez comme suit :
  1. Ouvrez le document.
  2. Dans le menu Fichier, cliquez sur Enregistrer sous.

    Enregistrez le document sur votre lecteur de disquette (en général lecteur A).
  3. Dans le menu Fichier, cliquez sur Fermer.
  4. Enlevez la disquette du lecteur de disquette.
Vous pouvez utiliser maintenant l'Explorateur Windows pour copier le document à partir de la disquette vers tout disque dur ou serveur réseau.

Remarque En raison de la limitation d'espace d'une disquette (en général 1,44 mégaoctets [Mo]), cette méthode ne peut pas être utilisée si la taille du fichier du document dépasse l'espace libre sur la disquette.

Les objets incorporés aux documents peuvent contenir des métadonnées

Si vous incorporez un objet dans un document, l'objet conserve ses propres propriétés, quelles que soient les opérations effectuées sur le document. Par exemple, si vous incorporez un classeur Microsoft Excel dans un document Word, le document et le classeur ont chacun leurs propres propriétés.

Pour supprimer des métadonnées d'un objet incorporé, activez l'objet, supprimez toutes les métadonnées comme décrit dans les sections précédentes, réactivez le document conteneur, puis enregistrez le document conteneur.

Remarque Lorsque vous activez un objet incorporé à un document, une partie seulement de l'objet incorporé s'affiche dans le document ; l'objet peut contenir des informations supplémentaires qui n'apparaissent pas. Si vous voulez qu'un document contienne seulement un rendu de l'objet incorporé et pas le contenu réel, utilisez la commande Couper dans le menu Edition pour supprimer l'objet, puis utilisez la commande Collage spécial pour coller l'objet dans le document en utilisant un format de métafichier. Après cela, vous ne pouvez plus modifier l'objet incorporé ; cependant il ne contiendra pas de métadonnées.

Les variables de documents peuvent contenir des métadonnées

Important Avant que vous n'utilisiez l'exemple de macro suivant, consultez la section relative à l'exclusion de responsabilité plus haut dans cet article.

Pour supprimer les variables de document contenues dans votre document Word, utilisez l'exemple de macro suivant :
Sub DeleteDocVars()

   Dim Response
   Dim myVar As Variable

   For Each myVar In ActiveDocument.Variables
      Response = MsgBox("The document variable: " & myVar.Name & vbCr & _
         "Value: " & myVar.Value & vbCr & vbCr & _
         "Do you want to delete the variable from this document?", vbYesNo)
            
      If Response = "6" Then
         ' Delete the variable.
         myVar.Delete
      Else
         End
      End If
   Next myVar
            
   MsgBox "There are no variables in the document."
   
End Sub
				
Pour plus d'informations sur les variables, dans Visual Basic Editor, cliquez sur Aide sur Microsoft Visual Basic dans le menu ? (Aide), tapez Propriété des variables dans le Compagnon Office ou dans l'Aide intuitive, puis cliquez sur Rechercher pour afficher la rubrique.

Comment faire pour supprimer la propriété AdHocReviewCycleID des documents

Lorsque vous envoyez un document Word 2002 dans un courrier électronique, la propriété AdHocReviewCycleID est ajoutée au document et il lui est affecté une valeur GUID de façon aléatoire. Lorsque vous ouvrez un document associé à une valeur AdHocReviewCycleID, cette valeur est comparée aux valeurs GUID des documents qui ont été préalablement créés sur votre ordinateur. Si cette valeur GUID correspond à l'une des valeurs GUID de votre ordinateur, vous voyez s'afficher la boîte de dialogue d'invite suivante :
Souhaitez-vous fusionner les modifications de nom_document dans chemin_fichiernom_document ?
Pour supprimer la propriété AdHocReviewCycleID, procédez comme suit :
  1. Ouvrez le document.
  2. Cliquez sur Fichier, sur Propriétés, puis sur l'onglet Personnalisation.
  3. Dans la fenêtre Propriétés, sous l'en-tête Nom, cliquez sur _AdHocReviewCycleID, puis sur Supprimer.
  4. Cliquez sur OK.

Suggestions générales relatives à la sécurité

Voici quelques suggestions générales qui peuvent contribuer à augmenter le niveau de sécurité de votre environnement informatique :
  • Chaque fois que vous vous absentez de votre ordinateur, sécurisez-le avec un écran de veille protégé par mot de passe, un mot de passe de mise sous tension ou la fonctionnalité de verrouillage de Windows NT.
  • Si votre ordinateur contient des dossiers partagés, assurez-vous de leur appliquer des mots de passe afin que seuls les utilisateurs autorisés puissent accéder à vos partages. Pour une sécurité encore accrue, utilisez le contrôle d'accès de niveau utilisateur afin de contrôler exactement qui peut accéder aux partages de votre ordinateur.
  • Lorsque vous supprimez un fichier, videz immédiatement la Corbeille. Vous pouvez envisager l'achat d'un utilitaire qui efface ou écrase complètement les fichiers lorsque vous les supprimez.
  • Lorsque vous sauvegardez vos données, stockez les fichiers de sauvegarde en lieu sûr, par exemple dans un coffre-fort ou un classeur verrouillé. Stockez une copie de vos sauvegardes à un emplacement sécurisé hors site pour le cas où votre emplacement principal serait inutilisable.
  • Assurez-vous que les documents importants sont protégés par un mot de passe afin de garantir que seuls les utilisateurs autorisés puissent les ouvrir. Stockez vos mots de passe à un emplacement sûr et séparé. Notez que si vous oubliez un mot de passe, il n'existe aucun moyen de récupérer le contenu d'un document protégé par mot de passe.
  • Ne distribuez pas de documents au format électronique. Au lieu de cela, imprimez-les. N'utilisez pas d'éléments identificateurs, tels que des polices distinctives, des filigranes, des logos ou du papier spécial, sauf en cas de nécessité (par exemple pour une présentation).
  • La messagerie électronique n'est pas anonyme. N'envoyez pas de document par voie électronique si vous ne souhaitez pas que votre identité soit jointe au document.
  • N'envoyez pas de document sur Internet à l'aide du protocole FTP ou HTTP. Les informations transmises à l'aide de ces protocoles sont envoyées sous forme de « texte en clair ». Cela signifie qu'il est techniquement possible (bien que peu probable) de les intercepter.

Propriétés

Numéro d'article: 290945 - Dernière mise à jour: jeudi 26 janvier 2012 - Version: 4.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Word 2002 Standard Edition
Mots-clés : 
kbconfig kbdta kbhowtomaster KB290945
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com