Riduzione della quantitÓ di metadati in Word 2002

Traduzione articoli Traduzione articoli
Identificativo articolo: 290945 - Visualizza i prodotti a cui si riferisce l?articolo.
Per la versione di questo articolo relativa a Microsoft Word 97, vedere 223790.

Per la versione di questo articolo relativa a Microsoft Word 2000, vedere 237361.

Per la versione di questo articolo relativa a Microsoft Word 2003, vedere 825576.
Espandi tutto | Chiudi tutto

In questa pagina

Sommario

In questo articolo vengono descritti i vari metodi che consentono di ridurre la quantitÓ dei metadati contenuti nei documenti di Microsoft Word.

Ogni volta che si crea, si apre o si salva un documento in Word 2002, quest'ultimo pu˛ includere dati che non si desidera condividere con altri utenti quando lo si distribuisce elettronicamente. Questi dati vengono indicati con il termine "metadati". I metadati consentono di aumentare le possibilitÓ di modifica, visualizzazione, archiviazione e recupero dei documenti di Microsoft Office.

Alcuni di essi sono facilmente accessibili attraverso l'interfaccia utente di Word. Altri sono accessibili solo utilizzando metodi straordinari, come l'apertura di un documento in un editor di file binario di basso livello. Seguono alcuni esempi di metadati che possono essere memorizzati nei documenti:
  • Nome utente
  • Iniziali
  • Nome della societÓ di appartenenza
  • Nome del computer
  • Nome del server di rete o del disco rigido in cui i documenti sono stati salvati
  • Altre proprietÓ dei file e informazioni di riepilogo
  • Parti non visibili di oggetti OLE incorporati
  • Nomi degli autori precedenti dei documenti
  • Revisioni dei documenti
  • Versioni dei documenti
  • Informazioni dei modelli
  • Testo nascosto
  • Commenti
I metadati vengono creati in vari modi nei documenti di Word, di conseguenza non esiste un unico metodo per eliminare tale contenuto dai documenti. Nelle sezioni seguenti sono indicate le aree in cui Ŕ possibile che i metadati contenuti nei documenti di Word vengano salvati.

In questo articolo vengono descritti i vari metodi che consentono di ridurre la quantitÓ dei metadati contenuti nei documenti di Word.


DECLINAZIONE DI RESPONSABILIT└

Microsoft fornisce esempi di programmazione a scopo puramente illustrativo, senza alcuna garanzia di qualsiasi tipo, sia espressa che implicita, ivi incluse, senza limitazioni, le garanzie implicite di commerciabilitÓ o idoneitÓ per uno scopo particolare. In questo articolo si presume che l'utente conosca il linguaggio di programmazione in questione e gli strumenti utilizzati per creare ed eseguire il debug delle procedure. Gli esperti Microsoft sono autorizzati a fornire spiegazioni in merito alla funzionalitÓ di una particolare procedura, ma in nessun caso a modificare questi esempi per fornire funzionalitÓ aggiuntive o creare procedure atte a soddisfare specifiche esigenze. Se si dispone di esperienza di programmazione limitata, si consiglia di contattare un Microsoft Certified Partner o la filiale Microsoft locale per informazioni sulla consulenza tecnica. Per ulteriori informazioni in merito ai Microsoft Certified Partner, visitare il seguente sito Web Microsoft:
hhttps://partner.microsoft.com/global/30000104
Per ulteriori informazioni sulle opzioni di supporto disponibili e su come contattare Microsoft, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/default.aspx?scid=fh;[LN];CNTACTMS
Per ulteriori informazioni sull'utilizzo del codice di esempio riportato in questo articolo, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
290140 OFFXP: Come eseguire il codice di esempio contenuto negli articoli della Knowledge Base

Rimozione automatica delle informazioni personali al momento del salvataggio

╚ ora possibile rimuovere automaticamente le informazioni personali da un documento di Word al momento del salvataggio. Per attivare questa opzione, attenersi alla seguente procedura:
  1. Scegliere Opzioni dal menu Strumenti.
  2. Nella scheda Protezione selezionare la casella di controllo Rimuovi le informazioni personali dalle proprietÓ del file al momento del salvataggio in Opzioni riservatezza, quindi scegliere OK.
Nota Questo Ŕ il metodo consigliato per rimuovere le informazioni personali quando si salva un documento di Word 2002.

Rimozione manuale del nome utente dai documenti

Per visualizzare o modificare il nome utente, attenersi alla seguente procedura:
  1. Scegliere Opzioni dal menu Strumenti e fare clic sulla scheda Inf. utente.

    Verranno visualizzate le seguenti caselle di testo:

    Nome
    Iniziali
    Indirizzo
  2. Se non si desidera che queste informazioni siano contenute nei propri documenti, immettere stringhe insignificanti o spazi nelle caselle di testo appropriate e scegliere OK per confermare le modifiche.
Nota I nuovi documenti che verranno creati conterranno queste informazioni ignorando i valori predefiniti immessi durante l'installazione di Office. I documenti esistenti, tuttavia, conterranno ancora le vecchie informazioni.

Rimozione manuale delle informazioni di riepilogo personali

Quando si crea o si salva un documento in Word, le informazioni di riepilogo possono essere salvate nel documento. Per accedere a queste informazioni Ŕ possibile utilizzare vari metodi:
  • Aprire il documento. Scegliere ProprietÓ dal menu File.

    Le schede Riepilogo, Statistiche, Contenuto e Personalizza possono contenere varie proprietÓ, quali il nome dell'utente, il nome del manager e il nome della societÓ.
  • In Esplora risorse, fare clic con il pulsante destro del mouse sul documento, quindi scegliere ProprietÓ.

    Le schede della finestra di dialogo ProprietÓ possono contenere informazioni personali.
  • ╚ possibile utilizzare una macro di Microsoft Visual Basic, Applications Edition oppure codice di un altro programma per leggere le proprietÓ visualizzate nella finestra di dialogo ProprietÓ.
Per cancellare informazioni riepilogative da un documento o un modello esistente, attenersi alla seguente procedura:
  1. Aprire il documento o il modello.
  2. Scegliere ProprietÓ dal menu File.
  3. Nella scheda Riepilogo cancellare il contenuto delle caselle Autore, Manager, SocietÓ e di eventuali altre caselle di testo che non si intende distribuire.
  4. Nella scheda Personalizza eliminare eventuali proprietÓ contenenti informazioni che non si desidera distribuire.
  5. Scegliere OK.

    Scegliere Salva dal menu File, quindi Chiudi.
Completata questa procedura, nel documento non saranno pi¨ contenute informazioni di riepilogo.

Rimozione manuale delle informazioni di riepilogo personali durante la connessione a una rete

Se si Ŕ connessi a una rete, Ŕ possibile che quando si salva un documento il proprio nome utente venga visualizzato nella casella Autore nella scheda Riepilogo e nel campo Autore ultimo salvataggio nella scheda Statistiche. Questo problema pu˛ verificarsi anche se tutte le altre informazioni personali sono state rimosse dal computer in uso.

Per rimuovere le informazioni di riepilogo da un documento quando si Ŕ connessi a una rete, attenersi alla seguente procedura:
  1. Se il documento Ŕ memorizzato su un server di rete, copiarlo sul disco rigido locale.
  2. Avviare il computer senza eseguire la connessione alla rete. Quando viene visualizzata la finestra di dialogo di accesso alla rete, scegliere Annulla o premere ESC.

    Nota Se non Ŕ possibile avviare Windows premendo ESC, ad esempio perchÚ il sistema operativo Ŕ Microsoft Windows NT, non sarÓ possibile continuare questa procedura.
  3. Aprire il documento.
  4. Scegliere ProprietÓ dal menu File.
  5. Nella scheda Riepilogo cancellare il contenuto delle caselle Autore, Manager, SocietÓ e di eventuali altre caselle di testo che contengono informazioni che non si intende distribuire.
  6. Nella scheda Personalizza eliminare eventuali proprietÓ contenenti informazioni che non si desidera distribuire.
  7. Scegliere OK.

    Scegliere Salva dal menu File, quindi Chiudi.
Quando si accede alla rete non aprire il file. In caso contrario il nome utente di rete potrebbe essere nuovamente scritto nel file. ╚ possibile tuttavia utilizzare Esplora risorse per copiare il file su un server di rete o su un disco floppy.

Rimozione manuale dei commenti nei documenti

╚ possibile aggiungere commenti nei documenti di Microsoft Word. Di norma i commenti contengono il nome della persona che li ha creati consentendo ad altri di individuare chi li ha scritti.

La presenza di un commento Ŕ segnalata da una parte di testo evidenziata. Facendo clic con il pulsante destro del mouse sul commento Ŕ possibile scegliere Elimina commento.

I nuovi commenti creati non dovrebbero contenere il nome dell'utente se questo Ŕ stato rimosso dalla finestra di dialogo Opzioni come descritto nella sezione "Rimozione manuale del nome utente dai documenti" in questo articolo.

Rimozione manuale di intestazioni e piŔ di pagina dai documenti

╚ possibile che intestazioni e piŔ di pagina dei documenti contengano informazioni identificative. Per rimuoverle, attenersi alla seguente procedura:
  1. Scegliere Intestazione e piŔ di pagina dal menu Visualizza.
  2. L'intestazione e il piŔ di pagina verranno visualizzati rispettivamente nella parte superiore e inferiore di ogni pagina del documento.

    Modificarli come si preferisce.
  3. Sulla barra degli strumenti Intestazione e piŔ di pagina fare clic su Chiudi.

Rimozione manuale dei segni di revisione

I documenti possono contenere segni di revisione che consentono di stabilire l'autore di determinate modifiche. Quando i segni di revisione vengono accettati o rifiutati, il testo revisionato viene salvato nel documento e i segni rimossi.

Per accettare o rifiutare le revisioni, attenersi alla seguente procedura:
  1. Scegliere Revisioni dal menu Strumenti e fare clic su Rivedi revisioni.
  2. Nella finestra di dialogo Rivedi revisioni, utilizzare i due pulsanti Trova per individuare revisioni specifiche allo scopo di accettarle o rifiutarle singolarmente oppure fare clic su Accetta tutto o Rifiuta tutto.
  3. Al termine scegliere Chiudi.
Nota Se sono state apportate modifiche alle impostazioni "Mostra" sulla barra degli strumenti Revisione, le revisioni non verranno rimosse.

Disattivazione del salvataggio veloce

La funzionalitÓ di salvataggio veloce accelera il processo di salvataggio salvando solo le modifiche apportate a un documento.

A causa del funzionamento del salvataggio veloce, il testo eliminato da un documento potrebbe in realtÓ continuare a essere presente, anche dopo aver salvato il documento. Se ci˛ costituisce un problema, attenersi alla seguente procedura:
  1. Scegliere Opzioni dal menu Strumenti.
  2. Fare clic sulla scheda Salva.
  3. Deselezionare la casella di controllo Consenti salvataggio veloce.

    Scegliere OK.
Per ulteriori informazioni sulla funzionalitÓ di salvataggio veloce, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
290945 HOW TO: Riduzione della quantitÓ di metadati in Microsoft Word 2002
291181 WD2002: Domande frequenti sull'opzione "Consenti salvataggio veloce"

Ricerca e rimozione di testo formattato come nascosto

Nei documenti di Word Ŕ possibile formattare testo come nascosto. PoichÚ il testo nascosto pu˛ contenere informazioni che non si desidera distribuire, pu˛ essere necessario visualizzarlo e rimuoverlo. Per rimuovere tutto il testo nascosto di un documento, attenersi alla seguente procedura:
  1. Scegliere Opzioni dal menu Strumenti, quindi fare clic sulla scheda Visualizza.
  2. Selezionare la casella di controllo Testo nascosto, quindi scegliere OK.
  3. Scegliere Sostituisci dal menu Modifica.
  4. Fare clic su Altro per espandere la finestra di dialogo.
  5. Fare clic nella casella di testo accanto a Trova.
  6. Scegliere il pulsante Formato, quindi fare clic su Carattere.

    Selezionare la casella di controllo Nascosto, quindi scegliere OK.
  7. Scegliere Sostituisci tutto.
Tutto il testo nascosto verrÓ rimosso dal documento. Per disattivare la visualizzazione del testo nascosto, attenersi alla seguente procedura:
  1. Scegliere Opzioni dal menu Strumenti, quindi fare clic sulla scheda Visualizza.
  2. Deselezionare la casella di controllo Testo nascosto.

    Scegliere OK.

Rimozione di collegamenti ipertestuali dai documenti

I documenti possono contenere collegamenti ipertestuali ad altri documenti o a pagine Web su reti Intranet o su Internet. I collegamenti ipertestuali sono solitamente stringhe di testo blu sottolineate.

Per eliminare manualmente un solo collegamento ipertestuale da un documento, fare clic con il pulsante destro del mouse sul collegamento, scegliere Collegamento ipertestuale, quindi Rimuovi collegamento ipertestuale.

Se si desidera eliminare tutti i collegamenti ipertestuali di un documento sarÓ possibile utilizzare una macro di Microsoft Visual Basic, Applications Edition (VBA). La macro di Microsoft Visual Basic, Applications Edition (VBA) di esempio riportata di seguito consente di rimuovere tutti i collegamenti ipertestuali di un documento.

Nota In questa macro di esempio viene rimosso solo il collegamento. Il testo del collegamento ipertestuale rimane nel documento.

Importante Prima di utilizzare la macro di esempio seguente, leggere la sezione Declinazione di responsabilitÓ sopra riportata.
Sub RemoveHyperlinks()

   Dim oDoc As Document
   Dim oStory As Range
   Dim oHlink As Hyperlink

   For Each oStory In ActiveDocument.StoryRanges
      For Each oHlink In oStory.Hyperlinks
         oHlink.Delete
      Next
   Next



End Sub
				
Per rimuovere completamente dal documento sia il collegamento ipertestuale sia il testo associato, utilizzare invece la seguente macro di esempio.
Sub RemoveAllHyperlinks()

   Dim oDoc As Document
   Dim oStory As Range
   Dim oHlink As Hyperlink

   For Each oStory In ActiveDocument.StoryRanges
      For Each oHlink In oStory.Hyperlinks
         oHlink.Range.Delete
      Next
   Next

End Sub
				

Rimozione degli stili dai documenti

Gli stili di un documento possono contenere metadati. ╚ possibile rimuovere tali stili o rinominarli. A questo scopo, attenersi alla seguente procedura:
  1. Aprire il documento contenente gli stili.
  2. Scegliere Stile dal menu Formato.
  3. Selezionare lo stile da eliminare o rinominare.

    Scegliere Elimina per eliminare lo stile oppure fare clic su Modifica per rinominarlo.

Rimozione delle vecchie versioni di file dai documenti

In Word Ŕ inclusa una funzionalitÓ che consente di salvare pi¨ versioni dello stesso documento nello stesso file. Potrebbe essere necessario eliminare le versioni precedenti del documento prima di condividerlo con altri utenti.

Per eliminare una o pi¨ versioni di un documento, attenersi alla seguente procedura:
  1. Scegliere Versioni dal menu File.
  2. Selezionare la versione del documento che si desidera eliminare.

    ╚ possibile selezionare pi¨ di una versione tenendo premuto CTRL mentre si selezionano le versioni.
  3. Scegliere Elimina.
  4. Dopo aver eliminato le versioni precedenti del documento, scegliere Salva dal menu File.

Rimozione di collegamenti dai codici di campo

Le immagini e gli altri oggetti collegati inclusi nei documenti di Word possono contenere informazioni sul collegamento, come il percorso dell'immagine o dell'oggetto collegato. ╚ possibile rimuovere dal documento le informazioni sul collegamento modificando i codici di campo.

Per visualizzare i codici di campo, attenersi alla seguente procedura:
  1. Scegliere Opzioni dal menu Strumenti, quindi fare clic sulla scheda Visualizza.
  2. Selezionare la casella di controllo Codici di campo.

    Scegliere OK.
Una volta visibili, Ŕ possibile verificare se nei codici di campo sono contenute informazioni identificative.

Per rimuovere informazioni sul collegamento da un'immagine collegata o da un altro oggetto, attenersi alla seguente procedura:
  1. Selezionare l'immagine o l'oggetto collegati oppure selezionare il codice di campo dell'immagine o dell'oggetto se i codici di campo sono visibili.
  2. Premere CTRL+MAIUSC+F9.
Il collegamento all'immagine o all'oggetto verrÓ cosý annullato. Quando si annulla il collegamento all'immagine o all'oggetto, non Ŕ possibile modificarlo.

Rimozione del nome e del percorso dei modelli

Tutti i documenti creati in Word si basano su un modello. In base all'impostazione predefinita, viene utilizzato il file modello Normal.dot memorizzato nella cartella Modelli. ╚ comunque possibile creare un documento basato su un modello diverso in un altro percorso. Le informazioni relative al percorso e al nome del modello sono memorizzate nelle proprietÓ del documento.

Per visualizzare il nome e il percorso del modello scegliere ProprietÓ dal menu File e fare clic sulla scheda Riepilogo.

Anche se il modello non viene distribuito con il documento, questo mantiene le informazioni relative al nome e al percorso del modello. Per sostituire il nome e il percorso del modello con valori non significativi, attenersi alla seguente procedura:
  1. Scegliere Modelli e aggiunte dal menu Strumenti.
  2. Scegliere Connetti.
  3. Selezionare un modello con un nome e un percorso non riservato o univoco.

    PoichÚ ad esempio su ogni computer in cui Ŕ installato Word Ŕ presente il modello Normal.dot, si pu˛ selezionare proprio questo file.
  4. Scegliere Apri, quindi OK.
Nota Nel modello potrebbero essere contenute macro, voci di glossario, stili personalizzati e barre degli strumenti personalizzate. Se il modello viene cambiato, alcuni di questi elementi potrebbero non essere pi¨ disponibili nel documento.

Rimozione delle informazioni delle liste di distribuzione

Se si invia un documento per posta elettronica tramite una lista di distribuzione, le informazioni di distribuzione vengono allegate al documento. Per rimuovere queste informazioni dal documento Ŕ necessario salvarlo in un formato che non mantenga le informazioni allegate.

In Word salvare il documento nel formato RTF (Rich Text Format) o HTML. Chiudere il documento, quindi riaprire il nuovo file. PoichÚ le informazioni della lista di distribuzione non sono pi¨ presenti, sarÓ possibile salvare il documento nel formato di Word.

╚ inoltre possibile attenersi alla seguente procedura:
  1. Disattivare Consenti salvataggio veloce secondo le istruzioni riportate in precedenza in questo articolo.
  2. Scegliere Invia a dal menu File, quindi scegliere Altra lista di distribuzione.
  3. Scegliere Cancella per rimuovere la lista di distribuzione, quindi fare clic su OK.
  4. Scegliere Salva dal menu File.
Il documento verrÓ salvato senza le informazioni della lista di distribuzione.

Rimozione delle informazioni relative ai destinatari di posta elettronica

In Word 2002 vengono conservati gli indirizzi di posta elettronica delle caselle A, CC e Ccn se si invia un documento utilizzando il comando Invia a dal menu File per poi scegliere Destinatario posta e se l'intestazione di posta elettronica Ŕ attivata nell'ambito di un documento. ╚ possibile rimuovere automaticamente tali informazioni in base a quanto giÓ descritto nella sezione "Rimozione manuale del nome utente dai documenti" in questo articolo.

╚ possibile utilizzare una macro di Microsoft Visual Basic, Applications Edition (VBA) per attivare l'impostazione "Rimuovi le informazioni personali dal file al momento del salvataggio".

Importante Prima di utilizzare la macro di esempio seguente, leggere la sezione Declinazione di responsabilitÓ sopra riportata.

Sub RemoveInformation()
ActiveDocument.RemovePersonalInformaation = True
End Sub

Rimozione dei nomi degli autori precedenti

In un documento di Word vengono memorizzati i nomi degli ultimi 10 utenti che hanno lavorato sul documento stesso. Si tratta di una funzionalitÓ automatica che non pu˛ essere disattivata.

╚ possibile rimuovere i nomi degli ultimi 10 autori utilizzando uno dei seguenti metodi:
  • Salvare il documento in un formato che non consente di conservare tali informazioni. Se ad esempio il documento viene salvato in formato RTF o HTML, le informazioni sugli autori andranno perdute. ╚ quindi possibile chiudere e riaprire il documento RTF o HTML e salvarlo nel formato di Word.
  • Creare un nuovo documento, quindi inserire il contenuto del documento esistente nel nuovo documento. A questo scopo, fare clic su Inserisci, quindi scegliere File.
  • Utilizzare l'opzione Rimozione delle informazioni personali descritta in questo articolo. Tale opzione consente di rimuovere i nomi degli autori precedenti.
Nota Queste informazioni non vengono memorizzate in Word 2003.

Rimozione del nome utente dal codice Visual Basic

Importante Prima di utilizzare la macro di esempio seguente, leggere la sezione Declinazione di responsabilitÓ sopra riportata.

Quando si registra una macro di Microsoft Visual Basic, Applications Edition (VBA) in Word, la macro registrata inizia con un'intestazione simile alla seguente:
' Macro1 Macro
' Macro recorded 3/11/1999 by <User Name>
				
Per rimuovere il nome utente dalle macro registrate, attenersi alla seguente procedura:
  1. Aprire il documento contenente le macro.
  2. Scegliere Macro dal menu Strumenti, quindi fare clic su Visual Basic Editor o premere ALT+F11.
  3. Nella finestra di progetto fare doppio clic sul modulo che contiene le macro.
  4. Rimuovere il nome utente dal codice della macro registrata.
Terminata questa operazione premere ALT+Q per tornare al programma, quindi fare clic su Salva nel menu File.

Rimozione dei riferimenti in Visual Basic ad altri file

Con Visual Basic Editor Ŕ possibile creare un riferimento a un altro file. Quando si apre un documento che contiene riferimenti ad altri file, Ŕ possibile leggervi i nomi dei file.

Per rimuovere questi riferimenti, attenersi alla seguente procedura:
  1. Aprire il documento contenente i riferimenti.
  2. Scegliere Macro dal menu Strumenti, quindi fare clic su Visual Basic Editor o premere ALT+F11.
  3. Scegliere Riferimenti dal menu Strumenti.
  4. Deselezionare la casella di controllo accanto al file o ai file di riferimento.

    Al termine, scegliere OK.
  5. Premere ALT+Q.
  6. Scegliere Salva dal menu File.
Nota Se si rimuovono i riferimenti ad altri file, questa scelta potrebbe influire negativamente sulle macro contenute nel documento che potrebbero non funzionare pi¨ correttamente.

Rimozione delle informazioni sulla rete o sul disco rigido

Quando si salva un documento sul disco rigido locale o su un server di rete, le informazioni che identificano il disco o il server vengono scritte nel documento.

Per rimuovere tali informazioni da un documento, attenersi alla seguente procedura:
  1. Aprire il documento.
  2. Scegliere Salva con nome dal menu File.

    Salvare il documento sull'unitÓ floppy (di solito A).
  3. Scegliere Chiudi dal menu File.
  4. Rimuovere il disco floppy dall'unitÓ.
Utilizzare quindi Esplora risorse per copiare il documento dal disco floppy a un disco rigido qualsiasi o un server di rete.

Nota A causa dei limiti di spazio di un disco floppy (in genere 1,44 MB), questo metodo non pu˛ essere utilizzato se le dimensioni del file superano lo spazio disponibile sul disco.

Gli oggetti incorporati nei documenti possono contenere metadati

Se si incorpora un oggetto in un documento, l'oggetto conserva le sue proprietÓ, indipendentemente dalle operazioni eseguite sul documento. Se ad esempio si incorpora una cartella di lavoro di Microsoft Excel in un documento di Word, il documento e la cartella mantengono proprietÓ distinte.

Per rimuovere metadati da un oggetto incorporato, attivare l'oggetto, rimuovere gli eventuali metadati come descritto nelle precedenti sezioni, riattivare il documento contenitore, quindi salvarlo.

Nota Quando si attiva un oggetto incorporato in un documento, solo una parte dell'oggetto viene visualizzata nel documento; l'oggetto potrebbe contenere informazioni aggiuntive non visualizzate. Se si desidera che il documento contenga solo un rendering dell'oggetto incorporato e non tutto il contenuto, utilizzare il comando Taglia nel menu Modifica per eliminare l'oggetto, quindi scegliere il comando Incolla speciale per incollarlo nel documento utilizzando un formato di metafile. In questo modo non sarÓ pi¨ possibile modificare l'oggetto incorporato che, d'altro canto, non conterrÓ metadati.

Le variabili di documento possono contenere metadati

Importante Prima di utilizzare la macro di esempio seguente, leggere la sezione Declinazione di responsabilitÓ sopra riportata.

Per eliminare le variabili di documento contenute nel documento di Word, utilizzare la macro di esempio seguente:
Sub DeleteDocVars()

   Dim Response
   Dim myVar As Variable

   For Each myVar In ActiveDocument.Variables
      Response = MsgBox("The document variable: " & myVar.Name & vbCr & _
         "Value: " & myVar.Value & vbCr & vbCr & _
         "Do you want to delete the variable from this document?", vbYesNo)
            
      If Response = "6" Then
         ' Delete the variable.
         myVar.Delete
      Else
         End
      End If
   Next myVar
            
   MsgBox "There are no variables in the document."
   
End Sub
				
Per ulteriori informazioni sulle variabili, in Visual Basic Editor scegliere Guida in linea Microsoft Visual Basic dal menu ?, digitare ProprietÓ variabili nell'Assistente di Office o nella Ricerca libera e scegliere Cerca per visualizzare l'argomento.

Rimozione della proprietÓ AdHocReviewCycleID dai documenti

Quando si invia un documento di Word 2002 mediante posta elettronica la proprietÓ AdHocReviewCycleID viene aggiunta al documento e assegnata a un valore GUID generato in modo casuale. Quando si apre un documento con un valore AdHocReviewCycleID, tale valore viene confrontato con i GUID dei documenti creati in precedenza nel computer in uso. Se il GUID corrisponde a un GUID del computer, verrÓ visualizzata la seguente finestra di dialogo contenente la richiesta:
Unire le modifiche di Nomedocumento in PercorsofileNomedocumento?
Per rimuovere la proprietÓ AdHocReviewCycleID, attenersi alla seguente procedura.
  1. Aprire il documento.
  2. Scegliere ProprietÓ dal menu File, quindi fare clic sulla scheda Personalizza.
  3. Nel riquadro ProprietÓ, nell'intestazione Nome in basso, fare clic su _AdHocReviewCycleID, quindi scegliere Elimina.
  4. Scegliere OK.

Suggerimenti generali sulla protezione

Seguono alcuni suggerimenti di carattere generale utilizzabili per aumentare il livello di protezione nell'ambiente informatico in cui si opera:
  • Quando non si utilizza il computer, aumentare la protezione utilizzando uno screen saver protetto da password, con una password di accesso o con la funzionalitÓ di blocco di Windows NT.
  • Se nel computer sono presenti cartelle condivise, applicarvi una password per consentire l'accesso alle informazioni condivise solo agli utenti autorizzati. Per aumentare ulteriormente la protezione, utilizzare il controllo di accesso impostato a livello di utente, in modo da controllare esattamente chi accede alle condivisioni del computer.
  • Quando si elimina un file, svuotare immediatamente il Cestino. ╚ consigliabile utilizzare un'utilitÓ che cancelli o sovrascriva completamente i file quando questi vengono eliminati.
  • Quando si esegue il backup dei dati, archiviare i file di backup in un posto sicuro, ad esempio una cassaforte, una cassetta di sicurezza o un armadietto dotato di serratura. Conservare una copia degli archivi di backup in un luogo esterno protetto, qualora l'archivio principale non sia accessibile.
  • Assicurarsi che i documenti importanti siano protetti con password per fare in modo che possano essere aperti solo da utenti autorizzati. Conservare le password in un luogo sicuro e separato. Qualora non si ricordi la password di un documento non sarÓ possibile in alcun modo recuperarne il contenuto.
  • Non distribuire documenti in formato elettronico. Preferire la versione stampata. Non fare uso di elementi identificativi come caratteri distintivi, filigrane, logo o carta speciale, a meno che non sia necessario, ad esempio per una presentazione.
  • La posta elettronica non Ŕ anonima. Non trasferire un documento per posta elettronica se non si desidera che la propria identitÓ possa essere allegata in qualche modo al documento.
  • Non inviare un documento via Internet utilizzando il protocollo HTTP o FTP (File Transfer Protocol). Le informazioni inviate tramite questi protocolli sono trasmesse come "testo non crittografato", il che significa che Ŕ tecnicamente possibile, anche se poco probabile, che vengano intercettate.

ProprietÓ

Identificativo articolo: 290945 - Ultima modifica: lunedý 29 gennaio 2007 - Revisione: 2.8
Le informazioni in questo articolo si applicano a
  • Microsoft Word 2002 Standard Edition
Chiavi:á
kbconfig kbdta kbhowtomaster KB290945
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com