JAK: Minimalizowanie ilości metadanych w programie Microsoft Word 2002

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 290945 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Ten artykuł został opublikowany wcześniej pod numerem PL290945
Rozwiń wszystko | Zwiń wszystko

Na tej stronie

Streszczenie

W tym artykule opisano różne metody, których można użyć w celu zminimalizowania ilości metadanych w dokumentach programu Word.

Po utworzeniu, otwarciu lub zapisaniu dokumentu programu Microsoft Word 2002, może on mieć zawartość, której użytkownik nie chce udostępniać innym osobom podczas dystrybuowania dokumentu. Te informacje noszą nazwę metadanych. Metadane są zwykle używane do zwiększenia efektywności edytowania, wyświetlania, wypełniania i pobierania dokumentów pakietu Office.

Niektóre metadane można odczytać za pomocą interfejsu użytkownika programu Word. Inne metadane są dostępne tylko za pomocą innych specyficznych metod, na przykład przez otwarcie dokumentu w edytorze binarnym niskiego poziomu. Poniżej podano przykłady metadanych, które mogą znajdować się w dokumentach:
  • Nazwa użytkownika
  • Inicjały
  • Nazwa firmy lub organizacji
  • Nazwa komputera
  • Nazwa serwera sieci lub dysku twardego, na którym są zapisywane dokumenty
  • Inne właściwości pliku i podsumowanie
  • Niewidoczne części osadzonych obiektów OLE
  • Imiona i nazwiska poprzednich autorów dokumentu
  • Poprawki dokumentu
  • Wersje dokumentu
  • Informacje o szablonach
  • Tekst ukryty
  • Komentarze
Metadane mogą być tworzone w dokumentach programu Word na wiele sposobów. Oznacza to, że nie ma jednej metody usuwania podobnej zawartości z dokumentów. W następujących sekcjach opisano obszary, w których metadane mogą być zapisane w dokumentach programu Word.

W tym artykule opisano różne metody, których można użyć do minimalizowania ilości metadanych w dokumentach programu Word.


ZASTRZEŻENIE

Firma Microsoft podaje przykłady programowania tylko dla celów ilustracyjnych, nie udzielając żadnej rękojmi, wyrażonej wprost lub domyślnie, w tym także, bez ograniczeń, ustawowej rękojmi co do przydatności handlowej lub do określonych celów. W tym artykule zakłada się, że czytelnik zna demonstrowany język programowania oraz narzędzia używane do tworzenia i debugowania procedur. Jeśli czytelnik ma niewielkie doświadczenie w programowaniu, może skontaktować się z autoryzowanym partnerem firmy Microsoft. Aby uzyskać więcej informacji dotyczących certyfikowanych partnerów firmy Microsoft, odwiedź następującą witrynę firmy Microsoft w sieci Web:
http://www.microsoft.com/poland/partner/mcp/lista.asp
Aby uzyskać więcej informacji na temat dostępnych opcji pomocy technicznej oraz sposobu kontaktowania się z firmą Microsoft, odwiedź następującą witrynę w sieci Web:
http://support.microsoft.com/default.aspx?scid=fh;PL;CNTACTMS
Aby uzyskać informacje dotyczące używania przykładowego kodu podanego w tym artykule, kliknij numer artykułu poniżej w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
290140 OFFXP: Jak uruchamiać kod przykładowy zamieszczony w artykułach z bazy wiedzy Knowledge Base

Jak automatycznie usuwać informacje osobiste podczas zapisywania

Informacje osobiste można automatycznie usuwać z dokumentu programu Word podczas jego zapisywania. Aby włączyć tę opcję, wykonaj następujące kroki:
  1. W menu Narzędzia kliknij polecenie Opcje.
  2. Na karcie Zabezpieczenia kliknij, aby zaznaczyć, pole wyboru Usuń informacje osobiste z tego pliku przy zapisywaniu w obszarze Opcje prywatności, a następnie kliknij przycisk OK.
UWAGA: Powyższa metoda jest preferowaną metodą usuwania informacji osobistych podczas zapisywania dokumentu programu Word 2002.

Jak ręcznie usunąć nazwę użytkownika z dokumentów

Aby wyświetlić lub zmienić nazwę użytkownika, wykonaj następujące kroki:
  1. W menu Narzędzia kliknij polecenie Opcje, a następnie kliknij kartę Informacje o użytkowniku.

    Pojawią się następujące pola edycji:
    Nazwa
    Inicjały
    Adres wysyłkowy
  2. Jeśli nie chcesz, aby te informacje pojawiały się w dokumentach, wprowadź w odpowiednich polach wyboru inne informacje lub spacje, a następnie kliknij przycisk OK, aby zaakceptować zmiany.
UWAGA: Wszystkie nowo tworzone dokumenty będą zawierały te informacje zamiast domyślnych wartości wprowadzonych podczas instalacji pakietu Office. Istniejące już dokumenty mogą nadal zawierać te informacje.

Jak ręcznie usunąć podsumowanie osobiste

Po utworzeniu lub zapisaniu dokumentu w programie Word, w dokumencie może zostać zapisane podsumowanie. Dostęp do tych informacji można uzyskać na wiele sposobów:
  • Otwórz dokument. W menu Plik kliknij polecenie Właściwości.

    Karty Podsumowanie, Statystyka, Zawartość oraz Niestandardowe mogą również zawierać różne właściwości, takie jak imię i nazwisko, nazwa przełożonego i nazwa firmy.
  • W Eksploratorze Windows kliknij dokument prawym przyciskiem myszy, a następnie kliknij polecenie Właściwości w menu skrótów.

    Karty w oknie dialogowym Właściwości mogą zawierać informacje.
  • Aby odczytać właściwości wyświetlone w oknie dialogowym Właściwości, można użyć makra programu Microsoft Visual Basic for Applications lub kodu innego programu.
Aby wyczyścić podsumowanie w istniejącym dokumencie lub szablonie, wykonaj następujące kroki:
  1. Otwórz dokument lub szablon.
  2. W menu Plik kliknij polecenie Właściwości.
  3. Na karcie Podsumowanie wyczyść pola Autor, Menedżer, Firma oraz inne pola, których nie chcesz dystrybuować.
  4. Na karcie Niestandardowe usuń właściwości zawierające informacje, których nie chcesz dystrybuować.
  5. Kliknij przycisk OK. W menu Plik kliknij polecenie Zapisz, a następnie kliknij przycisk Zamknij.
Po ukończeniu tych kroków dokument nie będzie zawierał właściwości podsumowań.

Jak ręcznie usunąć osobiste podsumowania przy podłączeniu do sieci

Jeśli użytkownik jest zalogowany do sieci, po zapisaniu dokumentu w polu edycji Autor na karcie Podsumowanie oraz w polu Ostatnio zapisany przez na karcie Statystyka może się pojawiać nazwa użytkownika sieci. To zdarzenie może wystąpić nawet, jeśli z komputera zostały usunięte wszystkie informacje osobiste.

Aby usunąć podsumowania z dokumentu przy podłączeniu do sieci, wykonaj następujące kroki:
  1. Jeśli dokument jest przechowywany na serwerze sieci, skopiuj go na lokalny dysk twardy.
  2. Uruchom komputer, ale nie loguj się do sieci. Po wyświetleniu okna dialogowego logowania kliknij przycisk Anuluj lub naciśnij klawisz ESCAPE.

    UWAGA: Jeśli nie można uruchomić systemu Windows po naciśnięciu klawisza ESCAPE (na przykład na komputerze uruchomiony jest system Microsoft Windows NT), nie można kontynuować kolejnych kroków.
  3. Otwórz dokument.
  4. W menu Plik kliknij polecenie Właściwości.
  5. Na karcie Podsumowanie wyczyść pola Autor, Menedżer, Firma oraz inne pola zawierające informacje, których nie chcesz dystrybuować.
  6. Na karcie Niestandardowe usuń właściwości zawierające informacje, których nie chcesz dystrybuować.
  7. Kliknij przycisk OK. W menu Plik kliknij polecenie Zapisz, a następnie kliknij przycisk Zamknij.
Po zalogowaniu do sieci nie otwieraj pliku. Jeśli plik zostanie otwarty, w pliku może zostać zapisana sieciowa nazwa użytkownika. Można jednak użyć Eksploratora Windows do skopiowania pliku na serwer sieciowy lub na dyskietkę.

Jak ręcznie usunąć komentarze w dokumentach

Program Word umożliwia dodawanie komentarzy do dokumentów. Zwykle komentarze zawierają imię i nazwisko osoby, która je utworzyła, aby można było stwierdzić, kto jest autorem.

Komentarze zwykle pojawiają się w wyróżnionej sekcji tekstu; można kliknąć prawym przyciskiem myszy komentarz, a następnie w menu skrótów kliknąć polecenie Usuń komentarz.

Żaden z utworzonych nowych komentarzy nie będzie zawierać nazwy użytkownika, ponieważ usunięto ją w oknie dialogowym Opcje w sposób opisany w sekcji „Jak ręcznie usunąć nazwę użytkownika z dokumentów” w tym artykule.

Jak ręcznie usunąć nagłówki i stopki z dokumentów

Nagłówki i stopki w dokumentach mogą zawierać informacje identyfikujące. Aby usunąć informacje z nagłówków i stopek:
  1. Kliknij przycisk Nagłówek i stopka w menu Widok.
  2. Nagłówek i stopka pojawiają się odpowiednio na górze i dole każdej strony w dokumencie. Można je zmienić w dowolny sposób.
  3. Kliknij przycisk Zamknij na pasku narzędzi Nagłówek i stopka.

Jak ręcznie usunąć oznaczenia poprawek

Dokumenty mogą zawierać oznaczenia poprawek, umożliwiające zidentyfikowanie osoby, która wprowadziła określone zmiany w dokumencie. Po zaakceptowaniu lub odrzuceniu oznaczeń poprawek w dokumencie zapisywany jest poprawiony tekst i oznaczenia poprawek są usuwane.

Aby zaakceptować lub odrzucić poprawki:
  1. W menu Narzędzia wskaż polecenie Rejestruj zmiany, a następnie kliknij polecenie Zaakceptuj lub odrzuć zmiany.
  2. W oknie dialogowym Zaakceptuj lub odrzuć zmiany użyj dwóch przycisków Znajdź, aby zlokalizować wybrane poprawki w celu indywidualnego ich zaakceptowania lub odrzucenia lub kliknij przycisk Zaakceptuj wszystkie lub Odrzuć wszystkie.
  3. Po zakończeniu kliknij przycisk Zamknij.

Jak wyłączyć szybkie zapisywanie

Funkcja Szybkie zapisywanie przyśpiesza proces zapisywania dokumentu przez zapisywanie tylko zmian wprowadzonych w dokumencie.

Zgodnie z projektem funkcji Szybkie zapisywanie, tekst usunięty z dokumentu może w nim pozostać, nawet po zapisaniu dokumentu. Jeśli nie chcesz, aby usunięty tekst pozostawał w dokumencie, wykonaj następujące kroki:
  1. W menu Narzędzia kliknij polecenie Opcje.
  2. Zaznacz kartę Zapisywanie.
  3. Kliknij, aby wyczyścić, pole wyboru Zezwalaj na szybkie zapisywanie. Kliknij przycisk OK.
Aby uzyskać dodatkowe informacje dotyczące Szybkiego zapisywania, kliknij numery artykułów poniżej w celu wyświetlenia tych artykułów z bazy wiedzy Microsoft Knowledge Base:
290945 JAK: Minimalizowanie ilości metadanych w programie Microsoft Word 2002
291181 WD2002: Frequently Asked Questions About "Allow Fast Saves"

Jak wyszukać i usunąć tekst sformatowany jako tekst ukryty

W dokumentach programu Word można sformatować tekst jako ukryty. Ponieważ tekst ukryty może zawierać informacje nie przeznaczone do dystrybucji, może być konieczne odkrycie tekstu i usunięcie. Aby usunąć z dokumentu cały tekst sformatowany jako tekst ukryty, wykonaj następujące kroki:
  1. W menu Narzędzia kliknij polecenie Opcje. Zaznacz kartę Widok.
  2. Kliknij, aby zaznaczyć, pole wyboru Tekst ukryty, a następnie kliknij przycisk OK.
  3. W menu Edycja kliknij polecenie Zamień.
  4. Kliknij przycisk Więcej, aby rozwinąć okno dialogowe.
  5. Kliknij gdziekolwiek w polu edycji obok opcji Znajdź.
  6. Kliknij przycisk Format, a następnie kliknij polecenie Czcionka. Kliknij, aby zaznaczyć, pole wyboru Ukrycie, a następnie kliknij przycisk OK.
  7. Kliknij przycisk Zamień wszystko.
Wszystkie ukryte teksty zostaną usunięte z dokumentu. Aby wyłączyć wyświetlanie ukrytego tekstu, wykonaj następujące kroki:
  1. W menu Narzędzia kliknij polecenie Opcje. Zaznacz kartę Widok.
  2. Kliknij, aby wyczyścić pole wyboru Tekst ukryty. Kliknij przycisk OK.

Jak ręcznie usunąć hiperłącza z dokumentów

Dokumenty mogą zawierać hiperłącza do innych dokumentów lub stron sieci Web w intranecie lub w Internecie. Hiperłącza zwykle są wyświetlane jako niebieski podkreślony tekst.

Aby ręcznie usunąć pojedyncze hiperłącze z dokumentu, kliknij prawym przyciskiem myszy hiperłącze, wskaż polecenie Hiperłącze w menu skrótów, a następnie kliknij polecenie Usuń hiperłącze.

Jeśli chcesz usunąć wszystkie hiperłącza w dokumencie, możesz w tym celu użyć makra programu Visual Basic for Applications. Poniższe przykładowe makro programu Visual Basic for Applications usuwa wszystkie hiperłącza w dokumencie.

UWAGA: W poniższym przykład usuwane jest tylko łącze. Tekst łącza pozostaje w dokumencie.

WAŻNE: Przez użyciem poniższego makra, przeczytaj Zastrzeżenie znajdujące się wcześniej w tym artykule.
Sub RemoveHyperlinks()

   Dim oDoc As Document
   Dim oStory As Range
   Dim oHlink As Hyperlink

   For Each oStory In ActiveDocument.StoryRanges
      For Each oHlink In oStory.Hyperlinks
         oHlink.Delete
      Next
   Next



End Sub
Aby usunąć wszystkie ślady po hiperłączach oraz tekście hiperłączy w dokumencie, można użyć poniższego przykładu makra zamiast poprzedniego.
Sub RemoveAllHyperlinks()

   Dim oDoc As Document
   Dim oStory As Range
   Dim oHlink As Hyperlink

   For Each oStory In ActiveDocument.StoryRanges
      For Each oHlink In oStory.Hyperlinks
         oHlink.Range.Delete
      Next
   Next

End Sub

Jak usunąć style z dokumentów

Dokumenty mogą zawierać style z metadanymi. Style można usunąć lub zmienić ich nazwę. W tym celu:
  1. Otwórz dokument zawierający style.
  2. W menu Format kliknij polecenie Styl.
  3. Wybierz styl do usunięcia lub zmiany nazwy. Kliknij przycisk Usuń, aby usunąć styl lub kliknij przycisk Modyfikuj, aby zmienić jego nazwę.

Jak usunąć stare wersje pliku z dokumentów

Program Word zawiera funkcję wersji plików, która zezwala na zapisywanie wielu wersji tego samego dokumentu w tym samym pliku. Przed udostępnieniem dokumentu innym osobom może się pojawić potrzeba usunięcia starszych wersji.

Aby usunąć jedną lub więcej wersji dokumentu, wykonaj następujące kroki:
  1. W menu Plik kliknij polecenie Wersje.
  2. Wybierz wersję dokumentu do usunięcia. Można wybrać więcej niż jedną wersję, naciskając klawisz CTRL podczas zaznaczania wersji.
  3. Kliknij przycisk Usuń.
  4. Po ukończeniu usuwania starszych wersji dokumentu kliknij przycisk Zapisz w menu Plik.

Jak usunąć łącza z kodów pól

Połączone obrazy i inne obiekty w dokumentach programu Word mogą zawierać informacje o łączach, takie jak ścieżki do połączonego obrazu lub obiektu. Informacje o łączach można usunąć z dokumentu, dokonując edycji kodów pól.

Aby wyświetlić kody pól:

  1. W menu Narzędzia kliknij polecenie Opcje. Zaznacz kartę Widok.
  2. Kliknij, aby zaznaczyć pole wyboru Kody pól. Kliknij przycisk OK.
Gdy kody pól staną się widoczne, można sprawdzić, czy zawierają informacje identyfikujące.

Aby usunąć informacje o łączach z połączonego obrazu lub innego obiektu:
  1. Zaznacz połączony obraz lub obiekt albo zaznacz kod pola obrazu lub obiektu, jeśli kody pól są widoczne.
  2. Naciśnij klawisze CTRL+SHIFT+F9.
Obraz lub obiekt zostanie rozłączony. Należy pamiętać, że rozłączenie obrazu lub obiektu może spowodować brak możliwości jego edycji.

Jak usunąć nazwę i lokalizację szablonu

Wszystkie dokumenty utworzone w programie Word są oparte na szablonie. Domyślnie jest to plik szablonu Normal.dot, zlokalizowany w folderze Szablony. Można jednak utworzyć dokument oparty na innym szablonie w innej lokalizacji. Ścieżka i nazwa pliku tego szablonu są przechowywane we właściwościach dokumentu.

Aby wyświetlić nazwę i lokalizację szablonu, kliknij polecenie Właściwości w menu Plik i zaznacz kartę Podsumowanie.

Jeśli nawet dokument nie jest wysyłany razem z szablonem, nazwa i lokalizacja szablonu zostaje w nim zachowana. Aby zmienić nazwę i lokalizację szablonu do wartości uniemożliwiającej identyfikację, wykonaj następujące czynności:
  1. W menu Narzędzia kliknij polecenie Szablony i dodatki.
  2. Kliknij przycisk Dołącz.
  3. Wybierz szablon, którego nazwa i lokalizacja są neutralne. Na przykład wybierz plik Normal.dot, ponieważ na każdym komputerze z zainstalowanym program Word znajduje się plik Normal.dot.
  4. Kliknij przycisk Otwórz, a następnie kliknij przycisk OK.
UWAGA: Szablon może zawierać makra, pozycje autotekstu, niestandardowe style i niestandardowe paski narzędzi. Zmieniając szablony, można sprawić, że niektóre z tych elementów staną się niedostępne w dokumencie.

Jak usunąć informacje o liście wysyłkowej

Po wysłaniu dokumentu pocztą e-mail z użyciem listy wysyłkowej, informacje o liście wysyłkowej mogą zostać dołączone do dokumentu. Aby usunąć te informacje z dokumentu, należy zapisać dokument w formacie, który nie zachowuje informacji o liście wysyłkowej.

W programie Word zapisz dokument w formacie RTF lub HTML. Zamknij dokument, a następnie ponownie otwórz nowy plik. Ponieważ informacje o liście wysyłkowej nie będą już obecne, można zapisać dokument ponownie w formacie programu Word.

Można również użyć następującej procedury:
  1. Wyłącz funkcję Zezwalaj na szybkie zapisywanie, korzystając z instrukcji podanych wcześniej w tym artykule.
  2. W menu Plik wskaż polecenie Wyślij do, a następnie kliknij polecenie Inny adresat z listy wysyłkowej.
  3. Kliknij przycisk Wyczyść, aby usunąć listę wysyłkową. Następnie kliknij przycisk OK.
  4. W menu Plik kliknij polecenie Zapisz.
Dokument zostanie zapisany bez informacji o liście wysyłkowej.

Jak usunąć nazwy poprzednich autorów

Program Word przechowuje nazwy ostatnich dziesięciu osób, które pracowały z dokumentem. Funkcja jest automatyczna i nie można jej wyłączyć.

Można jednak usunąć z dokumentu nazwy dziesięciu ostatnich autorów przez zapisanie dokumentu w formacie nie zachowującym tych informacji. Na przykład, jeśli dokument zostanie zapisany w formacie RTF lub HTML, informacje o autorach zostaną utracone. Następnie można zamknąć i ponownie otworzyć dokument w formacie RTF lub HTML i zapisać go w formacie programu Word.

Jak usunąć nazwę użytkownika z kodu języka Visual Basic

WAŻNE: Przez użyciem poniższego przykładu makra, przeczytaj Zastrzeżenie znajdujące się wcześniej w tym artykule.

Po zarejestrowaniu makra języka Visual Basic w programie Word, zarejestrowane makro zaczyna się od nagłówka podobnego do poniższego:
' Makro1 Makro
' Makro zapisane 1999-11-03 przez <NazwaUżytkownika>
Aby usunąć nazwę ze wszystkich zarejestrowanych wcześniej makr:
  1. Otwórz dokument zawierający makra.
  2. W menu Narzędzia wskaż polecenie Makro, a następnie kliknij polecenie Edytor Visual Basic. Ewentualnie naciśnij klawisze ALT+F11.
  3. W oknie projektu kliknij dwukrotnie moduł zawierający makra.
  4. Usuń nazwę z zarejestrowanego kodu makra.
Po ukończeniu usuwania nazwy naciśnij klawisze ALT+Q, aby powrócić do programu. Następnie kliknij polecenie Zapisz w menu Plik.

Jak usunąć odwołania języka Visual Basic do innych plików

W programie Edytor Visual Basic można tworzyć odwołania do innego pliku. Po otwarciu przez użytkownika dokumentu zawierającego odwołania do innych plików, można zobaczyć nazwy tych plików.

Aby usunąć te odwołania, wykonaj następujące kroki:
  1. Otwórz dokument zawierający odwołania.
  2. W menu Narzędzia wskaż polecenie Makro, a następnie kliknij polecenie Edytor Visual Basic. Ewentualnie naciśnij klawisze ALT+F11.
  3. W menu Tools kliknij polecenie References.
  4. Kliknij, aby wyczyścić, pole wyboru znajdujące się obok pliku lub plików, do których się odwoływano. Po zakończeniu kliknij przycisk OK.
  5. Naciśnij klawisze ALT+Q.
  6. W menu Plik kliknij polecenie Zapisz.
UWAGA: Usunięcie odwołań do innych plików może mieć wpływ na nieprawidłowe działanie makr w dokumentach.

Jak usunąć informacje o sieci lub dysku twardym

Podczas zapisywania dokumentu na lokalnym dysku twardym lub serwerze sieciowym w dokumencie mogą zostać zapisane informacje identyfikujące lokalny dysk twardy lub serwer sieciowy.

Aby usunąć te informacje z dokumentu, wykonaj następujące kroki:
  1. Otwórz dokument.
  2. W menu Plik kliknij polecenie Zapisz jako. Zapisz dokument na dyskietkę (zwykle dysk A).
  3. W menu Plik kliknij polecenie Zamknij.
  4. Usuń dyskietkę ze stacji dysków.
Możesz użyć Eksploratora Windows do skopiowania dokumentu z dyskietki na dysk twardy lub serwer sieciowy.

UWAGA: Z powodu ograniczeń miejsca na dyskietce (zwykle 1,44 megabajtów [MB]) metoda nie może być stosowana, jeśli rozmiar pliku dokumentu przekracza ilość wolnego miejsca na dyskietce.

Obiekty osadzone w dokumencie mogą zawierać metadane

Jeśli obiekt zostanie osadzony w dokumencie, niezależnie od czynności wykonanych w dokumencie obiekt nadal będzie zawierać odrębne właściwości. Na przykład, jeśli w dokumencie programu Word zostanie osadzony skoroszyt programu Microsoft Excel, dokument i skoroszyt będą mieć odrębne właściwości.

Aby usunąć metadane z osadzonego obiektu, usuń wszystkie metadane w sposób opisany w poprzednich sekcjach, uaktywnij ponownie dokument zawierający obiekt i zapisz go.

UWAGA: Po uaktywnieniu osadzonego obiektu w dokumencie jest wyświetlana tylko część osadzonego obiektu; obiekt może zawierać dodatkowe informacje, które się nie pojawiają. Jeśli chcesz, aby dokument zawierał tylko projekcję osadzonego obiektu, a nie jego całą zawartość, użyj polecenia Wytnij w menu Edycja do usunięcia obiektu i użyj polecenia Wklej specjalnie do wklejenia obiektu do dokumentu z użyciem formatu Metaplik. Po ukończeniu tych czynności nie będzie można edytować obiektu osadzonego; nie będzie on jednak zawierać żadnych metadanych.

Zmienne dokumentu mogą zawierać metadane

WAŻNE: Przez użyciem poniższego przykładowego makra, przeczytaj Zastrzeżenie znajdujące się wcześniej w tym artykule.

Aby usunąć zmienne dokumentu zawarte w dokumencie programu Word, użyj poniższego przykładowego makra:
Sub DeleteDocVars()

   Dim Response
   Dim myVar As Variable

   For Each myVar In ActiveDocument.Variables
      Response = MsgBox("Zmienna dokumentu: " & myVar.Name & vbCr & _
         "Wartość: " & myVar.Value & vbCr & vbCr & _
         "Czy chcesz usunąć zmienną z tego dokumentu?", vbYesNo)
            
      If Response = "6" Then
         ' Usunięcie zmiennej.
         myVar.Delete
      Else
         End
      End If
   Next myVar
            
   MsgBox "W dokumencie nie ma żadnych zmiennych."
   
End Sub
Aby uzyskać więcej informacji o zmiennych, w Edytorze Visual Basic kliknij polecenie Microsoft Visual Basic - Pomoc w menu Pomoc, wpisz tekst Variables Property, a następnie kliknij przycisk Wyszukaj, aby wyświetlić znaleziony temat.

Ogólne zalecenia dotyczące zabezpieczeń

Poniżej znajduje się kilka ogólnych sugestii, które mogą służyć do zwiększenia poziomu zabezpieczeń w środowisku komputerowym:
  • Gdy nie jesteś przy komputerze, zabezpiecz go wygaszaczem ekranu z hasłem, hasłem przy rozruchu komputera lub skorzystaj z funkcji blokowania systemu Windows NT.
  • Jeśli na komputerze są udostępnione foldery, upewnij się, że są zabezpieczone hasłem, aby mieli dostęp do nich tylko autoryzowani użytkownicy. Dla zwiększenia bezpieczeństwa użyj kontroli dostępu na poziomie użytkowników, aby można było dokładnie kontrolować, kto ma dostęp do udziałów komputera.
  • Po usunięciu pliku natychmiast opróżnij Kosz. Rozważ używanie narzędzia, które całkowicie usuwa lub zastępuje pliki po usunięciu.
  • Po wykonaniu kopii zapasowych danych, przechowuj je w bezpiecznych miejscach, takich jak sejfy, skrzynki depozytowe lub szafki zamykane na klucz.
  • Upewnij się, że ważne dokumenty są chronione hasłem, aby mogli je otwierać tylko autoryzowani użytkownicy. Przechowuj hasła w bezpiecznych, osobnych lokalizacjach. Pamiętaj, że jeśli zapomnisz hasła, nie będzie można odzyskać zawartości dokumentu chronionego hasłem.
  • Nie dystrybuuj dokumentów w formie elektronicznej. Drukuj je. Nie używaj elementów identyfikujących, takich jak wyróżniające się czcionki, znaki wodne, loga lub specjalny papier, chyba że to konieczne (na przykład do prezentacji).
  • Wiadomość e-mail nie jest anonimowa. Nie wysyłaj pocztą e-mail dokumentu, jeśli nie masz pewności, czy chcesz powiązać swoje imię i nazwisko z dokumentem.
  • Nie wysyłaj dokumentu przez Internet za pomocą protokołu HTTP lub FTP (File Transfer Protocol). Przy użyciu tych protokołów informacje są wysyłane „prostym tekstem”, co oznacza, że technicznie możliwe (choć mało prawdopodobne) jest jego przechwycenie.

Właściwości

Numer ID artykułu: 290945 - Ostatnia weryfikacja: 28 listopada 2003 - Weryfikacja: 1.0
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Word 2002 Standard Edition
Słowa kluczowe: 
kbhowto kbhowtomaster kbdta KB290945

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com