HOW TO:最小化 Microsoft Word 2002 的中繼資料

文章翻譯 文章翻譯
文章編號: 290945 - 檢視此文章適用的產品。
全部展開 | 全部摺疊

在此頁中

結論

本文說明用於最小化 Word 文件中的中繼資料量的各種方法。

每一次您在 Microsoft Word 2002 中建立、開啟或儲存文件,並以電子方式將散佈文件時,其中就可能包含您並不想與他人分享的內容。 此項資訊被通稱為中繼資料。 中繼資料被用於加強 Office 文件之編輯、檢視、歸檔及檢索等各種目的。

一些中繼資料可以直接透過 Word 的使用者介面存取。 其他的中繼資料只能透過特別方法存取,例如,在低階的二進位檔案編輯器開啟文件。 以下是可能儲存於文件中之中繼資料的範例:
  • 您的姓名
  • 您的姓名縮寫
  • 您的公司或組織名稱
  • 您的電腦名稱
  • 您儲存檔案的網路伺服器或硬碟名稱
  • 其他檔案屬性及摘要資訊
  • 內嵌 OLE 物件的不可見部分
  • 先前文件作者的姓名
  • 文件修訂
  • 文件版本
  • 範本資訊
  • 隱藏文字
  • 註解
在 Word 文件裡的中繼資料是由許不同方法建立的。 因此,並沒有單一方法能夠由您的文件移除所有這類內容。 以下的段落說明 Word 文件裡中繼資料的儲存區域。

本文說明您可以用於最小化 Word 文件內中繼資料數量的各種方法。


免責聲明

Microsoft 提供之程式設計範例僅供說明之用,並不提供任何明示或默示之擔保,其中包括但並不限於適售性以及適合某特殊用途之默示責任擔保。本文假設您已熟悉我們所示範的程式設計語言,以及建立和偵錯程序所用的工具。Microsoft 支援人員可以解釋特定程序的功能;不過卻不會修改這些範例,提供附加功能或建構程序,以符合您的需求。如果您的程式設計經驗有限,可以連絡 Microsoft Certified Partner,或 Microsoft 付費顧問專線 (800) 936-5200。如需有關 Microsoft Certified Partner 的詳細資訊,請造訪以下的 Microsoft 網站:
https://partner.microsoft.com/global/30000104
如需有關可用支援選項與如何聯絡 Microsoft 的詳細資訊,請造訪以下的 Microsoft 網站:
http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS
如需如何使用本文中範例程式碼的詳細資訊,請按一下以下的文件編號,以檢視 Microsoft Knowledge Base 中的文件:
290140 OFFXP: How to Run Sample Code from Knowledge Base Articles

如何在儲存時自動移除個人資訊

您現在可以在儲存文件時,自動地由 Word 文件移除個人資訊。若要開啟此選項,請遵循以下步驟:
  1. [工具] 功能表,按一下 [選項]
  2. [安全性] 索引標籤,按一下以選擇 [隱私選項] 之下的 [存檔時自檔案中移除個人資訊] 核取方塊,再按一下 [確定]
注意: 此為儲存 Word 2002 文件時,移除個人資訊的慣用方法。

如何由文件手動移除使用者名稱

若要檢視或變更您的使用者名稱,請遵循下列步驟:
  1. [工具] 功能表,按一下 [選項],再按一下 [使用者資訊] 索引標籤。

    下列的編輯方塊會出現:

    [姓名]
    [縮寫]
    [地址]
  2. 如果您不要任何這些資訊出現在文件裡,請在適當的編輯方塊中輸入無法辨識的字串或空格,再按一下 [確定] 以接受變更。
注意: 任何您所建立的新文件都會包含這些資訊,而非當您在安裝 Office 時所輸入的預設值。 不過,現有的文件可能已經包含這些資訊。

如何手動移除個人摘要資訊

當您在 Word 建立或儲存一份文件時,可以在文件裡儲存摘要資訊。 有數種方法存取這項資訊:
  • 開啟文件。在 [檔案] 功能表,按一下 [摘要資訊]

    [摘要資訊][統計資料][內容],及 [自訂] 索引標籤可以包含各種屬性如:您的姓名、您主管的姓名、您公司的名稱。
  • 在 Windows 檔案總管,對文件按右鍵,再按一下快顯功能表的 [內容]

    [內容] 對話方塊裡的索引標籤可能包含資訊。
  • 您可以使用 Microsoft Visual Basic for Applications 巨集,或是其他的程式碼來讀取顯示在 [內容] 對話方塊的內容。
若要由現存的文件或範本清除摘要資訊,請遵循下列步驟:
  1. 開啟文件或範本。
  2. [檔案] 功能表,按一下 [摘要資訊]
  3. [摘要資訊] 索引標籤,清除 [作者][主管][公司],以及其他您不要散佈的編輯方塊。
  4. [自訂] 索引標籤,刪除任何包含您不要散佈資訊的內容。
  5. 按一下 [確定]。在 [檔案] 功能表,按一下 [儲存檔案],再按一下 [關閉]
在您完成這些步驟以後,文件便不會包含摘要內容。

如何在連線至網路時手動移除個人摘要資訊

如果您登入了網路,在儲存文件時,您的網路使用者名稱就會出現在 [摘要資訊] 索引標籤的 [作者] 編輯方塊,以及 [統計資料] 索引標籤的 [前次存檔人員] 欄位。 即使您已由電腦移除所有其他個人資訊,這種情形依然會發生。

若要在連線到網路時,由文件移除摘要資訊,請遵循下列步驟:
  1. 如果文件儲存在網路伺服器上,請將之複製到本機硬碟上。
  2. 啟動電腦,不過先不要登入您的網路。 當您看到網路登入對話方塊,請按一下 [取消] 或按一下 Esc 鍵。

    注意: 如果您無法按下 Esc 鍵以啟動 Windows (例如:您的電腦正在執行 Microsoft Windows NT),您就無法繼續下列步驟。
  3. 開啟文件。
  4. [檔案] 功能表,按一下 [摘要資訊]
  5. [摘要資訊] 索引標籤,清除 [作者][主管][公司],以及其他任何包含您不要散佈資訊的編輯方塊。
  6. [自訂] 索引標籤,刪除任何包含您不要散佈資訊的內容。
  7. 按一下 [確定]。在 [檔案] 功能表,按一下 [儲存檔案],再按一下 [關閉]
當您登入網路時,不要開啟檔案。 如果這樣做的話,您的網路使用者名稱就會被寫入檔案。 不過,您可以使用 Windows 檔案總管以複製檔案到網路伺服器或磁片。

如何手動移除文件的註解

Word 提供在文件內加入註解的能力。 一般而言,註解包含建立者的姓名,因此您可分辨出是誰寫下註解。

註解一般以文字的醒目顯示部分出現;您可以在註解上按右鍵,然後在快顯功能表按一下 [刪除註解]

任何您所建立的新註解都不會包含您的使用者名稱,因為如本文之<如何由文件手動移除使用者名稱>一節所述,您已經將之由 [選項] 對話方塊移除。

如何由文件手動移除頁首與頁尾

文件的頁首與頁尾可能包含識別的資訊。 若要由頁首與頁尾移除資訊:
  1. 按一下在 [檢視] 功能表上的 [頁首/頁尾]
  2. 頁首與頁尾會出現在文件中每頁的頂端及底部。 根據您想要的方式進行變更。
  3. 之後在 [頁首及頁尾] 工具列,按一下 [關閉]

如何手動移除修訂記號

文件所包含的修訂記號,讓您可以看出誰對文件作過特定的變更。 當您接受或拒絕修訂記號時,修訂文字會儲存在文件裡,修訂記號則會遭到移除。

若要接受或拒絕修訂:
  1. [工具] 功能表,指向 [追蹤修訂] 再按一下 [接受或拒絕修訂]
  2. [接受或拒絕修訂] 對話方塊,使用兩個 [尋找] 按鈕找到特定的修訂文字,再個別接受或拒絕,或者按一下 [全部接受][全部拒絕]
  3. 在完成之後,按一下 [關閉]。

如何關閉快速儲存

僅儲存對文件所作的新的變更,「快速儲存」的功能加快了儲存文件的程序。

由於「快速儲存」功能的設計,就算在文件儲存過後,由文件刪除的文字依然可能留在文件裡。 如果您關切刪除文字留在文件裡的問題,請遵循下列步驟:
  1. [工具] 功能表,按一下 [選項]
  2. 選擇 [儲存] 索引標籤。
  3. 按一下以清除 [允許快速儲存] 核取方塊。按一下 [確定]
如需有關「快速儲存」的其他資訊,請按一下以下的文章編號,以檢視「Microsoft 知識庫」中的文章:
290945 WD2002: How to Minimize Metadata in Microsoft Word Documents
291181 WD2002:「允許快速儲存」的常見問題集

如何搜尋及移除隱藏格式文字

在 Word 文件裡,您可以將文字的格式設定為隱藏。 由於隱藏文字可能包含您不想散佈的資訊,您最好將之解除隱藏並且移除掉。 若要移除在文件中具有隱藏格式的全部文字,請遵循下列步驟:
  1. [工具] 功能表,按一下 [選項]。 選擇 [檢視] 索引標籤。
  2. 按一下以選擇 [隱藏文字] 核取方塊,再按一下 [確定]
  3. [編輯] 功能表,按一下 [取代]
  4. 按一下 [更多] 以展開對話方塊。
  5. 按一下 [尋找目標] 旁編輯方塊的任何位置。
  6. 按一下 [格式] 按鈕,再按一下 [字型]。 按一下以選擇 [隱藏] 核取方塊,再按一下 [確定]
  7. 按一下 [全部取代]
已經由文件中移除所有隱藏文字。 若要關閉隱藏文字的顯示,請遵循下列步驟:
  1. [工具] 功能表,按一下 [選項]。 選擇 [檢視] 索引標籤。
  2. 按一下以清除 [隱藏文字] 核取方塊。按一下 [確定]

如何由文件移除超連結

文件可能包含指向網際網路或內部網路上,其他文件或網頁的超連結。 超連結一般是以有藍色底線的文字字串出現。

若要用手動由文件刪除單一超連結,請對超連結按右鍵,指向快顯功能表上的 [超連結],再按一下 [移除超連結]

如果要刪除文件的所有超連結,您可以使用 Visual Basic for Applications 巨集進行此項作業。 以下的 Visual Basic for Applications 範例巨集可移除文件的所有超連結。

注意: 在以下的範例巨集中,僅有連結遭到移除。 超連結的文字會留在文件裡。

重要: 在您使用以下的巨集範例之前,請先檢閱本文先前的免責聲明
Sub RemoveHyperlinks()

   Dim oDoc As Document
   Dim oStory As Range
   Dim oHlink As Hyperlink

   For Each oStory In ActiveDocument.StoryRanges
      For Each oHlink In oStory.Hyperlinks
         oHlink.Delete
      Next
   Next



End Sub
				
若要由文件移除所有超連結及超連結文字的蹤跡,您可以改用以下的範例巨集。
Sub RemoveAllHyperlinks()

   Dim oDoc As Document
   Dim oStory As Range
   Dim oHlink As Hyperlink

   For Each oStory In ActiveDocument.StoryRanges
      For Each oHlink In oStory.Hyperlinks
         oHlink.Range.Delete
      Next
   Next

End Sub
				

如何由文件移除樣式

文件可能包含具有中繼資料的樣式。 您可以移除或重新命名這些樣式。如果要執行這項動作:
  1. 請開啟包含該樣式的文件。
  2. [格式] 功能表,按一下 [樣式]
  3. 選擇您要移除或重新命名的樣式。 按一下 [刪除] 以刪除樣式,或按一下 [修改] 以重新命名。

如何由文件移除舊檔案版本

Word 包含一項檔案版本功能,可以允許您在相同檔案裡,儲存相同文件的多重版本。 在跟他人分享文件之前,您可能需要先刪除文件的舊版本。

若要刪除一個或更多文件的版本,請遵循下列步驟:
  1. [檔案] 功能表,按一下 [版本]
  2. 選擇您要刪除的文件版本。 在選擇版本時壓住 CTRL,即可選擇一個以上的版本。
  3. 按一下 [刪除]
  4. 在您完成刪除文件的舊版本以後,按一下 [檔案] 功能表上的 [儲存檔案]

如何由功能變數代碼移除連結

Word 文件裡的連結圖像與其他物件,都有可能包含連結資訊 (例如:指向連結圖像或物件的路徑)。 您可以藉由編輯功能變數代碼,將連結資訊由文件中移除。

若要顯示功能變數代碼:

  1. 請在 [工具] 功能表,按一下 [選項]。 選擇 [檢視] 索引標籤。
  2. 按一下以選擇 [功能變數代碼] 核取方塊。按一下 [確定]
當功能變數代碼變為可見之後,您就可以檢查它們是否包含辨識的資訊。

若要由連結的圖像或其他物件,移除連結資訊:
  1. 請選擇連結圖像或物件,或者如果看得見功能變數代碼,選擇圖像或物件的功能變數代碼。
  2. 按 CTRL+SHIFT+F9。
該圖像或物件已經解除連結。 注意:解除圖像或物件的連結,可能會使之再也無法編輯。

如何移除範本名稱及位置

所有的 Word 文件都根據一個範本建立。 依預設,這也就是位於 Templates 資料夾的 Normal.dot 範本檔案。 不過,您也可以根據位於其他位置的不同範本,來建立您的文件。 此範本的路徑與名稱都會儲存在文件的摘要資訊裡。

若要檢視範本的名稱及位置,請按一下 [檔案] 功能表上的 [摘要資訊],並選擇 [摘要資訊] 索引標籤。

儘管您並未連同文件傳送範本,文件依然會保留範本的名稱及位置。 若要將範本名稱及位置變更為無法辨識的內容,請遵循下列步驟:
  1. [工具] 功能表,按一下 [範本與增益集]
  2. 按一下 [貼附於]
  3. 選擇一個名稱及位置不區分大小寫,也非唯一的範本。 例如:由於每台安裝 Word 的電腦都有包含 Normal.dot,您可能會想選擇 Normal.dot。
  4. 按一下 [開啟],再按一下 [確定]
注意: 範本可能包含巨集、自動圖文集項目、自訂樣式,以及自訂工具列。 範本經過變更以後,其中的一些項目可能會無法在文件中使用。

如何移除傳閱名單資訊

如果您使用傳閱名單,透過電子郵件傳送文件,傳閱資訊可能會附加在文件上。 若要由文件移除此項資訊,您必須將文件儲存為不保留傳閱名單資訊的格式。

在使用 Word 的時候,您可以將文件儲存為 RTF 或 HTML 格式。 關閉文件,再重新開啟新檔案。 由於傳閱資訊已經不復存在,您現在可以將文件儲存為 Word 格式。

您也可以使用下列的程序:
  1. 按照本文先前的指示,關閉 [允許快速儲存]
  2. [檔案] 功能表,指向 [傳送到],再按一下[傳閱名單收件者]
  3. 按一下 [清除] 以移除傳閱名單。再按一下 [確定]
  4. [檔案] 功能表,按一下 [儲存檔案]
現在文件已經儲存而不包含任何傳閱名單資訊。

如何移除先前作者姓名

在 Word 文件裡,儲存著至少 10 位最後處理過文件的人員姓名。 這是一項無法關閉的自動功能。

不過,您可以藉由將文件儲存為不保留此種資訊的格式,移除最後 10 位文件作者的姓名。 例如:如果您將文件儲存為 RTF 或 HTML 格式,作者資訊就會遺失。 然後您就可以關閉並重新開啟 RTF 或 HTML 文件,再將之儲存為 Word 格式。

如何由 Visual Basic 程式碼移除您的姓名

重要: 在您使用以下的巨集範例之前,請先檢閱本文先前的免責聲明

當您在 Word 中錄製 Visual Basic 巨集時,錄製的巨集會以如下的標頭開始:
' Macro1 Macro
' Macro recorded 3/11/1999 by <User Name>
				
若要由任何您所錄製的巨集移除您的姓名:
  1. 請開啟包含巨集的文件。
  2. [工具] 功能表,指向 [巨集],再按一下 [Visual Basic 編輯器]。 或者按 ALT+F11。
  3. 在專案視窗中,連按兩下包含巨集的模組。
  4. 由錄製的巨集程式碼移除您的姓名。
在完成移除您的姓名以後,按 ALT+Q 以返回程式。 再按一下 [檔案] 功能表的 [儲存檔案]

如何移除 Visual Basic 對其他檔案的參照

在「Visual Basic 編輯器」裡,您可以建立對其他檔案的參照。 如果使用者開啟包含參照到其他檔案的文件,使用者即可看見參照檔案的名稱。

若要移除這些參照,請遵循下列步驟:
  1. 開啟包含參照的文件。
  2. [工具] 功能表,指向 [巨集],再按一下 [Visual Basic 編輯器]。 或者按 ALT+F11。
  3. [工具] 功能表,按一下 [參照位址]
  4. 按一下以清除參照檔案旁的核取方塊。 在您完成之後,按一下 [確定]
  5. 按 ALT+Q。
  6. [檔案] 功能表,按一下 [儲存檔案]
注意: 移除對於其他檔案的參照,可能會使文件內的巨集因為受損而無法正確作用。

如何移除網路或硬碟資訊

當您將文件儲存到本機硬碟或網路伺服器時,辨識本機硬碟或網路伺服器的資訊,就可能被寫入文件裡。

若要由文件移除這類資訊,請遵循下列步驟:
  1. 開啟文件。
  2. [檔案] 功能表,按一下 [另存新檔]。 將文件儲存到您的軟碟機 (通常是 A 磁碟機)。
  3. [檔案] 功能表,按一下 [關閉]
  4. 將磁片由軟碟機中移除。
現在您可以使用 Windows 檔案總管,由磁片複製文件到任何硬碟或網路伺服器。

注意: 由於磁片有空間限制 (一般為 1.44 MB),如果文件檔案的大小超過軟碟片的可用空間,此一方法就會無法使用。

文件的內嵌物件可能包含中繼資料

如果您將物件內嵌在文件裡,無論您對文件作出何種變更,該物件都會依然保留自身的內容。 例如:如果您將一個 Microsoft Excel 活頁簿內嵌到 Word 文件裡,文件及活頁簿兩者都會各有自己的內容。

若要將中繼資料由一個內嵌物件移除,請啟動該物件,按照本文先前的說明移除一切中繼資料,然後重新啟動容器文件,再儲存容器文件。

注意: 當您在文件中啟動內嵌物件時,只有部分的內嵌物件會顯示在文件裡;物件可能還包含其他未顯示的資訊。 如果您要使文件只包含內嵌物件的對應內容,而非其實際內容,請使用 [編輯] 功能表的 [剪下] 命令以刪除物件,再使用 [選擇性貼上] 命令以使用中繼檔 (Metafile) 格式將物件貼入文件。 完成此項操作後,您就再也不能編輯此內嵌物件;不過,它也不會包含任何中繼資料。

文件變數可能包含中繼資料

重要: 在您使用下列範例巨集之前,請先檢視本文先前的免責聲明

若要移除包含在 Word 文件中的文件變數,請使用下列的範例巨集:
Sub DeleteDocVars()

   Dim Response
   Dim myVar As Variable

   For Each myVar In ActiveDocument.Variables
      Response = MsgBox("The document variable: " & myVar.Name & vbCr & _
         "Value: " & myVar.Value & vbCr & vbCr & _
         "Do you want to delete the variable from this document?", vbYesNo)
            
      If Response = "6" Then
         ' Delete the variable.
         myVar.Delete
      Else
         End
      End If
   Next myVar
            
   MsgBox "There are no variables in the document."
   
End Sub
				
如需有關變數的詳細資訊,請在「Visual Basic 編輯器」,按一下 [說明] 功能表的 [Microsoft Visual Basic 說明],在「Office 小幫手」或「解答精靈」中輸入:變數屬性,再按一下 [搜尋],以檢視主題。

關於安全性的一般建議

此處是一般性建議,可以讓您用於增進電腦環境的安全性等級:
  • 無論何時,只要不在電腦旁邊,請使用密碼保護的螢幕保護程式、開機密碼以及 Windows NT 鎖定功能來維持安全。
  • 如果您的電腦具有任何共用的資料夾,請確定已針對它們指定密碼,限制僅有授權的使用者才能存取共用資源。 若要達成更高的安全性,請採用使用者等級控制,如此就能控制存取電腦共用資源的確切人員。
  • 在刪除檔案之後,立即清理資源回收筒。 您可以考慮使用在刪除檔案時完全清除或覆寫一切的公用程式。
  • 在您備份資料時,請將備份儲存在安全的位置 (例如:保險櫃、貴重物品保管箱,或是上鎖的檔案櫃)。
  • 請確定重要的文件都受到密碼保護,如此唯有授權使用者才能開啟它們。 將您的密碼儲存在安全的其他位置。 注意:如果您無法想起密碼,沒有任何方法可以取得密碼保護文件的內容。
  • 不要以電子形式散佈文件。 反之,要將它們列印出來。 除非絕對有必要 (例如:為了簡報),不要使用可供辨識的項目如:有特色的字型、浮水印、標誌、或特別紙張。
  • 電子郵件不是匿名的。 如果您關切身份資訊會以任何方式附加到文件上,就不要以電子郵件傳送文件。
  • 不要用 HTTP 或 FTP 通訊協定在網際網路上傳送文件。 通過這些通訊協定所傳送的資訊都屬「純文字」,這就表示在技術上資訊有可能 (雖然可能性不大) 遭到攔截。

屬性

文章編號: 290945 - 上次校閱: 2006年11月23日 - 版次: 1.1
這篇文章中的資訊適用於:
  • Microsoft Word 2002 Standard Edition
關鍵字:?
kbdta kbhowto kbhowtomaster KB290945
Microsoft及(或)其供應商不就任何在本伺服器上發表的文字資料及其相關圖表資訊的恰當性作任何承諾。所有文字資料及其相關圖表均以「現狀」供應,不負任何擔保責任。Microsoft及(或)其供應商謹此聲明,不負任何對與此資訊有關之擔保責任,包括關於適售性、適用於某一特定用途、權利或不侵權的明示或默示擔保責任。Microsoft及(或)其供應商無論如何不對因或與使用本伺服器上資訊或與資訊的實行有關而引起的契約、過失或其他侵權行為之訴訟中的特別的、間接的、衍生性的損害或任何因使用而喪失所導致的之損害、資料或利潤負任何責任。

提供意見

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com