WD2002: Aparece una advertencia de virus de macro cuando no existe ninguna macro en el archivo

Seleccione idioma Seleccione idioma
Id. de artículo: 290960 - Ver los productos a los que se aplica este artículo
Este artículo se publicó anteriormente con el número E290960
Para obtener una versión para Microsoft Word 2000 de este artículo, consulte 238851.
Para obtener una versión para Microsoft Word 97 de este artículo, consulte 161515.
Expandir todo | Contraer todo

En esta página

Síntomas

Cuando abra un documento o una plantilla de Microsoft Word 2002, es posible que reciba la siguiente advertencia de virus de macro, incluso si el documento o la plantilla no contiene macros:
C:\<ruta de acceso>\<nombre de archivo> contiene macros.

Algunas macros pueden contener virus. Siempre es más seguro deshabilitarlas, pero si las macros son de confianza y las deshabilita, puede perder funcionalidad.

Causa

Cuando se eliminan macros de un documento o de una plantilla, algunos componentes de almacenamiento de macros permanecen. La característica de protección contra virus de macros encuentra esta información y es posible que aparezca el mensaje de advertencia.

Solución

Para evitar este problema, utilice uno de los métodos siguientes apropiados para su situación.

Método 1: eliminar el componente de almacenamiento de macros restante

Microsoft proporciona ejemplos de programación con fines ilustrativos únicamente, sin ninguna garantía tanto expresa como implícita, incluyendo pero sin limitarse a, las garantías implícitas de comerciabilidad e/o idoneidad para un fin determinado. En este artículo se da por supuesto que ya conoce el lenguaje de programación que se demuestra y las herramientas empleadas para crear y depurar procedimientos. Los profesionales de soporte técnico de Microsoft pueden explicarle la funcionalidad de un determinado procedimiento, pero no modificarán estos ejemplos para ofrecer mayor funcionalidad o crear procedimientos adaptados a sus necesidades específicas. Si tiene poca experiencia en programación, quizá desee ponerse en contacto con un Microsoft Certified Solution o con la línea del servicio de consultoría que ofrece, mediante pago, llamando al Centro de Atención al Cliente de Microsoft en el número 902 197 198. Para obtener más información acerca de los Certified Partners, consulte la siguiente página en World Wide Web:
http://www.microsoft.com/certifiedpartner/
Para obtener más información acerca de las opciones de soporte técnico de Microsoft, consulte la siguiente página en el World Wide Web:
http://www.microsoft.com/Spain/support/supportnet/default.htm
Las macros que se encuentran en el documento o la plantilla de Word se guardan en un módulo. Una vez eliminadas las macros de un documento o de una plantilla, el módulo que contiene las macros no desaparece cuando se eliminan las macros.

Para eliminar el módulo de un documento o de una plantilla de Word y evitar que aparezca la advertencia de virus de macro, siga estos pasos.

NOTA: cuando se quita un módulo se eliminan las macros que éste contiene.
  1. Abra el documento o la plantilla que emite la advertencia de virus de macro.
  2. En el menú Herramientas, seleccione Macro y haga clic en Editor de Visual Basic.
  3. En la ventana Proyecto expanda el proyecto de documento (plantilla). El proyecto de documento (plantilla) debe parecerse al siguiente ejemplo:
    Proyecto ( nombreArchivo )
    NOTA: Si la ventana Proyecto no se ve, haga clic en Explorador de proyectos en el menú Ver. Para expandir el proyecto de documento (plantilla), haga clic en el signo más situado a la izquierda de Proyecto ( nombreArchivo ).
  4. Expanda la carpeta Módulos.
  5. Haga clic para seleccionar el módulo. Por ejemplo, haga clic para seleccionar NewMacros.

    NOTA: el nombre del módulo enumerado puede ser diferente en su proyecto (plantilla) de documento. Por ejemplo, es posible que se llame Module1 o de otra manera.
  6. En el menú Archivo, haga clic en Quitar nombreMódulo . Haga clic en No en el siguiente mensaje:
    ¿Desea exportar <nombreMódulo> antes de quitarlo?
    NOTA: si no está seguro de si el módulo que está quitando contiene macros, haga clic en y, a continuación, exporte el módulo como Archivos de Basic (*.bas).
  7. Repita los pasos 5 y 6 para cada módulo enumerado en la carpeta Módulos de Proyecto (nombreArchivo).
  8. En el menú Archivo, haga clic en Cerrar y volver a Microsoft Word.
  9. Guarde y cierre el documento de Word (plantilla).
La advertencia de virus de macro ya no aparecerá cuando abra el documento (plantilla).

Método 2: copiar la plantilla en un nuevo archivo de Word

NOTA: utilice este procedimiento cuando la plantilla de Word no contenga macros, pero muestre la advertencia de virus de macro, como se describe en la sección "Síntomas" de este artículo, cuando la abra o intente crear un nuevo documento basado en ella (en el menú Archivo, haga clic en Nuevo). Cree una nueva plantilla mediante los pasos que se indican a continuación.

NOTA: una vez creada la nueva plantilla, puede copiar en ella todos los estilos personalizados, las entradas de Autotexto, etc., pero no debe copiar ninguna macro.
  1. En el menú Archivo haga clic en Cerrar para cerrar el archivo que muestra la advertencia de virus de macro.
  2. En el menú Archivo, haga clic en Nuevo.
  3. En la ficha General, haga clic para seleccionar Documento en blanco y, a continuación, haga clic en Aceptar.
  4. En el menú Insertar, haga clic en Archivo.
  5. En el cuadro de diálogo Insertar archivo cambie el cuadro Tipo de archivo a Plantilla de documento (*.dot).
  6. En el cuadro Buscar en: indique la carpeta que contiene la plantilla con el problema. Por ejemplo, en el cuadro Buscar en: indique la siguiente carpeta:
    C:\WINDOWS\Application Data\Microsoft\Templates
    NOTA: es posible que su plantilla se encuentre en otra carpeta.
  7. Haga clic para seleccionar la plantilla que presenta el problema y, a continuación, haga clic en Insertar.
  8. En el menú Archivo, haga clic en Guardar como.
  9. En el cuadro de diálogo Guardar como cambie el cuadro Guardar como tipo a Plantilla de documento (*.dot).
  10. En el cuadro Nombre de archivo escriba un nombre de archivo para la nueva plantilla y, a continuación, haga clic en Guardar.
  11. En el menú Archivo, haga clic en Cerrar para cerrar la nueva plantilla.
Las macros o los componentes de almacenamiento de macros restantes de la plantilla con problemas no se guardarán en la nueva plantilla. La advertencia de virus de macro ya no aparecerá cuando abra la plantilla o la utilice para crear un nuevo documento.

Método 3: guardar el documento de Word como Formato de texto enriquecido (RTF)

NOTA: utilice este procedimiento cuando el documento de Word no contenga macros, pero muestre la advertencia de virus de macro como se describe en la sección "Síntomas" de este artículo.
  1. Abra el documento que emite la advertencia de virus de macro.
  2. En el menú Archivo, haga clic en Guardar como.
  3. En el cuadro de diálogo Guardar como, en Guardar como tipo, haga clic en Formato de texto enriquecido (*.rtf) y, a continuación, haga clic en Guardar. Haga clic en en el siguiente mensaje:
    Si se guarda el documento en Formato de texto enriquecido, se perderán todas las macros que contiene. ¿Desea guardar con este formato?
  4. En el menú Archivo haga clic en Cerrar para cerrar el documento en Formato de texto enriquecido que acaba de guardar.
  5. En el menú Archivo haga clic en Abrir para abrir el documento en Formato de texto enriquecido que guardó en el paso 3.
  6. En el menú Archivo, haga clic en Guardar como.
  7. En el cuadro de diálogo Guardar como, en Guardar como tipo, haga clic en Documento de Word (*.doc) y, a continuación, haga clic en Guardar. Si está guardando el archivo con su nombre original, haga clic en en el siguiente mensaje:
    El archivo <nombreArchivo> ya existe. ¿Desea reemplazarlo?
  8. Cierre y vuelva a abrir el documento.
Las macros o los componentes de almacenamiento de macros restantes no se guardarán en el nuevo documento. La advertencia de virus de macro ya no aparecerá cuando abra el documento.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados al principio de este artículo.

Más información

Un documento o una plantilla de Word no contiene componentes de almacenamiento de macros hasta que almacena una macro en el archivo. Estos componentes existen como estructuras de soporte para la existencia y almacenamiento de macros en un archivo. Cuando elimina todas las macros de un archivo, los componentes de almacenamiento de macros no desaparecen. La característica de advertencia de virus de macro de Microsoft Word 2002 detecta los componentes de almacenamiento de macros en el archivo y presenta la advertencia de virus de macro cuando abre el archivo.

Para eliminar macros de un documento de Word, siga estos pasos:
  1. Abra el archivo en Word.
  2. En el menú Herramientas, seleccione Macro y haga clic en Macros.
  3. En el cuadro de diálogo Macros seleccione un nombre de macro y, a continuación, haga clic en Eliminar. Esto eliminará la macro del archivo.
  4. Repita el paso 3 con cada macro que desee eliminar.

Propiedades

Id. de artículo: 290960 - Última revisión: jueves, 10 de abril de 2003 - Versión: 1.0
La información de este artículo se refiere a:
  • Microsoft Word 2002 Standard Edition
Palabras clave: 
kbbug kbdta kbpending KB290960

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com