Descrição do modo de segurança do Office para o Word 2002

Traduções de Artigos Traduções de Artigos
Fechar Fechar
Artigo: 291013 - Ver produtos para os quais este artigo se aplica.
Este artigo poderá conter hiperligações para conteúdo em inglês (ainda não traduzido).

Para obter uma versão deste artigo referente ao Microsoft Office Word 2003, consulte 827706.
Expandir tudo | Reduzir tudo

Sumário

O modo de segurança do Microsoft Office permite utilizar o Microsoft Word com segurança depois de este programa ter encontrado determinados problemas de arranque. Quando um problema é detectado no arranque, a funcionalidade Modo de segurança automático do Word corrige o problema ou isola (desactiva) o mesmo, permitindo que o Word seja iniciado com êxito. Também é possível iniciar manualmente o Word no Modo de segurança iniciado pelo utilizador utilizando o parâmetro /safe.

Mais Informação


Modo de segurança automático

Durante o arranque, o Word verifica a existência de problemas como, por exemplo, um suplemento que não é iniciado ou um recurso, ficheiro, chave de registo ou modelo danificado. Se o Word encontrar um problema da próxima vez que for iniciado, será apresentada uma mensagem que identifica o problema e pergunta ao utilizador se pretende desactivar o componente do programa que tem um problema. As mensagens de erro são semelhantes às seguintes:
O Word detectou um problema relacionado com algumas das actuais preferências. Deseja restaurar os valores predefinidos destas preferências?
-ou-
O Word detectou um problema com Normal.Dot existente. Deseja criar um novo Normal.Dot?
As opções do modo de segurança do Office variam consoante a causa do erro. Seguem-se algumas das possíveis soluções temporárias:
  • Desactivar suplementos, modelos ou documentos colocando-os na lista Itens desactivados.

    - ou -
  • Repor as predefinições de chaves de registo e/ou do Normal.dot.
Se receber uma mensagem de erro a indicar que o problema foi causado por um suplemento ou ficheiro, pode optar por desactivar a funcionalidade clicando em Sim. A mensagem de erro será semelhante à seguinte:
O Word determinou que ocorreu um problema recente ao utilizar o "descrição_do_ficheiro".

Deseja desactivar este "descrição_do_ficheiro"?
em que descrição_do_ficheiro é o suplemento ou ficheiro que causou o problema.

Poderá visualizar uma lista de itens desactivados na caixa de diálogo Itens desactivados (clique em Acerca do Microsoft Word no menu Ajuda). Nesta caixa de diálogo é possível activar itens desactivados. Ao activar alguns itens, poderá necessitar de carregar ou instalar novamente um suplemento ou abrir novamente um ficheiro. A activação de um item não corrige necessariamente o problema raiz; um item activado poderá ser colocado novamente na lista Itens desactivados da próxima vez que iniciar o programa.

Se um suplemento ou ficheiro for adicionado à lista Itens desactivados, da próxima vez que tentar aceder ao item, será apresentada uma mensagem de erro semelhante à seguinte:
O documento "descrição_do_ficheiro" deu origem a um grave erro da última vez que foi aberto. Deseja continuar a abri-lo?
Pode optar por continuar ou não. Se continuar, o item poderá voltar a causar um problema.

Para activar itens que foram desactivados pelo modo de segurança do Office, siga estes passos.

Nota: a activação de um item desactivado pode fazer com que o problema ocorra novamente quando reiniciar o Microsoft Word ou quando tentar utilizar o item (por exemplo, abre um documento que foi desactivado).
  1. No menu Ajuda, clique em Acerca do Microsoft Word.
  2. Clique em Itens desactivados.
  3. Seleccione os itens que pretende activar.
  4. Clique em Activar.
Se o nome do ficheiro Normal.dot tiver sido alterado durante o modo de segurança do Office, o nome do ficheiro será Normal.bak. Se o ficheiro Normal.dot cujo nome foi alterado durante o modo de segurança do Office contiver personalizações como estilos, macros ou entradas de texto automático que não possam ser facilmente recriadas, poderá conseguir copiar estas personalizações do ficheiro Normal.bak para o novo ficheiro Normal.dot utilizando o Organizador.

Para obter mais informações sobre como utilizar o Organizador, clique em Ajuda do Microsoft Word no menu Ajuda, escreva organizador no Assistente do Office ou no Assistente de respostas e clique em Procurar para visualizar os tópicos devolvidos.


Modo de segurança iniciado pelo utilizador

Quando inicia o Microsoft Word no modo de segurança do Office "iniciado pelo utilizador", são aplicadas as seguintes restrições:
  • Não é possível guardar modelos.
  • O Assistente do Office não é apresentado automaticamente.
  • Não são carregadas nem podem ser guardadas personalizações de barras de comandos ou de barras de ferramentas.
  • A lista de correcção automática não é carregada e as alterações não são guardadas.
  • Os documentos recuperados não são abertos automaticamente.
  • As etiquetas inteligentes não são carregadas e não é possível guardar novas etiquetas.
  • Todas as opções da linha de comandos são ignoradas excepto "/a" e "/n".
  • Não é possível guardar preferências do utilizador (no menu Ferramentas, clique em Opções).
  • Funcionalidades e programas (suplementos) adicionais não serão carregados automaticamente.
É possível abrir o Microsoft Word no modo de segurança do Office premindo CTRL enquanto inicia o programa ou utilizando a opção /safe quando inicia o programa a partir da linha de comandos. Para iniciar o Microsoft Word no modo de segurança utilizando a opção /safe, siga estes passos:
  1. No menu Iniciar do Windows, clique em Executar.
  2. Na caixa de diálogo Executar, efectue um dos seguintes procedimentos:
    • Na caixa Abrir, escreva Winword.exe /safe.

      - ou -
    • Aponte para o ficheiro Winword.exe e adicione o parâmetro /safe ao caminho. Para tal, siga estes passos:
      1. Clique em Procurar.
      2. Na caixa de diálogo Procurar, altere a caixa Procurar em para a pasta que contém o ficheiro Winword.exe. Por predefinição, o ficheiro Winword.exe está localizado na seguinte pasta:
        C:\Programas\Microsoft Office\Office10\
      3. Seleccione o ficheiro Winword.exe e clique em Abrir.
      4. Na caixa de diálogo Executar, clique na caixa Abrir e mova o ponto de inserção para o fim da instrução de caminho. Depois das aspas de fecho, introduza um espaço e escreva /safe. A instrução de caminho na caixa Abrir deverá ser semelhante ao exemplo que se segue:
        "C:\Programas\Microsoft Office\Office10\Winword.exe" /safe
  3. Clique em OK para iniciar o Microsoft Word no modo de segurança.

Propriedades

Artigo: 291013 - Última revisão: 30 de novembro de 2004 - Revisão: 1.2
A informação contida neste artigo aplica-se a:
  • Microsoft Word 2002 Standard Edition
Palavras-chave: 
kbsafemod kbstartprogram kbhowto KB291013

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com