XL2002: 손상된 통합 문서에서 데이터를 복구하는 방법

기술 자료 번역 기술 자료 번역
닫기 닫기
기술 자료: 291057 - 이 문서가 적용되는 제품 보기.
이 문서는 이전에 다음 ID로 출판되었음: KR291057
본 문서의 Microsoft Excel 2000 버전에 대한 내용은 179871을 참조하십시오.
본 문서의 Microsoft Excel 98과 이전 버전에 대한 내용은 142117을 참조하십시오.
모두 확대 | 모두 축소

이 페이지에서

요약

손상된 파일에서 정보를 복구하기 위해 사용할 수 있는 몇 가지 방법이 있습니다. 본 문서에서는 그러한 방법들을 설명하고 그 방법들에 대한 자세한 내용이 나와 있는 Microsoft 기술 자료 문서를 알려줍니다.

손상된 Microsoft Excel 파일에서 데이터를 복구하는 방법

  • 문서의 복구된 복사본을 사용합니다.
  • 열기 및 복구 명령을 사용합니다.
  • 파일을 HTML(Hypertext Markup Language) 형식으로 저장합니다.
  • 손상된 파일에 연결된 외부 참조를 사용합니다.
  • 파일을 열 수 있으면 파일을 SYLK 형식으로 저장합니다.
  • 저장된 문서로 되돌리기 명령을 사용합니다.
  • 손상된 파일에 차트가 연결되어 있으면 매크로를 사용하여 데이터를 추출합니다.
  • Microsoft Excel 파일 복구 매크로를 사용합니다.
  • 파일을 Microsoft Word에서 엽니다.
  • 파일을 Microsoft Excel Viewer에서 엽니다.

추가 정보

문서의 복구된 복사본 사용

통합 문서에서 작업하는 동안 Microsoft Excel이 응답하지 않으면 Microsoft Office 응용 프로그램 복구 관리자 프로그램을 사용하여 Excel과 통합 문서를 복구하십시오. 이렇게 하려면 다음과 같이 하십시오.
  1. 시작을 누르고 프로그램, Microsoft Office 도구를 차례로 가리킨 다음 Microsoft Office 응용 프로그램 복구 관리자를 누릅니다.
  2. 응용 프로그램 목록에서 Microsoft Excel을 누른 다음 응용 프로그램 복구를 누릅니다.

    참고: 응용 프로그램 종료를 누르면 통합 문서의 최근 변경 내용이 손실됩니다.
  3. Excel을 엽니다.

    문서 복구 작업 창에 나와 있는 파일 목록에 복구된 통합 문서가 포함되어 있습니다.
  4. 통합 문서를 열거나 저장하려면 작업 창에서 통합 문서 옆에 있는 화살표를 누릅니다.
Excel 자동 복구 기능에 대한 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
289273 XL2002: 자동 복구 기능의 개요

"열기 및 복구" 명령 사용

  1. Excel을 시작합니다. 파일 메뉴에서 열기를 누릅니다.
  2. 열기 대화 상자에서 열 파일을 선택합니다. 열기 단추에 있는 화살표를 누른 다음 열기 및 복구를 누릅니다.
  3. 최근 변경 내용을 복구할 것인지 묻는 메시지가 나타나면 복구를 누릅니다.

    참고: Excel에서 통합 문서를 복구할 수 없으면 복구 대신 데이터 추출을 누릅니다.
    1. 통합 문서에 수식이 포함되어 있으면 Excel에서 값으로 변환 또는 수식 복구 중 하나를 선택하라는 메시지가 나타납니다.
    2. 다음 메시지가 나타나면 를 누릅니다.
      file name 문서를 마지막으로 열었을 때 심각한 오류가 발생하였습니다. 이 문서를 계속 여시겠습니까?
      이 오류 메시지에 대한 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
      286017 OFFXP: Error Message: The Document Caused a Serious Error the Last Time It Was Opened
  4. 복구한 통합 문서를 저장합니다.

파일을 HTML(Hypertext Markup Language) 형식으로 저장

손상된 Microsoft Excel 파일을 열 수 있으면 파일을 HTML 형식으로 저장한 후 닫았다가 다시 열어 파일을 "필터링"할 수 있습니다. 이렇게 하려면 다음과 같이 하십시오.
  1. 파일 메뉴에서 웹 페이지로 저장을 누릅니다.
  2. 저장에서 전체 통합 문서를 누른 다음 저장을 누릅니다.
  3. 파일을 닫습니다.
  4. 파일을 Excel에서 다시 엽니다.
  5. 파일 메뉴에서 다름 이름으로 저장을 누릅니다. 파일 형식 목록에서 Microsoft Excel 통합 문서를 누릅니다. 파일 이름을 변경하여 원래 파일을 교체하지 않고 새로운 "필터링된" 복사본을 만듭니다.
참고: HTML 형식으로 저장하면 일부 기능이 없어질 수 있습니다. 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
300637 XL2002: Some Workbook Features Not Retained When Saving as a Web Page

외부 참조를 사용하여 데이터 복구

손상된 파일에서 정보를 복구하는 가장 일반적인 방법은 파일에 연결된 외부 참조를 사용하여 파일에서 값을 추출하는 것입니다. 이 방법을 사용하려면 파일 구조가 완전해야 하며 그렇지 않으면 Microsoft Excel이 정보를 읽을 수 없습니다.

파일을 SYLK 형식으로 저장

손상된 Microsoft Excel 파일을 열 수 있으면 파일을 SYLK 형식으로 저장하고, 파일을 닫았다가 다시 열어 파일을 "필터링"할 수 있습니다.

자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
300639 XL2002: Handling Corrupted Excel Files by Saving in the SYLK Format

저장된 문서로 되돌리기 명령을 사용하여 데이터 복구

Microsoft Excel 워크시트를 편집하는 중에 파일의 변경 내용을 저장하지 않았는데 실수로 파일이 손상된 경우 다음과 같이 하면 원래 워크시트를 복구할 수 있습니다.

  1. 파일 메뉴에서 열기를 누르고 편집할 파일의 이름을 선택합니다. 대화 상자가 열리고 "저장된 문서로 되돌리시겠습니까?"라고 묻는 메시지가 나타납니다.
  2. 확인을 누릅니다.

    편집 중인 파일이 마지막으로 저장된 버전으로 되돌려집니다.

매크로를 사용하여 차트의 데이터 추출

Microsoft Excel 버전 5.0 이상에서는 데이터가 외부 워크시트나 통합 문서에 있는 경우에도 차트에서 데이터를 가져올 수 있습니다. 사용할 수 없는 상태거나 어떤 식으로든 손상된 다른 파일로부터 만들어진 차트 또는 그러한 파일에 연결된 차트가 있는 경우 이 동작은 매우 유용할 수 있습니다.

차트에 연결된 원본 데이터가 손실된 경우에도 Visual Basic for Applications(VBA) 매크로를 사용하여 차트 자체에서 데이터를 가져올 수 있습니다.

자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
300643 XL2002: Macro to Extract Data from a Chart

Microsoft Excel 파일 복구 매크로를 사용하여 정보 복구

통합 문서를 Microsoft Excel에서 열 수 있으면 Microsoft Excel 파일 복구 매크로를 사용하여 Excel 워크시트, XLM 매크로 시트 및 모듈 시트를 새 통합 문서에서 다시 만들 수 있습니다. 또한, 이 매크로를 사용하여 항목을 새 통합 문서로 전송할 때 문제를 일으키는 항목을 확인할 수 있도록 이 매크로는 로그 파일을 생성합니다. Microsoft Excel 파일 복구 매크로가 실패할 경우 로그 파일에서 마지막 항목을 보고 문제를 일으킨 항목을 확인한 다음 그 항목 없이 통합 문서를 다시 만들 수 있습니다.

참고: 통합 문서에서 VBA 구성 요소를 다시 만들려면 이 매크로를 실행하기 전에 Visual Basic 프로젝트에 안전하게 액세스할 수 있음 확인란을 선택하십시오. 도구 메뉴에서 매크로를 가리키고 보안을 누른 다음 신뢰할 수 없는 원본 탭을 눌러 선택합니다.

이 매크로에 대한 정보를 보거나 다운로드하려면 아래 Microsoft 웹 사이트에 있는 Office Resource Kit을 방문하십시오..
http://www.microsoft.com/korea/office/ork/

파일을 Microsoft Word 또는 워드패드에서 열기

Microsoft Excel 변환기가 설치되어 있으면 Microsoft Excel 통합 문서를 Microsoft Word에서 열 수도 있습니다. 파일을 Microsoft Word에서 여는 경우에는 모듈 시트, 대화 상자 시트, 차트 시트, 매크로 시트 또는 포함된 차트를 복구할 수 없습니다. 또한, 셀 수식은 복구할 수 없고 현재 셀에 있는 수식의 결과만 복구됩니다.

Microsoft Excel 통합 문서를 워드패드에서 열 수도 있습니다. 파일이 열리면 모듈과 클래스 모듈에 있는 Visual Basic 코드를 복구할 수도 있습니다. "Sub" 또는 "Function"이라는 단어를 검색하여 코드를 찾습니다.

파일을 Microsoft Excel Viewer에서 열기

Microsoft Excel Viewer가 설치되어 있으면 Microsoft Excel 통합 문서를 Microsoft Excel Viewer에서 열고, 셀을 복사한 다음 해당 셀을 새 통합 문서에 붙여 넣습니다. 그러나 모듈 시트, 차트 시트 또는 매크로 시트는 복구할 수 없습니다. 또한 셀 수식은 복구할 수 없고 현재 셀에 있는 수식의 결과만 복구됩니다.

Microsoft Excel Viewer에 대한 자세한 내용을 보려면 다음 Microsoft 웹 사이트를 방문하십시오.
http://office.microsoft.com/downloads/2000/xlviewer.aspx



Microsoft 제품 관련 기술 전문가들과 온라인으로 정보를 교환하시려면 Microsoft 뉴스 그룹에 참여하시기 바랍니다.

속성

기술 자료: 291057 - 마지막 검토: 2006년 9월 8일 금요일 - 수정: 2.0
본 문서의 정보는 다음의 제품에 적용됩니다.
  • Microsoft Excel 2002 Standard Edition
키워드:?
kbhowto kbdownload kbdta KB291057

피드백 보내기

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com