MSDSS Migration of Users from NDS Does Not Finish Successfully

Article translations Article translations
Article ID: 291134
This article was previously published under Q291134
Notice
This article contains a reference to the MDSS utility, which is a utility that Microsoft Support provides as-is and does not support. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of the MDSS utility.
Expand all | Collapse all

Symptoms

When you use Microsoft Directory Synchronization Services (MSDSS) to migrate users from Novel Directory Services (NDS) to Active Directory, the migration may not finish successfully and you may receive an error message that is similar to:
MSDSS did not initialize the reverse synchronization or migration session - not enough storage is available.
When this occurs, event IDs 0 and 60 are recorded in the event log by MSDSS, indicating error 0x8007000e ("Not Enough Storage").

Cause

This problem is caused by a logic error in the Ndsread.dll dynamic-link library (DLL).

Resolution

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this fix should have the following file attributes or later:
   Date        Time     Version        Size    File name
   -------------------------------------------------------
   4/17/2001  12:01p	5.0.2195.3512  40,208	Ndsread.dll 

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

More information

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the article number below to view the article in the Microsoft Knowledge Base:
265173 The Datacenter Program and Windows 2000 Datacenter Server Product
For additional information about how to install multiple hotfixes with only one reboot, click the article number below to view the article in the Microsoft Knowledge Base:
296861 Use QChain.exe to Install Multiple Hotfixes with One Reboot
For additional information about how to install Windows 2000 and Windows 2000 hotfixes at the same time, click the article number below to view the article in the Microsoft Knowledge Base:
249149 Installing Microsoft Windows 2000 and Windows 2000 Hotfixes

Properties

Article ID: 291134 - Last Review: August 8, 2012 - Revision: 4.0
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbbug kbfix kbwin2000presp3fix KB291134

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com