OL2002: 如何更改为的所有联系人字段的文件

文章翻译 文章翻译
文章编号: 291144 - 查看本文应用于的产品
展开全部 | 关闭全部

本文内容

概要

本文介绍如何使用自定义 Outlook 窗体和 Visual Basic 脚本版 (VBScript) 来以编程方式更改为大量现有联系人的 表示为 字段。

更多信息

要点: 如果使用标准的 Outlook 联系人窗体更改 表示为 字段的格式确保了 Outlook,此字段的格式不会影响其他区域,这种类型的信息的显示位置 (如当在地址卡视图中查看联系人的顶部)。但是,此示例只是对 表示为 字段本身进行更改,因此不会执行相同的功能为 Outlook 联系人窗体。Microsoft 建议您制作您的联系人文件夹的副本,然后使用以确保使用此示例的好处超过这种方法的任何潜在的缺陷所复制的文件夹上的下面的示例代码。

: 当您更改 表示为 字段时,联系人在 Outlook 通讯簿中的显示的顺序不受影响。

Microsoft 提供的编程示例只,用于说明不附带任何明示或暗示保证,其中包括但不是限于对适销性和/或针对特定用途的适用性的暗示的担保。本文假定您熟悉所演示的编程语言和工具用于创建和调试过程。Microsoft 支持专业人员可以帮助解释某个特定过程的功能,但他们不会修改这些示例以提供额外的功能或构建过程来满足您特定需要。
如果有限编程体验您可能需要联系 Microsoft 认证合作伙伴或 Microsoft 咨询服务。有关更多的信息请访问以下 Microsoft 网站:

Microsoft 认证合作伙伴-https://partner.microsoft.com/global/30000104

Microsoft 咨询服务-http://support.microsoft.com/gp/advisoryservice

有关可用的支持选项和有关如何与 Microsoft 联系的详细信息,请访问下面的 Microsoft 网站: http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS您在创建新的自定义 Outlook 窗体时您可以更改所有联系人的 表示为 字段为以下格式:
  • 第一个最后
  • 最后一个名字
  • 公司
  • 上第一个 (公司) 的一,次
  • 公司 (最后,第一个)

如何设计自定义窗体

  1. 文件 菜单上指向 新建,然后单击以打开一个新的电子邮件的 邮件
  2. 在在新的电子邮件的 工具 菜单上指向 窗体,然后单击 设计该窗体
  3. 插入新的窗体上的五个命令按钮。若要此操作:
    1. 单击转到一个空白页窗体上的 (P.2) 选项卡。
    2. 窗体 菜单上单击 控件工具箱 并单击 命令按钮,然后将按钮拖动到空白窗体页。
    3. 用鼠标右键单击新按钮,单击 属性,然后键入在 名称 框中的 cmdLastFirst
    4. 标题 框中键入 姓氏名字,然后单击 确定
    5. 工具箱 对话框中单击 命令按钮,然后拖动到空白窗体页的第二个按钮。
    6. 用鼠标右键单击新按钮,单击 属性,然后键入在 名称 框中的 cmdFirstLast
    7. 标题 框中键入 ,然后单击 确定
    8. 工具箱 对话框中单击 命令按钮,然后将第三个按钮拖至空白窗体页。
    9. 用鼠标右键单击新按钮,单击 属性,然后键入在 名称 框中的 cmdCompany
    10. 标题 框中键入 公司,然后单击 确定
    11. 工具箱 对话框中单击 命令按钮,然后将第四个按钮拖至空白窗体页。
    12. 用鼠标右键单击新按钮,单击 属性,然后键入在 名称 框中的 cmdLastFirstCompany
    13. 标题 框中键入 最后一首 (公司),然后单击 确定
    14. 工具箱 对话框中单击 命令按钮,然后将一个第五个按钮拖至空白窗体页。
    15. 用鼠标右键单击新按钮,单击 属性,然后键入在 名称 框中的 cmdCompanyLastFirst
    16. 标题 框中键入 公司 (最后,第一个),然后单击 确定
  4. 键入下面的 Visual Basic 脚本版 (VBScript) 代码。若要此操作:
    1. 窗体 菜单上单击 查看代码 以打开脚本编辑器。
    2. 在脚本编辑器中键入或复制下面的代码:
      Option Explicit
      Dim strSortBy
      
      Sub cmdLastFirst_Click()
         strSortBy = "LastFirst"
         UpdateContacts
      End Sub
      
      Sub cmdFirstLast_Click()
         strSortBy = "FirstLast"
         UpdateContacts
      End Sub
      
      Sub cmdCompany_Click()
         strSortBy = "Company"
         UpdateContacts
      End Sub
      
      Sub cmdLastFirstCompany_Click()
         strSortBy = "Last, First (Company)"
         UpdateContacts
      End Sub
      
      Sub cmdCompanyLastFirst_Click()
         strSortBy = "Company (Last, First)"
         UpdateContacts
      End Sub
      
      Sub UpdateContacts()
      
         Dim CurFolder
         Dim MyItems
         Dim MyItem
         Dim NumItems, i
      
         ' Use whichever folder is currently selected
         Set CurFolder = Application.ActiveExplorer.CurrentFolder
      
         ' Make sure it's a contact folder
         If CurFolder.DefaultItemType = 2 Then
            MsgBox "This process may take some time. You will be " & _
            "notified when complete.", , "Contact Tools Message"
            Set MyItems = CurFolder.Items
            NumItems = MyItems.Count
            For i = 1 to NumItems
               Set MyItem = MyItems.Item(i)
               ' Make sure it's not a distribution list in the folder
               ' (really only applies to OL98 and OL2000)
               If TypeName(MyItem) = "ContactItem" Then
                  Select Case strSortBy
                     Case "LastFirst"
                        If MyItem.LastNameandFirstName <> "" Then
                           MyItem.FileAs = MyItem.LastNameandFirstName
                        Else
                           MyItem.FileAs = MyItem.CompanyName
                        End IF
                     Case "FirstLast"
                        If MyItem.Subject <> "" Then
                           MyItem.FileAs = MyItem.Subject
                        Else
                           MyItem.FileAs = MyItem.CompanyName
                        End IF
                     Case "Company"
                        If MyItem.CompanyName <> "" Then
                           MyItem.FileAs = MyItem.CompanyName
                        Else
                           MyItem.FileAs = MyItem.LastNameandFirstName
                        End IF
                     Case "Last, First (Company)"
                        MyItem.FileAs = MyItem.LastNameAndFirstName
                        If MyItem.CompanyName <> "" Then
                           If MyItem.FileAs <> "" Then
                              MyItem.FileAs = MyItem.FileAs & " (" & _
                                              MyItem.CompanyName & ")"
                           Else
                              MyItem.FileAs = MyItem.FileAs & _
                                        MyItem.CompanyName
                           End If
                        End If
                     Case "Company (Last, First)"
                        MyItem.FileAs = MyItem.CompanyName
                        If MyItem.LastNameandFirstName <> "" Then
                           If MyItem.FileAs <> "" Then
                              MyItem.FileAs = MyItem.FileAs & " (" & _
                                     MyItem.LastNameAndFirstName & ")"
                           Else
                              MyItem.FileAs = MyItem.FileAs & _
                                     MyItem.LastNameAndFirstName
                           End If
                        End If
                  End Select
                  MyItem.Save
               End If           ' check TypeName
            Next
            MsgBox "Finished updating contacts."
         Else
            MsgBox "The current folder must be a contacts folder."
         End If                 ' check contacts folder
      
         Set MyItem = Nothing
         Set MyItems = Nothing
         Set CurFolder = Nothing
      
      End Sub
      						
    3. 文件 菜单在脚本编辑器中,单击 关闭 返回到窗体。
    4. 单击窗体的 邮件 页面。
    5. 窗体 菜单上单击 显示此页。此操作会隐藏窗体页,以便它不出现时使用该窗体。
  5. 将窗体发布。若要此操作:
    1. 工具 菜单上指向 窗体,然后单击 将窗体发布为
    2. 验证 查找范围中的 按钮旁边您会看到 个人窗体库
    3. 显示名称 框中键入的新窗体 (如,更改表示为字段),discriptive 名称,然后单击 发布
    4. 当系统提示您保存窗体定义与项目时,单击
    5. 不进行保存就关闭邮件。

如何使用自定义窗体

要使用新窗体,请执行以下操作:
  1. 找到您要 re-sequence 联系人文件夹。
  2. 文件 菜单上指向 新建,然后单击 选择窗体
  3. 在查找范围 框更改为 个人窗体库 并单击您新的窗体然后单击 确定
  4. 单击相应的按钮来更新 表示为 字段。

参考

有关可用资源和 $ answersto 有关 Microsoft Outlook 解决方案的常见问题的其他信息请单击下面文章编号,以查看 Microsoft 知识库中相应的文章:
287530OL2002: 有关自定义窗体和 Outlook 解决方案的问题

属性

文章编号: 291144 - 最后修改: 2006年11月23日 - 修订: 2.4
这篇文章中的信息适用于:
  • Microsoft Outlook 2002 标准版
关键字:?
kbmt kbhowto KB291144 KbMtzh
机器翻译
注意:这篇文章是由无人工介入的微软自动的机器翻译软件翻译完成。微软很高兴能同时提供给您由人工翻译的和由机器翻译的文章, 以使您能使用您的语言访问所有的知识库文章。然而由机器翻译的文章并不总是完美的。它可能存在词汇,语法或文法的问题,就像是一个外国人在说中文时总是可能犯这样的错误。虽然我们经常升级机器翻译软件以提高翻译质量,但是我们不保证机器翻译的正确度,也不对由于内容的误译或者客户对它的错误使用所引起的任何直接的, 或间接的可能的问题负责。
点击这里察看该文章的英文版: 291144
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。

提供反馈

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com