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Records newly inserted into Access database are not immediately available when reselecting in Microsoft Access

Article ID:291238
Last Review:July 28, 2006
Revision:5.2
This article was previously published under Q291238
Advanced: Requires expert coding, interoperability, and multiuser skills.

This article applies only to a Microsoft Access database (.mdb).

For a Microsoft Access 2000 version of this article, see 245676 (http://support.microsoft.com/kb/245676/EN-US/).
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SYMPTOMS

When inserting records into a Microsoft Access database, immediately attempting to reselect them occasionally does not return all inserted records. This occurs even when the records are inserted and reselected on the same connection.

The problem described in this article affects the Microsoft Jet database engine's ability to locate data stored in the connection's cache. Jet examines changes stored in the connection's cache when it processes a query. Because of this problem, running a query on that same connection may not retrieve all of the newly inserted data that satisfy the query's search criteria immediately after adding new rows to your database.

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Important Information:

To increase performance, Jet stores modifications in its cache before writing the changes to the file. As a result, modifications currently stored in the connection's cache are visible only on that connection. Other connections are unable to see these changes until Jet flushes them to the database. NOTE: This behavior is normal and is not related to the problem described in this article.

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CAUSE

Internal to Jet, the Seek methods used to locate the inserted records are occasionally accessing uninitialized memory and picking up incorrect values. Based on these incorrect values, the attempt to locate the appropriate record fails.

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RESOLUTION

To resolve this problem, install the the latest Microsoft Jet 4.0 service pack. To download the latest Microsoft Jet 4.0 service pack, see the following article in the Microsoft Knowledge Base:
239114 (http://support.microsoft.com/kb/239114/) How To: Obtain the Latest Service Pack for the Microsoft Jet 4.0 Database Engine

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Jet 4.0 Service Pack 5 (SP5).

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APPLIES TO
Microsoft Office Access 2003
Microsoft Access 2002 Standard Edition
Microsoft Data Access Components 2.1 Service Pack 2
Microsoft Data Access Components 2.1 Service Pack 1

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Keywords: 
kbbug kbfix kbmdac210sp2fix kbaccess97fix kbaccess900fix KB291238

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