Työkalurivit puuttuvat, valikkorivi puuttuu tai mukautettuja asetuksia ei säilytetä, kun Word käynnistetään

Artikkeleiden käännökset Artikkeleiden käännökset
Artikkelin tunnus: 291484 - Näytä tuotteet, joita tämä artikkeli koskee.
Tämä artikkeli on aiemmin julkaistu tunnuksella FI291484
Tämä artikkeli on mukautettu seuraavasta aiemmin saatavana olleesta artikkelista: 242368

Tärkeää Tässä artikkelissa käsitellään rekisterin muokkaamista. Muista varmuuskopioida rekisteri ennen sen muokkaamista. Varmista myös, että osaat palauttaa rekisterin ongelmatilanteessa. Lisätietoja rekisterin varmuuskopioimisesta, palauttamisesta ja muokkaamisesta saat napsauttamalla seuraavaa artikkelin numeroa, jolloin pääset lukemaan artikkelin Microsoft Knowledge Base -tietokannassa:
256986 Microsoft Windowsin rekisterin kuvaus
Laajenna kaikki | Kutista kaikki

Tällä sivulla

Oire

Kun käynnistät Microsoft Wordin, saatat kohdata jonkin seuraavista ongelmista:
  • Työkalurivit puuttuvat.
  • Valikkorivi puuttuu.
  • Mukautettuja asetuksia ei säilytetä.

Workaround

Palauta työkalurivit, valikot tai mukautetut asetukset tilanteen mukaan jollakin seuraavista tavoista.

Poista koko näytön tila käytöstä

Koko näytön tila näyttää asiakirjasta mahdollisimman suuren osan näytössä. Tässä tilassa Word poistaa näyttöelementit, kuten valikkorivin, työkalurivit ja vierityspalkit. Voit palauttaa työkalurivit ja valikot poistamalla koko näytön tilan käytöstä.
  • Jos asiakirja on avoinna, tee jompikumpi seuraavista:
    • Tuo Näytä-valikko näkyviin painamalla ALT+N ja poista koko näytön tila käytöstä painamalla Ä.
    • Jos Koko näyttö -työkalurivi on näkyvissä, valitse Sulje koko näyttö.
  • Jos asiakirja ei ole avoinna, toimi seuraavasti:
    1. Avaa uusi asiakirja painamalla CTRL+N.
    2. Tuo Näytä-valikko näkyviin painamalla ALT+N ja poista koko näytön tila käytöstä painamalla Ä.
Lopeta Word ja käynnistä se uudelleen. Jos Word käynnistyy oikein, ongelma on korjaantunut. Ongelma oli se, että Word suljettiin koko näytön tilan ollessa käytössä, jolloin Word tallensi kyseisen asetuksen.

Saat lisätietoja koko näytön tilasta napsauttamalla seuraavaa artikkelin numeroa, jolloin pääset lukemaan artikkelin Microsoft Knowledge Base -tietokannassa:
290947 Valikot sekä työkalurivit katoavat ja tilarivillä näkyy teksti "Toistoarvo: 8" (tämä artikkeli saattaa olla englanninkielinen)

Oletustyökalurivien ottaminen käyttöön

Valitse Näytä-valikosta Työkalurivit. Tarkista, onko työkalurivejä valittu. Jos työkalurivejä ei ole valittu, valitse haluamasi työkalurivit. Voit tehdä tämän napsauttamalla haluamasi työkalurivin nimeä. Toista tämä jokaisen haluamasi työkalurivin osalta. Oletusarvoisesti valitut työkalurivit ovat Vakio- ja Muotoilu-työkalurivit ja Tehtäväruutu.

Huomautus Jos et näe valikkoriviä, tuo Näytä-valikko näkyviin painamalla ALT+N ja tuo Työkalurivi-valikko näkyviin painamalla T-näppäintä.

Lopeta Word ja käynnistä se uudelleen. Jos Word käynnistyy oikein, ongelma on korjaantunut. Ongelma oli se, että oletustyökalurivit ja valikkorivi oli poistettu käytöstä, kun Word suljettiin, jolloin Word tallensi kyseiset asetukset.


Käynnistä Word niin, ettei makroja suoriteta

Tarkista, käynnistyykö Wordin käynnistyksen yhteydessä jokin Microsoft Visual Basic for Applications (VBA) -makro. Saatat käyttää VBA-makroa, joka käynnistää Wordin näyttämättä valikoita tai työkalurivejä.

Jos käynnistät Wordin pikakuvakkeen avulla, tarkista, onko pikakuvakkeen käyttämässä komentorivissä makroja. Voit tehdä tämän seuraavasti:
  1. Etsi pikakuvake, jolla käynnistät Wordin.
  2. Napsauta pikakuvaketta hiiren kakkospainikkeella ja valitse pikavalikosta Ominaisuudet.
  3. Valitse Pikakuvake-välilehti.
  4. Etsi Kohde-ruudusta seuraavankaltaista komentoriviä:
    "C:\Program Files\Microsoft Office\Office10\WINWORD.EXE" /mmakron nimi
    , jossa /mmakron nimi on makron nimi.

  5. Jos komentorivillä on teksti /m makron nimi, poista kyseinen teksti ja käynnistä Word tavalliseen tapaan.

    Huomautus Valitsin /m, jonka perässä on makron nimi, suorittaa määritetyn makron Wordin käynnistyksen yhteydessä. Valitsin /m myös estää Wordia suorittamasta AutoExec-makroja.
Jos Word käynnistyy oikein, ongelma on korjaantunut. Ongelma oli se, että Wordin käynnistyksen yhteydessä suoritetaan makro, joka muuttaa Word-ikkunan ulkoasun.

Saat lisätietoja Wordin käynnistämisessä käytettävistä komentorivivalitsimista napsauttamalla seuraavaa artikkelin numeroa, jolloin pääset lukemaan artikkelin Microsoft Knowledge Base -tietokannassa:
210565 WD: Wordin käynnistysvalitsimet (komentorivillä) ja niiden käyttämisen vaikutus (tämä artikkeli saattaa olla englanninkielinen)

Jokin ohjelma (kuten Wordin laajennus) on muokannut käyttöliittymää ja piilottanut työkalurivit tai muuttanut asetuksia

Vaihe 1: Käynnistä Word käyttäen oletusasetuksia

Kun Word käynnistetään käyttämällä komentorivivalitsinta /a, se käyttää kaikkia oletusasetuksia ja estää laajennuksien ja yleisten mallien lataamisen.

Valitsimen /a avulla voit käynnistää Wordin niin, että seuraavia osia ei ladata:
  • yleinen malli (Normal.dot)
  • Käynnistys-kansiossa olevat laajennusmallit
  • laajennuskirjastot (.wll-tiedostot)
  • Windowsin rekisterin Data-avaimeen tallennetut käyttäjän asetukset.
Huomautus Kun käynnistät Wordin käyttäen valitsinta /a, Wordin näihin osiin tekemiäsi muutoksia ei tallenneta kiintolevylle, kun suljet Wordin, vaan ne menetetään.

Seuraavassa esimerkissä oletetaan, että Word sijaitsee seuraavassa kansiossa:
C:\Program Files\Microsoft Office\Office10
Huomautus Word saattaa olla asennettuna eri kansioon tietokoneessasi.

Voit käynnistää Wordin käyttäen valitsinta /a seuraavasti:
  1. Napsauta Käynnistä-painiketta, valitse Suorita ja valitse sitten Selaa.
  2. Etsi Kohde-ruudun avulla Winword.exe-tiedosto ja valitse se.
  3. Valitse Avaa.

    Huomautus Tämä vaihe tuo tiedot Suorita-valintaikkunan Avaa-ruutuun.
  4. Napsauta Avaa-ruutua Winword.exe-nimen jälkeisessä kohdassa.

    Huomautus Winword.exe-tiedoston polun ympärillä Suorita-valintaikkunassa on lainausmerkit. Varmista, että napsautat kohtaa oikeanpuoleisen lainausmerkin jälkeen.
  5. Kirjoita välilyönti ja kirjoita sitten /a.

    Avaa-ruudussa pitäisi nyt näkyä seuraavanlainen teksti:
    "C:\Program Files\Microsoft Office\Office10\Winword.exe" /a
Jos Word käynnistyy oikein, ongelma on korjaantunut. Ongelma oli se, että laajennus tai malli, Normal-oletusmalli tai rekisterin data-avain vaikuttaa siihen, miten Word-ikkuna avautuu, kun Word käynnistetään.

Vaihe 2: Nimeä yleinen malli uudelleen

Huomautus Lisätietoja tämän vaiheen automaattisesta suorittamistavasta on tämän artikkelin "Lisätietoja"-osassa mainitussa artikkelissa.

Voit estää yleiseen malliin (Normal.dot) tallennettujen muotoilujen, automaattisen tekstin ja makrojen vaikutuksen Wordiin ja avattaviin asiakirjoihin nimeämällä Normal.dot-tiedoston uudelleen.

Huomautus Nimeämällä Normal.dot-mallin uudelleen saat nopeasti selville, aiheutuuko ongelma Normal-mallista. Kun Normal.dot-malli nimetään uudelleen, useat määritykset palautetaan oletusasetuksiksi. Näitä ovat muun muassa mukautetut tyylit, mukautetut työkalurivit, makrot ja automaattiset tekstit. Tästä syystä Microsoft ei suosittele Normal.dot-tiedoston nimeämistä uudelleen.

Tietyissä kokoonpanoissa saatetaan luoda useita Normal.dot-tiedostoja. Näin voi tapahtua muun muassa silloin, kun samassa tietokoneessa on useita Word-versioita tai useita käyttöjärjestelmien asennuksia. Näissä tapauksissa kaikki Normal.dot-tiedostot on nimettävä uudelleen. Nimeä yleinen malli (Normal.dot) uudelleen seuraavasti:
  • Microsoft Windows 98 tai Microsoft Windows NT 4.0
    1. Sulje kaikki Word-esiintymät. Jos käytät Wordia sähköpostieditorina, sulje myös Microsoft Outlook.
    2. Napsauta Käynnistä-painiketta, valitse Etsi ja valitse sitten Tiedostot tai kansiot.
    3. Kirjoita Nimi-ruutuun Normal.dot.
    4. Valitse Kohde-ruudussa paikallinen kiintolevy (tai muu käyttäjän mallien sijainti, jos käytät Wordia verkkopalvelimesta).
    5. Etsi tiedostoa valitsemalla Etsi.
    6. Napsauta jokaista Etsi-valintaikkunassa näkyvää Normal.dot-tiedoston esiintymää hiiren kakkospainikkeella. Valitse pikavalikosta Nimeä uudelleen. Anna tiedostolle uusi nimi, esimerkiksi OldNormal.dot tai Normal-1.dot, ja paina sitten ENTER-näppäintä.
    7. Sulje Etsi-valintaikkuna valitsemalla Tiedosto-valikosta Lopeta ja käynnistä sitten Word uudelleen normaalisti (ilman valitsinta /a).
  • Microsoft Windows Millennium Edition (Me) tai Microsoft Windows 2000
    1. Sulje kaikki Word-esiintymät. Jos käytät Wordia sähköpostieditorina, sulje myös Microsoft Outlook.
    2. Napsauta Käynnistä-painiketta, valitse Etsi ja valitse sitten Tiedostoja tai kansioita.
    3. Kirjoita Etsi tiedostoja tai kansioita nimeltä -ruutuun Normal.dot.
    4. Valitse Kohde-ruudussa paikallinen kiintolevy (tai muu käyttäjän mallien sijainti, jos käytät Wordia verkkopalvelimesta).
    5. Etsi tiedostoa valitsemalla Etsi.
    6. Napsauta jokaista Etsi-valintaikkunassa näkyvää Normal.dot-tiedoston esiintymää hiiren kakkospainikkeella. Valitse pikavalikosta Nimeä uudelleen. Anna tiedostolle uusi nimi, esimerkiksi OldNormal.dot tai Normal-1.dot, ja paina sitten ENTER-näppäintä.
    7. Sulje Etsi-valintaikkuna valitsemalla Tiedosto-valikosta Sulje ja käynnistä sitten Word uudelleen normaalisti (ilman valitsinta /a).
  • Windows XP
    1. Sulje kaikki Word-esiintymät. Jos käytät Wordia sähköpostieditorina, sulje myös Microsoft Outlook.
    2. Napsauta Käynnistä-painiketta ja valitse Etsi.
    3. Valitse Kaikki tiedostot ja kansiot.
    4. Valitse Lisävaihtoehdot ja valitse Etsi piilotiedostoista ja kansioista -valintaruutu.
    5. Kirjoita Tiedostonimi tai nimen osa -ruutuun normal.dot.
    6. Valitse Kohde-ruudussa paikallinen kiintolevy (tai muu käyttäjän mallien sijainti, jos käytät Wordia verkkopalvelimesta).
    7. Käynnistä tiedoston etsintä valitsemalla Etsi.
    8. Napsauta Etsinnän tulokset -valintaikkunan oikeanpuoleisessa ruudussa Normal.dot-tiedostoa hiiren kakkospainikkeella ja valitse näyttöön tulevasta pikavalikosta Nimeä uudelleen. Kirjoita uusi tiedostonimi (esimerkiksi OldNormal.dot) ja paina sitten ENTER-näppäintä.
    9. Sulje Etsinnän tulokset -valintaikkuna ja käynnistä Word uudelleen normaalisti (ilman /a-valitsinta).
Jos Word käynnistyy oikein, ongelma on korjaantunut.

Tässä tapauksessa ongelma aiheutui vioittuneesta Normal.dot-mallista. Jos haluat palauttaa valitsemasi asetukset, saatat joutua muuttamaan joitakin määrityksiä.

Jos uudelleennimetyssä Normal.dot-tiedostossa on mukautuksia, kuten tyylejä, makroja tai automaattista tekstiä, joita ei ole helppo luoda uudelleen, voit ehkä kopioida nämä mukautukset vanhasta Normal.dot-tiedostosta uuteen Normal.dot-tiedostoon arkistoimalla.

Saat lisätietoja arkistoinnin käyttämisestä valitsemalla Ohje-valikosta Microsoft Wordin ohje, kirjoittamalla Office-avustajaan tai vastaustoimintoon arkistointi ja valitsemalla sitten Etsi, jolloin näyttöön tulee aiheeseen liittyviä tietoja.

Windowsin rekisterin Data-avaimen nimeäminen uudelleen

Huomautus Lisätietoja tämän vaiheen automaattisesta suorittamistavasta on tämän artikkelin "Lisätietoja"-osassa mainitussa artikkelissa.

Varoitus Rekisterieditorin virheellinen käyttö saattaa aiheuttaa vakavia ongelmia, joiden vuoksi käyttöjärjestelmä on ehkä asennettava uudelleen. Microsoft ei takaa, että virheellisestä Rekisterieditorin käyttämisestä johtuvat ongelmat voidaan ratkaista. Käytät Rekisterieditoria omalla vastuullasi.
Huomautus Kun Data-avain nimetään uudelleen, useat asetukset palautetaan oletusasetuksiksi, mukaan lukien Tiedosto-valikon viimeksi käytettyjen tiedostojen luettelo sekä useat Työkalut-valikon Asetukset-toiminnolla mukautetut asetukset. Kun Word käynnistetään seuraavan kerran, se luo Data-avaimen uudelleen käyttäen oletusasetuksia.

Nimeä Data-avain uudelleen seuraavasti:
  1. Sulje kaikki käynnissä olevat Windows-ohjelmat.
  2. Napsauta Käynnistä-painiketta, valitse Suorita, kirjoita Avaa-ruutuun regedit ja valitse sitten OK.
  3. Etsi seuraava avain kaksoisnapsauttamalla Word-versiosi mukaisia kansioita:

    Microsoft Office Word 2003:
    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Word\Data
    Microsoft Word 2002:
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Data
    Microsoft Word 2000:
    HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Word\Data
  4. Kun Data-kansio on valittuna, valitse Muokkaa-valikosta Nimeä uudelleen.
  5. Kirjoita Data-kansiolle uusi nimi (esimerkiksi OldData) ja paina sitten ENTER-näppäintä.
  6. Sulje Rekisterieditori ja käynnistä sitten Word normaalisti (ilman valitsinta /a).
Jos Word käynnistyy oikein, ongelma on korjaantunut. Ongelma aiheutui vahingoittuneesta Data-avaimesta. Jos haluat palauttaa haluamasi asetukset, saatat joutua muuttamaan joitakin määrityksiä.


Esikatselumakron luominen

Muuta Wordin esikatselumakroa niin, että haluamasi asetukset näytetään.

Jos esimerkiksi haluat tuoda Muotoilu-työkalurivin näkyviin esikatselussa, toimi seuraavasti:
  1. Valitse Työkalut-valikosta Makro ja valitse sitten Makrot.
  2. Muuta Makrojen lähde -ruudun asetukseksi Word-komennot.
  3. Valitse Makron nimi -luettelosta FilePrintPreview.
  4. Muuta Makrojen lähde -ruudun asetukseksi Normal.dot (Yleinen malli).
  5. Valitse Luo.
  6. Luo seuraava makro:
    Sub FilePrintPreview()
    '
    ' FilePrintPreview-makro
    ' Näyttää koko sivut niin kuin ne näkyvät tulosteessa.
    '
       ActiveDocument.PrintPreview
       CommandBars("Formatting").Visible = True
    End Sub
    					
  7. Valitse Tiedosto-valikosta Sulje ja palaa sovellukseen Microsoft Word.

Enemmän tietoa

Lisätietoja työkalurivien sekä työkalurivien painikkeiden luomisesta ja mukauttamisesta saat napsauttamalla seuraavaa artikkelin numeroa, jolloin pääset lukemaan artikkelin Microsoft Knowledge Base -tietokannassa:
291292 Työkalurivien ja työkalurivien painikkeiden käyttäminen Word 2002:ssa: Lisää, Luo, Muokkaa, Poista, Palauta ja Lisää painikkeita

Suositukset


Saat lisätietoja Word-ongelmien vianmäärityksen automatisoimisesta mahdollisesti vioittuneiden tai Microsoft Wordin kanssa ristiriitoja aiheuttavien pääosien poistamisen avulla, kun napsautat seuraavaa artikkelin numeroa, jolloin pääset lukemaan artikkelin Microsoft Knowledge Base -tietokannassa:
289506 Support.dot-mallin asentaminen ja käyttäminen Microsoft Word 2002:ssa (tämä artikkeli saattaa olla englanninkielinen)

Ominaisuudet

Artikkelin tunnus: 291484 - Viimeisin tarkistus: 22. tammikuuta 2007 - Versio: 5.0
Artikkelin tiedot koskevat seuraavia tuotteita:
  • Microsoft Office Word 2003
  • Microsoft Word 2002 Standard Edition
  • Microsoft Word 2000 Standard Edition
Hakusanat: 
kbsettings kbtoolbar kbmenu kbmacro kbprb KB291484

Anna palautetta

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com