Brak pasków narzędzi, paska menu lub po uruchomieniu programu Word nie są zachowywane ustawienia spersonalizowane

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 291484 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Ten artykuł został opublikowany wcześniej pod numerem PL291484
Ten artykuł jest konsolidacją następującego dostępnego wcześniej artykułu: 242368

Ważne: Ten artykuł zawiera informacje na temat modyfikowania rejestru. Przed zmodyfikowaniem rejestru utwórz jego kopię zapasową i upewnij się, że wiesz, jak przywrócić rejestr w przypadku pojawienia się problemu. Aby uzyskać informacje dotyczące tworzenia kopii zapasowej, przywracania i edytowania rejestru, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
256986 Opis rejestru systemu Microsoft Windows
Rozwiń wszystko | Zwiń wszystko

Na tej stronie

Symptomy

Po uruchomieniu programu Microsoft Word może wystąpić jeden z następujących problemów:
  • Brak pasków narzędzi.
  • Brak paska menu.
  • Ustawienia spersonalizowane nie są zachowywane.

Obejście problemu

Aby przywrócić paski narzędzi, menu lub ustawienia spersonalizowane, użyj jednej z następujących metod odpowiednio do sytuacji.

Wyłącz tryb pełnoekranowy

W trybie pełnoekranowym na ekranie jest wyświetlany dokument w największych możliwych wymiarach. W tym trybie program Word usuwa elementy ekranu, takie jak pasek menu, paski narzędzi i paski przewijania. Aby przywrócić paski narzędzi i menu, wyłącz tryb pełnoekranowy.
  • Jeśli jest otwarty dokument, wykonaj jedną z następujących czynności:
    • Naciśnij klawisze ALT+V, aby wyświetlić menu Widok, a następnie naciśnij klawisz U, aby wyłączyć tryb pełnoekranowy.
    • Jeśli widoczny jest pasek narzędzi Pełny ekran, kliknij polecenie Zamknij pełny ekran.
  • Jeśli nie jest otwarty żaden dokument, wykonaj jedną z następujących czynności:
    1. Naciśnij klawisze CTRL+N, aby utworzyć nowy dokument.
    2. Naciśnij klawisze ALT+V, aby wyświetlić menu Widok, a następnie naciśnij klawisz U, aby wyłączyć tryb pełnoekranowy.
Zamknij, a następnie ponownie uruchom program Word. Jeżeli program Word jest uruchamiany prawidłowo, problem został rozwiązany. Problem został spowodowany tym, że program Word został zamknięty w trybie pełnoekranowym i zachował to ustawienie.

Aby uzyskać więcej informacji o trybie pełnoekranowym, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
290947 Menus and toolbars disappear and "Repeat Value:8" is displayed on Status bar

Włącz domyślne paski narzędzi

W menu Widok kliknij polecenie Paski narzędzi. Należy zwrócić uwagę, czy zostały zaznaczone jakiekolwiek paski narzędzi. Jeśli nie został zaznaczony żaden pasek narzędzi, wybierz te, których potrzebujesz. Aby to zrobić, kliknij nazwę paska. Powtórz tę procedurę dla każdego paska narzędzi, który chcesz wyświetlić. Domyślnie są zaznaczone paski narzędzi Standardowy i Formatowanie oraz Okienko zadań.

Uwaga: Jeśli nie widać paska menu, należy nacisnąć klawisze ALT+V, aby wyświetlić menu Widok, a następnie klawisz T, aby wyświetlić menu Pasek narzędzi.

Zamknij, a następnie ponownie uruchom program Word. Jeżeli program Word jest uruchamiany prawidłowo, problem został rozwiązany. Problem został spowodowany tym, że domyślne paski narzędzi oraz pasek menu zostały wyłączone po zamknięciu programu Word, a program zachował te ustawienia.


Uruchamianie programu Word bez uruchamiania makr

Sprawdź, czy uruchamiasz program Word za pomocą makra Microsoft Visual Basic for Applications (VBA). Może być uruchomione makro VBA, które uruchamia program Word bez wyświetlania pasków menu i pasków narzędzi.

Jeśli uruchamiasz program Word za pomocą skrótu, sprawdź wiersz polecenia wykorzystywany przez skrót jako nazwę makro. Aby to zrobić, wykonaj następujące kroki:
  1. Odszukaj skrót, za pomocą którego uruchamiasz program Word.
  2. Kliknij skrót prawym przyciskiem myszy, a następnie wybierz z menu skrótów polecenie Właściwości.
  3. Kliknij kartę Skrót.
  4. Sprawdź w polu Element docelowy wiersz polecenia wyglądający podobnie jak poniższy
    "C:\Program Files\Microsoft Office\Office10\WINWORD.EXE" /mnazwa makra
    gdzie /mnazwa makra jest nazwą makra.

  5. Jeśli w wierszu polecenia widzisz /mnazwa makra, usuń tekst, a następnie uruchom program Word w normalny sposób.

    Uwaga: Przełącznik /m poprzedzający nazwę makra uruchamia program Word oraz konkretne makro. Przełącznik /m uniemożliwia również uruchomienie przez program Word jakichkolwiek makr AutoExec.
Jeśli program Word jest uruchamiany prawidłowo, problem został rozwiązany. Problem został spowodowany tym, że podczas uruchamiania programu Word jest również uruchamiane makro zmieniające wygląd okna programu.

Aby uzyskać dodatkowe informacje dotyczące przełączników wiersza polecenia, których można użyć do uruchomienia programu Word, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
210565 WD2000: Przełączniki wiersza polecenia programu Word i ich cel

Program (taki jak dodatek programu Word) dokonał modyfikacji interfejsu użytkownika, spowodował ukrycie pasków narzędzi lub zmianę ustawień

Krok 1: Uruchom program Word, używając ustawień domyślnych

Uruchomienie programu Word za pomocą przełącznika /a w wierszu polecenia powoduje, że program używa domyślnych ustawień dla wszystkich opcji i uniemożliwia pobieranie dodatków i szablonów.

Przełącznik /a umożliwia uruchomienie programu Word bez pobierania następujących składników:
  • Szablon globalny (Normal.dot)
  • Szablony dodatków znajdujące się w folderze Autostart
  • Biblioteki dodatków (pliki .wll)
  • Ustawienia użytkownika zapisane w kluczu danych znajdującym się w rejestrze systemu Windows
Uwaga: Po uruchomieniu programu Word za pomocą przełącznika /a zmiany dokonane w programie mające wpływ na te składniki nie są zapisywane na twardym dysku, a zamknięcie programu powoduje ich utracenie.

W następującym przykładzie zakładamy, że program Word jest zapisany w następującym folderze:
C:\Program Files\Microsoft Office\Office10
Uwaga: Program może być również zapisany w innym folderze.

Aby uruchomić program Word za pomocą przełącznika /a, wykonaj następujące kroki:
  1. Kliknij przycisk Start, kliknij polecenie Uruchom, a następnie kliknij przycisk Przeglądaj.
  2. Użyj pola Szukaj w, aby odszukać plikWinword.exe, a następnie zaznacz go kliknięciem myszy.
  3. Kliknij przycisk Otwórz.

    Uwaga: Ten krok wypełnia pole Otwórz, znajdujące się w oknie dialogowym Uruchom.
  4. Kliknij po pliku Winword.exe w polu Otwórz.

    Uwaga: Ścieżka do pliku Winword.exe w oknie dialogowym Uruchamianie jest ujęta w cudzysłów. Upewnij się, że klikasz po prawej stronie cudzysłowu.
  5. Wpisz spację, a następnie wpisz przełącznik /a.

    Tekst widoczny w oknie Otwórz powinien wyglądać podobnie do poniższego:
    „C:\Program Files\Microsoft Office\Office10\Winword.exe" /a
Jeśli program Word jest uruchamiany prawidłowo, problem został rozwiązany. Problem został spowodowany tym, że dodatek lub szablon, domyślny szablon Normal lub klucz danych w rejestrze wpływa na sposób wyświetlania okna programu Word po jego uruchomieniu.

Krok 2: Zmienianie nazwy szablonu globalnego

Uwaga: Informacje o zautomatyzowanej metodzie wykonywania tego kroku można znaleźć w artykule znajdującym się w sekcji "References" tego artykułu.

Aby formatowanie, Autotekst i makra przechowywane w szablonie globalnym (Normal.dot) nie wpływały na zachowanie programu Word lub otwieranych dokumentów, należy zmienić nazwę pliku Normal.dot.

Uwaga: Zmiana nazwy szablonu Normal.dot pozwala szybko ustalić, czy szablon Normal jest przyczyną omawianego problemu. Zmiana nazwy szablonu Normal.dot resetuje wiele opcji do ich wartości domyślnych, w tym style niestandardowe, niestandardowe paski narzędzi, makra i wpisy Autotekstu. Z tego powodu firma Microsoft zaleca zmianę nazwy pliku Normal.dot.

Niektóre rodzaje konfiguracji mogą utworzyć więcej niż jeden plik Normal.dot. Dzieje się tak, gdy na tym samym komputerze jest uruchamianych wiele wersji programu Word lub istnieje wiele instalacji stacji roboczych. W takich sytuacjach należy się upewnić, czy zostały zmienione nazwy wszystkich kopii szablonu Normal.dot. Aby zmienić nazwę szablonu globalnego (Normal.dot), wykonaj następujące kroki:
  • Microsoft Windows 98 i Microsoft Windows NT 4.0
    1. Zamknij wszystkie wystąpienia programu Word. Jeżeli używasz programu Word jako edytora poczty e-mail, upewnij się, że program Microsoft Outlook również został zamknięty.
    2. Kliknij przycisk Start, wskaż polecenie Znajdź, a następnie kliknij polecenie Pliki lub foldery.
    3. W polu Nazwa wpisz tekst Normal.dot.
    4. W polu Szukaj w zaznacz lokalny dysk twardy (lub inną lokalizację szablonów użytkownika, jeśli program Word jest uruchamiany z serwera sieciowego).
    5. Kliknij przycisk Znajdź, aby wyszukać plik.
    6. W przypadku każdego wystąpienia pliku Normal.dot w oknie dialogowym Znajdowanie prawym przyciskiem myszy kliknij plik. Kliknij polecenie Zmień nazwę w menu skrótów. Nadaj plikowi nową nazwę, taką jak StaryNormal.dot lub Normal-1.dot, a następnie naciśnij klawisz ENTER.
    7. W menu Plik kliknij polecenie Wyjdź, aby zamknąć okno dialogowe Znajdź, a następnie uruchom ponownie program Word w normalny sposób (bez użycia przełącznika /a).
  • Microsoft Windows Millennium Edition (Me) lub Microsoft Windows 2000
    1. Zamknij wszystkie wystąpienia programu Word. Jeżeli używasz programu Word jako edytora poczty e-mail, upewnij się, że program Microsoft Outlook również został zamknięty.
    2. Kliknij przycisk Start, wskaż polecenie Wyszukaj, a następnie kliknij polecenie Pliki lub foldery.
    3. W polu Wyszukaj pliki i foldery o nazwie wpisz Normal.dot.
    4. W polu Szukaj w zaznacz lokalny dysk twardy (lub inną lokalizację szablonów użytkownika, jeśli program Word jest uruchamiany z serwera sieciowego).
    5. Kliknij przycisk Wyszukaj teraz, aby wyszukać plik.
    6. W przypadku każdego wystąpienia pliku Normal.dot w oknie dialogowym Wyszukaj kliknij plik prawym przyciskiem myszy. Kliknij polecenie Zmień nazwę w menu skrótów. Nadaj plikowi nową nazwę, taką jak StaryNormal.dot lub Normal-1.dot, a następnie naciśnij klawisz ENTER.
    7. W menu Plik kliknij polecenie zamknij, aby zamknąć okno dialogowe Wyszukaj, a następnie uruchom ponownie program Word w normalny sposób (bez użycia przełącznika /a).
  • System Windows XP
    1. Zamknij wszystkie wystąpienia programu Word. Jeżeli używasz programu Word jako edytora poczty e-mail, upewnij się, że program Microsoft Outlook również został zamknięty.
    2. Kliknij przycisk Start, a następnie kliknij polecenie Wyszukaj.
    3. Kliknij polecenie Pliki i foldery.
    4. Kliknij łącze Bardziej zaawansowane opcje, a następnie kliknij pole wyboru Przeszukaj ukryte pliki i foldery, aby je zaznaczyć.
    5. W polu Cała nazwa pliku lub jej część wpisz nazwę normal.dot.
    6. W polu Szukaj w zaznacz lokalny dysk twardy (lub inną lokalizację szablonów użytkownika, jeśli program Word jest uruchamiany z serwera sieciowego).
    7. Kliknij przycisk Wyszukaj, aby wyszukać plik.
    8. W prawym okienku okna dialogowego Wyniki wyszukiwania kliknij prawym przyciskiem myszy plik Normal.dot, a następnie w wyświetlonym menu skrótów kliknij polecenie Zmień nazwę. Wpisz nową nazwę pliku (na przykład StaryNormal.dot), a następni naciśnij klawisz ENTER.
    9. Zamknij okno dialogowe Wyniki wyszukiwania, a następnie uruchom ponownie program Word w normalny sposób (bez użycia przełącznika /a).
Jeśli program Word jest uruchamiany prawidłowo, problem został rozwiązany.

W tym przypadku przyczyną problemu był uszkodzony szablon Normal.dot. Aby przywrócić ulubione opcje, konieczna będzie zmiana kilku ustawień.

Jeżeli plik Normal.dot, którego nazwa została zmieniona, zawiera dostosowania niemożliwe do odtworzenia w prosty sposób, takie jak style, makra lub pozycje Autotekstu, można je skopiować ze starego pliku Normal.dot do nowego pliku Normal.dot za pomocą Organizatora.

Aby uzyskać więcej informacji dotyczących sposobu korzystania z Organizatora, w menu Pomoc kliknij polecenie Microsoft Word — Pomoc, w Asystencie pakietu Office lub Kreatorze odpowiedzi wpisz organizator i kliknij przycisk Wyszukaj w celu wyświetlenia znalezionych tematów.

Zmienianie nazwy klucza danych w Rejestrze Windows

Uwaga: Informacje o zautomatyzowanej metodzie wykonywania tego kroku można znaleźć w sekcji "References" tego artykułu.

Ostrzeżenie: Nieprawidłowe wykorzystanie Edytora rejestru może stać się przyczyną poważnych problemów, które spowodują, że konieczna będzie ponowna instalacja systemu operacyjnego. Firma Microsoft nie może zagwarantować, że możliwe będzie rozwiązanie problemów spowodowanych niepoprawnym użyciem Edytora rejestru. Możesz używać Edytora rejestru na własną odpowiedzialność.
Uwaga: Zmiana nazwy klucza danych powoduje przywrócenie ustawień domyślnych kilku opcji, w tym listy ostatnio używanych plików w menu Plik, a także wielu ustawień dostosowanych przez użytkownika po kliknięciu polecenia Opcje w menu Narzędzia. Podczas następnego uruchomienia program Word odbudowuje klucz danych, korzystając z ustawień domyślnych.

Aby zmienić nazwę klucza danych, wykonaj następujące czynności:
  1. Zamknij wszystkie programy systemu Windows.
  2. Kliknij przycisk Start, kliknij polecenie Uruchom, w polu Otwórz wpisz polecenie regedit, a następnie kliknij przycisk OK.
  3. Zlokalizuj następujący klucz, klikając dwukrotnie foldery odpowiednie dla używanej wersji programu Word:

    Program Microsoft Office Word 2003
    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Word\Data
    Program Microsoft Word 2002:
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Data
    Program Microsoft Word 2000:
    HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Word\Data
  4. Po zaznaczeniu folderu Dane kliknij w menu Edycja polecenie Zmień nazwę.
  5. Wpisz nową nazwę folderu Dane (na przykład wpisz OldData), a następnie naciśnij klawisz ENTER.
  6. Zamknij Edytor rejestru i uruchom ponownie program Word w normalny sposób (nie używając przełącznika /a).
Jeśli program Word jest uruchamiany prawidłowo, problem został rozwiązany. Przyczyną problemu jest uszkodzony klucz danych. Aby przywrócić ulubione opcje, konieczna będzie zmiana kilku ustawień.


Utwórz makro podglądu wydruku

Zmień makro podglądu wydruku w programie Word, tak aby były wyświetlane żądane ustawienia.

Na przykład, aby automatycznie wyświetlić w podglądzie wydruku pasek narzędzi Formatowanie, wykonaj następujące kroki:
  1. W menu Narzędzia wskaż polecenie Makro, a następnie kliknij polecenie Makra.
  2. Zmień wybór w polu Makra w na Polecenia programu Word.
  3. Z listy Nazwa makra wybierz opcję FilePrintPreview.
  4. Zmień ustawienie z polu Makra w na Normal.dot (szablon globalny).
  5. Kliknij przycisk Utwórz.
  6. Utwórz następujące makro:
    Sub FilePrintPreview()
    '
    ' FilePrintPreview Macro
    ' Pokazuje całe strony tak, jak będą wydrukowane.
    '
       ActiveDocument.PrintPreview
       CommandBars("Formatting").Visible = True
    End Sub
    					
  7. W menu Plik kliknij polecenie Zamknij i powróć do programu Microsoft Word.

Więcej informacji

Aby uzyskać więcej informacji dotyczących dostosowania i tworzenia pasków narzędzi i przycisków pasków narzędzi, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
291292 HOW TO: Work with toolbars and toolbar buttons: add, create, edit, delete, restore, and more in Word 2002

Materiały referencyjne


Aby uzyskać więcej informacji o automatyzacji rozwiązywania problemów przez usuwanie określonych ważnych składników, które mogą być uszkodzone lub działać niezgodnie z programem Microsoft Word, kliknij numer artykułu poniżej w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
289506 JAK: Instalowanie i korzystanie z szablonu Support.dot w programie Microsoft Word 2002

Właściwości

Numer ID artykułu: 291484 - Ostatnia weryfikacja: 24 maja 2006 - Weryfikacja: 5.0
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Office Word 2003
  • Microsoft Word 2002 Standard Edition
  • Microsoft Word 2000 Standard Edition
Słowa kluczowe: 
kbsettings kbtoolbar kbmenu kbmacro kbprb KB291484

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com