Unable to Uninstall a Previous Version of Internet Explorer After You Uninstall the Current Version of Internet Explorer

Article translations Article translations
Article ID: 291558 - View products that this article applies to.
This article was previously published under Q291558
Expand all | Collapse all

SYMPTOMS

After you uninstall any version of Internet Explorer, either the Uninstall Internet Explorer and all its components or Restore the previous Windows configuration option is unavailable (dimmed).

You can use these options to uninstall Internet Explorer. The options are available in the Control Panel Add/Remove Programs tool when you click Add/Remove for Internet Explorer.

CAUSE

This behavior occurs because Internet Explorer maintains only one set of backup (or uninstall) information. If you uninstall a version of Internet Explorer, you cannot use the Add/Remove Programs tool in Control Panel to remove the browser that was installed before the version of Internet Explorer that you uninstalled.

WORKAROUND

To work around this behavior, install Internet Explorer 5 or later (which creates new backup, or uninstall, information), or view the following Microsoft Knowledge Base articles for additional information:
174265 How to Uninstall Internet Explorer 4.0
217344 How to Uninstall Internet Explorer 5
246194 How to Uninstall Internet Explorer 5.01

STATUS

This behavior is by design.

MORE INFORMATION

Either the Uninstall Internet Explorer and all its components or Restore the previous Windows configuration options are unavailable if you click Delete the backup information for Internet Explorer in the Advanced dialog box in the Add/Remove Programs tool. For additional information, view the following Microsoft Knowledge Base article:
172919 Uninstall Internet Explorer Option Is Missing

Properties

Article ID: 291558 - Last Review: January 31, 2007 - Revision: 4.2
APPLIES TO
  • Microsoft Internet Explorer 5.5 Service Pack 1
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 4.01 Service Pack 1
  • Microsoft Internet Explorer 4.01 Service Pack 2
  • Microsoft Internet Explorer 4.0 128-Bit Edition
  • Microsoft Internet Explorer 5.5 Service Pack 1
  • Microsoft Internet Explorer 5.5 Service Pack 1
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.5 Service Pack 1
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 4.0 128-Bit Edition
  • Microsoft Internet Explorer 5.5 Service Pack 1
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 6.0, when used with:
    • Microsoft Windows 2000 Advanced Server
    • Microsoft Windows 2000 Datacenter Server
    • Microsoft Windows 2000 Professional Edition
    • Microsoft Windows 2000 Server
    • Microsoft Windows NT Server 4.0 Standard Edition
    • Microsoft Windows NT Server 4.0, Terminal Server Edition
    • Microsoft Windows NT Workstation 4.0 Developer Edition
    • Microsoft Windows Millennium Edition
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows 98 Standard Edition
Keywords: 
kbprb kbsetup KB291558

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com