Outlook se nemůže připojit přes bránu firewall nebo proxy server, který provádí překlad adres (NAT) mezi veřejnými a privátními sítěmi.

Původní číslo KB: 291615

Příznaky

Klienti Outlooku se nemůžou připojit přes bránu firewall nebo proxy server, který provádí překlad adres (NAT) mezi veřejnými a privátními sítěmi.

Příčina

Pokud jsou během překladu upraveny pakety PROTOKOLU IP obsahující informace o vzdáleném volání procedur (RPC), pakety PROTOKOLU IP ztratí informace o připojení RPC. To způsobí, že se klient nepřipojí k serveru. Kromě toho může mít Outlook problémy s překladem názvu Microsoft Exchange Server počítače za bránou firewall nebo proxy serverem.

Řešení

Řešením pro brány firewall nebo proxy servery, které nejsou založené na Microsoft systém Windows NT, je provedení překladu 1:1 mezi těmito dvěma sítěmi. To se také označuje jako otevření kanálu nebo tunelu mezi veřejnými a privátními sítěmi. Tím se převezmou všechny požadavky na konkrétní adresu ve veřejné síti a předají se přímo do privátní sítě. Další informace o tom, jak nakonfigurovat překlad 1:1, najdete v dokumentaci od výrobce.

Překlad 1:1 nefunguje u bran firewall a proxy serverů založených na systém Windows NT, protože se klient Outlooku pokusí vytvořit vazbu na port mapovače koncových bodů (EPM), port 135 v bráně firewall. Tento server nevrací správné Exchange Server informace o připojení ke klientovi aplikace Outlook.

Dalším možným řešením je použití Outlook Web App. To vyžaduje jenom povolení provozu HTTP přes bránu firewall nebo proxy server.

Další informace

Další informace najdete v následujících dokumentech RFC (Requests for Comments):

  • RFC 1631 – Překladač IP adres (NAT)
  • RFC 1918 – Přidělování adres pro privátní internet

Tyto dokumenty RFC najdete tady.