Outlook не удается подключиться через брандмауэр или прокси-сервер, выполняющий преобразование сетевых адресов (NAT) между общедоступными и частными сетями

Исходный номер базы знаний: 291615

Симптомы

Клиенты Outlook не могут подключаться через брандмауэр или прокси-сервер, который выполняет NAT между общедоступными и частными сетями.

Причина

При изменении IP-пакетов, содержащих сведения об удаленном вызове процедуры (RPC), во время преобразования IP-пакеты теряют сведения о подключении RPC. Это приводит к тому, что клиент не подключается к серверу. Кроме того, в Outlook могут возникнуть проблемы с устранением имени Microsoft Exchange Server компьютера за брандмауэром или прокси-сервером.

Обходной путь

Обход брандмауэров или прокси-серверов, которые не основаны на microsoft Windows NT, заключается в выполнении преобразования "один к одному" между двумя сетями. Это также называется открытием канала или туннеля между общедоступными и частными сетями. Он принимает все запросы на определенный адрес в общедоступной сети и передает их непосредственно в частную сеть. Дополнительные сведения о настройке перевода "один к одному" см. в документации производителя.

Преобразование "один к одному" или канал не работает для брандмауэров на основе Windows NT и прокси-серверов, так как клиент Outlook пытается выполнить привязку к порту EPM(EPM), порту 135, в брандмауэре. Этот сервер не возвращает правильные сведения о подключении Exchange Server клиенту Outlook.

Другим возможным обходом является использование Outlook Web App. Для этого необходимо только разрешить трафик HTTP через брандмауэр или прокси-сервер.

Дополнительная информация

Дополнительные сведения см. в следующих запросах на комментарии (RFC):

  • RFC 1631 — переводчик IP-адресов (NAT)
  • RFC 1918 — выделение адресов для частного Интернета

Эти RFC можно найти здесь.