Co dělat, pokud má počítač s Office pro Mac nainstalován program virus makra

Překlady článku Překlady článku
ID článku: 291824 - Produkty, které se vztahují k tomuto článku.
Microsoft Word 98 verzi tohoto článku naleznete 181080.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Souhrn

Tento článek popisuje, co jsou viry v makrech, co dělat, pokud se domníváte, že počítač pravděpodobně virus makra Word a jak zajistit, že vaše dokumenty stanou není napaden virem makro.

Další informace

Byl zjištěn virus první makro v létě 1995. Se od doby, neobsahují viry v makrech nezobrazují.

Virus v makru je škodlivý program, který je napsán pomocí makra jazyka programu, například Word. Virus se šíří se mezi datové soubory a mohou poškodit soubory nebo operační systém.

Word viry v makrech není cestování přes Internet nebo jiné médium volně; může pouze být přesunou když uživatel otevře dokument nebo šablonu obsahující makro virus.

Viry v makrech nemohou být přeneseny pomocí e-mailu, pokud ohrožený dokumentu je vložen v e-mailové zprávě a příjemce otevře dokument.

Příznaky virus makra

Některé příznaky Word viry v makrech, které jsou známé ovlivnit Word a Word jsou následující dokumenty:
  • Při pokusu o uložení dokumentu aplikace Word pouze umožňuje uložit dokument jako šablonu.

    Nebo
  • Ikona pro soubor vypadá jako šablonu, nikoli dokument.

    Nebo
  • Při otevření dokumentu se zobrazí dialogové okno zobrazující číslo 1.

    Nebo
  • Makra a Vlastní příkazy se již nezobrazí v nabídce Nástroje.

    Nebo
  • Nová makra se zobrazí v seznamu maker. AutoOpen a FileSaveAs makra může také zobrazit, pokud již dříve makra podle těchto názvů, jejich obsah může být změněno podle virus makra.

    Nebo
  • Neobvyklé nebo neočekávané zprávy zobrazí při otevření dokumentu nebo šablony.
Poznámky
  • V Word 2001 pro systém Macintosh, můžete nastavit možnost Antivirová ochrana maker (v nabídce Úpravy klepněte na tlačítko Předvolby a klepněte na kartu Obecné), který je určen upozorní, pokud otevřete soubor, který obsahuje makra, bez ohledu na to, co dělat makra. V aplikaci Word X pro Mac můžete nastavit možnost Antivirová ochrana maker v nabídce Word klepnutím na tlačítko Předvolby, klepnutím na kartu Obecné a klepnutím na možnost Antivirová ochrana maker zapnout nebo vypnout. V Word 2004 for Mac můžete nastavit možnost Antivirová ochrana maker v nabídce Word klepnutím na tlačítko Předvolby, klepnutím na kartu zabezpečení a klepnutím na možnost Antivirová ochrana maker zapnout nebo vypnout. Trvalé řešení je nutné použít antivirový software, který je navržen speciálně k rozpoznání a zabránit virům v makrech.
  • Word není Vyhledejte viry v makrech nebo z existující dokumenty a šablony odebrat viry v makrech. Jej pouze upozornění Pokud otevíráte dokument obsahuje makra. Potom můžete buď otevřít dokument s makry aktivní nebo otevřete se zakázanými makry. Neměli byste otevírat dokument s aktivní makra nejste zcela jisti, že dokument obsahuje žádné viry nebezpečné makro.
  • Antivirové programy jiných výrobců musí být často aktualizován zůstat efektivní. Obraťte se na dodavatele a informace o aktualizaci.
  • Disinfectant freeware antivirový nástroj Mac OS 9 a starších verzích není pomáhá chránit před viry v makrech. Vývoj Disinfectant program má bylo přerušeno. Konečné verze Disinfectant je verze 3.7.1.

    Odkazy na aktuální antivirový software navštivte odkazy, které jsou v další části. Norton's AntiVirus Symantec a Sophos obě integrována Mac OS X, budou obě vyhledávat makro viry.

Nainstalovat antivirový program

Dlouhodobé řešení viry v makrech nainstalujte antivirový software, který je speciálně určena ke zjištění viry v makrech. Další informace o dodavatelích antivirového softwaru, včetně softwaru schopný detekce a zabránění viry v makrech klepněte na následující číslo článku databáze Microsoft Knowledge Base:
49500Seznam výrobců antivirového softwaru
Společnost Microsoft se vám snaží usnadnit získání technické podpory poskytnutím informací o kontaktech na jiné výrobce. Kontaktní informace se mohou změnit bez předchozího upozornění. Společnost Microsoft neručí za správnost těchto informací o kontaktech.

Co dělat, když si myslíte, že počítač pravděpodobně virus makra

Jako dočasné řešení, pouze pokud se domníváte, že počítač pravděpodobně virus makra, použijte následující metody.

Metoda 1: Zakázat makra a kopírovat text do nového dokumentu

Pokud není setkáte žádné příznaky popsané výše v tomto článku, ale nechcete být ovlivněny virus v makru, podržte klávesu SHIFT při otevření souboru, který může být napaden virus makra. Stisknutím klávesy SHIFT zabraňuje spuštění makra Word automatický; Pokud je přítomen virus v makru, jej není načten.

Metoda 2: Odstranit makro a obnovení dokumentu

Pokud se setkáváte s příznaky popsané výše v tomto článku nebo pokud máte podezření, že máte virus makra popsaného v tomto článku, postupujte takto podezřelých makro odstranit a opravě ohroženého dokumentu.

Poznámka: Toto je pouze dočasné řešení, protože vytvoření nového makra jsou tyto kroky nemusí pracovat na nová makra.
  1. Zavřete Word a přesunout normální šablona na ploše.
  2. Vytvořte záložní kopii ovlivněného souboru.
  3. Spusťte aplikaci Word. V nabídce soubor klepněte na tlačítko Otevřít.
  4. Přejděte do složky obsahující ohrožený soubor.
  5. Klepnutím vyberte ohrožený soubor.
  6. Stiskněte a podržte klávesu SHIFT a klepněte na tlačítko Otevřít. Pokračovat, dokud ohrožený soubor je otevřen v aplikaci Word, že podržíte klávesu SHIFT.

    Poznámka: Podržením klávesy SHIFT při otevírání souboru zabraňuje makra Word automatického spuštění.
  7. Chcete-li odstranit podezřelých makro, použijte následující kroky:
    1. V nabídce Nástroje přejděte na příkaz makro a potom klepněte na příkaz makra.
    2. V Makra V místní nabídce vyberte všechny Active šablony a dokumenty.
    3. Vyberte podezřelých makro a klepněte na příkaz Odstranit. Klepněte na tlačítko Ano po zobrazení výzvy, zda chcete odstranit makro.
    4. Opakujte krok c podezřelých všechna makra.
    5. Klepnutím na tlačítko Storno zavřete dialogové okno makro.
  8. Obnovení textu napadené dokumentu, postupujte takto:
    1. Stisknutím kláves COMMAND + A nebo klepnutím na příkaz Vybrat vše v nabídce Úpravy vyberte celý dokument.
    2. Odstranit poslední znak konce odstavce dokumentu z výběru stisknutím klávesy SHIFT + ŠIPKA vlevo.
    3. V nabídce Úpravy klepněte na tlačítko Kopírovat.
    4. V nabídce soubor klepněte na tlačítko Nový. Vyberte šablonu, kterou chcete použít a potom klepněte na tlačítko OK.
    5. V nabídce Úpravy klepněte na tlačítko Vložit.
    6. Opakujte krok 7 zajistit makro obsahující virus nebyl replikován.
    7. Uložte dokument.
  9. Opakujte tyto kroky pro dokument, který podezření může obsahovat virus makra.
Poznámka: Pokud Metoda 2 nefunguje, vyzkoušejte metodu 3.

Metoda 3: Použití organizátoru dočasně vyčistit virus makra

Organizátor použít vyčistit virus makra. Mějte na paměti, že pokud otevřete jiné soubory po otevření souboru napadené, tyto soubory pravděpodobně jsou napadeny také.

Virus odebrat z šablony Normal, postupujte takto:
  1. Zavřete všechny dokumenty. Pokud je otevřeno napadených dokumentů, můžete snadno re-infect šablony Normal.
  2. V nabídce Nástroje klepněte na příkaz šablony a doplňky a klepněte na tlačítko Organizátor.
  3. Klepněte na kartu Makra a potom přejmenovat nebo odstranit všechny následující makra:
    • NewMacros
    • AutoClose
    • AutoExec
    • AutoOpen
    • FileExit
    • FileNew
    • FileOpen
    • FileSave
    • FileSaveAs
    • makra,
    • ToolsMacro
  4. Klepněte na tlačítko Zavřít.
  5. Stiskněte a podržte klávesu SHIFT při klepnutí Uložit vše v nabídce soubor šablonu uložit.
z napadeného dokumentu odebrat virus makra:

Soubor je napaden, použít stejným způsobem jako v krocích 1 až 5, ale odebrat makra z normální šablony a také z napadeného dokumentu (šablona) v organizátoru. Po dokončení stiskněte a podržte klávesu SHIFT, zatímco v nabídce soubor klepněte na tlačítko Uložit vše a pak přesunout na další soubor. Mějte na paměti, že při každém otevření napadený soubor jej napadne šablony Normal, takže makra musí opakovaně odebrat z šablony Normal.dot.

Metoda 4: Vložení napadeného souboru do nového dokumentu

Tato metoda je užitečná zejména s "CAP" virus makra, která odebere makra a Vlastní z nabídky Nástroje.

Poznámka: V této situaci šablony a doplňky v nabídce Nástroje nemusí fungovat.
  1. Zavřete Word a přesunutí šablony Normal na plochu.
  2. Spusťte aplikaci Word a potom ověřte, že makra a vlastní se v nabídce Nástroje.
  3. Otevřete nový dokument. V nabídce Vložit klepněte na soubor.
  4. Přejděte do složky obsahující ohrožený soubor.
  5. Klepnutím vyberte ohrožený soubor.
  6. Stiskněte a podržte klávesu SHIFT a klepněte na tlačítko Otevřít. Pokračujte, dokud ohrožený soubor je otevřen v aplikaci Word, podržte klávesu SHIFT.
    Poznámka: Podržením klávesy SHIFT při otevírání souboru zabraňuje makra Word automatického spuštění.
  7. K ověření, zda existují makra v novém dokumentu (žádný by měly být uvedeny), přejděte v nabídce Nástroje na příkaz makro a potom klepněte na příkaz makra. Makra v místní seznam klepněte na všechny aktivní šablony a dokumenty. V části Název makra by měla být uvedena žádná makra. Klepněte na tlačítko Storno.
  8. Uložte soubor s jiným názvem souboru.
  9. Infikovaný soubor odstranit.

Vlastnosti

ID článku: 291824 - Poslední aktualizace: 31. ledna 2007 - Revize: 3.3
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Office 2004 for Mac Standard Edition
  • Microsoft Office X pro počítače Mac Standard Edition
  • Microsoft Office 2001 pro počítače Macintosh
  • Microsoft Word 2004 for Mac
  • Microsoft Word X pro počítače Macintosh
  • Microsoft Word 2001 pro počítače Mac
Klíčová slova: 
kbmt kbinfo KB291824 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:291824

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com