Qué hacer si el equipo con un Office para Mac programa instalado tiene un virus de macro

Seleccione idioma Seleccione idioma
Id. de artículo: 291824 - Ver los productos a los que se aplica este artículo
Para obtener una versión de Microsoft Word 98 de este artículo, consulte 181080.
Expandir todo | Contraer todo

En esta página

Resumen

En este artículo describe qué son los virus de macro, qué hacer si piensa que su equipo puede tener un virus de macro de Word y cómo asegurarse de que los documentos no se convierten en infectado con un virus de macro.

Más información

El primer virus de macro se descubrió en el verano de 1995. Desde ese momento, han aparecido otros virus de macro.

Un virus de macro es un programa malintencionado que se escribe utilizando el lenguaje de macros de un programa como Word. El virus propaga entre archivos de datos y puede dañar los archivos o sistema operativo de su equipo.

Los virus de macro de Word no viajan libremente por Internet ni por otros medios; únicamente pueden transmitirse cuando un usuario abre un documento o una plantilla que contiene el virus de macro.

Los virus de macro no pueden transferirse por correo electrónico, a menos que un documento afectado está incrustado en el mensaje de correo electrónico y el destinatario abre el documento.

Síntomas de un virus de macro

Los siguientes son algunos síntomas de virus de macro de Word que se sabe que afectan a Word y Word documentos:
  • Cuando intenta guardar un documento, Word sólo le deja guardar el documento como plantilla.

    -o bien -
  • El icono del archivo tiene el aspecto de una plantilla en lugar de un documento.

    -o bien -
  • Cuando abre un documento, aparece un cuadro de diálogo que muestra el número 1.

    -o bien -
  • Los comandos de macro y Personalizar ya no aparecen en el menú Herramientas .

    -o bien -
  • Nuevas macros aparecen en la lista de macros. También pueden aparecer las macros AutoOpen y FileSaveAs; si ya tenía macros con estos nombres, se puede modificar su contenido por el virus de macro.

    -o bien -
  • Aparecen mensajes extraños o inesperados cuando abre un documento o una plantilla de Word.
notas
  • En Word 2001 para Mac, puede establecer la opción Protección antivirus en macros (en el menú Edición , haga clic en Opciones y, a continuación, haga clic en la ficha General ) que está diseñada para informarle si abre un archivo que contiene macros, independientemente de lo que las macros. En Word X para Mac, puede establecer la opción Protección antivirus haciendo clic en Opciones en el menú Word , haciendo clic en la ficha General y, a continuación, en la opción Protección antivirus , activar o desactivar. En Word 2004 para Mac, puede establecer la opción Protección antivirus haciendo clic en Opciones en el menú Word , haciendo clic en la ficha seguridad y, a continuación, en la opción Protección antivirus , activar o desactivar. Para una solución permanente, debe utilizar software antivirus que está diseñado específicamente para detectar y evitar virus de macro.
  • Word no buscar virus de macro o quitar cualquier virus de macros de documentos existentes y plantillas. Sólo le avisa si el documento que está abriendo contiene macros. A continuación, puede abrir el documento con las macros activas o abrirlo con las macros deshabilitadas. No debería abrir un documento con las macros activas a menos que esté totalmente seguro de que el documento no contiene virus de macros que puedan dañar su equipo.
  • Programas antivirus de terceros deben actualizarse con frecuencia para permanecer eficaz. Póngase en contacto con el fabricante para obtener información de actualización.
  • Disinfectant, una utilidad antivirus de freeware para Mac OS 9 y versiones anteriores, no ayuda a proteger contra virus de macro. Desarrollo en el programa Disinfectant ha suspendido. La versión final de Disinfectant es la versión 3.7.1.

    Para vínculos a software antivirus actualizado, visite los vínculos en la sección siguiente. Antivirus ?s Norton, Symantec y Sophos, ambos diseñados para Mac OS X, ambos buscará los virus de macro.

Instalar un programa antivirus

Para una solución a largo plazo a virus de macro, instalar software antivirus que está diseñado específicamente para detectar virus de macro. Para obtener información adicional acerca de proveedores antivirus, incluido el software capaz de detectar y evitar virus de macro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
49500Lista de proveedores de software antivirus
Microsoft proporciona información de contacto con otros proveedores para ayudarle a encontrar soporte técnico. Esta información de contacto puede cambiar sin previo aviso. Microsoft no ofrece ninguna garantía con respecto a la exactitud de esta información de contacto con otros proveedores.

Qué hacer cuando piensa que el equipo que tiene un virus de macro

Utilice los métodos siguientes como soluciones temporales sólo cuando piensa que el equipo podrían tener un virus de macro.

Método 1: Deshabilitar las macros y copie el texto en un documento nuevo

Si no experimenta alguno de los síntomas descritos anteriormente en este artículo, pero no quiere verse afectados por un virus de macro, mantenga presionada la tecla MAYÚS cuando abre un archivo que pueda estar infectado por un virus de macro. Presiona la tecla MAYÚS impide cualquier macros automáticas de Word que se ejecute; si hay un virus de macro, no se carga.

Método 2: Eliminar la macro y recuperar el documento

Si experimenta los síntomas descritos anteriormente en este artículo, o si sospecha que tiene un virus de macro que no se describe en este artículo, siga estos pasos para eliminar la macro sospechosa y corregir documento afectado.

Nota Éste es sólo una solución temporal; dado que se se crean nuevas macros, estos pasos no funcionen en nuevas macros.
  1. Cierre Word y mueva la plantilla Normal al escritorio.
  2. Hacer una copia de seguridad copia de un archivo afectado.
  3. Abra Word. En el menú archivo , haga clic en Abrir .
  4. Desplácese a la carpeta que contiene el archivo afectado.
  5. Haga clic para seleccionar el archivo infectado.
  6. Presione y mantenga presionada la tecla MAYÚS y, a continuación, haga clic en Abrir . Continuar la mantiene presionada la tecla MAYÚS hasta que el archivo afectado que se abra en Word.

    Nota Al mantener presionada la tecla MAYÚS mientras abre un archivo impide que se ejecuten las macros automáticas de Word.
  7. Para eliminar una macro sospechosa, utilice los pasos siguientes:
    1. En el menú Herramientas , elija macro y, a continuación, haga clic en macros .
    2. En el menú emergente Macros en , seleccione todas las plantillas activas y documentos .
    3. Seleccione la macro sospechosa y, a continuación, haga clic en Eliminar . Haga clic en cuando se le pregunte si desea eliminar la macro.
    4. Repita el paso c con todas las macros sospechosas.
    5. Haga clic en Cancelar para cerrar el cuadro de diálogo macro .
  8. Para recuperar el texto de un documento infectado, siga estos pasos:
    1. Seleccionar todo el documento presionando comando+A o haciendo clic en Seleccionar todo en el menú Edición .
    2. Eliminar la última marca de párrafo del documento de la selección presionando MAYÚS+flecha izquierda.
    3. En el menú Edición , haga clic en Copiar .
    4. En el menú archivo , haga clic en nuevo . Seleccione la plantilla que desee utilizar y, a continuación, haga clic en Aceptar .
    5. En el menú Edición , haga clic en Pegar .
    6. Repita el paso 7 para asegurarse de que la macro que contiene el virus no ha replicado.
    7. Guarde el documento.
  9. Repita estos pasos para cualquier documento que sospecha que es posible que contenga un virus de macro.
Nota Si el método 2 no funciona, pruebe 3.

Método 3: Utilizar el Organizador para limpiar temporalmente un virus de macro

Utilizar el Organizador para limpiar el virus de macro. Tenga en cuenta que si abrir otros archivos después de abrir el archivo infectado, estos archivos probablemente están infectados así.

Para quitar el virus de la plantilla Normal, siga estos pasos:
  1. Cierre todos los documentos. Si está abierto un documento infectado, lo puede re-infect fácilmente la plantilla Normal.
  2. En el menú Herramientas , haga clic en plantillas y complementos y haga clic en el botón Organizador .
  3. Haga clic en la ficha Macros y, a continuación, cambie el nombre o eliminar todas las macros siguientes:
    • NewMacros
    • AutoClose
    • AutoExec
    • AutoOpen
    • FileExit
    • FileNew
    • FileOpen
    • ArchivoGuardar
    • FileSaveAs
    • Macros
    • ToolsMacro
  4. Haga clic en Cerrar .
  5. Mantenga presionada la tecla MAYÚS mientras hace clic en Guardar todo en el menú archivo para guardar la plantilla.
para quitar un virus de macro de un documento infectado:

Si un archivo está infectado, utilice el método mismo como en los pasos 1 a 5, pero quitar las macros de ambos en la plantilla Normal y también desde el documento infectado (plantilla) mientras en el organizador. Cuando haya terminado, mantenga presionada MAYÚS mientras haga clic en Guardar todo en el menú archivo y, a continuación, vaya al siguiente archivo. Tenga en cuenta que cada vez que abra un archivo infectado, infecta su plantilla Normal, modo repetidamente debe quitar las macros de la plantilla Normal.

Método 4: Insertar el archivo infectado en un documento nuevo

Este método es especialmente útil con el virus de macro "CAP", que quitan macro y Personalizar en el menú Herramientas .

Nota En esta situación, plantillas y complementos en el menú Herramientas no funcionen.
  1. Cierre Word y mueva la plantilla Normal al escritorio.
  2. Abra Word y, a continuación, compruebe que macro y personalizar aparecen en el menú Herramientas .
  3. Abra un documento nuevo. En el menú Insertar , haga clic en archivo .
  4. Explore la carpeta que contiene el archivo infectado.
  5. Haga clic para seleccionar el archivo infectado.
  6. Presione y mantenga presionada la tecla MAYÚS y, a continuación, haga clic en Abrir . Continúe presionando la tecla MAYÚS hasta que el archivo infectado se abra en Word.
    Nota Al mantener presionada la tecla MAYÚS mientras abre un archivo impide que se ejecuten macros automáticas de Word.
  7. Para comprobar si existen macros en el documento nuevo (ninguno debe enumerarse), elija macro en el menú Herramientas y, a continuación, haga clic en macros . En la lista emergente Macros en , haga clic en todas las plantillas activas y documentos . En Nombre de macro , no deben aparecer macros. Haga clic en Cancelar .
  8. Guarde el archivo con un nombre distinto.
  9. Elimine el archivo infectado.

Propiedades

Id. de artículo: 291824 - Última revisión: miércoles, 31 de enero de 2007 - Versión: 3.3
La información de este artículo se refiere a:
  • Microsoft Office 2004 for Mac Standard Edition
  • Microsoft Office X para Macintosh Standard Edition
  • Microsoft Office 2001 para Macintosh
  • Microsoft Word 2004 for Mac
  • Microsoft Word X para Macintosh
  • Microsoft Word 2001 para Macintosh
Palabras clave: 
kbmt kbinfo KB291824 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 291824

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com