High Memory Consumption by SMTP Message Screener Under Stress

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Article ID: 292010 - View products that this article applies to.
This article was previously published under Q292010
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SYMPTOMS

In medium-stress situations in which messages with attachments are screened by the message screener, memory consumption by Inetinfo.exe (in which the message screener runs) can rise quickly. The memory that is being used is released slowly as messages are delivered. In heavy-stress situations, the system can quickly reach a low-virtual-memory state, potentially running out of all memory.

CAUSE

The ADO stream that the message screener uses is not released. It is released later, when the message is delivered. The message screener should release this resource as soon it no longer needs it.

RESOLUTION

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this fix should have the following file attributes or later:
   Date       Time       Version      Size    File name   
   -------------------------------------------------------
   3/13/2001  4:37:08PM  3.0.1200.56  59,152  Fltrsnk1.dll
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Properties

Article ID: 292010 - Last Review: October 23, 2013 - Revision: 2.6
APPLIES TO
  • Microsoft Internet Security and Acceleration Server 2000 Standard Edition
Keywords: 
kbnosurvey kbarchive kbautohotfix kbproductlink kbqfe kbhotfixserver kbenv kbfix kbprb KB292010

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