Przejdź do głównej zawartości
Pomoc techniczna
Zaloguj się przy użyciu konta Microsoft
Zaloguj się lub utwórz konto.
Witaj,
Wybierz inne konto.
Masz wiele kont
Wybierz konto, za pomocą którego chcesz się zalogować.

Objawy

Załóżmy, że masz komputer z systemem Windows RT 8.1, 8.1 systemu Windows, Windows Server 2012 R2, okno 7 Service Pack 1 (SP1) lub Windows Server 2008 R2 z dodatkiem SP1. Na komputerze jest zainstalowany z Zatoką rekina Intel platformy GPU model, który korzysta osadzone DisplayPort (eDP). W takiej sytuacji pojawić się jeden z następujących problemów:

  • Na pulpicie, możesz podłączyć się do zewnętrznego urządzenia wyświetlającego, takich jak monitor, a następnie podłącz w tym samym lub innym monitor, wyświetla czarny ekran.

  • Na komputerze przenośnym Zamknij pokrywę komputera przenośnego, a następnie otworzyć go, pokazuje czarny ekran.


Przyczyna

Ten problem występuje, ponieważ system nie wysyła wywołania DxgkDdiCommitVidPn , gdy urządzenie wyświetlające jest odłączony lub zamknięciu pokrywy komputera przenośnego.

Rozwiązanie

Aby rozwiązać ten problem w systemie Windows 8.1 i Windows Server 2012 R2, należy zainstalować aktualizację 2919355.
Aby rozwiązać ten problem w systemie Windows 7 i Windows Server 2008 R2, należy zainstalować poprawki, którą opisano w tym artykule.

Informacje o aktualizacji dla systemu Windows Server 2012 R2 i Windows 8.1

Aby uzyskać więcej informacji dotyczących sposobu uzyskiwania aktualizacji 2919355, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:

Windows RT 8.1, Windows 8.1 i systemu Windows Server 2012 R2 aktualizacji kwietnia 2014

Poprawka informacji dla systemu Windows 7 i Windows Server 2008 R2



Obsługiwana poprawka jest udostępniana przez firmę Microsoft. Jednak ta poprawka jest przeznaczona tylko do usunięcia problemu opisanego w tym artykule. Tylko w systemach, których dotyczy ten problem, należy zastosować tę poprawkę.

Jeśli poprawka jest dostępna do pobrania, pojawi się sekcja "Poprawka dostępna do pobrania" na początku tego artykułu z bazy wiedzy Knowledge Base. Jeśli nie ma tej sekcji, należy przesłać żądanie do centrum obsługi klienta firmy Microsoft i obsługi technicznej w celu uzyskania poprawki.

Uwaga Jeśli wystąpią dodatkowe błędy lub konieczność rozwiązania problemu, być może trzeba będzie utworzyć osobne zlecenie usługi. Zwykłe koszty obsługi będą zastosowane do dodatkowych pytań i problemów, których nie można rozwiązać przy użyciu określonej poprawki. Aby uzyskać pełną listę numerów telefonów działu obsługi klienta firmy Microsoft lub utworzyć osobne zlecenie usługi odwiedź następujące witryny firmy Microsoft:

Uwaga "Poprawka dostępna do pobrania" zawiera listę języków, dla których dostępna jest poprawka. Jeśli odpowiedni język nie jest widoczny, to dlatego, że poprawka nie jest dostępna dla danego języka.

Wymagania wstępne

Aby zastosować tę poprawkę, musisz korzystać z systemu Windows 7 z dodatkiem SP1 lub Windows Server 2008 R2 z dodatkiem SP1.

Aby uzyskać więcej informacji dotyczących sposobu uzyskiwania dodatku service pack dla systemu Windows Server 2008 R2 lub Windows 7, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:

informacje o dodatku Service Pack 1 dla systemu Windows 7 i Windows Server 2008 R2.

Informacje dotyczące rejestru

Aby użyć poprawki w tym pakiecie, nie trzeba wprowadzać żadnych zmian w rejestrze.

Wymagania dotyczące ponownego uruchomienia

Po zastosowaniu tej poprawki należy ponownie uruchomić komputer.

Informacje dotyczące zastępowania poprawek

Ta poprawka nie zastępuje wcześniej wydanej poprawki.


Wersja globalna tej poprawki instaluje pliki, których atrybuty wymieniono w poniższych tabelach. Daty i godziny odpowiadające tym plikom są podane w formacie uniwersalnego czasu koordynowanego (UTC, Coordinated Universal Time). Daty i godziny odpowiadające tym plikom na komputerze lokalnym są wyświetlane w formacie czasu lokalnego, wraz z Twoim bieżącym bias czasu letniego (DST). Dodatkowo, daty mogą ulec zmianie podczas wykonywania pewnych operacji na plikach.

Informacje o plikach systemu Windows 7 i Windows Server 2008 R2 i notatkiWażne Poprawki systemu Windows 7 i Windows Server 2008 R2 są zawarte w tych samych opakowaniach. Jednak poprawki na stronie żądanie poprawki są wymienione w obu systemach operacyjnych. Aby zażądać pakietu poprawek, który dotyczy jednej lub obu systemów operacyjnych, wybierz poprawkę, która jest wyświetlana w obszarze "Windows 7/Windows Server 2008 R2" na stronie. Zawsze sprawdzaj w sekcji „Stosuje się do”, do jakiego systemu operacyjnego dotyczy każda z poprawek.

  • Pliki dotyczące określonego produktu, etapu rozwoju (RTM, SPn) i składnika usługi (LDR, GDR) można zidentyfikować przez sprawdzenie wersji pliku, jak pokazano w poniższej tabeli:

  • Składniki usługi GDR zawierają tylko te poprawki, które są publicznie wydane w celu rozwiązania często występujących, krytycznych problemów. Składniki usługi LDR zawierają też inne poprawki, a nie tylko publicznie rozpowszechniane poprawki.

  • Pliki MANIFESTU (.manifest) i pliki MUM (.mum) zainstalowane dla każdego środowiska są wymienione osobno w sekcji „Informacje o dodatkowych plikach dla systemu Windows 7 i Windows Server 2008 R2”. Pliki MUM i pliki MANIFESTU oraz skojarzone pliki katalogu zabezpieczeń (.cat), są krytyczne dla utrzymania stanu zaktualizowanego składnika. Pliki katalogu zabezpieczeń, których atrybuty nie zostały wymienione, są podpisane za pomocą podpisu cyfrowego firmy Microsoft.

Stan

Firma Microsoft potwierdziła, że jest to problem występujący w produktach firmy Microsoft wymienionych w sekcji „Dotyczy”.

Więcej informacji

Aby uzyskać więcej informacji dotyczących terminologii aktualizacji oprogramowania, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:

Opis standardowej terminologii używanej do opisywania aktualizacji oprogramowania firmy Microsoft.





Informacje o dodatkowych plikach dla systemu Windows 7 i Windows Server 2008 R2

Dodatkowe pliki dla wszystkich obsługiwanych wersji systemu Windows 7 z procesorami x86

Produkty innych firm omówione w tym artykule są wytwarzane przez producentów niezależnych od firmy Microsoft. Firma Microsoft nie udziela żadnych gwarancji, domniemanych ani żadnego innego rodzaju, odnośnie do wydajności lub niezawodności tych produktów.

Potrzebujesz dalszej pomocy?

Chcesz uzyskać więcej opcji?

Poznaj korzyści z subskrypcji, przeglądaj kursy szkoleniowe, dowiedz się, jak zabezpieczyć urządzenie i nie tylko.

Społeczności pomagają zadawać i odpowiadać na pytania, przekazywać opinie i słuchać ekspertów z bogatą wiedzą.

Czy te informacje były pomocne?

Jaka jest jakość języka?
Co wpłynęło na Twoje wrażenia?
Jeśli naciśniesz pozycję „Wyślij”, Twoja opinia zostanie użyta do ulepszania produktów i usług firmy Microsoft. Twój administrator IT będzie mógł gromadzić te dane. Oświadczenie o ochronie prywatności.

Dziękujemy za opinię!

×